none
Win 7 Media Center is not recognizing my TV Tuner Pinnacle

    Question

  • My win 7 media center TV set-up does not recognize my TV Tuner (Pinnacle 801e) what can I do to solve this problem. I tried to download drivers but that just did not seem to help. Am I installing the drivers wrong?  My computer it's self does not have a TV Tuner (HP Pavillion Dr 9535us).  I have to rely on the usb Pinnacle. I did not have one problem with this when I downloaded the first beta for Win 7. Why am I having it now with the new one? Please help
    Tuesday, June 09, 2009 3:25 AM

All replies

  • Possibly you simply installed the wrong drivers.  It happens, especially when Pinnacle has multiple choices for that tuner.
    Recommendation:
    Uninstall the tuner from Device Manager, and tick the box to 'remove all drivers.'
    Pull the tuner.  Reboot.
    Download this driver package (found on this page at Pinnacle.)  Plug in the tuner.  Watch your system tray for the 'found new hardware' wizard, and cancel it.
    Extract the driver package, and run the installer.  Reboot if requested.
    Re-run Media Center setup.
    Post back with results.

    HTH,
    Chris
    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Tuesday, June 09, 2009 4:34 AM
  • I also received the it can't find an installed tuner message. I then found the new Win 7 driver for the mini stick at the Piunacle site

    http://www.pctvsystems.com/tabid/62/default.aspx/Downloads/MicrosoftMediaCentersupport/tabid/196/language/en-US/Default.aspx

    This allowed me to activate the stick in Media Centre. When it did the channel scan it did not find any channels although using the Pinnacle software it found nine channels.

    It worked fine in Pinnacle until I changed channels at which poiint I received a " TV Pro unhandled exception!!! The application will restart'  error message ".


    "System.Argument Parameter is not valid. at System>Drawing.Grphics.ScaleTransform(Single sx, Single sy, MatrixOrder order) ......See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.

    ************** Exception Text **************
    System.ArgumentException: Parameter is not valid.
       at System.Drawing.Graphics.ScaleTransform(Single sx, Single sy, MatrixOrder order)
       at System.Drawing.Graphics.ScaleTransform(Single sx, Single sy)
       at Pinnacle.Spezi.Controls.Text.TextManager.DoPaint(Graphics gfx, Brush brush, String text, Font font, Rectangle rect, Boolean hotkeyunderline)
       at Pinnacle.Spezi.Controls.PcleTextControl.OnPaint(PaintEventArgs e)
       at System.Windows.Forms.Control.PaintWithErrorHandling(PaintEventArgs e, Int16 layer, Boolean disposeEventArgs)
       at System.Windows.Forms.Control.WmPaint(Message& m)
       at System.Windows.Forms.Control.WndProc(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
       at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)."  and then the program shuts down
    .

    The stick works fine on my old XP machine.

    Monday, January 04, 2010 5:06 AM