none
Windows 8 Mail Wont Send

    Question

  • As of Yesterday, (27th Sept) My windows mail has stopped sending email to any of the IMAP accounts set up, I have seen this on multiple PCs with multiple IMAP accounts, so i'm pretty sure it's not a Mail server issue, and I have tried it via different internet connections to rule out ISP issues.

    Symptoms:

    Compose new email, click send, click sync, email then goes into drafts - in the top right, it says account@server.com is unavailable.

    I have tried removing the account and re-adding it, and removing the mail app altogether then re installing it from the store with no joy.

    Syncing with Hotmail is unaffected and works just fine.

    Friday, September 28, 2012 7:41 AM

Answers

  • I have resolved this now

    I checked my SMTP logs - no errors in there, couldn't even see the client trying to connect!

    Now my mail package comes with a web hosting package that is hosted on a virtual server, and I think this may have been causing me issues.

    Consider this:

    I enter my settings in the windows mail client as mail.mydomain.com

    if I ping this server, then do a reverse lookup on the IP address it returns, I find that the mail server is actually called mail32.myhostersdomain.com.

    Once I change my settings from mail.mydomain.com to mail32.myhostersdomain.com, email starts to work, both SSL and non SSL.

    This is NOT how the mail client should work - Outlook and all other mail clients I have used, will happily work with mail.mydomain.com,  I can only assume that for some reason Windows Mail is comparing the DNS name of your mail server with the name an NSlookup returns and refusing to send if they don't match..

    Hope this helps someone!

    • Marked as answer by jimmywhite Monday, October 29, 2012 1:33 PM
    Monday, October 29, 2012 1:33 PM

All replies

  • You need to check your SMTP server, not IMAP. Although IMAP and SMTP may be running on the same server these are two different and independent services and each asks for user authentication.

    Friday, September 28, 2012 8:32 AM
  • I should have pointed out that using the outlook client on the machines works perfectly, with the same account settings (IMAP/SMTP), which further proves there is no issue with the mail providers, the issue is indeed with SMTP, but not at the server end, this is definatley a client side issue.
    Friday, September 28, 2012 11:55 AM
  • You may need to check the type of SMTP authentication.

    It can be

    • clear text
    • secure password authentication

    Perhaps this type is different on your clients.

    Friday, September 28, 2012 12:51 PM
  • You may need to check the type of SMTP authentication.

    It can be

    • clear text
    • secure password authentication

    Perhaps this type is different on your clients.

    Have tried both with the same results... the email goes into draft, no obvious error messages. Does the mail app create a log anywhere?
    Friday, September 28, 2012 2:15 PM
  • Hi,

    Since it works before, try to perform a system restore to check if it works.

    Furthermore, try to temporary disable firewall and antivirus programs on windows 8.

    Regards,

    Leo   Huang


    Leo Huang

    TechNet Community Support

    Monday, October 01, 2012 6:20 AM
    Moderator
  • I get the same issue but only (it seems) where I have attached fairly large files. In the latest example, I have attached 3 x 2MB jpegs and this email went straight to drafts. Reduce the size of the jpegs to c. 500kb each and off it goes. Is this a configurable option somewhere?

    Regards

    Gary

    Monday, October 01, 2012 7:04 PM
  • All I really need to be able to do is find / enable some error logging - system restore is not the answer, I need to know why it broke in the first place!
    Tuesday, October 02, 2012 7:23 AM
  • Hi,

    I am trying to involve someone familiar with this topic to further look at this issue.

    Regards,

    Leo   Huang


    Leo Huang

    TechNet Community Support

    Wednesday, October 03, 2012 8:39 AM
    Moderator
  • Hi,

    Does the issue still occur after the clean boot?

    Perform a clean startup to determine whether background programs are interfering with your game or program

    http://support.microsoft.com/kb/331796

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, October 04, 2012 9:09 AM
  • I have the same problem, desktop Live Mail works perfectly, W8 will not send..  I have been working with an MS tech support person via the forums to no avail for over a month.  I sent logs two weeks ago per their request, and since then I have heard only 'complete silence'. 

    Tuesday, October 09, 2012 3:38 PM
  • I have the same problem. If I remove the mail app and set it up again it works for a while. After a few hours or maybe a few days a mail gets stuck in the outbox and no further mails will be delivered. I have had this on more than one PC. If I install Outlook on the same computer it works perfectly. My mail account is gmail. I have a personal domain for email hosted delivered to gmail.

    Will B

    Wednesday, October 10, 2012 1:11 PM
  • Hotmail won't work for me either (in Windows 8 RTM Mail app...) Yahoo and Google accounts work perfectly in the same app!
    Thursday, October 11, 2012 5:42 PM
  • Hi,

    Have you uninstalled and installed it to have a try?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, October 12, 2012 9:13 AM
  • I have uninstalled and re-installed more times than I care to count, including just now before typing this message.  My mail will not send.

    (And as a side note, for this problem and future problems, MS, please add a way to delete from the outbox.)

    Friday, October 12, 2012 5:25 PM
  • Hi,

    Wish this post can help you

    http://answers.microsoft.com/en-us/windows/forum/windows_8-winapps/i-cant-see-facebook-twitter-or-flickr-content-when/5621e57d-49d3-4efc-ac93-340fcb5c0833?auth=1

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, October 15, 2012 1:26 AM
  • Hi,

    I installed Windows 8 Pro 64-bit this weekend and noticed today that emails in the mail app are not being sent for my IMAP account. This account works fine when in Outlook. My GMail account works fine in the Mail app.

    The SMTP server is reporting the following:

    Transcript of session follows.

      Out: 220 mail2.*****.com ESMTP Postfix (2.3.3)

     In:  ???

     Out: 502 5.5.2 Error: command not recognized

     In:  ?S?&?h?OdJ??R

     Out: 502 5.5.2 Error: command not recognized

     In:  ???????

     Out: 502 5.5.2 Error: command not recognized

     Out: 421 4.7.0 mail2.*****.com Error: too many errors

     Session aborted, reason: too many errors


    Tuesday, October 16, 2012 4:50 PM
  • Hi,

    Since this is a bland new installed Windows 8, if there are any Email available updates, please try to install them first.

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, October 17, 2012 8:01 AM
  • I have all the updates installed, both from the Store and from the Windows Update.

    The Mail app installed is 16.4.4391.1005

    Wednesday, October 17, 2012 9:42 AM
  • Any updates on this?  I have the same issue for accounts on two different IMAP/SMTP servers-- emails don't send, just get stuck in outbox indefinitely.  Removing and reinserting the accounts makes no difference.

    The inability to send email is obviously a showstopper-- using Outlook on the desktop for now.

    The Mail app is less than half-baked-- pales in comparison to even the Windows Phone mail app...

    Wednesday, October 24, 2012 6:03 PM
  • All,

    Not sure if it will help you but I fixed my problem (at least for the moment) by unchecking the 'Use SSL' for SMTP.  In my opinion, its should not work this way, my provider insists it is required and I have it checked in Windows Live Mail which works, but unchecking 'Use SSL' for SMTP fixed my problem and my W8 mail now sends.  Don't like that I am not using SSL though. 

    Regards

    Thursday, October 25, 2012 3:56 AM
  • I can't get it to work even without SSL.  Tried 3 different IMAP/SMTP servers- same issue on all of them, both on my Win 8 ultrabook and my new (email-less) Surface RT.
    Sunday, October 28, 2012 2:12 AM
  • I still have the issue, things tried so far:

    Remove and re-add email account

    Remove and re-install Email App

    Turn on SSL

    Turn off SSL

    No Firewall issues, this happens from multiple sites, home, office, public Wi-Fi etc.

    Hotmail works fine, its just SMTP that wont work, irrespective of authentication method!

    Im going to try and do some more trouble shooting this afternoon, as I have some time, but may end up opening a support call.

    Monday, October 29, 2012 12:35 PM
  • I have resolved this now

    I checked my SMTP logs - no errors in there, couldn't even see the client trying to connect!

    Now my mail package comes with a web hosting package that is hosted on a virtual server, and I think this may have been causing me issues.

    Consider this:

    I enter my settings in the windows mail client as mail.mydomain.com

    if I ping this server, then do a reverse lookup on the IP address it returns, I find that the mail server is actually called mail32.myhostersdomain.com.

    Once I change my settings from mail.mydomain.com to mail32.myhostersdomain.com, email starts to work, both SSL and non SSL.

    This is NOT how the mail client should work - Outlook and all other mail clients I have used, will happily work with mail.mydomain.com,  I can only assume that for some reason Windows Mail is comparing the DNS name of your mail server with the name an NSlookup returns and refusing to send if they don't match..

    Hope this helps someone!

    • Marked as answer by jimmywhite Monday, October 29, 2012 1:33 PM
    Monday, October 29, 2012 1:33 PM
  • I got all excited with your answer, but then no joy (for me at least).

    I did the same as you and also found that the IP address for my SMTP server was, like yours, pointing to a different name (i.e. advertised name is smtp.1and1.com, real name is smtp.perfora.net).  So, like you I entered the different name, and it does not work.  Not with SSL and not without SSL.

    Now, just for fun, I changed the IMAP settings to the new name as well for a test, and that works just fine, so I am pretty sure the naming is correct.  I also tried just the IP address, and no luck there. 

    The only thing that is working for me is to turn off SSL (which, for MS if you are listening, IS NOT GOOD SECURITY!)

    Tuesday, October 30, 2012 3:21 AM
  • I got all excited with your answer, but then no joy (for me at least).

    I did the same as you and also found that the IP address for my SMTP server was, like yours, pointing to a different name (i.e. advertised name is smtp.1and1.com, real name is smtp.perfora.net).  So, like you I entered the different name, and it does not work.  Not with SSL and not without SSL.

    Now, just for fun, I changed the IMAP settings to the new name as well for a test, and that works just fine, so I am pretty sure the naming is correct.  I also tried just the IP address, and no luck there. 

    The only thing that is working for me is to turn off SSL (which, for MS if you are listening, IS NOT GOOD SECURITY!)

    So are you saying that SMTP does not work full stop, but IMAP does? Have you run netstat to see if anything else is using those ports?

    Tuesday, October 30, 2012 8:02 AM
  • I had not checked, but at your prompting I have done so and do not see anything that jumps out at me as an issue.

    For more fun, I configured Windows Live Mail with the new server name just now and tried to send.  I got this message:

    The server you are connected to is using a security certificate that could not be verified.  The certificates CN name does not match the passed value.  Do you want to continue. 

    I said 'yes' and the message sent just fine.  Not sure how to read a certificate form an SMTP server, so not sure what it says (I suspect it points to 1and1.com).  W8 mail must just be conking out instead of providing me the option to send highly unsecured email.

    Tuesday, October 30, 2012 4:25 PM
  • I am not helping here I know but just wanted to put my hand up to say "I am having the same issue". IMAP email acc just wont send emails out. Tried all the above without success. The irony is the MS Mail app on my Nokia Lumia 900 running WP7.5 works with the same IMAP acc without issues, same settings. Any has an alternative Win8 Mail app to recommend ? Thanks in advance.

    Saturday, November 03, 2012 1:12 PM
  • I have uninstalled and re-installed more times than I care to count, including just now before typing this message.  My mail will not send.

    (And as a side note, for this problem and future problems, MS, please add a way to delete from the outbox.)

    I have the same issue, within the Win8 mail app receiving works fine, sending is nogo...
    In the desktop app of win 8 with outlook 2013 and my lumia 800 WP7.5 (same settings) it works perfect!

    I tried reinstalling the mail app, other mail account (same domain), strong password, other win8 account, clean boot, installed telnet-client works perfect, ... but nothing seems to help. I keep trying I just want to mail with this app!

    (my workarround: uncheck authentication, sync, they go to concepts where you can delete, yours?)

    Thursday, November 08, 2012 11:24 PM
  • Dear MS, this issue has been going on since September. Is anyone out there reading these things? Anyone going to respond? I have thought I might like to buy a surface, but can't even think of doing that without usable mail.
    Friday, November 23, 2012 3:19 AM
  • Dear MS, this issue has been going on since September. Is anyone out there reading these things? Anyone going to respond? I have thought I might like to buy a surface, but can't even think of doing that without usable mail.

    You are funny. The only response you'll get in these forums from anyone at Microsoft is either: 

    a> bummer that didn't work. It's by design.

    b> bummer that didn't work. I'll send that right off to team A as a suggestion (which you'll never near back from).

    or

    c> Here's a completely random answer to a question that you didn't ask. Did that solve your problem?

    I wish I was making this stuff up...but seriously...go and check the answers that MSFT staff have provided in these forums and I'll bet 95% of the time...it'll be one of those 3 I've listed above. 

    In any case, the Metro Mail was abysmal when it first came out. They have patched it a few times....and now it's slightly better...but still well below freeware e-mail clients. I suspect over the next year Microsoft will keep patching it...and hopefully sometime a year from now it will actually be somewhat usable. Nowhere near say Outlook or Touchdown, or any of those apps...but...merely usable...and equivalent to the hundreds of freeware desktop mail applications.

    Friday, November 23, 2012 4:37 AM
  • Finally figured it out...at least for me. Go to your email account settings, then more settings. Under the Advanced tab change your outgoing server from 25 to 587. This worked for me in both Outlook and Windows Mail.

    Good Luck-

    Tuesday, March 12, 2013 6:07 PM
  • Hey guys,

    I think I solved this one pretty quickly. Took about five minutes. Had the same problem - name@server.com is unavailable.

    I have several email addresses at my domain, so the problem occurring on multiple personal business accounts of mine and not on any of my gmail or yahoo accounts made me believe that it was fixable. My domain is hosted at bluehost which is reliable. If you are having problems with your outgoing messages but you are receiving messages fine - it's obviously not the domain and probably not the email client. The server settings can be finicky and need readjusting from time to time though.

    As previously suggested by mtzenterprises - change your outgoing port to something besides what it is now. If you're using 25 (which I was,) try changing it to 26. That worked for me. You should also contact your domain provider, if you can't solve this issue on your own.

    Good Luck,

    Nick



    Saturday, April 06, 2013 3:53 AM
  • This worked for me too.  Thanks. I should have remembered this.
    Monday, June 24, 2013 12:47 AM
  • curious if anything more was learned on this issue?   I have a brand new Windows 8 machine.   Noticed today (out of the blue) that no emails were sending.   I have a bad practice of mailing myself notes, like to dos, draft emails, notes on something.   And then I come back later and clean them up.   Well today, two very important draft emails did not come thru my inbox (from me, to me).    Then I noticed they weren't in the Outbox or Sent Mail.   I never could find a reason for why, or definitive fix...but I just turned off SSL (per the comment on Oct 25, 2012 at 356am) and that worked...a test email to myself went thru immediately.      

    I care less about 'why' and desperately want to know if you or anyone know a way to retrieve those two emails I mailed myself?!?!?!   They've vanished from my view point.   

    Friday, June 28, 2013 10:46 PM
  • curious if anything more was learned on this issue?   I have a brand new Windows 8 machine.   Noticed today (out of the blue) that no emails were sending.   I have a bad practice of mailing myself notes, like to dos, draft emails, notes on something.   And then I come back later and clean them up.   Well today, two very important draft emails did not come thru my inbox (from me, to me).    Then I noticed they weren't in the Outbox or Sent Mail.   I never could find a reason for why, or definitive fix...but I just turned off SSL (per the comment on Oct 25, 2012 at 356am) and that worked...a test email to myself went thru immediately.      

    I care less about 'why' and desperately want to know if you or anyone know a way to retrieve those two emails I mailed myself?!?!?!   They've vanished from my view point.   


    What I did to fix this was I went into credential manager in the control panel and removed the generic credential that was created. Whether its right or not I don't know but its fixed now.
    • Proposed as answer by Colin Moden Tuesday, October 29, 2013 6:04 PM
    Friday, August 16, 2013 6:17 AM
  • I has the same problem, IMAP (receive mail) working fine, SMTP (send mail) not working, messages piling up in the Outbox. FWIW My server is gmail and I am using the shiny new Windows 8.1 release. I have 2 gmail accounts and bizarrely 1 was sending fine & 1 was stuck, from  the same Mail app on the same PC.

    Removing the credentials for the blocked gmail account worked. no idea why or how. I did change my password to that gmail account a week ago which might have something to do with it.

    Tuesday, October 29, 2013 6:09 PM
  • Windows 8.1 Mail app worked fine for a few months then suddenly had this problem. Using my ISP's email. Have tried a number of things suggested on this forum (SSL on/off, firewall off, authentification required off) just to try and force an email through. Nothing worked. Have just tried Nick's suggestion of changing port. My ISP recommended 587 which works for all my other machines (including 2 windows 8.1 devices it seems). However on the Dell all-in-one I'm having problems with I changed the outgoing port to 25 and it now works. Although I do get a message popping up saying that 'email address is not available' the email is sent ok.
    Monday, March 03, 2014 2:47 PM
  • hi to all people have problem with windows 8.1 mail app

    

    after all I have found the solution for this annoying problem

    

    here is steps

    1- close your email from task bar

    

    right click on the taskbar go to task manager in processors tab you can see your mail

    right click on it and press end task

    

     

    

    2- go to control panel click on windows firewall

    

    then click on advanced settings and go to outbound settings  from right click on new rules

    

    select program and click next in next step select this program path and browse

    

    go to C:\Windows\System32

    and find WWAHOST.exe click on it and open it

    

    

    click next and press Allow the connection and press next and next

    at the end write name as MAIL for your permission

    and press finish

    

    the last change is you should go to windowsfirewall and click on Allow an app or feature through windows firewall  click on change settings in bellow click on Allow another app and browse open again WWAHOST.exe to let the app go through the firewall then select private and public

    that's all sorry for my bad English

    

    and this is my E-mail : abolfazlillustray920@outlook.com

    for more question

    Saturday, June 07, 2014 7:06 AM