none
There is no email program associated....

    Question

  • Hi,

    I am running an evaluation copy of Windows 7 bld 7100 and am getting an error message when ever I try to sync my PDA or use Genie backup that reads as follows..."There is no email program associated to perform the requested action. Please install an email program or, if one is already installed, create an association in the Default Programs control panel." I did not have this problem until I installed Windows 7. I tried un/installing Thunderbird (my email program) with no change. What really has me wondering is my it shows up when I start Genie Backup Manager Pro v 8.

    Thanks
    Thursday, September 10, 2009 10:58 PM

Answers

  • Hi,

    Thanks for the post.

    Thunderbird is excellent, but lacks Mail's OS X integration. Occasionally, Extensions may cause problems with Thunderbird, including reduced stability and performance. If you encounter problems relating to parts of the mail client no longer working, the mail client not starting, windows with strange or distorted appearance, degraded performance, etc., you may be suffering from Extension or Theme trouble. Restart the mail client in Safe Mode. On Windows, start using the "Safe Mode" shortcut created in your Start menu or by running thunderbird.exe -safe-mode.

    However if still the problem persist you can logg your issue on http://forums.mozillazine.org/index.php?c=8

    Please Note: Windows 7 no longer comes with Windows Mail or Outlook Express or any other email application. That application has been offloaded to the Windows Live Essentials. You can find the link in the start menu under the Getting Started fly-out. You'll need Windows Live Mail (part of the Essentials pack) or you'll need to install Office/Outlook or another email app.

    Hope this helps

    Thanks
    Abhay

    NOTE - Disclaimer

    The links in this message may lead to third-party Web sites. Microsoft provides third-party resources to help you find customer service and/or technical support resources. Information at these sites may change without notice. Microsoft is not responsible for the content at any third-party Web sites and does not guarantee the accuracy of third-party information.

     

    Friday, September 11, 2009 7:38 PM
    Moderator

All replies

  • Hi,

    Thanks for the post.

    Thunderbird is excellent, but lacks Mail's OS X integration. Occasionally, Extensions may cause problems with Thunderbird, including reduced stability and performance. If you encounter problems relating to parts of the mail client no longer working, the mail client not starting, windows with strange or distorted appearance, degraded performance, etc., you may be suffering from Extension or Theme trouble. Restart the mail client in Safe Mode. On Windows, start using the "Safe Mode" shortcut created in your Start menu or by running thunderbird.exe -safe-mode.

    However if still the problem persist you can logg your issue on http://forums.mozillazine.org/index.php?c=8

    Please Note: Windows 7 no longer comes with Windows Mail or Outlook Express or any other email application. That application has been offloaded to the Windows Live Essentials. You can find the link in the start menu under the Getting Started fly-out. You'll need Windows Live Mail (part of the Essentials pack) or you'll need to install Office/Outlook or another email app.

    Hope this helps

    Thanks
    Abhay

    NOTE - Disclaimer

    The links in this message may lead to third-party Web sites. Microsoft provides third-party resources to help you find customer service and/or technical support resources. Information at these sites may change without notice. Microsoft is not responsible for the content at any third-party Web sites and does not guarantee the accuracy of third-party information.

     

    Friday, September 11, 2009 7:38 PM
    Moderator
  • That's not an answer to the topic starter's issue at all, in fact it might be the worst response I've seen ojn a forum in a while.

    I have the same issue as the topic starter. Which is not about Thunderbird not functioning, but Windows 7 failing to see what the default email application is. I get this error every time I connect my phone to my PC (over USB). The error comes from Windows Mobile Device Center / Syncing Center. Once I press OK Syncing Center will continue to work properly and sync my calendar and contacts, but having to click OK each time I sync my phone (at least once a day) is highly annoying.

    I checked the Default Programs control panel as the error message suggests and set Thunderbird as the default application for every email related task I could find, but no fix yet.
    Thursday, October 01, 2009 3:24 PM
  • That's not an answer to the topic starter's issue at all, in fact it might be the worst response I've seen ojn a forum in a while.

    I have the same issue as the topic starter. Which is not about Thunderbird not functioning, but Windows 7 failing to see what the default email application is. I get this error every time I connect my phone to my PC (over USB). The error comes from Windows Mobile Device Center / Syncing Center. Once I press OK Syncing Center will continue to work properly and sync my calendar and contacts, but having to click OK each time I sync my phone (at least once a day) is highly annoying.

    I checked the Default Programs control panel as the error message suggests and set Thunderbird as the default application for every email related task I could find, but no fix yet.
    I had to laugh at that first line, but alas it's true. On the other hand the lack of useful responses isn't limited to TechNet; a search for "there is no email program associated to perform" shows dozens of hits across dozens of forums, each with either no response at all or, as in this case, an irrelevant response followed by silence when the response is questioned.

    To be honest I don't think anyone has the first clue as to what's happening here, although Windows 7 64bit does seem to be a common factor. For what it's worth I'm seeing this behaviour with my iPAQ PDA synchronizing with Thunderbird/Lightning via BirdySync and the Sync Center. Everything works beautifully (and I can finally rid myself of the horror that is Outlook) except for this annoying error dialog on every initial connection.

    I'm kind of hoping this is one of those quirky issues that will just "go away" in a couple of weeks when I move from RC build 7100 to the full release version of Windows 7, but I'm not holding my breath. On the other hand once Win7 officially ships and they have millions of users to deal with rather than tens of thousands of early adopters, maybe the frequency of this problem will be such that Microsoft will have no choice but to investigate it. Maybe.

    In the mean time we can only treat answers that invoke Windows Live Mail and OS X (!?!) with the contempt they deserve.
    Sunday, October 04, 2009 9:10 PM
  • Moving to the final won't solve it, I'm already on RTM, which is the build everybody will use starting the 22nd (TechNet Subscriber).

    For the full details: Windows 7 Home Premium 64bit. So the Win7 64 does seem to be a common factor. But perhaps even more interesting is you mention using BirdieSync. So do I. Although it doesn't make sense for BirdieSync to sync this either, I guess I'll try it without tomorrow just to check :).
    Sunday, October 04, 2009 9:27 PM
  • Removing BirdieSync didn't have any effect.

    I also tried installing Windows Live Mail and set it up with a @live.com address I never used, but this didn't solve the problem either. I didn't try setting Windows Live Mail as the default mail application though, as this is definitely not something I want to do. Thunderbird is already the default mail application.

    So for now the problem remains and I wouldn't know what else to try. If anyone has any ideas, or the same problem, please reply. I'm subscribed to this thread :).
    Monday, October 05, 2009 2:26 PM
  • No solution here, but I'm having what I think is the same issue. I'm running Genie Home Backup 8.0 on Windows 7 RTM. Whenever I launch Genie and then close it to the taskbar, I see the "No email program..." dialog. I schedule nighttime backups, and every morning after a backup I see this message as well. I use Gmail, so I thought installing Thunderbird might solve the problem, but that had no effect.
    Wednesday, October 14, 2009 4:01 AM
  • Part of the issue with this error seems to be the handful of different scenarios that can make it appear. A trawl of the forums shows people seeing it because they genuinely haven't installed an e-mail client (fixable), because they haven't set a default program for the mailto: protocol (fixable), or because their AV product is causing a conflict (fixed in many cases by the AV vendor, although I suspect it's more of a workaround than a fix. The core problem is definitely Microsoft's).

    The problem with these scenarios is that they divert attention away from those of us seeing problems with Sync Center . PDA users, iPhone users, Thunderbird users, Outlook users, the Genie user in this thread. The common factor seems to be the Sync Center. The mailto: and e-mail client thing is a red herring in these cases and none of the posted 'fixes' will work. One guy in one thread even states categorically that he is not trying to sync anything with his device, just partner it so he can copy files. All of these default e-mail client fixes aren't going to resolve that problem, and I strongly suspect they're not going to solve ours either.

    Of course if Microsoft are seeing a 60-70%+ success rate with the client install / mailto: solution, and third-party vendors are patching away some of the remaining issues, it stands to reason Microsoft are going to keep trotting out these answers whenever this error gets a mention. Because in most cases it will be the correct solution. It's the handful of us for whom these fixes don't work who'll continue to be frustrated.

    Menthix, can I ask whether your current installation of RTM 64bit was a clean install (I'm assming so), and whether or not you've ever had Outlook installed on it? I did have an ancient version of Outlook 2002 on this machine that I was using in conjunction with gSyncIt to sync my PDA to Google Calendars and I don't recall seeing the "default e-mail" error then. (I saw many other errors, just not that one!). Now that BirdieSync is handling all my sync tasks I've uninstalled Outlook, but as you know Outlook is one of those programs notorious for leaving bits of itself all over the place and I can't help but wonder if an errant Outlook .dll or registry entry is playing some part in this issue.

    I will be wiping this installation and starting afresh with retail Windows 7 Home Premium on the 22nd, and part of me is still hoping this problem will miraculously go away once my system is free of any Outlook remnants. But if you've already done that with the RTM and the issue is still apparent, I'd rather not get my hopes up. Please let me know.

    Since I'll be spending quite a bit of time on or after the 22nd installing stuff anyway, I may try the 32bit build first and see what that does. A large number of people reporting this issue seem to be running 64bit; it'd be nice to know whether that's a definite factor or merely a coincidence.

    This all may seem like such a petty thing to gripe about -- a single dialog that can be easily clicked away. But I'm so impressed with Windows 7 and I have this system working so smoothly now compared with the nightmare of previous setups that this errant dialog is really, really , starting to pee me off!
    Wednesday, October 14, 2009 6:51 AM
  • denali: Yes, this is a clean install. No Outlook, never had it on this install. I do have Office 2007 installed, but it's the student version which comes without Outlook.
    Wednesday, October 14, 2009 10:00 AM
  • Adding to the noise: I get this when trying to format an envelope in Corel Wordperfect x4! (???)  T-bird isset as the default email pgm.  IIRC, it also popped up several times during x4 install and update.

    Z.
    Wednesday, October 14, 2009 3:50 PM
  • The problem, at least as it related to Genie Backup Manager, has been solved. I opened a support ticket with Genie, and they told me they had a build available that addressed the issue. They sent it to me, I installed it, and it works as advertised- no more warning dialog. If you're having the issue with Genie, I suggest you contact them and get the new build.
    Thursday, October 15, 2009 9:37 PM
  • I'm having the same problem with Windows 7 x64, Office 2010 Beta 2 and my iPhone.
    Jeff Day, Social Platform GPM
    Monday, October 26, 2009 4:10 PM
  • I can attest that the issue is not specific to 64bit as I have two machines, one running 64bit and the other 32bit and they both exhibit the same behaviour when attempting to sync using Birdiesync/Thunerbird combo along with WMDC.  I've tried everything I possibly can in the Default Programs in Control Panel and nothing seems to resolve this issue.  I know the issue seems trivial but it is rather annoying to always have to click OK for an error that should just automatically be rectified when an email program is installed and set to default.

    Out of curiosity, is anyone syncing email as well?  I only have it set to sync contacts and calendars between my mobile and my pc.  I was just wondering if possibly telling it to sync email as well might make it realize that a program is in fact installed.  But that might just be me living in a fantasy world.
    Tuesday, October 27, 2009 12:01 AM
  • Out of curiosity, is anyone syncing email as well?  I only have it set to sync contacts and calendars between my mobile and my pc.  I was just wondering if possibly telling it to sync email as well might make it realize that a program is in fact installed.  But that might just be me living in a fantasy world.
    I am not syncing email, just contacts and calendar like you. But I do remember trying to sync mail in the past, without any positive result.
    Tuesday, October 27, 2009 6:34 PM
  • Well thank goodness I'm not the only one using birdie syn and is having the exact same problem. I connect my phone, up pops the stupid "default email" error, I click OK and Thunderbird comes right up... so what are we missing here? It somehow knows to load Thunderbird.

    I've tried setting the default program manually, I've also tried looking through file types and seeing if I associate anything email related to Thunderbird. No luck. This ONLY happens on Windows 7, for whatever reason. I love my thunderbird.

    I even opened a ticket in expertsexchange.com (but my 30 day trial was up and no solution; i'm not wasting my money there so i had canceled).

    I'm open to suggestions :)
    Friday, October 30, 2009 12:30 AM
  • I've posted a solution here:
    http://www.wieser-software.com/topdrop/help/faq.htm#mapierr

    based on information here:
    http://support.microsoft.com/kb/315458


    Anthony Wieser
    Wieser Software Ltd
    • Proposed as answer by Anthony Wieser Wednesday, November 04, 2009 9:04 AM
    Wednesday, November 04, 2009 9:03 AM
  • I've tried Anthony's solution but I'm still having no joy. I used the registry keys under Mozilla Thunderbird rather than Windows Live Mail (the latter of which I don't have installed) but followed the same procedure of copying the DLL path to the DLLPathEx key, rebooted and I still got the annoying pop-up. Right now I'm considering installing Windows Live Mail just so I can try this solution with the original keys but my gut feeling is that, while this solution is clearly on the right track with reference to the Knowledge Base page, there's more going on with my particular setup than meets the eye. And possibly with others' as well.

    This is definitely a problem that Microsoft needs to address, but it sounds as though even they don't know exactly what all of the circumstances are that can lead to this behaviour. Right now I'd settle for a patch that puts a 'Never tell me about this again' tick-box on the dialog, but I appreciate this could lead to issues if people with more serious MAPI problems erroneously choose to suppress the pop-up.

    It's still bloody annoying though. I used to use a program back in the mid 1990s called RTVReco which could look out for certain windows popping up and automatically click buttons on them. I'm almost tempted to resurrect it and put it to use suppressing this default e-mail dialog, that's how disproportionately annoying it is.
    Wednesday, November 04, 2009 7:15 PM
  • yea, sorry, it didn't work on this end either, I did exactly as denali_uk... it made no difference.
    Thursday, November 05, 2009 1:44 AM
  • For what it's worth, same here. Anthony 's possible solution didn't work for me applying the suggested steps to Thunderbird. Denali, if you install windows Live Mail as a workaround, let us know if it worked.
    Thursday, November 05, 2009 11:06 PM
  • For what it's worth, same here. Anthony 's possible solution didn't work for me applying the suggested steps to Thunderbird. Denali, if you install windows Live Mail as a workaround, let us know if it worked.

    Alas, no. I even tried pointing Thunderbird's DLLPathEx value to Windows Live Mail's MAPI DLL, and vice versa, with each program as default in turn and reboots between each combination. None of these rid me of the annoying Email popup.

    It would be nice to have some sort of feedback from Microsoft that at least acknowledges this problem, but other than the useless "answer" on September 11 there's been nothing. Very disappointing.
    Friday, November 06, 2009 7:29 AM
  • For what it's worth, same here. Anthony 's possible solution didn't work for me applying the suggested steps to Thunderbird. Denali, if you install windows Live Mail as a workaround, let us know if it worked.

    Alas, no. I even tried pointing Thunderbird's DLLPathEx value to Windows Live Mail's MAPI DLL, and vice versa, with each program as default in turn and reboots between each combination. None of these rid me of the annoying Email popup.

    It would be nice to have some sort of feedback from Microsoft that at least acknowledges this problem, but other than the useless "answer" on September 11 there's been nothing. Very disappointing.
    I'm also running into the same problem.  I just want to sync my phone contacts (using WinMo 6.1).  I've pretty much tried all the same steps you have, using both Windows Live Mail and Thunderbird and the registry edits Anthony suggested.  Clearly I'm not having any luck if I'm posting here.  And I also wanted to echo the lack of real MS support since the "moderator's" post was so useless.
    Friday, November 06, 2009 11:45 PM
  • Well, I fixed mine. I no longer get that annoying pop-up message! I hit "connect via Bluetooth" on my phone and the computer goes right into Thunderbird with no messages stating "no default email".

    I will warn you, not everyone may like this solution, or may have the means as it requires Microsoft Outlook. However, those who are interested in getting rid of that annoying message, I hope this works for you:

    -Install Microsoft Outlook 2007 (version number may not matter, 2000, XP may work as well).
    -Ran Outlook, but cancel the wizard; don't set up any accounts. Close Outlook (this step may not be necessary, but it's what I did).
    -Clicked Start, Default Programs.
    -Drop down custom and under "Set Default Email" select Microsoft Outlook. (Don't worry, Thunderbird will still somehow be your default, keep reading).
    -Connect your phone and activate your activesync (USB or Bluetooth).
    -For me, Thunderbird came right up and it synced with no problems whatsoever. Somehow Thunderbird remains to be the default email client. I even googled a test mailto link just to be sure, and sure enough, Thunderbird opens.

    The only down side is, you have to leave outlook on your PC (yes, I tried uninstalling Outlook and the message returned, so I reinstalled it), which for me, I can live with that as long as I no longer get that stupid error message. You can just pretend Outlook is not even there, delete the start menu and desktop shortcuts (if any) if it makes you feel like it doesn't exist on your machine. Until some other solution presents itself, this is how I'm going to do it. I DID try installing Windows Live Mail and setting it as default; but it seems to only work with Outlook. Hope some find this useful!
    • Proposed as answer by XIInator Sunday, November 08, 2009 6:54 AM
    Sunday, November 08, 2009 6:51 AM
  • I don't know if it makes a difference, but I'm running the latest copy of windows Live Mail on Windows 7.

    The build is 14.0.8089.0726

    Anthony Wieser
    Wieser Software Ltd
    Monday, November 09, 2009 7:28 AM
  •  I don't think anything makes any difference until microsoft sort it out, I am on a windows7 32bit upgrade and I also get the message everytime the computer boots up. All my defaults are set so come on Mr Gates get it sorted, don't know why you took the email client out in the first place, a new windows system starting with a backward step, not very clever there than.
    Wednesday, November 11, 2009 11:07 AM
  • Hi,

    I just installed the "off the shelf" upgrade from Vista to Windows 7 Home premium 64 bit. I did a clean install, reinstalling everything from scratch. I still have the same problem. It shows up when ever I connect to my PDA, when ever I use Genie-Soft backup and there is another program that has the same problem I just can't remember what it is. I have a very tough time believing that this isn't a Win 7 bug. I NEVER had this problem show up until I installed Windows 7. The first install was the RC version installed over Vista, the second install was clean. This little bug is awfully annoying and I would like to see a fix. I do have Office 2003 installed w/o Outlook. I never have had Outlook installed, before or after Win 7.

    Thanks,
    Dale
    Sunday, February 21, 2010 12:24 AM
  • I've posted a solution here:
    http://www.wieser-software.com/topdrop/help/faq.htm#mapierr

    based on information here:
    http://support.microsoft.com/kb/315458


    Anthony Wieser
    Wieser Software Ltd
    This solution does not work.
    Sunday, February 21, 2010 9:23 PM
  • For what it's worth, same here. Anthony 's possible solution didn't work for me applying the suggested steps to Thunderbird. Denali, if you install windows Live Mail as a workaround, let us know if it worked.

    Windows Live Mail is not a workaround.  Live Mail is the only mail app I have installed on my machine, it's selected as the default for all possible applications (I also tried manually configuring the app associations) and it still does not work.  I get the "no e-mail program associated..." error every time I plug my phone in.
    Sunday, February 21, 2010 9:25 PM
  • For what it's worth, same here. Anthony 's possible solution didn't work for me applying the suggested steps to Thunderbird. Denali, if you install windows Live Mail as a workaround, let us know if it worked.

    Alas, no. I even tried pointing Thunderbird's DLLPathEx value to Windows Live Mail's MAPI DLL, and vice versa, with each program as default in turn and reboots between each combination. None of these rid me of the annoying Email popup.

    It would be nice to have some sort of feedback from Microsoft that at least acknowledges this problem, but other than the useless "answer" on September 11 there's been nothing. Very disappointing.
    I'm also running into the same problem.  I just want to sync my phone contacts (using WinMo 6.1).  I've pretty much tried all the same steps you have, using both Windows Live Mail and Thunderbird and the registry edits Anthony suggested.  Clearly I'm not having any luck if I'm posting here.  And I also wanted to echo the lack of real MS support since the "moderator's" post was so useless.

    If you just need to sync your phone contacts, there is a workaround: if your contacts are on Live.com (online) you can sync to your phone via Windows Live on your phone.  I don't want to derail this thread with an explanation, so try this link: http://danbeahm.blogspot.com/2009/02/syncing-vista-windows-contacts-with.html
    Sunday, February 21, 2010 9:28 PM
  • A "solution" that requires Outlook is in no way a solution.
    Sunday, February 21, 2010 9:28 PM
  • I find it incredibly frustrating that when you click "check for updates" in Windows Live Mail under Help, it takes you to a page with a screen shot showing you how to "use your start menu to check for updates," and then when you do this, it doesn't update Windows Live Mail (or even give you an option to).

    Fantastic solution, Microsoft!
    Sunday, February 21, 2010 9:31 PM
  • So, I assume Microsoft is just going to pretend this issue doesn't exist.

    Awesome.
    Sunday, February 21, 2010 9:32 PM
  • I've posted a solution here:
    http://www.wieser-software.com/topdrop/help/faq.htm#mapierr

    based on information here:
    http://support.microsoft.com/kb/315458


    Anthony Wieser
    Wieser Software Ltd
    This solution does not work.

    For those of you who haven't managed to get this to work, which version of windows 7 are you on?  64 bit?  I've tested it on 32 bit, and the problem definitely went away here.

    Anthony Wieser
    Wieser Software Ltd

    Anthony Wieser | Wieser Software Ltd | www.wieser-software.com
    Sunday, February 21, 2010 9:41 PM
  • I don't know if it makes a difference, but I'm running the latest copy of windows Live Mail on Windows 7.

    The build is 14.0.8089.0726

    Anthony Wieser
    Wieser Software Ltd

    Just installed the update, restarted computer, verified that the HKEY adjustments were still there, and I still get the "no default email" pop up every time.
    Sunday, February 21, 2010 9:55 PM
  • For those of you who haven't managed to get this to work, which version of windows 7 are you on?  64 bit?  I've tested it on 32 bit, and the problem definitely went away here.

    Anthony Wieser
    Wieser Software Ltd

    Anthony Wieser | Wieser Software Ltd | www.wieser-software.com

    I'm on Windows 7 64-bit, but I followed your direction to use the 64-bit node.  I've also noticed on several other forums and blogs you've posted your solution to that people seem to be responding saying they are using 32-bit, but it still doesn't work.

    Hopefully a solution is found soon, or Microsoft at least admits the problem exists and starts creating a solution.
    Sunday, February 21, 2010 9:59 PM
  • I've updated the status here on the other similar thread:
    http://social.technet.microsoft.com/Forums/en-US/w7itproappcompat/thread/161188c6-94fe-486b-b600-c21931c52edc

    And I've confirmed that it does not work on 64 builds of W7, though does on my W7 32 system here.

    Anthony Wieser
    Wieser Software Ltd

    Anthony Wieser | Wieser Software Ltd | www.wieser-software.com
    • Proposed as answer by davepster Wednesday, March 24, 2010 4:09 PM
    Monday, February 22, 2010 11:18 AM
  • One proposed solution which did not work for my Win 7 64 but may work on a 32 bit machine is below.  This article could also be titled "No Default Mail Client Error in Windows 7" instead.

    None of the programs I use that allow for integration with an email client, regardless of if it is officce 2010, office 2007, acrobat pro, itunes contact integration or any other app that needs to use the default mail application work on my new system.  Installed on 1/2010.

    Dave

    http://www.brighthub.com/computing/windows-platform/articles/66114.aspx

    Wednesday, March 24, 2010 4:23 PM
  • I find it incredibly frustrating that when you click "check for updates" in Windows Live Mail under Help, it takes you to a page with a screen shot showing you how to "use your start menu to check for updates," and then when you do this, it doesn't update Windows Live Mail (or even give you an option to).

    Fantastic solution, Microsoft!


    yeah... kinda had the same thought while tring to update to build 14.0.8089.0726

    Still looking for that little pearl.

    Sunday, May 23, 2010 10:00 AM
  • I got this error message too "There is no email program associated...".  I solved it easily.  I'd installed MS Office 2000 when I had Office 2007 already installed.  That caused the problem.  So I uninstalled both and reinstalled Office 2007.  Perfect.  Incidentally, the reason I installed Office 2000 Premium was that it included Frontpage and Powerpoint which Office 2007 Basic didn't come with.  I've had to forgo those luxuries to get clean syncing from Outlook to my iPad without getting the error message.
    Saturday, June 05, 2010 10:50 AM
  • Same problem ("no email program associated...." "installation failure" etc.) installing and transferring outlook (email, calendar, contacts, etc.) from windows xp to windows 7 professional. Read lot of forums and tried, none worked but newbilli's solution worked. Uninstalled ALL microsoft office programs including trial and other support programs, restarted, defragmented, restarted, then loaded office 2003 professional (custom, no outlook), then loaded outlook 2007. No error messages, no problem, and did not slow down windows. Set up email accounts then transferred outlook (.pst) as data file (http://support.microsoft.com/kb/287070). Works great. No issues. 
    Thursday, July 29, 2010 9:41 AM
  • I have this error message on start-up.  That is, it isn't caused by me trying to do anything at all.  I'm running Windows 7 on a new Dell netbook, and I cannot find anyway to stop it.

     

    I tried installing two different email programs, Mulberry first (and gave it all the defaults), then Thunderbird, (and gave that all the defaults).

     

    Didn't help at all...

     

    :(

    • Proposed as answer by cromey Wednesday, November 03, 2010 10:02 PM
    Wednesday, October 27, 2010 11:14 AM
  • Super simple workaround (not a fix, as none exists as of this date) for those who have tried everything and still get that INCREDIBLY ANNOYING dialog popup every time they plug in their phone:

    Download Clickoff from: http://www.johanneshuebner.com/en/clickoff.shtml

    It's compatible with W7 32bit. Not sure about 64bit.

    Install it then plug in your phone. Click on the annoying dialog box so that it's in the foreground (don't close it). Press CTRL ALT D. The dialog box will disappear. And from now on it will disappear automatically! :)

    I watched the CPU Usage meter and saw no impact on my system's performance both at idle and during the time it was dismissing the dialog box.

    Once Microsoft finally addresses this problem just uninstall Clickoff.

    I'm SO happy I've probably clicked that dialog box well over 1,000 times over last several months as I keep my phone in a USB dock so I'm always plugging it back in to keep it charged.

    No Outlook!

    No Windows Live Mail!

    Haha Microsoft, we win! :p

     

    Thursday, February 24, 2011 7:10 AM
  • I had the same problem.  It was because windows 7 doesn't come with an e-mail client.  I installed thunderbird, and now I have no problems.
    Tuesday, May 10, 2011 3:18 AM
  • Hi,

    I am running an evaluation copy of Windows 7 bld 7100 and am getting an error message when ever I try to sync my PDA or use Genie backup that reads as follows..."There is no email program associated to perform the requested action. Please install an email program or, if one is already installed, create an association in the Default Programs control panel." I did not have this problem until I installed Windows 7. I tried un/installing Thunderbird (my email program) with no change. What really has me wondering is my it shows up when I start Genie Backup Manager Pro v 8.

    Thanks

    Saturday, November 12, 2011 6:32 PM