none
No file association for.eml files

    Question

  • I've downloaded Windows Live Mail to use as my e-mail client programme. Unfortunately, the .eml file suffix is not present on the list of file associations in Control Panel, and consequently, I can't open forwarded e-mails with attachments in that format. Is there a way to add additional file suffixes to the list of associations, and then to add the necessary programme with which to open it?
    Wednesday, July 29, 2009 1:44 PM

Answers

  • Yesterday, I got round to backing up all my e-mails and contacts, and uninstalling, then reinstalling, Windows Live Mail.  Unfortunately, after I had done all this, the situation was exactly the same as before; namely, that if I clicked on an attachment with the .eml file extension, it re-opened the WLM program as a whole, and not the attachment. This morning, I've switched on, and out of the blue, it will now open .eml attachments as it should have done all along. So the problem is solved, but I don't know how or why....
    Thursday, August 06, 2009 11:54 AM

All replies

  • Yes, I got the same problem.
    Will there be any mail program integrated with Win 7?
    Wednesday, July 29, 2009 11:04 PM
  • Double click on an .eml file. If you don't have one create one by selecting new text document and canging the extension from .txt to .eml. A diologue will ask if want to go to the web to find a program or select from a list.
    Choose select from the list. Select the browse button.  Make sure "always use this program" in the lower left is selected. It should be by default. Browse to program files\ windows live\mail, and double click on "wlmail.exe".
    • Edited by ONE ZERO Thursday, July 30, 2009 5:51 AM
    Thursday, July 30, 2009 4:22 AM
  • Also there may be a setting to have windows live mail be the default mail program and this might associate .eml files with it.

    Thursday, July 30, 2009 4:24 AM
  • Set the default mail program in Control Panel > All Control Panel Items > Default Programs > Set your default programs > e.g. Windows Live Mail (in the left pane) > then look at Set… or Choose…

    If it doesn’t work, try changing this registry key. Click the Windows Orb (Start), type regedit, press Enter and navigate to registry key HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail. In the right pane Double-click Default and type Windows Live Mail as the value data.

    Thursday, July 30, 2009 8:03 AM
  • Eventually I managed to work this out for myself. I used a method broadly similar to that suggested by Mr. Seven, creating a dummy file and then replacing its suffix with .eml. This put the .eml extension into the list, and I then moved WLM on to the 'Open with' list.

    BurrWalnut's first solution would not have worked for me, because WLM is not on the list of programs for which defaults can be set; that was one of the avenues I first explored. The second method would not work quite as stated, because 'Mail' is not the end of the registry string; you have to go further.

    Although I've solved one connundrum problem, I have merely created another, for if I click on an attachment with the .eml file extension, it simply opens the WLM program again; it doesn't open the attachment. Curiously, I can open a .eml attachment with Word 2007. I wonder whether it is something to do with my having disabled inline image attachments, although I did this in Vista too, and neither saw .eml extensions on attachments nor had any problems opening attachments then. Any thoughts, chaps?

    In answer to MMikeVV, my understanding is that there will not be an inbuilt client e-mail program in Windows 7.
    Thursday, July 30, 2009 10:41 AM
  • An atachment with the .eml extension? Or an attachment within an opened .eml file?


    Mr. Seven. A name you can trust.
    Thursday, July 30, 2009 10:48 AM
  • What your saying is clicking on an .eml file opens the mail program but not the actual file?
    Mr. Seven. A name you can trust.
    Thursday, July 30, 2009 11:08 AM
  • I can only suppose that there were errors during the installation of Windows Live Mail. If installed correctly, it appears in "Default Programs", is set to open all files it can open by default (other e-mail programs, if present, are set to open nothing by default), and *.eml is associated (in "Associate a file type...") only to WML.
    Mobile AMD64 3000+, VIA Apollo K8T800 chipset, 1 G RAM, ATIRadeonMobility 9700, 20x DVDRW, C:XPSP3 (55G),D:WIN7 (25G),F:DATA (250G)
    Thursday, July 30, 2009 11:40 AM
  • WIndows live mail works best in xp sp3 compatibility mode on windows 7.
    Mr. Seven. A name you can trust.
    Thursday, July 30, 2009 11:43 AM
  • The attachment within the e-mail itself has a .eml file extension; if I click on the attachment, though, it simply opens WLM again, not the extension..... others running Vista or XP can open the attachments in question, and I've certainly not suffered any similar problems in the past using WLM with Vista.

    I'm beginning to think that Sanmartin has it about right; certainly, .eml did not appear in the 'associate file type' list until I put it there, and Windows Live Mail was not, and indeed still is not, on the list of programmes for which deaults can be set.
    Thursday, July 30, 2009 7:32 PM
  • Very odd. I'm sure youv'e sent yourself a number of test messeges and the attatchments now have the .eml extenstion which makes it unusable. You could try creating a new user account with administrator rights and testing the client there.


    It's a bird. It's a plane. It's Mr. Seven.
    Thursday, July 30, 2009 9:21 PM
  • Even worse! If I send myself attachments, they are either .jpg or .docx, and they come back in that form. I have tried forwarding myself e-mails, and replying to my own e-mails, and in neither case does an attachment form at all- yet on two occasions, others have somehow managed to send me e-mails with a .eml file extension, and in neither instance could I open the attachment using WLM; that merely opens WLM up again. i'd love to know just why this happens....
    Thursday, July 30, 2009 10:23 PM
  • The thing is there's no Windows Live Mail in the Default Programs list. And there's no *eml file extension in the files extensions list either.
    And there always pops up this dialogue window:
    "There is no email program associated to perform the requested action. Please install an email program or, if one is already installed, create an association in the Default Programs control panel"
    But Windows Live Mail is already set as default mail client.
    Saturday, August 01, 2009 2:45 AM
  • MMikeVV , it's not too difficult to add the .eml file extension list on the 'Associate a file type or protocol with a program' page. Once you've achieved that, you then need to add WLM to the List of programs oin the 'Open with' window. However, I don't know how to get WLM onto the Default Programs list. I can't understand just how this seeming conflict between Windows 7 and WLM 2009 has been overlooked.

    Meanwhile, I've received another e-mail containing an attachment with a .eml file extension. I clicked on it to open it, and once again, all it did was to re-open Windows Live Mail. I am beginning to find it profoundly depressing that such a seemingly-simple glitch cannot be resolved.
    Saturday, August 01, 2009 1:00 PM
  • It would be easier if it were a seperate standalone package but even so have you tried removing the program and reinstalling it?

    Saturday, August 01, 2009 4:28 PM
  • Yesterday, I got round to backing up all my e-mails and contacts, and uninstalling, then reinstalling, Windows Live Mail.  Unfortunately, after I had done all this, the situation was exactly the same as before; namely, that if I clicked on an attachment with the .eml file extension, it re-opened the WLM program as a whole, and not the attachment. This morning, I've switched on, and out of the blue, it will now open .eml attachments as it should have done all along. So the problem is solved, but I don't know how or why....
    Thursday, August 06, 2009 11:54 AM
  • Unfortunately, for no reason that I can determine, whilst running through a batch of e-mails with attachments yesterday, I discovered that a number of file extensions ( .jpg and .wmv) had lost their program associations, and .eml had unilaterally disappeared from the list of extensions completely.

    I re-established .eml on the list, reinstated Windows Live Mail as its associated program, and guess what? If I click on a .eml attachment, instead of opening the attachment, it simply re-opens the program again. So I'm now back exactly where I was on 30th July. I am drawn to conclude that this is an on-going problem with 7 RC. It's also not the only example of Windows 7 not remembering its settings; mine won't remember pane sizes (I have to manually reset them every time), and periodically resets the power button setting back to shutdown from switch users.

    Any ideas, guys?
    Tuesday, August 18, 2009 12:20 PM
  • Yesterday, I got round to backing up all my e-mails and contacts, and uninstalling, then reinstalling, Windows Live Mail.  Unfortunately, after I had done all this, the situation was exactly the same as before; namely, that if I clicked on an attachment with the .eml file extension, it re-opened the WLM program as a whole, and not the attachment. This morning, I've switched on, and out of the blue, it will now open .eml attachments as it should have done all along. So the problem is solved, but I don't know how or why....

    As long as works. Lets just hope it stays this way.
    Tuesday, August 18, 2009 12:23 PM
  • But it doesn't work! See my previous post made just four minutes before your last one....
    Tuesday, August 18, 2009 1:05 PM
  • Unfortunately, for no reason that I can determine, whilst running through a batch of e-mails with attachments yesterday, I discovered that a number of file extensions ( .jpg and .wmv) had lost their program associations, and .eml had unilaterally disappeared from the list of extensions completely.

    I re-established .eml on the list, reinstated Windows Live Mail as its associated program, and guess what? If I click on a .eml attachment, instead of opening the attachment, it simply re-opens the program again. So I'm now back exactly where I was on 30th July. I am drawn to conclude that this is an on-going problem with 7 RC. It's also not the only example of Windows 7 not remembering its settings; mine won't remember pane sizes (I have to manually reset them every time), and periodically resets the power button setting back to shutdown from switch users.

    Any ideas, guys?

    This wasn't here when I hit the submit button because of the posting delay but you really should unmark that answer.
    Tuesday, August 18, 2009 1:26 PM
  • Hopefully you have the same values as below for classes root .eml extension.
    -----------------------------------------------------------------------------------------
    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\.eml]
    "Content Type"="message/rfc822"
    @="Microsoft Internet Mail Message WLMail"
    "CachedFilterIID"="{0563DB41-F538-4B37-A92D-4659049B7766}"
    "PersistentHandler"="{0563DB41-F538-4B37-A92D-4659049B7766}"

    [HKEY_CLASSES_ROOT\.eml\shellex]

    [HKEY_CLASSES_ROOT\.eml\shellex\{8895B1C6-B41F-4C1C-A562-0D564250836F}]
    @="{b9815375-5d7f-4ce2-9245-c9d4da436930}"

     -----------------------------------------------------------------------------------------------

    Some of these keys need permission.

    Tuesday, August 18, 2009 1:32 PM
  • Mr. Seven

    I've checked the values, and they are all as stated.
    Thursday, August 20, 2009 11:32 AM
  • I believe I solved it. Windows live mail sometimes has a bug habbit of turning .eml files into ._eml file when you drag them to the desktop from windows mail main window. So, if you add this extension

    "._eml"

    to 

    "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts"  the ._eml file will open with the reading pane like it should instead of the main window.



    Open note pad, paste the text below and save as "fix_email.reg".


    Windows Registry Editor Version 5.00

    [-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\._eml]

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\._eml]

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\._eml\OpenWithList]

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\._eml\OpenWithProgids]
    "Microsoft Internet Mail Message WLMail"=hex(0):

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\._eml\UserChoice]
    "Progid"="Microsoft Internet Mail Message WLMail"

     

    • Proposed as answer by ONE ZERO Thursday, September 17, 2009 9:07 PM
    • Edited by ONE ZERO Thursday, October 08, 2009 5:34 AM
    Wednesday, September 16, 2009 7:32 PM
  • It worked! :)
    It happened again today, I draged an email to the desktop and it was  "Email from somebody._eml" with the wierd extension but I had the registry ready for it and it opened in the reading pane like a normal .eml file.

    Thursday, September 17, 2009 9:11 PM
  • I solved this problem by downloading PST Viewer Pro at http://www.encryptomatic.com/pstviewer
    Friday, September 23, 2011 6:47 PM