none
SD Card Reader not working

    Question

  • I upgraded my Vaio VGN-FW190 from Vista to 7 and now my built in SD reader no longer works.  It doesn't even show up as a drive.  What gives?
    Monday, October 26, 2009 11:47 PM

Answers

  • There is a new mode (and it is the default) with Windows 7 where empty drives are not shown in the Compter folder. This can be changed by going to Folder options. View and then scroll down and uncheck  "Hide empty drives in the conputer folder"
    • Marked as answer by Linda Yan Tuesday, October 27, 2009 7:57 AM
    Tuesday, October 27, 2009 3:53 AM
  • Hi,
    Try to install Your Vista driver form here . If there will be any problems with installation try compability mode. All informations about it here .

    If You want to say thanks to anyone just click on Vote As Helpful (which is under every user avatar).

    If Your problem is solved please mark then Your thread is with solution.

    • Proposed as answer by Daniel PotyralaMVP Tuesday, October 27, 2009 3:15 AM
    • Marked as answer by Linda Yan Tuesday, October 27, 2009 7:57 AM
    Tuesday, October 27, 2009 3:15 AM

All replies

  • Me too.  I have a new gaming PC with an ASUS motherboard in it.  The tower has a 9in1 card reader, including a USB port.  As soon as the Windows 7 upgrade arrived at my house I installed it and now my card reader drives don't show up.  Only the USB port on it works, but not the rest.

    Any help would be great.
    Tuesday, October 27, 2009 2:20 AM
  • Hi,
    Try to install Your Vista driver form here . If there will be any problems with installation try compability mode. All informations about it here .

    If You want to say thanks to anyone just click on Vote As Helpful (which is under every user avatar).

    If Your problem is solved please mark then Your thread is with solution.

    • Proposed as answer by Daniel PotyralaMVP Tuesday, October 27, 2009 3:15 AM
    • Marked as answer by Linda Yan Tuesday, October 27, 2009 7:57 AM
    Tuesday, October 27, 2009 3:15 AM
  • There is a new mode (and it is the default) with Windows 7 where empty drives are not shown in the Compter folder. This can be changed by going to Folder options. View and then scroll down and uncheck  "Hide empty drives in the conputer folder"
    • Marked as answer by Linda Yan Tuesday, October 27, 2009 7:57 AM
    Tuesday, October 27, 2009 3:53 AM
  • There is a new mode (and it is the default) with Windows 7 where empty drives are not shown in the Compter folder. This can be changed by going to Folder options. View and then scroll down and uncheck  "Hide empty drives in the conputer folder"

    Yes, that was it, thanks so much.  Seems like a really stupid setting to have as default.  The drive wasn't showing up even when it wasn't actually empty.  But changing that setting now shows my sd card.
    Tuesday, October 27, 2009 11:14 AM
  • I have a VGN-AR71S (originally with Vista Home Premium and upgraded to W7 HP a week ago) - it is only 10 months old and got this response from Sony Support about the loss of my built in SD reader:

    "If you install Windows 7 on your VAIO you may lose some functionality as we do not supply drivers for your VAIO. Please note we cannot support Windows 7 on your VAIO."

    It appears that if your Vaio falls outside the most recent group of machines then Sony aren't supporting upgrades to W7 and therefore won't be engineering drivers for us.

    A USB converter for SD/SDHC cards is the only solution I can see.  I have hidden the empty non functioning drive so it doesn't appear on the My Computer screen to stop me fretting about it...

    Cheers,
    Vaughan
    • Proposed as answer by Veejayuu Tuesday, November 03, 2009 7:23 PM
    Tuesday, November 03, 2009 7:08 PM
  • I have just found a solution to the card reader problem

     

    Use the link below and download the file

     

    ftp://ftp.support.acer-euro.com/.....TI_v2_0_0_7.zip
    It worked in a second after installation.
    Thursday, September 23, 2010 1:41 AM