none
Windows 7 - External Hard drive not showing

    Question

  • Checked out the other threads and I still cannot get my hard drive working.
     

    Situation:  I have a Fantom Drive Green Drive USB external hard drive and a Lenovo Laptop running Windows 7.   The hard drive works fine on another Lenovo Laptop running Windows 7.   On laptop in question the computer recognizes the disk under device manager but not under my computer, aka I can't browse to it.

     

    Steps I've taken:  I've read the other threads and performed these actions

    I've uninstalled and reinstalled the drivers


    Checked for upper and lower filter values in the registry (they weren't there)

     

    Went to Computer Management -> Storage -> Disk Management

    Here my disk does not show unless I scan disks, then it will show in the bottom pane listed as Disk 1, Unknown, Not Initialized.   When I try to initialize the disk it returns incorrect function.  At this point I'm not sure what else I can do as assigning drive letters requires the disk to be initialized or so it appears.

     

    Any other ideas?   Is it possible I've shut down some service it needs to run?  

    Thursday, September 15, 2011 3:59 PM

All replies

  • FYI-Here is "a" solution IF it sees the drive but access is denied.

    Many folks are having this problem with external hard drives.

    go to start.

    type in "user access control"

    (select this as the option if  you get more than one choice),

    there is a bar asking for you to be notified for system changes.

    MOVE the BAR for user access control to ZERO...or whatever you are comfortable with.

    AT zero,,,I was able to see my external drive. YES!!!!

    Set the bar where you wish.

    At medium I could not access anything..

    I recommend you only keep the access control bar low, when needed.

    Like when you want to access a special  drive, or make system changes.

    I am not an expert...

    so I can tell you the above worked for me...

    so create a file to tell you how to change...keep UAC high except when you want to make changes..

    Microsoft is a big draw for hackers...so keep your guard up.

    Good luck.

    Linda

    Friday, June 01, 2012 11:30 PM
  • I am having a similar issue. Running Windows 7 Starter with a Toshiba 250 GB HD. Never had a problem on Vista. In my case however, my HD is running, the light is on. But the drive is not visible ANYWHERE. I have tried so many things. Rescan does nothing either. I'm seeing this everywhere and am wondering if this could be a Windows 7 issue

    -Karla

    Sunday, August 26, 2012 12:16 AM