none
This file does not have a program associated with it for performing this action. Please install a program or, if one is already installed, create an association in the Default Programs control panel.

    Question

  • I watched 3 or 4 online movies and downloaded a mpvie from megaupload.com and I have picked up a virus.

    Every time I attempt to run a program's .exe file the message in the title of this thread appears. I can't run a system restore because the message appears. I think every .exe command has been disabled by the virus. I can only access Internet Explorer because I thought to create a hyperlink in word and click on it.

    Any help would be appreciated, thanks.

    Thursday, December 29, 2011 8:13 AM

Answers

  • Liam

     

    Boot to Safe Mode (start tapping F8 when you switch on) and choose Safe Mode with Command Prompt. At the prompt, type assoc .exe=exefile and press Enter. There will be no acknowledgement, just type exit and press Enter. Now press Ctrl+Alt+Del and restart the computer.

     

    You may also have to restore the .exe association here  http://www.winhelponline.com/blog/file-asso-fixes-for-windows-7/

     

    As soon as you can access your ‘anti’ programs, run them to clear out any lingering infections.

    Thursday, December 29, 2011 9:15 AM
  • The File Association for this computer is cor

    rupted. What you have to do is you have to Open

    the registry. For that.

    Please press on the key Alt+Crtl+Delete key on the keyboard. Now you will get a new window

    called Task Manager.


    Now please hold the Ctrl key on the key board and click on File, New Task on the Task Manager.

    Now you will get a new black window.

    Type REGEDIT and hit on enter. It will open Registry Editor.
    Now got to the location

    HKEY_CLASSES_ROOT\exefile\shell\open\command

    and in the rigth side you have to add

    "%1" %*

    If any thing else is there delete it.

    Same way got to
    HKEY_CLASSES_ROOT\.exe\shell\open\command

    and in the rigth side you have to add

    "%1" %*

    If any thing else is there delete it.

    Now everything will work fine.

    http://securityresponse.symantec.com/avcenter/UnHookExec.inf

    Download this tool Norton tool using Internet Explore. And save it to the desktop.
    After that rightclick on the file and select install.

     

     

    Screen shorts for the registry edit is available in the last session of this page

    http://123seminarsonly.com/Tips/007/How-to-remove-Vista-Antispyware-2010.html

     

    All the Best.

    Thursday, December 29, 2011 1:35 PM

All replies

  • Liam

     

    Boot to Safe Mode (start tapping F8 when you switch on) and choose Safe Mode with Command Prompt. At the prompt, type assoc .exe=exefile and press Enter. There will be no acknowledgement, just type exit and press Enter. Now press Ctrl+Alt+Del and restart the computer.

     

    You may also have to restore the .exe association here  http://www.winhelponline.com/blog/file-asso-fixes-for-windows-7/

     

    As soon as you can access your ‘anti’ programs, run them to clear out any lingering infections.

    Thursday, December 29, 2011 9:15 AM
  • I tried the first thing and it made no change and I can't download anything due to the virus so the program in the second thing might fix it but I cannot access it.

    Any other suggestions?

    Thursday, December 29, 2011 9:36 AM
  • Liam

     

    Did you try downloading the .exe fix using Safe Mode with Networking?

    Thursday, December 29, 2011 12:35 PM
  • The File Association for this computer is cor

    rupted. What you have to do is you have to Open

    the registry. For that.

    Please press on the key Alt+Crtl+Delete key on the keyboard. Now you will get a new window

    called Task Manager.


    Now please hold the Ctrl key on the key board and click on File, New Task on the Task Manager.

    Now you will get a new black window.

    Type REGEDIT and hit on enter. It will open Registry Editor.
    Now got to the location

    HKEY_CLASSES_ROOT\exefile\shell\open\command

    and in the rigth side you have to add

    "%1" %*

    If any thing else is there delete it.

    Same way got to
    HKEY_CLASSES_ROOT\.exe\shell\open\command

    and in the rigth side you have to add

    "%1" %*

    If any thing else is there delete it.

    Now everything will work fine.

    http://securityresponse.symantec.com/avcenter/UnHookExec.inf

    Download this tool Norton tool using Internet Explore. And save it to the desktop.
    After that rightclick on the file and select install.

     

     

    Screen shorts for the registry edit is available in the last session of this page

    http://123seminarsonly.com/Tips/007/How-to-remove-Vista-Antispyware-2010.html

     

    All the Best.

    Thursday, December 29, 2011 1:35 PM
  • First i would try to address the virus problem.

    http://windows.microsoft.com/en-US/windows/products/security-essentials

    http://housecall.trendmicro.com/

    Once you are sure that virus is removed then you can try to fix the file association.
    Very often when the virus is removed the file association will start working again.

    Friday, December 30, 2011 10:07 PM
  • I'm having the same problem. It started today. I can't open any .exe file, cant open the comand prompt, cant open regedit. I can't download anything including trendmicro housecall or mircrosoft security essentials, because once downloaded i still have to open a .exe file to get them to run, which won't work. I booted to safe mode with cmnd prompt (the only way (could get it to show up) and did the assoc .exe=exefile and the response was that it repeated the command back to me. BTW command prompted booted to c:/something something. I knew enough to cd\ back to c:/, but do I need to go one step farther?

     

    Similar to the original poster, I can get around the .exe problem and get IE to open and then surf by going to the control panel and clicking around help menues until one of them launches IE. This is what tipped me off that it must be a virus because only the normal interface icons and explorer file locations are blocked, but some "backdoor" command is able to open IE. I do have Trendmicro installed already and it reported that two malicious things were successfully blocked, but I didnt see the names and it was too late as soon as I started poking around and found that everything was disabled.

     

    Lastly, I found on some other forums a solution that seemed to work for some people and that was going to control panel-folder options-files, but that option doesn't seem to exist on WIN7 so that was a dead end for me.

     

    If I must, and can find the necessary discs I will reinstall windows if that will solve the problem. What repurcussions should I expect? I have a SSD that runs my OS and a few critical programs but all my data is on a separate d:/ data drive. Will all that stuff be safe?

    Monday, January 02, 2012 5:48 PM
  • HAHA I found a workaround. I was able to launch CMD by going to task manager and clicking file, then holding down Cntl and clicking new task. This went straight to cmd prompt and I was then able to enter regedit and modify the .exe and exefile entries, and now my programs open!

     

    Will post again if any problems are lingering. The Ctrl_New Task shortcut was a big help, never would have found that.

    Monday, January 02, 2012 6:32 PM
  • Ok, definitely still have some issues but at least alot of pc resources are now opened up. Here's where things stand now:

    I downloaded the latest version of Malwarebytes (did not have installed on this machine previously)

    Though icons and menu bars are opening programs, I'm seeing alot of .exe files that are listed a NJi files under "Type" in explorer. When I go to the properties of the file, under type of file it says NJi (.exe) and these will not open. I don't see a folder for this type of file in regedit.  Now that I look elsewhere in my computer it seems like all .exe files now have that NJi tag attached to them. Not sure as of yet why shortcuts will open these files, but Malwarebytes will not. Though all my .exe's appear to be NJI's now, MB is the only thing that I can't get to open. The "Opens with" button is now missing from the properties of these files. Also, when I right click on files, the first two options should be open and open with. Instead, both of the first two options are just "open."

     

    The error I get when trying to open MB is "ShellExecuteEX failed; code 1155. No application is associated with the specified file for this operation"

    After a little digging, NJi files do exist in conjunction with NERO programs, which I've never had installed on this machine.

     

    I'm assuming that a virus is still at work here. Running a Trend Micro full scan. Any ideas will be greatly appreciated.

    Monday, January 02, 2012 7:03 PM
  • Hi LiamDuncan and PinSpree,

    You need to fix the .exe association issue first. Please download the EXE association fix registry from the link Burr provided. If it cannot be load, I suggest downloading it from another PC, then copy to the problematic PC and import it.

    http://www.winhelponline.com/blog/file-asso-fixes-for-windows-7/

    After fixing the EXE file association, the antiviruses can be installed properties.

    Regards,

    LS

    Tuesday, January 03, 2012 3:57 AM
  • I just had this problem.  Every time I inserted a DVD movie, a dialogue pops up that says This file does not have a program associated with it for performing this action...   I just had a live chat with MICROSOFT technician and he fixed it.  He explained that my system was missing a few CODECS. I'm not sure if it's because I just upgraded to Windows 8 three weeks ago. So technician did a research and found solution.  The software he installed is VLC Media Player.  And now it's working.   I advise that you go to MICROSOFT Live Chat and connect with one of them.  I just hope you find the same person who helped me.  I tried so many suggested solutions from different sources: internets. websites, and MICROSOFT communities.  None of them solved my problem. 
    Friday, January 04, 2013 5:49 AM
  • Dont ry save and run, just save to the HD. Once downloaded right click on file and select runa s administartor, same go's for any other executable file, word, excel or installed program. right click and run as administrator! work around...
    Sunday, January 06, 2013 4:21 AM