none
Cannot load Java applets behind ISA proxy in Windows 7 (Works OK in XP)

    Question

  • After the organization I work for recently implemented an ISA proxy, we began noticing that websites implementing Java applets could no longer work on our Windows 7 computers. After several attempts of installing/uninstalling Java, the problem persists. The strange thing is that the Windows XP computers can access these websites without any problem. In XP, a Java window pops up requesting for username/domain/password information, and entering in this information correctly will load the website OK. No such window pops up in Windows 7. Has anyone experienced this and/or knows of a way to resolve this? Our current workaround is installing Windows XP Mode on our Windows 7 systems.
    Tuesday, January 04, 2011 3:33 PM

All replies

  • Hi,

     

    According to your description, I suggest to perform these tests to troubleshoot your problem:

     

    1 Logon Clean Boot

    2 Temporally disable firewall

    3 Make sure all add-ons are enabled in IE

     

    This link maybe helpful to you:

    http://social.answers.microsoft.com/Forums/en-US/InternetExplorer/thread/221beabb-53cd-42c9-ac64-ce324e93a864

    http://social.answers.microsoft.com/Forums/en-US/InternetExplorer/thread/52998750-ed88-4c06-8bc6-95db3b3abcc2

     

    Hope it helps.

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, January 06, 2011 8:35 AM
  • Hi Leo,

    Thanks for the information - however the steps described above do not work. Please note that this is not an IE-specific problem. None of the browsers we have tried (Mozilla, Chrome, IE) have been able to work. My thinking is that this is a Windows 7 issue because everything works OK in Windows XP.

    Friday, January 07, 2011 7:18 AM
  • Hi wexes,

     

    Please kindly to try these tests:

    1 Login with Safe Mode with networking to see if the same issue occurs.

     

    2 Temporarily bypass ISA proxy

     

    3 Add a credential in “Credential Manager” in Windows 7

     

    Hope that helps.

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, January 13, 2011 8:04 AM
  • Hi Leo,

    Thanks for your advise. However, after following steps 1 and 3, the problem persists. I bypassed the ISA proxy by connecting directly to the internet and the sites affected worked OK. Connect back to the proxy and the same error occurs.

    Thursday, January 13, 2011 12:10 PM
  • Hello, I am having the same exact issue with a windows 7 machine. We also use an ISA proxy and configured both the browser (IE) and the Java Client to pass thru that proxy but the connection is still originating as the machines IP and not the proxy. I installed the microsoft firewall client (2004) to force all connections thru the proxy and it works, but breaks other services. I have tried IE8, Firefox, and chrome with no success. Does anyone know of a fix for this?
    Thursday, June 09, 2011 9:08 PM