none
Exe files invisible with file sharing

    Question

  •             I’m sure this is a setting problem, but I just can’t find it:

    I have 2 machines running Win7 Ultimate, 64-bit and another running WinXP.  For one of the Win7 machines, I can’t see the .exe files on my old Win7 machine from either of the other machines using file sharing.  I can see them on the other (new) Win7 and WinXP machines from either of those machines or from the machine that won’t show its own .exe files.

                The settings in Control Panel—Network and Sharing Center – Advanced seem to be exactly the same between the two Win7 machines.

     

                This may be related, but it is probably a separate issue.  Feel free to ignore it if this is getting to be too much:

    I tried to put all 3 machines on the same network, but the WinXP machine shows 2 networks.  My home network is a work network because one of the machines is XP and I read somewhere that you can’t have an XP machine on a home network.  Before I added the new Win7 machine, both machines showed up under one network named “Sneakers”, which I named after my cat.  It showed up that way on both the XP and the “old” Win7 machine and everything was fine.  Since I added the new Win7 machine, however, it shows up under "Workgroups" on the WinXP machine.   Yet it still shows up correctly under “Sneakers” on the old Win7 machine.  It seems to be working OK, but I’m afraid that having dual networks will mess things up if it hasn’t already. How can I make the WinXP machine see it under “Sneakers”?

    Monday, July 05, 2010 7:15 PM

Answers

  • Can you see the other shares on the problematic computer from other computers? How does it work if you move other files, for example, *doc or *.txt files into the shared folder that stores the *.exe files on the problematic computer?

    Additionally, please let us know if Password Protected Sharing is enabled.

    I suggest you check the file sharing permission for the problematic shared folder. If Password Protected Sharing is turned off, make sure that Guest account is in the permission list.

    Also you may temporary disable firewall on the problematic computer and check the result.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by techniq1 Thursday, July 08, 2010 2:44 AM
    Wednesday, July 07, 2010 8:59 AM
    Moderator

All replies

  • Can you see the other shares on the problematic computer from other computers? How does it work if you move other files, for example, *doc or *.txt files into the shared folder that stores the *.exe files on the problematic computer?

    Additionally, please let us know if Password Protected Sharing is enabled.

    I suggest you check the file sharing permission for the problematic shared folder. If Password Protected Sharing is turned off, make sure that Guest account is in the permission list.

    Also you may temporary disable firewall on the problematic computer and check the result.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by techniq1 Thursday, July 08, 2010 2:44 AM
    Wednesday, July 07, 2010 8:59 AM
    Moderator
  • Thank you very much! 

    It was a sharing problem.  I had added subfolders to a shared folder thinking the subfolders would be shared.  Then I fooled myself by comparing folders with only .exe files with folders with no .exe files.  Thinking that all folders had the same sharing rules, I blamed the problem on the file type.

    Is there a way to make sure all my new subfolders get shared in the future?

    Also, please explain something to me:  I can make sharing assignments either of two ways after I right-click on a folder.  Either I can go to PROPERTIES and work the SHARING tab, or I can select SHARE WITH.  Why have 2 ways of doing it?  Do they do exactly the same thing?

    Thursday, July 08, 2010 2:50 AM