none
How do i stop the UAC prompts for one particular program im trying to run at startup with windows 7?

    Question

  • I need some help with this one. Whenever the computer starts I get two prompts from the UAC to allow a program (RivaTuner.exe) to run from an unknown publisher. I searched online and found that by adding the program to the scheduled tasks list that this may solve the problem.  I created a scheduled task for my rivatuner.exe program to run at system startup and the program starts but I still get the two prompts from the UAC to allow the program to run from an unknown publisher. How do I make it so that I don’t get the prompts for this program every time I start up the computer without turning off the UAC all together? I understand the usefulness of the UAC and don’t want to completely shut it off but the prompts are getting annoying.  The UAC was my greatest annoyance in vista and I had hoped the issue had been fixed in windows seven by having a program acceptance list added but I have yet to find one. Any help provided would be greatly appreciated.

    Here are the settings for running the program as a scheduled task.

    Under general tab:

    Name: RivaTuner.exe

    Run only when user is logged on (I’m the only user on the computer)

    The run with highest privileges box is checked.

    Configure for: windows 7

    Under Triggers tab:

    At startup – enabled

    Under Actions tab:

    Start a program – C:\Program Files\Riva Tuner v2.24\RivaTuner.exe

    Other than the above setting changes, everything else was kept at their default settings.

     

    Thanks again in advance for your help.

     

     

    Thursday, November 12, 2009 8:13 PM

Answers

  • Did you set to run the tasks as administrator? FYI I include the steps below.

    1. Click Start, right click on Computer and choose “Manage”.
    2. Click “Task Scheduler” on the left panel.
    3. Click “Create Task” on the right panel.
    4. Type a name for the task.
    5. Check “Run with highest privileges”.
    6. Click Actions tab.
    7. Click “New…”.
    8. Browse to the program in the “Program/script” box. Click OK.
    9. On desktop, right click, choose New and click “Shortcut”.
    10. In the box type: schtasks.exe /run /tn TaskName where TaskName is the name of task you put in on the basics tab and click next.
    11. Type a name for the shortcut and click Finish.

    Additionally, you need to run the saved scheduled task shortcut to run the program instead of running the application shortcut to ignore the IAC prompt. When startup the system will run the program via the original shortcut. Therefore you need to change the location to run the saved task. Please:

    1. Open Regedit.
    2. Find the entry of the startup item in Registry. It will be stored in one of the following branches.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
    HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Run
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run

    3. Double-click on the correct key, change the path to the saved scheduled task you created.


    Arthur Xie - MSFT
    Monday, November 16, 2009 9:33 AM

All replies

  • If you feel it is safe to run this program you can try using a resource editor to remove the "24" table in the program's executible.
    Thursday, November 12, 2009 8:16 PM
  • Did you set to run the tasks as administrator? FYI I include the steps below.

    1. Click Start, right click on Computer and choose “Manage”.
    2. Click “Task Scheduler” on the left panel.
    3. Click “Create Task” on the right panel.
    4. Type a name for the task.
    5. Check “Run with highest privileges”.
    6. Click Actions tab.
    7. Click “New…”.
    8. Browse to the program in the “Program/script” box. Click OK.
    9. On desktop, right click, choose New and click “Shortcut”.
    10. In the box type: schtasks.exe /run /tn TaskName where TaskName is the name of task you put in on the basics tab and click next.
    11. Type a name for the shortcut and click Finish.

    Additionally, you need to run the saved scheduled task shortcut to run the program instead of running the application shortcut to ignore the IAC prompt. When startup the system will run the program via the original shortcut. Therefore you need to change the location to run the saved task. Please:

    1. Open Regedit.
    2. Find the entry of the startup item in Registry. It will be stored in one of the following branches.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
    HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Run
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run

    3. Double-click on the correct key, change the path to the saved scheduled task you created.


    Arthur Xie - MSFT
    Monday, November 16, 2009 9:33 AM
  • Hello Shadow:

    I made this possible, since I created the program: UAC Trust Shortcut 1.0.
    With my software tool you can selectively create a whitelist.
    Download from my website: http://www.itknowledge24.com

    I hope you find this information useful and if you need any further assistance,
    please feel free to contact me and let me know.

    I hope this information was helpful…

    Have a nice day…

    Best regards,
    Fisnik


    Itknowledge24.com
    Sunday, May 23, 2010 3:40 PM
  • Hi,

    The original postor asked, "How do i stop the UAC prompts for one particular program im trying to run at startup with windows 7 ?"

    If this is a "scheduled task" that autoruns immediately after you logon, open Task Scheduler, find the task, and change "when running the task use the following user account" from Users/YourUserName/Whatever, to  the Local System account.

    And like Authur said, "Check “Run with highest privileges”.

    Regards,
    Bret


    2
    Saturday, August 21, 2010 9:45 PM
  • If you feel it is safe to run this program you can try using a resource editor to remove the "24" table in the program's executible.

    Hi Zero, Could you please explain how to do this

    Regards

    Anton

    Thursday, November 17, 2011 9:02 AM
  • If the program works as a regular user, you can use the Application Compatibility Toolkit to create a shim to disable the UAC prompt.

     

    Thursday, November 17, 2011 4:55 PM
  • hey your program works for opening a program, but not when you have a file that opens with that program. for instance, I have .pie files that are associated with glovepie to use the xbox controller on non xinput games, and would like to open the file for each game. having to go through the uac each time i play the game is a pain, but its also a pain to open the non uac shortcut your program would make and then open the script from glovepie
    Tuesday, July 16, 2013 6:00 PM