locked
Windows 8 Server Hyper-V

    Question

  • After installing Windows 8 and the Hyper-V role, I tried to open Virtual Switch Manager in Hyper-V manager. It pop-up with the following error:

    An error occurred while trying to retrieve a list of virtual switches.

    The operation on computer 'localhost' failed.

    Anyone has a solution for this problem?

    Monday, March 05, 2012 9:50 AM

Answers

  • If you have already configured one or more switches in Hyper-V, run the PowerShell cmdlet Get-VMSwitch and see what the output is.

    Chuck Timon Senior, Support Escalation Engineer (SEE) Windows 8 Beta Engineer Microsoft Corporation

    Wednesday, March 07, 2012 6:27 AM

All replies

  • Is the network card on this host installed and working properly?


    --Joseph [MSFT] http://blogs.technet.com/b/joscon/

    Monday, March 05, 2012 10:55 PM
  • If you have already configured one or more switches in Hyper-V, run the PowerShell cmdlet Get-VMSwitch and see what the output is.

    Chuck Timon Senior, Support Escalation Engineer (SEE) Windows 8 Beta Engineer Microsoft Corporation

    Wednesday, March 07, 2012 6:27 AM
  • I had the same problem,

    I ran Get-VMSwitch and get:

    Get-VMswitch : Generic failure

    At line:1 char:1
    + Get-VMswitch
    + ~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Get-VMSwitch], ManagementException
        + FullyQualifiedErrorId : Unspecified,Microsoft.HyperV.PowerShell.Commands.GetVMSwitchCommand

    Thursday, June 28, 2012 6:46 AM
  • I have the same problem, I ran Get-VMSwitch and get like T-Mek. Any help please
    Friday, July 13, 2012 12:06 AM
  • I am having the same issue. it was working but when changing network cards the virtual switch manager became unstable. Any way to tell the virtual switch manager to re-run the initial setup or refresh?

    Monday, August 20, 2012 2:00 PM
  • This must be a new error message that was introduced in Windows 8 / Server 2012.  The only search result I got when looking up this error message was this thread.

    What finally ended up working for me was the nvspscrub script: http://archive.msdn.microsoft.com/nvspscrub

    This will remove **ALL** Hyper-V switching components, whether or not they are in a faulty state.  It will be as though you'd never setup virtual switching at all.  Then you can start over, and it will hopefully work again.

    (In my case, it was switching from a wired to a wireless NIC that screwed up the virtual switch configuration.  This problem also led to a minute-long timeout in IE startup, which did not affect any other browser.  Finally resolved the problem in IE by turning off Automatic LAN configuration.)

    Saturday, September 08, 2012 3:20 AM
  • I have a Windows Server 2012 installation and I started getting that error as well.  I tried the nvspscrub script but when I run it with the /p switch it end up crashing on me.

    This is very distressing.  I have all my VMs just sitting there like dead ducks....

    Any registry hacks that might work?

    Friday, September 14, 2012 7:59 PM
  • I ended up removing the Hyper-V role, rebooting the server and then adding it back in.  That solved the problem.
    Friday, September 14, 2012 9:05 PM
  • I have the same problem in Windows 8. The Hyper-V Extensible Virtual Switch was missing on my ethernet adapter.

    I resovled the problem by:

    1. Add the Hyper-V Extensible Virtual Switch protocol to the physical ethernet adapter inside Windows 8.

    2. Reconfigure the ethernet in the Hyer-V Manager -> Virtual Switch Manager.

    3. Reconfigure each ethernet adapter on all the hyper-v client machines beacuase the virtual switchs has been changed.

    Monday, October 01, 2012 2:44 PM
  • HI,

    I have the same problem and when I run Get-VMSwitch command I get the following error: Generic Error

    The problem it is related that my Network Adapter doesn't have Hyper-V switch protocol, I disable it because I was trying to give it a static ip to access it from another machine.

    Now, the emulator doesn't work and I don't know how can I reset the network adapter to be able to have Hyper-V protocol.

    And because this problem as well, I cant add the adapter in the Hyper-V Switch manager as well, since the Hyper-V protocol is not enabled on the adapter.

    Any help is appreciated in this stopper issue.


    Mostafa Arafa Elzoghbi

    Sunday, March 24, 2013 10:16 PM
  • I have had exactly same problem on my Lenovo S430 notebook and Window 8 Enterprise. I tried to re-install "Hyper-V" feature and to install fresh NIC drivers, run Get-VMSwitch cmdlet and nvspscrub.js script - all of these actions did not help to solve the problem.

    To resolve this bug I added "Hyper-V Extensible Virtual Switch protocol" to the physical ethernet adapter on the NIC properties page. I not enabled it, only added in the list. And right after that  Virtual Network Manager starts without any messages or errors.

    Thank you Dan Sandqvist for a good solution!

    Wednesday, May 08, 2013 8:01 AM