none
Unable to open COM1. Please check your port settings

    Question

  • I have some XP SP2 workstations that are utilized in the plant.  I use Clonezilla to reimage the workstations (yes, we have valid licenses for all units) when we have to replace a hard drive or have warranty work that requires a new install.  We have devices set up on specified comm ports.  The printer is attached to COM1.  When I test the unit to make sure all devices work, the printer test will not open COM1.  When I use Hyperterminal to test COM1, I get the message "Unable to open COM1. Please check your port settings."  I've checked the BIOS of a working station and compare it to the non-working station.  All information matches correctly.  When I check COM1 property resources, the problem station looks identical to the good station, and not conflicts.  IRQ 04 is the current setting.  To get the reimaged workstation to open COM1, I open COM1 properties, resource tab, un-check then re-check the "Use automatic settings" box without applying the un-check status.  After re-checking the "Use automatic settings", I click OK.  I then go back to see what the settings are.  It has changed to IRQ 07.  This change works until the workstation has been rebooted then these steps have to be applied again.  Also, if I perform these same steps on a workstation, I get the same results with the IRQ change.  I do not have the problem with any comm ports except COM1.  We're using canned software.  Changing to use a different comm port is not an option.

    It appears the cloning process causes the problem.  Clonezilla is fast and reliable except for what appears to be a comm port problem.  I'm looking for anyone that can tell me what setting(s) I can change to make COM1 to work without having to go through additional steps after restarting the workstation.

    Thanks,
    Rick
    Friday, July 08, 2011 1:50 PM

Answers

All replies