none
Access denied to external Hard Drive on Windows 7?

    Question

  • Hey,

    Thanks in Advance for your help. Yesterday I downloaded and installed Windows 7 (which looks like its going to be a massive improvement on Vista!!). Though I had a problem when I tried to open my external Hard drive (which is an Internal hard drive in an enclosure ":H"). An error message pops up every time I double click it saying that access to this drive is denied.

    This used to happen when I would change from PC to PC but was able to fix it using instructions from this Link http://www.le.ac.uk/cc/dsss/docs/acls2.shtml

    Any help would be much appreciated.
    Regards
    Jordan
    Monday, July 13, 2009 8:50 PM

Answers

  • Check disk management. I had this same problem and had to initialize the hdd in disk management.
    1. click on start
    2. type administrative tools
    3. click on computer management
    4. click on disk management
    5. the drive you want will show as a "foreign" hdd
    6. right click and choose import foreign disk
    7. ENJOY

    Hope this helps,
    PB
    Wednesday, July 15, 2009 3:29 AM

All replies

  • Check disk management. I had this same problem and had to initialize the hdd in disk management.
    1. click on start
    2. type administrative tools
    3. click on computer management
    4. click on disk management
    5. the drive you want will show as a "foreign" hdd
    6. right click and choose import foreign disk
    7. ENJOY

    Hope this helps,
    PB
    Wednesday, July 15, 2009 3:29 AM
  • i have the same issue.
    the disk doesn't show up as foreign in disk management, it was formatted as NTFS in XP

    Running cmd & doing a dir shows all the files on the drive

    Trying to take permisson of all the objects doesn't work either, even though it looks like windows can enumerate all the files & folders on the drive
    Wednesday, July 15, 2009 1:08 PM
  • i have the same issue.
    the disk doesn't show up as foreign in disk management, it was formatted as NTFS in XP

    Running cmd & doing a dir shows all the files on the drive

    Trying to take permisson of all the objects doesn't work either, even though it looks like windows can enumerate all the files & folders on the drive

    I had this exact same problem as well.

    When I ran in safe mode, I found that I could at least search the contents of the drive, but I couldn't move anything. Once I took permission and ownership of the drive and all subfolders etc. I found that I could access the files in safe mode.

    I'm currently in the process of copying the files to my desktop and backing them up on disks. Once this is done, I guess I will just reformat the drive (that is assuming I don't get blocked from doing so).

    This seems like a pretty cumbersome work around, and I'd like to think there's an easier way...

    From activity on other forums, it looks like this is one of the principal problems with Windows 7; namely that using an administrator account doesn't give you complete, unrestricted access to everything on your computer.
    Monday, March 08, 2010 9:40 PM
  • Hey,

    I had that same Problem retrieving data from a crashed laptop hd. I read all forums and tried all the security related tweaks... still no access to my HD.

    The solution then was a last call try: i plugged my HD into a macbook. worked like a charm, no seccurity denied issues. could get all my data. after that, I formated my HD and used it under win 7. as easy as that... sometimes, apple seams to be worth a try ;-).

     

    Farahead

    Tuesday, April 13, 2010 12:16 PM
  • After 12 months of trying every answer in every forum, I gave up, I could either chuck the 640G hard drive - or I could format the drive. So that's the solution, lose all of your data but keep the drive, in my case I lost all the family photos that I'd scanned in over the years. Thanks eveyone in many many forums for your hints & advice. My external harddrive is now connected to my pc & running perfectly, It is recognised every time & I now have no problems with it. By the way my pc now runs on Ubantu as we have ditched windows 7 & windows vista from both of our pcs. If we ever buy another computer, it will be a Mac.
    Thursday, March 10, 2011 9:51 PM
  • Check disk management. I had this same problem and had to initialize the hdd in disk management.
    1. click on start
    2. type administrative tools
    3. click on computer management
    4. click on disk management
    5. the drive you want will show as a "foreign" hdd
    6. right click and choose import foreign disk
    7. ENJOY

    Hope this helps,
    PB

    I installed windows 7 ultimate, followed the steps and it is working now !!!! so happy
    Sunday, April 17, 2011 12:31 AM
  • Folks,

     

    I faced a similar problem when trying to move a NTFS formatted disk from XP to windows 7. I tried suggestions on various forums but nothing worked. Finally though, i was able to identify the root cause empirically and fix it.

     

    1. In my understanding, Windows 7 interprets the permissions on a NTFS drive very strictly. Hence while a NTFS HDD with tweaked security settings - say with only administrator access/ownership under security tab may work perfectly in XP, OS X, Ubuntu etc , Win 7 will show you access denied unless permissions for ALL of the following: AuthenticatedUsers, SYSTEM, Administrator & Users is set correctly (which is default for a newly formatted drive in windows)

     

    2. You can do this either manually by adding these one by one or by simply formatting the drive (this however is destructive for data).

     

    3. I therefore simply set the permissions correctly AFTER taking ownership of the drive and I was able to access the drive just fine.

     

    4. To prove that its merely a permission issue where Windows 7 is arguabily behaving correctly, before making any permission changes, try booting your computer in Safe Mode and you should be able to access your data just fine while you are in the Safe Mode.

     

    5. Lesson for me was to be very careful with NTFS permissions, especially while removing those present by default.

     

    6. I managed to solve the issue before seeing this thread. Hence i do not know if "foreign drive" solution below would have worked in my case.

     

    To Microsoft: This solution should be WAY more easier to find on the net. Hell, its shouldn't even be a be a problem! Windows should be able to reset the permissions to default with a single click on a non encrypted NTFS drive if the person trying to do this has the administrator access.

     

    Hope this allows people to save time and data.

     

    Cheers!

    • Proposed as answer by BStuffer Sunday, May 08, 2011 9:38 AM
    Sunday, May 08, 2011 9:37 AM
  • Great thanks!

    As suggested here, I changed NTFS permissions to full control for SYSTEM, PC Admins, and current user and I was able to see the drive

    Good work

    Friday, June 24, 2011 2:59 PM
  • Thanks BStuffer, this was the key to unlocking my problem.

    I had an "Access Denied" on a healthy NTFS drive. The permissions tab in Explorer was giving me trouble.

    Strangely, the best way for me to change permissions was by going into Computer Management (see above) and right-clicking and selecting Properties/Security from there. I expected this to be the same as explorer, but it worked better.

    I copied the permissions from a working drive, and bingo!

    Friday, July 08, 2011 10:50 PM
  • Thanks BStuffer.  Setting the AuthenticatedUsers, SYSTEM, and Administrator privileges via Computer Management as indicated by BStuffer and Astrid02 worked like a champ for me too.  I did this on a system with Windows 7 Pro to re-gain access to a drive connected via external USB enclosure that had Windows Vista Home Premium installed.
    Saturday, August 13, 2011 5:07 PM
  • Hi All,

    I have same problem and tried everything suggested by various members of this & other forums but failed to resolve this problem. I have followed below approaches but encountered some or the other blockers in all:

    1. Tried taking owership : I tried taking the ownership however, got the below error when clicked on Ok. I got the same error while taking ownership in advanced settings.

      2. Tried TakeOwn in elevated command mode: Tried to take ownership through televated command prompt and got the same error "Access Dened" there as well.

      3. Tried to take & explore the drive in safe mode, but there as well faced the same issue.

    Interesting part is that this issue is only when I try to access my hard disk on my system. It works perfectly fine on other systems. It seems there have been some changes done in my system which is causing this issue. .

    Can somebody please help me in resolving this problem.

    Regards,

    Ratnesh Pandey

    Saturday, December 10, 2011 9:02 PM
  • Hi Vegan,

    Its "Seagate FreeAgent GoFlex 1TB"  Hard disk..

    Let me know in case you need any other information. Thanks in advance.

    Saturday, December 10, 2011 10:53 PM
  • No Vegan. It gets connected like a USB. No additional power source is required.

    Saturday, December 10, 2011 11:30 PM
  • Hi Vegan,

    Missed to add an important point tht its not only that I am facing this problem with my hard disk. I am facing this problem with Memory Card and Data Cards as well. So, it may not be problem with USB2 power.

    Kindly suggest.

     

    Saturday, December 10, 2011 11:41 PM
  • I am referring to SD Memory card & Broadband USB data card. I am using Dell Latitude E5400 laptop with windows 7 enterprise version.
    Saturday, December 10, 2011 11:50 PM
  • I confirm that setting the owner of a Windows 8 internal hard disk data partition whose size had been changed using a Paragon disk Director tool to SYSTEM, and setting *ALL* the permissions for AuthenticatedUsers, SYSTEM, Administrator & Users is set correctly (copying the default from another formatted drive or partition in Windows) worked for me.

    (I used access from Computer Management (see above) and right-clicking and selecting Properties/Security but I don't think that it is the key to success.

    I was able to CHKDSK the partition (and list contents) from the Windows 8 recovery disk, so I knew that the data was 'all present and correct'.



    Paul A. Bristow

    Thursday, December 13, 2012 10:32 AM
  • empirical observation correct Thanks for the Advice and agreed with argument against Microsoft way to locate the problem...

    Tuesday, December 18, 2012 9:52 AM
  • What worked for me was

    1. Start -> Run and type CMD

    2. Right click and run as Administator

    3. selected the drive in question i.e. mine was E drive so type : e:

    4. make sure you are in the root directory so you should see E:\ for drive E

     - If not type : cd \

    5. type : takeown /f * /r

    may work for you.

    • Proposed as answer by TeddyG68 Monday, January 07, 2013 7:44 PM
    Friday, December 21, 2012 8:51 AM
  • What worked for me was

    1. Start -> Run and type CMD

    2. Right click and run as Administator

    3. selected the drive in question i.e. mine was E drive so type : e:

    4. make sure you are in the root directory so you should see E:\ for drive E

     - If not type : cd \

    5. type : takeown /f * /r

    may work for you.

    Bang On!

    Thank you very much!!!!

    Monday, January 07, 2013 7:44 PM
  • Hi there! i just recently experiencing the same problem as you guys, and i've tried all solution above which nothing works, and then i also noticed that i could access the disk from safe mode which indicates ownership problem with my current user. Also when i checked advaced tab in security tab, i found that my user does not present in the list , so how i fixed this problem is by simply going to safe mode, click properties on my disk, security tab, click edit button, and add my username there, annd finally click the Full control checkbox. Restarted my pc and viola! the disk is usable as usual :)

    *note that your current username can be found by "net user" command in cmd :D
    Sunday, June 30, 2013 6:55 AM
  • I tried doing this and got:

    "SUCCESS: The file (or folder): "F:\" now owned by user: "..." ."

    but when I try to access the hard drive I still get an "access denied" error. The hard drive is probably corrupt, or at least partially and I'm trying to do a file recovery. Any more suggestions?

    Wednesday, December 25, 2013 4:30 PM
  • I have figured out how to make it work. If you're running windows 7, do the following:

    1 restart your computer

    2 BEFORE THE WINDOWS LOGO APPEARS press and hold F8

    3 start your computer up in safe mode

    4 start windows explorer, then right click on the name of the drive and select porperties

    5 go to the security tab and click advanced then click owner

    6 click edit and then try changing the owner from there

    I'm not sure why but when I tried this normally it didn't work but it did in safe mode.

    Hope this helps.

    Tuesday, December 31, 2013 1:52 AM
  • Thank you so much brother 

    Cheers !

    Thursday, August 21, 2014 5:38 AM