none
Can't ping unqualified hostname, but nslookup resolves it

    Question

  • Hi everyone,

    I'm having a bit of trouble with my home network.  My local DNS server (dnsmasq) is assigning an entry for each host, but Windows 7 seems to be unable to use them.  For example:

    C:\>nslookup xbox
    Server:  DD-WRT
    Address:  192.168.1.1

    Name:    xbox
    Address:  192.168.1.115


    C:\>ping xbox
    Ping request could not find host xbox. Please check the name and try again.

    It's clear that the server is returning the proper response if it's queried, it's just that Windows isn't sending queries.  Here's a copy of my ipconfig /all:

     

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : MyPC
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No

     

    Wireless LAN adapter Wireless Network Connection 3:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Linksys WMP600N Wireless-N PCI Adapter with Dual-Band
       Physical Address. . . . . . . . . : 00-25-9C-07-98-F1
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2001:470:1f07:13b:225:9cff:fe07:98f1(Preferred)
       Link-local IPv6 Address . . . . . : fe80::225:9cff:fe07:98f1%26(Preferred)
       IPv4 Address. . . . . . . . . . . : 192.168.1.149(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : Sunday, October 30, 2011 8:03:31 AM
       Lease Expires . . . . . . . . . . : Monday, December 11, 2147 4:51:11 AM
       Default Gateway . . . . . . . . . : fe80::2ff:ffff:fe00:1%26
                                           192.168.1.1
       DHCP Server . . . . . . . . . . . : 192.168.1.1
       DNS Servers . . . . . . . . . . . : 192.168.1.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

     

    As you can see, Windows is configured to use the correct DNS server, it's just not sending the queries for some reason.  Other non-Windows machines on the network can both resolve and connect to hosts by name.  I've searched the forum and found issues where people want unqualified names to be expanded, but not a case like mine where the unqualified names should work as-is.  This isn't the end of the world, but any help would be greatly appreciated.  Thanks!

    Edited for additional info:

    This problem occurs with all applications, not just ping.

    Friday, November 04, 2011 2:39 AM

Answers

All replies

  • Adam Friedlander wrote:

    Hi everyone,

    I'm having a bit of trouble with my home network.  My local DNS
    server (dnsmasq) is assigning an entry for each host, but Windows 7
    seems to be unable to use them.  For example:

    C:\>nslookup xbox
    Server:  DD-WRT
    Address:  192.168.1.1

    Name:    xbox
    Address:  192.168.1.115


    C:\>ping xbox
    Ping request could not find host xbox. Please check the name and try
    again.

    It's clear that the server is returning the proper response if it's
    queried, it's just that Windows isn't sending queries.  Here's a copy
    of my ipconfig /all:

     

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : MyPC
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No

     

    Wireless LAN adapter Wireless Network Connection 3:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Linksys WMP600N Wireless-N PCI
    Adapter with Dual-Band    Physical Address. . . . . . . . . :
    00-25-9C-07-98-F1    DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . :
    2001:470:1f07:13b:225:9cff:fe07:98f1(Preferred)    Link-local IPv6
    Address . . . . . : fe80::225:9cff:fe07:98f1%26(Preferred)    IPv4
    Address. . . . . . . . . . . : 192.168.1.149(Preferred)    Subnet
    Mask . . . . . . . . . . . : 255.255.255.0    Lease Obtained. . . . .
    . . . . . : Sunday, October 30, 2011 8:03:31 AM    Lease Expires . .
    . . . . . . . . : Monday, December 11, 2147 4:51:11 AM    Default
    Gateway . . . . . . . . . : fe80::2ff:ffff:fe00:1%26
                                           192.168.1.1    DHCP Server . .
    . . . . . . . . . : 192.168.1.1    DNS Servers . . . . . . . . . . .
    : 192.168.1.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

     

    As you can see, Windows is configured to use the correct DNS server,
    it's just not sending the queries for some reason.  Other non-Windows
    machines on the network can both resolve and connect to hosts by
    name.  I've searched the forum and found issues where people want
    unqualified names to be expanded, but not a case like mine where the
    unqualified names should work as-is.  This isn't the end of the
    world, but any help would be greatly appreciated.  Thanks!

    Edited for additional info:

    This problem occurs with all applications, not just ping.

    As you don't use DNS prefixes, uncheck the "Append primary and
    connection specific DNS suffixes" under "Advanced TCP/IP settings" /
    "DNS tab" of the properties of TCP/IPv4 of your "Wireless LAN adapter
    Wireless Network Connection 3" .


    Wolfgang
    Friday, November 04, 2011 3:51 PM
  • As you don't use DNS prefixes, uncheck the "Append primary and

    connection specific DNS suffixes" under "Advanced TCP/IP settings" /
    "DNS tab" of the properties of TCP/IPv4 of your "Wireless LAN adapter
    Wireless Network Connection 3" .


    Wolfgang
    Unfortunately, that option is a radio button and not a checkbox; the only alternative is to append suffixes from the list below, and an error message is generated if the box is closed with that list empty.  There doesn't seem to be a "Resolve unqualified names as-is" setting.
    • Proposed as answer by BrinMan Friday, December 09, 2011 4:13 AM
    • Unproposed as answer by BrinMan Friday, December 09, 2011 4:13 AM
    Friday, November 04, 2011 3:57 PM
  • Hi,

    Please use Network Monitor to capture the package for the nslookup and Ping individually, then upload the log to Skydrive and post the link here.

    Download Network Monitor at http://www.microsoft.com/download/en/details.aspx?id=4865 


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, November 10, 2011 11:03 AM
  • Thanks for the link; I'll run that as soon as I get home today and post the results.
    Thursday, November 10, 2011 4:38 PM
  • I can't remember where I came across this solution, but I do believe it will "resolve" your problem.  It worked for me with the exact same scenario.

     

    The answer provided by Wolfgang is nearly there.  Under the DNS tab of the properties of TCP/IPv4 you need to change the radio button to "Append these DNS Suffixes in order" AND THEN click "Add" and for the suffix just enter a period.  "." (without the quotes of course).

     

    "Works for me."  :)

     

    Good luck.

    • Proposed as answer by BrinMan Friday, December 09, 2011 4:17 AM
    Friday, December 09, 2011 4:17 AM
  • Worked for me also.  thanks.
    Wednesday, April 04, 2012 12:07 AM
  • What worked for me: Under the "Append primary and connection specific DNS suffixes" I UNchecked the box for "Append parent suffixes of the primary DNS suffix".  So...now to find out how to set this with a GPO.  Thanks for the tips.
    • Proposed as answer by TigeraUna Saturday, November 02, 2013 6:03 AM
    Friday, June 08, 2012 12:01 PM
  • BrinMan's solution worked for me
    Monday, November 05, 2012 3:42 AM
  • Had the same issue. JayMan's solution worked for me, unchecking the "Append parent suffixes of the primary DNS suffix" box. If I manually entered ".", I could ping my_local_machine.lan (.lan is my DNSMasq domain), but pinging my_local_machine (without .lan) would not work. expand-hosts is in my DNSMasq config and it works elsewhere, as well as with nslookup on this box. So just uncheck that "Append parent" box and you should be all set. Thanks everyone!
    Saturday, November 02, 2013 6:02 AM