none
USB to ATA/ATAPI Bridge show but cant read the drive

    Question

  • I recently upgraded to studio 456 with win7 64. I kept my old drive to retrieve all documents thinking i could just put it in an external case plug it in and walla. But no. Why not. Its slaved and the system sees it but i cant figure out how to get my data?
    Wednesday, December 16, 2009 1:56 AM

Answers

All replies

  • I recently upgraded to studio 456 with win7 64. I kept my old drive to retrieve all documents thinking i could just put it in an external case plug it in and walla. But no. Why not. Its slaved and the system sees it but i cant figure out how to get my data?
    I have the exact same issue. I plugged an Drive enclosure and my laptop recognizes it as a USB to ATA/ATAPI Bridge but will not let me browse it.
    Wednesday, December 16, 2009 2:58 AM
  • Couple of things you guys could do. Check and make sure that any jumper on that drive is set to MASTER and give it a whirl, if that doesn't work, change the jumper to Cable Select but I think on my older external cases, I normally set the jumper to Master.  Its possible you might have to go into Computer/Manage/Disk Management and initialize the drives (or just see what the status is). Let me know.
    MCSE, MCSA, MCDST
    Wednesday, December 16, 2009 5:06 AM
  • Hi,

    Does it appear in disk manager? Does it have any Drive letter?

    You can also apply the hotfix discussed below:

    http://social.technet.microsoft.com/Forums/en-US/w7itprohardware/thread/38f25c1d-de67-4c74-8845-2cd3a15d8e41

    This hotfix will update your usb related driver.
    Wednesday, December 16, 2009 8:05 AM
  • Thanks for your suggestion.  I just connected a 1 TB seagate drive using USB to ATA/ATAPI bridge and the drive is getting detected in my windows 7, but disk is not getting mounted though.  After initializing in Disk Manager, I am now able to see the drive.  Thanks so much!
    Friday, October 08, 2010 12:06 PM
  • Thanks, I had the same problem.  I have Win 7 64.  Right clicking on My computer and using the disk manager worked.  I am so used to everything recognizing everything, that it never occurred to me that I might have to ask Windows to use the new hard as a hard drive.  :)   Thanks again. 
    Tuesday, February 08, 2011 4:55 PM
  • Brilliant. Sorrow67 has outlined directly above exactly what I did to solve the problem except I'll just add that I formatted my hard drive with the following settings:

    1. Default Cluster Unit Allocation size (I think it might be 512 bytes?). I looked it up and since I have files of all sorts of sizes, the best allocation size is the default one. Warning: Unit Allocation Size greater than 4kB means you won't be able to defragment. Read more at http://technet.microsoft.com/en-us/library/cc767961.aspx

    2. Do not enable compression for best hard drive performance. Even copying a file from one part of the drive to another, it needs to decompress, move the file and then recompress!

    3. Quick format is all that is necessary if it is a new hard drive. Regular format if you are worried about others accessing your files that were on there before, but then it is probably advisable to use hard drive scrambler/shredder software to do that. If you already had files on it beforehand, I don't know whether you would actually need to use the Disk Manager in the first place though!

     

    Thursday, February 10, 2011 9:16 AM
  • i have the same problem, and i think i might have tried it all! when i check out the HD in computer management it says this one is "unallocated" and i'm not able to access the files on it. any other suggestions? it reads it and everything because the usb sound goes off when i plug it in and all that
    • Edited by therealmayo Sunday, September 02, 2012 7:36 PM
    Sunday, September 02, 2012 7:35 PM