none
Resolution, Aspect Ratio & Black Bars! How to stretch screen?

    Question

  • Hi!

    I have a HP HDX 9200 series laptop computer with an ATI 2600 HD XT and running latest Windows 7 Beta and I first noticed that my games didn't streched to full screen when they weren't using the native resolution on the LCD screen (1680*1050), so, let's say, when running one of them in 1024*768, I get two huge black bars at the side! Now, this didn't happen with previouses OSes (Vista). Then, I noticed that the same happened if I went to change the Windows resolution to 1024*768, I would get the same bars at the sides while being in Windows!

    I tried downloading latest ATI W7 drivers to see if there was an option or something to stretch the image, but I couldn't find one.

    Can you please let me know how to make the screen scale to the whole display, even if it isn't in the native resolution?

    Thanks in advance.
    Thursday, April 09, 2009 6:38 PM

Answers

  • HERE'S THE SOLUTION TO THE ATI BLACK BARS PROBLEM

    It took months for me to find this on the web, so I thought I would share it here, the first hit for 'ATI Black Bars windows 7' on Google.

    1) Open Catalyst Control Center
    2) Use the drop down box at the top to click on Desktops and Displays
    3) At the very bottom where your monitors are displayed, click on the little black arrow and click "Configure".  Note that if configure does not appear, you are clicking on the wrong black triangle (you must use the one in the very bottom section).
    4) This will bring up properties for that display.  Choose "Full Screen" or "Maintain aspect ratio", whatever your preference.  If you are getting black bars on all sides, you are likely on "Centered".
    5) IF THE OPTIONS ARE GREYED OUT, as they were when I first tried this, the workaround is to lower your display resolution before attempting the above.  Once you have changed the setting, you can return your display resolution back to whatever you like and the setting will remain as your display changes (movies, games, etc).

    Hope that helps!!
    Sunday, November 08, 2009 8:56 AM
  • There won't be a tweek for this kind of behavior. You will have to wait to see what the feature complete Release Candidate does in a clean install, and report it to us in a thread there.
    Rating posts helps other users
    Mark L. Ferguson MS-MVP
    Sunday, April 19, 2009 8:04 AM
    Moderator

All replies

  • Not an answer for you but, normally to handle scaling it would be option of the video driver and/or the display panel itself, not the OS. That is not to say that maybe OS is preventing it to happen properly if such scaling was indeed selected in the driver options (CCC or whatever it is ATi calls it). But that is pretty much the only place to look for that as you've indeed attempted.
    • Proposed as answer by Tsujiku Tuesday, November 10, 2009 11:34 PM
    Thursday, April 09, 2009 6:49 PM
  • Not an answer for you but, normally to handle scaling it would be option of the video driver and/or the display panel itself, not the OS. That is not to say that maybe OS is preventing it to happen properly if such scaling was indeed selected in the driver options (CCC or whatever it is ATi calls it). But that is pretty much the only place to look for that as you've indeed attempted.

    I have to disagree, and here is why. If on the same installation running Windows Vista; even if we compare running native Windows display drivers in Vista vs native drivers in 7, in Vista the screen gets streched to fill the whole display, while in 7 the screen doesnt and instead, add 2 black bars to compensate the "missing" space.

    Now as the only variable changing seems to be the OS, that's why I'm saying that it's the responsible for this behavior.
    Thursday, April 09, 2009 7:13 PM
  • Dan, First, keep in mind that the drivers for 7 are for all intents and purposes in beta, so the OS is not the only changing variable. As such of course this may still be a bug (in your case) to be addressed. As to which party is actually responsible I couldn't say. Second, just because the driver handles certain tasks in one way on one system does not translate to doing the same in another. I agree they should but often enough don't and reasons for it may vary not in the least that the driver model or API may have changed and the OEM is not yet fully compliant. Some drivers will always provide native ( or 1:1) display, some always stretch and some will give you a choice. As an afterthought, I have no problem displaying a native resolution, or stretched on my panels using either nvidia cards' control panel options or selecting display mode on the panel itself, hence why I said you may be barking up a wrong tree. Unless someone else chimes in to actually help you resolve the problem easily enough the only thing I could suggest is to submit the Feedback to MS (via Submit Feedback link on most of your Window headers) and shoot ATi an email as well describing your issue.
    Thursday, April 09, 2009 7:48 PM
  • Yes... I understand your point Luna, and I thank you for your support. There might be other things involved causing this to happen, and what I find strange is that there are not much threads talking about it.

    I just hope there is a registry setting, ATI tweak, something that someone could contribute to make this work.

    Thanks.

    Thursday, April 09, 2009 10:15 PM
  • There won't be a tweek for this kind of behavior. You will have to wait to see what the feature complete Release Candidate does in a clean install, and report it to us in a thread there.
    Rating posts helps other users
    Mark L. Ferguson MS-MVP
    Sunday, April 19, 2009 8:04 AM
    Moderator
  • I hope there will be a tweak for this as I have had the same problem with the black bars whilst running Battlefield 1942, no matter what I did in compatibility modes still could not get it to go full screen.  I have not had that problem with Windows Vista Premium.  I have got just one suggestion least until it is resolved, you will have to set your desktop resolution to the same you are running the game at this then gives you full screen the black bars dissapear in Battlefield 1942.  Hope it helps for a while.
    Wednesday, May 06, 2009 7:03 PM
  • It's a bug, tons of users are getting this when set lower than native resolutions on desktop. Wait for the RTM version, cause this isn't video driver either your monitor, both XP and Vista stretch correctly in clean install with native default drivers.

    Monday, May 11, 2009 10:14 PM
  • It's a bug, tons of users are getting this when set lower than native resolutions on desktop. Wait for the RTM version, cause this isn't video driver either your monitor, both XP and Vista stretch correctly in clean install with native default drivers.


    Yeah... that's exactly what I meant in my post! In other versions of Windows worked that way, out of the box. mzcbr, have you found some posts / people talking about this issue? Can you please paste them here?

    @Cobra: changing the desktop resolution is the same... because EVEN the Windows desktop gets the two black bars at the side!
    Tuesday, May 12, 2009 11:19 PM
  • I found a solution!

    1. Install the lastest NVIDIA driver.
    2. Enter in NVIDIA Control Panel, choose advance settings.
    3. Go to Display -> Manage Custom Resolutions
    4. Click Create... button
    5. Fill your desired resolutions settings and GDI Refresh Rate.. (60, 75..) and click Advanced...
    6. In Timing standard, select one of the options available (GTF, DMT, CVT...) continue testing those options until you get no black borders.

    I got here: 1280x800, 75Hz, CVT, no black borders.






    • Edited by mzcbr Friday, May 15, 2009 8:56 PM
    Friday, May 15, 2009 5:15 PM
  • Hello,
    I am having the same problem with the black bars but in my case any resolution higher then 1280X800 except for 2560X1600 which is the highest setting will resalut in my desktop top being put into almost like a window mode... with a ton of black space above and below it.

    Like someone else mentioned I get this in games as well.
    I'm running a radeon x1950 in which ATI have not released any graphical drivers for yet.

    So bug or not? I am not entirly sure
    Monday, May 18, 2009 8:46 PM
  • I found a solution!

    1. Install the lastest NVIDIA driver.
    2. Enter in NVIDIA Control Panel, choose advance settings.
    3. Go to Display -> Manage Custom Resolutions
    4. Click Create... button
    5. Fill your desired resolutions settings and GDI Refresh Rate.. (60, 75..) and click Advanced...
    6. In Timing standard, select one of the options available (GTF, DMT, CVT...) continue testing those options until you get no black borders.

    I got here: 1280x800, 75Hz, CVT, no black borders.






    Does that work for the ATI ?????

    @ToddCP : yesterday I received an update from Microsoft Update of the ATI 2600 HD XT driver. You can't imagine how happy I was when I saw it that it was downloading! Then... after installation, I went to try setting my native 1600 x 1280 in 1024 x 768 and... it didn't work neither! The black bars were still appearing! I don't know what they did update but it sure as ____ didn't fix that. Although the driver release date in device properties is newer than the original (April 28 2009).

    And still ATI haven't released another driver: http://support.amd.com/us/gpudownload/windows/Pages/radeonmob_win7-64.aspx



    Tuesday, May 19, 2009 12:52 PM
  • ATI released 9.5 CC, I think that it would have the same drivers that Microsoft Update deployed (I'm downloading it now)

    In any case, the releases notes doesn't list anymore the "aspect ratio settings may not work", but neither do I see it in the list of fixed stuff. And if this is the same drivers as the Microsoft Update, then I'm swearing that it would not work neither.

    Let me know if you download this or if you can make it work!
    Wednesday, May 20, 2009 12:17 PM
  • Dan, look for a similar option that let's you choose between CVT, GVT and DMT.
    Wednesday, May 20, 2009 7:08 PM
  • Well... version 9.5 worked!!! Now it stretches the image to fit the display!

    One thing though... I'd really, REALLY love to just use the Windows drivers instead of having to install the whole CCC which is like 200 MB just to select "Fit to Panel" and that's all! So... do you know what does that option modifies? I think it must change something in the registry and the drivers picks it up to fit the display or keep the aspect ratio.

    So, what I'm going to do is to snapshot and compare the registry before and after applying the setting. If something comes along, I'll try to replicate that in the native drivers and see if it works. I'll let you know.

    Wednesday, May 20, 2009 10:41 PM
  • I found how ti fix itDo this:
    1-Go to Start
    2-Go to Control Panel
    3-Go to Nvidia Contol Panel
    In case is first time choose advanced settings
    4-Go to Display
    5-In display go to Change flat panel scaling
    6-Than go to 2
    7-Normaly the option that is selected is the "Use my display built in scaling"
    8-What you gonna do is to check the 1st one "Use nvidia Scaling"
    9-Aplly
    10-Done
    Enjoy

    In xfire: kolha
    hotmail: mykola_16@hotmail.com
    In case it didnt worked pm me.
    i hope it helped.
    28/08/2009
    Thursday, August 27, 2009 5:39 PM
  • I encountered this error today and fixed it by changing my refresh rate to 70 from 60 at 1024x768. The screen is now stretched properly. I am using nvidia (if that matters.)
    Monday, September 14, 2009 1:12 AM
  • I don't think it's a bug.  I think it's just Windows finally being smart enough to properly display aspect ratios (4:3 as opposed to 16:9, for example.)  If your resolution is set to one that is 4:3 with a widescreen monitor, it will display as 4:3 with the black bars on the sides.
    Random question: Why do you *want* to have the display stretched?  Circles will show up as ovals, faces will be disproportionate, etc.  That's been one of the more irritating things in my opinion.

    Personally, I'd prefer the black bars than having any circle in the game show up as a stretched oval (this especially with people's faces too).
    Friday, October 09, 2009 8:04 AM
  • I don't think it's a bug.  I think it's just Windows finally being smart enough to properly display aspect ratios (4:3 as opposed to 16:9, for example.)  If your resolution is set to one that is 4:3 with a widescreen monitor, it will display as 4:3 with the black bars on the sides.
    Random question: Why do you *want* to have the display stretched?  Circles will show up as ovals, faces will be disproportionate, etc.  That's been one of the more irritating things in my opinion.

    Personally, I'd prefer the black bars than having any circle in the game show up as a stretched oval (this especially with people's faces too).

    Well, I thought so at first as well, but the most major problem is that it doesn't only fix the aspect ratio, it adds black bars on all sides of the display! So if I set a resolution that has the same AR as my native, win7 adds black borders both above, under and on the sides of the picture...

    Some problems that this leads to:

    Problem 1:
    I live in a country that uses the PAL system for TV and DVDs. This means that the movie is played at 25 or 50fps. The "problem" is that my monitor only shows 60fps when run in its native resolution which will result in a jerky picture. However if I lower the resolution from 1680x1050 to 1280x800 I can set the monitor to 75Hz and movies will run smoothly. But since the resolution isn't really lowered, just simulated (it still sends a 1680x1050 signal to the monitor) I can't switch to 75Hz for that resolution

    Problem 2:
    My graphics card is not the best there is, therefore if I want to play a new game I usually run it at a lower resolution that native in order to get a decent fps (my screen interpolates quite good from lower resolutions so the amount of blur it adds is not an issue). However, when I play a game on my 22" screen I want to use 22" of my screen! Not just 19" or whatever it becomes when all the borders are added.


    I can honestly say that this is the single most annoying thing related to software that I have experienced in 10 years. I've spent hours trying to fix it but it does not want to work.
    Apart from this I have not found anything that I don't like in win7, but if this isn't fixed I'm seriously considering to move back to XP.

    Wednesday, October 14, 2009 7:46 AM
  • HERE'S THE SOLUTION TO THE ATI BLACK BARS PROBLEM

    It took months for me to find this on the web, so I thought I would share it here, the first hit for 'ATI Black Bars windows 7' on Google.

    1) Open Catalyst Control Center
    2) Use the drop down box at the top to click on Desktops and Displays
    3) At the very bottom where your monitors are displayed, click on the little black arrow and click "Configure".  Note that if configure does not appear, you are clicking on the wrong black triangle (you must use the one in the very bottom section).
    4) This will bring up properties for that display.  Choose "Full Screen" or "Maintain aspect ratio", whatever your preference.  If you are getting black bars on all sides, you are likely on "Centered".
    5) IF THE OPTIONS ARE GREYED OUT, as they were when I first tried this, the workaround is to lower your display resolution before attempting the above.  Once you have changed the setting, you can return your display resolution back to whatever you like and the setting will remain as your display changes (movies, games, etc).

    Hope that helps!!
    Sunday, November 08, 2009 8:56 AM
  • Hi,

    anyone have got a fix for onboard graphic cards? to those that are arguing why would we want a 4:3 resolution in 16:9 environment, this is my answer. I have encoutered this problem with wc3 which is something i play very very frequently. I have bought this laptop with a 16:9 screen and i used to be able to play my game on 800x600 reso in vista with no problem. now they have shrunk it so tiny that i have seriously problem seeing whats in the game. I hope MS could just leave the monitor scalling part more flexible.

    as i am working as a tech support in a company, some staffs will request to have their reso to be set as 800x600 too. it is becoz they'll have larger fonts and icons. now if this were to be disabled, we'll bound to have more complains from corporate users ~

    please help me to fix it :(
    klutch.
    Thursday, November 12, 2009 10:05 AM
  • HERE'S THE SOLUTION TO THE ATI BLACK BARS PROBLEM

    It took months for me to find this on the web, so I thought I would share it here, the first hit for 'ATI Black Bars windows 7' on Google.

    1) Open Catalyst Control Center
    2) Use the drop down box at the top to click on Desktops and Displays
    3) At the very bottom where your monitors are displayed, click on the little black arrow and click "Configure".  Note that if configure does not appear, you are clicking on the wrong black triangle (you must use the one in the very bottom section).
    4) This will bring up properties for that display.  Choose "Full Screen" or "Maintain aspect ratio", whatever your preference.  If you are getting black bars on all sides, you are likely on "Centered".
    5) IF THE OPTIONS ARE GREYED OUT, as they were when I first tried this, the workaround is to lower your display resolution before attempting the above.  Once you have changed the setting, you can return your display resolution back to whatever you like and the setting will remain as your display changes (movies, games, etc).

    Hope that helps!!

    This DOES NOT WORK for DirectX9-based ATI graphics devices on Windows 7.  In fact, there is currently NO SOLUTION to this problem if you are using a DX9-based ATI graphics device on Windows 7.

    ATI has refused to release any proper Windows 7 drivers for their DX9-based devices, so if you are running Windows 7 with such a device, then your only choice is to install the "legacy" Vista driver onto Windows 7. 

    If your computer is a laptop, this situation is made even more convoluted by the fact that ATI's driver packages refuse to install on laptops unless you use a third-party utility called "ATI Mobility Modder" to first modify ATI's driver package.   Apparently ATI wants you to get the driver from your laptop manufacturer, but since most laptop manufacturers have not bothered to release newer video drivers that really isn't a reasonable expectation on ATI's part.

    There is a bug in ATI's "legacy" Vista drivers on Windows 7 which hides the scaling/stretching options that should be present.  Normally you would find these options under the "Notebook Panel Properties" node of the treeview in the Catalyst Control Center.  They show up there fine using the same driver on Vista on the same hardware, but they are mysteriously absent when using the same driver on the same hardware on Windows 7.

    It looks increasingly unlikely that ATI will EVER update their "legacy" drivers for their DX9-based graphics devices.  It looks even more unlikely that they will ever develop proper Windws 7 drivers for these devices.  Instead they are focusing all their efforts on their newer DX10-based devices and drivers.  

    This leaves users of laptops with DX9-based ATI graphics in a particularly frustrating and stupid situation.  DirectX 9 graphics devices are perfectly adequate for running Windows 7, and therefore they should have proper Windows 7 drivers released for them by the manufacturer (ATI).  I shouldn't have to buy an entirely new laptop just so I can get a DX10-based video device just so I can get the stretching/scaling options in Windows 7.  If this were a desktop PC, I could just swap out the video card, but that's not an option on a laptop.

    Therefore, it falls on Microsoft to either (1) put pressure on ATI to fix their broken "legacy" Vista DX9 drivers to add back the scaling/stretching options when running on Windows 7, or (2) add an OS-level user option (independent of drivers) that can be used to control the resolution scaling/stretching. 

    My specific situation:
    I have an HP Compaq 6910p laptop with the ATI Mobility Radeon X2300 graphics chipset (DX9-based).  I am running Windows 7 x64 RTM.  Neither ATI nor HP supply an official Windows 7 driver for this graphics chipset, and the driver supplied by Microsoft is bare-bones (no advanced options/settings like ATI's Catalyst Control Center offers).  So I installed the latest (9.11) ATI "legacy" Vista x64 CCC package (after using ATI Mobility Modder to modify it so it will actually install on the laptop). 

    I run a lot of classic video game emulators and older games that use old 4:3 resolution modes like 800x600 or 1024x768. When they switch into these modes, I get huge black borders around all edges of the screen (top/bottom/left/right) and a tiny little viewable area right in the center of the screen.  I have to squint to see anything.  What I want -- and I don't think it's an unreasonable expectation at all -- is for the image to be stretched to fill the screen WITHOUT being distorted to change the aspect ratio.  In other words, when I switch to any 4:3 mode (like 800x600) I expect the image to completely fill my screen vertically (all the way to the top and bottom edges) but with black bars along the left/right edges so that the aspect ratio is still truly 4:3.  This is how I was able to make it work with Vista on this same laptop before, so I expect to be able to do the same thing using Windows 7.  Unfortunately there is currently no way to do that, which completely destroys my abillity to use lower resolution modes comfortably on this laptop at all.



    Friday, November 27, 2009 4:16 PM
  • GOD !!  I really love you ... i have been trying to fix this annoying problem for weeks ... Thank you very much it worked perfectly for me !
    ... But really where can i send you flowers ..

    Sunday, December 13, 2009 9:43 AM
  • More or less in addition to c0d3h4x0r: the problem still exists:

    I have upgraded my originally vista and ATI x1200 based Acer L5100 to Windows 7, and now face the same problems: older games are now displayed in their native resolution, with black bars around it. While under Vista the aspect ratio was nicely adjusted. All proposed fixes do not apply, since the latest Catalyst Control Center does not show the Display and devices option that used to be there under Vista. (The L5100 is not a notebook, but a small desktop).

    So with ATI not supporting, everybody that supports Microsoft :-) by upgrading to W7 is now left in the lurch!

    Who is to blame? I dont know, and I basically do not care, but I would really really like to have a solution for this incompatibility! 

    But it could be a step forwards if Microsoft takes a stand on this issue?



    Monday, December 14, 2009 4:04 PM
  • HERE'S THE SOLUTION TO THE ATI BLACK BARS PROBLEM

    It took months for me to find this on the web, so I thought I would share it here, the first hit for 'ATI Black Bars windows 7' on Google.

    1) Open Catalyst Control Center
    2) Use the drop down box at the top to click on Desktops and Displays
    3) At the very bottom where your monitors are displayed, click on the little black arrow and click "Configure".  Note that if configure does not appear, you are clicking on the wrong black triangle (you must use the one in the very bottom section).
    4) This will bring up properties for that display.  Choose "Full Screen" or "Maintain aspect ratio", whatever your preference.  If you are getting black bars on all sides, you are likely on "Centered".
    5) IF THE OPTIONS ARE GREYED OUT, as they were when I first tried this, the workaround is to lower your display resolution before attempting the above.  Once you have changed the setting, you can return your display resolution back to whatever you like and the setting will remain as your display changes (movies, games, etc).

    Hope that helps!!
    Thank You! This actually worked. I was wondering why those options where greyed out! I set my resolution to 1024x600 then those options became active again. I changed the setting to first maintain aspect ration then changed it to full screen. I re-set my resolution to 1280x800 again and tried a full screen game and it was stretched, no bars! Thanks!
    Tuesday, December 15, 2009 5:35 PM
  • Thank You! This actually worked. I was wondering why those options where greyed out! I set my resolution to 1024x600 then those options became active again. I changed the setting to first maintain aspect ration then changed it to full screen. I re-set my resolution to 1280x800 again and tried a full screen game and it was stretched, no bars! Thanks!

    reiciello, can you please confirm exactly what video card you have and exactly what version of Catalyst Control Center you have installed?  I'm guessing you have a DX10-capable ATI card and the corresponding "non-legacy" CCC (greater than version 9.11).
    Tuesday, December 15, 2009 6:00 PM
  • HERE'S THE SOLUTION TO THE ATI BLACK BARS PROBLEM

    It took months for me to find this on the web, so I thought I would share it here, the first hit for 'ATI Black Bars windows 7' on Google.

    1) Open Catalyst Control Center
    2) Use the drop down box at the top to click on Desktops and Displays
    3) At the very bottom where your monitors are displayed, click on the little black arrow and click "Configure".  Note that if configure does not appear, you are clicking on the wrong black triangle (you must use the one in the very bottom section).
    4) This will bring up properties for that display.  Choose "Full Screen" or "Maintain aspect ratio", whatever your preference.  If you are getting black bars on all sides, you are likely on "Centered".
    5) IF THE OPTIONS ARE GREYED OUT, as they were when I first tried this, the workaround is to lower your display resolution before attempting the above.  Once you have changed the setting, you can return your display resolution back to whatever you like and the setting will remain as your display changes (movies, games, etc).

    Hope that helps!!

    This "solution" also DOES NOT WORK on the non-legacy (DX10-based) Catalyst 9.12 Windows 7 x64 drivers.
    Step 5 does not work.  When I close CCC, switch to a lower resolution mode using the windows Display properties CPL, and then relaunch CCC, the options for sizing/scaling are still greyed out.
    My configuration: Radeon HD 4890 card, connected to an LCD panel via DVI, running Windows 7 Ultimate x64.

    Everyone who is having this problem on Windows 7 with either the DX9-based "legacy" Catalyst 9.11 drivers, or the DX10-based non-legacy Catalyst 9.12 drivers, please send feedback about this problem to AMD/ATI using this link: http://www.amdsurveys.com/se.ashx?s=5A1E27D27E29B0E3

    If enough users start complaining about the same thing directly to ATI, maybe they will finally wake up and do something about it.
    Friday, January 08, 2010 5:47 PM
  • so far i have only found it possible to stretch the aspect ratio from 4:3 (1024x768) to a 16:10 (1280x800 native res) ratio using CCC for my laptop integrated Radeon 3200.

    for some reason it allows you to change the theater mode options if you connect a second display device, even though the options apply to the 1st monitor and the second monitor is unchanged o.0

    as soon as i unplugged the second monitor the settings reverted to defaults and the theater mode screen stretch options were greyed out... i dont see why its neccesary, but perhaps its just a bug that will be fixed in a driver update or 2?

    Edit: also @ people saying its not the OS's fault, you may be right but it kind of is the OS's fault, as vista did the stretching aspect ratio to fullscreen by default, it is just missing in windows 7.... which is no bad thing since its nice to have the option of black borders.... i guess.....
    Friday, January 15, 2010 8:24 PM
  • HERE'S THE SOLUTION TO THE ATI BLACK BARS PROBLEM

    It took months for me to find this on the web, so I thought I would share it here, the first hit for 'ATI Black Bars windows 7' on Google.

    1) Open Catalyst Control Center
    2) Use the drop down box at the top to click on Desktops and Displays
    3) At the very bottom where your monitors are displayed, click on the little black arrow and click "Configure".  Note that if configure does not appear, you are clicking on the wrong black triangle (you must use the one in the very bottom section).
    4) This will bring up properties for that display.  Choose "Full Screen" or "Maintain aspect ratio", whatever your preference.  If you are getting black bars on all sides, you are likely on "Centered".
    5) IF THE OPTIONS ARE GREYED OUT, as they were when I first tried this, the workaround is to lower your display resolution before attempting the above.  Once you have changed the setting, you can return your display resolution back to whatever you like and the setting will remain as your display changes (movies, games, etc).

    Hope that helps!!

    This DOES NOT WORK for DirectX9-based ATI graphics devices on Windows 7.  In fact, there is currently NO SOLUTION to this problem if you are using a DX9-based ATI graphics device on Windows 7.

    ATI has refused to release any proper Windows 7 drivers for their DX9-based devices, so if you are running Windows 7 with such a device, then your only choice is to install the "legacy" Vista driver onto Windows 7. 

    If your computer is a laptop, this situation is made even more convoluted by the fact that ATI's driver packages refuse to install on laptops unless you use a third-party utility called "ATI Mobility Modder" to first modify ATI's driver package.   Apparently ATI wants you to get the driver from your laptop manufacturer, but since most laptop manufacturers have not bothered to release newer video drivers that really isn't a reasonable expectation on ATI's part.

    There is a bug in ATI's "legacy" Vista drivers on Windows 7 which hides the scaling/stretching options that should be present.  Normally you would find these options under the "Notebook Panel Properties" node of the treeview in the Catalyst Control Center.  They show up there fine using the same driver on Vista on the same hardware, but they are mysteriously absent when using the same driver on the same hardware on Windows 7.

    It looks increasingly unlikely that ATI will EVER update their "legacy" drivers for their DX9-based graphics devices.  It looks even more unlikely that they will ever develop proper Windws 7 drivers for these devices.  Instead they are focusing all their efforts on their newer DX10-based devices and drivers.  

    This leaves users of laptops with DX9-based ATI graphics in a particularly frustrating and stupid situation.  DirectX 9 graphics devices are perfectly adequate for running Windows 7, and therefore they should have proper Windows 7 drivers released for them by the manufacturer (ATI).  I shouldn't have to buy an entirely new laptop just so I can get a DX10-based video device just so I can get the stretching/scaling options in Windows 7.  If this were a desktop PC, I could just swap out the video card, but that's not an option on a laptop.

    Therefore, it falls on Microsoft to either (1) put pressure on ATI to fix their broken "legacy" Vista DX9 drivers to add back the scaling/stretching options when running on Windows 7, or (2) add an OS-level user option (independent of drivers) that can be used to control the resolution scaling/stretching. 

    My specific situation:
    I have an HP Compaq 6910p laptop with the ATI Mobility Radeon X2300 graphics chipset (DX9-based).  I am running Windows 7 x64 RTM.  Neither ATI nor HP supply an official Windows 7 driver for this graphics chipset, and the driver supplied by Microsoft is bare-bones (no advanced options/settings like ATI's Catalyst Control Center offers).  So I installed the latest (9.11) ATI "legacy" Vista x64 CCC package (after using ATI Mobility Modder to modify it so it will actually install on the laptop). 

    I run a lot of classic video game emulators and older games that use old 4:3 resolution modes like 800x600 or 1024x768. When they switch into these modes, I get huge black borders around all edges of the screen (top/bottom/left/right) and a tiny little viewable area right in the center of the screen.  I have to squint to see anything.  What I want -- and I don't think it's an unreasonable expectation at all -- is for the image to be stretched to fill the screen WITHOUT being distorted to change the aspect ratio.  In other words, when I switch to any 4:3 mode (like 800x600) I expect the image to completely fill my screen vertically (all the way to the top and bottom edges) but with black bars along the left/right edges so that the aspect ratio is still truly 4:3.  This is how I was able to make it work with Vista on this same laptop before, so I expect to be able to do the same thing using Windows 7.  Unfortunately there is currently no way to do that, which completely destroys my abillity to use lower resolution modes comfortably on this laptop at all.





    Well you can work past that actualy, but the option is annoying to do everytime since when i go to a lower resolution everything becomes blurry and so on.
    Heres what you do when you use a dx9 graphics card. 

    1. lower you resolution one step down. I use 1680x1050 so i went to 1600x1024.
     You should have the black bars lower bottom on the side different to everyone.
    2. Since CCC dosnt give the scaeling option under "Notebook & Panel Properties" in Advanced View
        you change to basic and do it under Quick Settings.
    3. take "Notebook & Panel Properties" on the right side in the box click on " Resize the desktop to fit the display panel" and click go change it to "Resize to fit the display panel"

    NOTE.  the trick is that it changes back automaticaly to "Do not resize" when you have your maximum resolution that is recommended by W7 thats why you need to take some other resolution.


    I know its annoying to change it all the time but its the best there is right now and atleast you got the games fit to the screen and you can change the resolution back each time but then you got to do the resize with CCC again when you want to play some games.

    Hope it was a help to you.
    • Proposed as answer by Shadur Saturday, January 16, 2010 4:01 PM
    Saturday, January 16, 2010 4:01 PM
  • Well you can work past that actualy, but the option is annoying to do everytime since when i go to a lower resolution everything becomes blurry and so on.
    Heres what you do when you use a dx9 graphics card. 

    1. lower you resolution one step down. I use 1680x1050 so i went to 1600x1024.
     You should have the black bars lower bottom on the side different to everyone.
    2. Since CCC dosnt give the scaeling option under "Notebook & Panel Properties" in Advanced View
        you change to basic and do it under Quick Settings.
    3. take "Notebook & Panel Properties" on the right side in the box click on " Resize the desktop to fit the display panel" and click go change it to "Resize to fit the display panel"

    NOTE.  the trick is that it changes back automaticaly to "Do not resize" when you have your maximum resolution that is recommended by W7 thats why you need to take some other resolution.


    I know its annoying to change it all the time but its the best there is right now and atleast you got the games fit to the screen and you can change the resolution back each time but then you got to do the resize with CCC again when you want to play some games.

    Hope it was a help to you.

    Actually, this approach is not a solution, because as soon as you launch a full-screen game or emulator (such as MAME) that tries to set the resolution mode itself, the scaling/stretching setting gets overridden and you get the default behavior.

    Saturday, January 16, 2010 4:08 PM
  • Hmm so far this has worked for me and havent seen anything else help me so far.

    I did try to change the resolution then put "Resize to fit the display panel" and then went back to my max resolution but it overrided CCC and automaticaly put it back to "Do not resize" but when i left it at a lower resolution it didnt change it and it worked for the games as well  and all the games ive tried so far are not centerd but stretched.

    Im using ATI Mobility Radeon X1600 with "Ati Mobility Modder" modded desktop drivers.
    Saturday, January 16, 2010 7:30 PM
  • Thank you times infinity.
    Monday, January 18, 2010 8:15 PM
  • Hey Amigo, THIS IS THE SOLUTION!!!!! You GOT IT !!!!!!!!!
    THERES IS THE REAL REAL REAL REAL SOLUTION FOR ATI THANKS A LOT MAN!!!!!!!!

    I give you 100/10 man!

    Schnutzli is really right when he said :

    1) Open Catalyst Control Center
    2) Use the drop down box at the top to click on Desktops and Displays
    3) At the very bottom where your monitors are displayed, click on the little black arrow and click "Configure".  Note that if configure does not appear, you are clicking on the wrong black triangle (you must use the one in the very bottom section).
    4) This will bring up properties for that display.  Choose "Full Screen" or "Maintain aspect ratio", whatever your preference.  If you are getting black bars on all sides, you are likely on "Centered".
    5) IF THE OPTIONS ARE GREYED OUT, as they were when I first tried this, the workaround is to lower your display resolution before attempting the above.  Once you have changed the setting, you can return your display resolution back to whatever you like and the setting will remain as your display changes (movies, games, etc)

    Thanks a Million aMigo thanks thanks thanks thanks , you cAN't know how i'm Happy at the moment !!!!!
    Purkillah2036, 
    a really happy guy at the moment!!!!!
    Saturday, February 06, 2010 7:40 AM
  • Hey Amigo, THIS IS THE SOLUTION!!!!! You GOT IT !!!!!!!!!
    THERES IS THE REAL REAL REAL REAL SOLUTION FOR ATI THANKS A LOT MAN!!!!!!!!

    I give you 100/10 man!

    Schnutzli is really right when he said :

    1) Open Catalyst Control Center
    2) Use the drop down box at the top to click on Desktops and Displays
    3) At the very bottom where your monitors are displayed, click on the little black arrow and click "Configure".  Note that if configure does not appear, you are clicking on the wrong black triangle (you must use the one in the very bottom section).
    4) This will bring up properties for that display.  Choose "Full Screen" or "Maintain aspect ratio", whatever your preference.  If you are getting black bars on all sides, you are likely on "Centered".
    5) IF THE OPTIONS ARE GREYED OUT, as they were when I first tried this, the workaround is to lower your display resolution before attempting the above.  Once you have changed the setting, you can return your display resolution back to whatever you like and the setting will remain as your display changes (movies, games, etc)

    Thanks a Million aMigo thanks thanks thanks thanks , you cAN't know how i'm Happy at the moment !!!!!
    Purkillah2036, 
    a really happy guy at the moment!!!!!

    Actually, these instruction still aren't right.  The GPU scaling options will ONLY appear if the resolution is set to less than maximum AND YOUR MONITOR REFRESH RATE IS SET TO 60 Hz.   If you switch to a lower mode like 1024x768 but your monitor refresh in that mode is, say, 75Hz, then the options will still be greyed out. 

    Also, these instructions are only applicable to the new "non-legacy" Catalyst drivers for ATI graphics hardware that support DirectX 10 (i.e. the "HD" series products).  If you have an older ATI graphics card that only supports DirectX 9 (i.e. the "X" series products) then you have to use the old "legacy" Catalyst drivers, which have a completely different Catalyst Control Center that these instructions don't work for.

    So allow me to revise Schnutzli's instructions:

    WORKAROUND _ONLY_ FOR DIRECTX-10-BASED ATI CARDS ONLY (E.G. THE "HD" SERIES CARDS) USING THE NON-LEGACY CATALYST DRIVERS:

    1) Open Catalyst Control Center.
    2) From the "Graphics" menu at the top-left corner, click "Desktops & Displays".
    3) At the very bottom where your monitors are displayed, click on the little black arrow on the monitor you care about and click "Configure".  Note that if configure does not appear, you are clicking on the wrong black triangle (don't click on the one on the large monitor in the center area; you must click on the one on the tinty monitor icon in the bottom section).
    4) This will bring up properties for that display, including GPU scaling options ("Full Screen", "Maintain aspect ratio", "Centered").
    5) Check the box labeled "Enabled GPU Scaling" and click the "Apply" button.
    6) I
    F THE GPU SCALING OPTIONS ARE STILL GREYED OUT / DISABLED, continue to step 7.
    7) From the "Graphics" menu at the top-left corner, click "Desktop Properties".
    8) Change to a lower desktop resolution (such as 1024x768) and change the monitor refresh rate to 60Hz, and click the "Apply" button.
    9) Go back to Step 1 and repeat these instructions until you get to Step 6 again.  At that point the GPU scaling options should no longer be disabled.
    Saturday, February 06, 2010 1:59 PM
  • Open up regedit

    HKLM\System\ControlSet001\Control\GraphicsDrivers\Configuration

    Click on display listed, should see 00 subkey and if multiple displays 01. Click those and change scaling to 3

    Reboot.

     

    No need for ati control panel. I use this at college I work for.

     

    A guy made a program that does this for  you, but only works on the first display listed in the registry.  Search agentgod  ati fix

    • Proposed as answer by MedievalSpawn Saturday, July 17, 2010 3:46 AM
    Monday, May 03, 2010 6:24 PM
  • Open up regedit

    HKLM\System\ControlSet001\Control\GraphicsDrivers\Configuration

    Click on display listed, should see 00 subkey and if multiple displays 01. Click those and change scaling to 3

    Reboot.

     

    No need for ati control panel. I use this at college I work for.

     

    A guy made a program that does this for  you, but only works on the first display listed in the registry.  Search agentgod  ati fix


    This is the actual solution. Confirmed even for other displays such as Intel. Old games like Warcraft and Starcraft wont strech.

    • Proposed as answer by Clyde So Saturday, July 24, 2010 12:38 PM
    Saturday, July 17, 2010 3:48 AM
  • A solution for people with ATI HD x cards with problems with black bars running on windows 7.

    1) Open CCC (recent version)

    2) Go to Desktop and Display

    3) Go to the bottom where monitors are displayed and select configure

    4) click on the scaling options tab and set the overscan 0%

     

    This should stretch 1080p out to fit the ratio of the screen. No need to set the resolution lower.

    I'm not sure if all ATI cards do this but mine was definitely set default with black bars.

    Saturday, July 24, 2010 12:47 PM
  • Thanx soooo much. The black bars on the sides of my games were driving me crazy. I followed ur directions and it worked. I am so excited. Thanx again. You really made me happy. Cheers
    Saturday, August 07, 2010 10:00 PM
  • THX SO MUCH M8!!NO WONDER I COULDNT FIND IT LOL!!i did exactely what you said and it worked.i got naw my screen on 1080xwhatever and my screen its full no more black bars.love it.but i have to say that im very desapointed with both windows 7 and ati for not making this easyer,such a big important option maybe the most important and they hide it from hus.like theres options for nonthes like shadows and pixels but they manage to hide how to scale the screen to full.anyaway disapointed.but naw im happy thx to you Schmutzli,no wonder it took you months to find out about this.THX FOR CAMING FORWARD.

    Saturday, August 14, 2010 9:46 AM
  • I'm an old man 65 to be exact!! I tried dell, hp, e-machine, and toshiba with the same results with windows 7. When you try to move to a resoulation you can read, ie, 600 x 800 black bars appear on each side and essentually a 17 inch screen becoms 9 x 5. I cannot read this size nor do the games fit. Vista doesn't have the problem as all resoulations expand to fit the screen. I had to retro-buy a laptop with windows vista or earlier to solve my problem!!!!!! All the new systems have this windows 7 ____!!!! I can't believe no one has talked about this as most older people couldn't possibly read the resolutions available without magnifing glasses. Additionally, games we normally see easily full screen now are cut off on the bottom!!!! Hay who tested this thing!!!! 
    Wednesday, September 01, 2010 9:31 PM
  • Unfortunately, I can't agree fully to each "solution found" message from here. I've experimented long enough with this interesting problem, and all I can say for certain is this: 1) Windows 7 changed the graphics driver model again (XP: XPDM, Vista: WDDM 1.0, 7: WDDM 1.1), and not all available drivers, mostly for older cards, were updated in a correct way. 2) Whether an update did address this specific issue, is completely random. Sometimes an older driver which is outdated on other sectors, like performance, will give you the stretching ability, whereas a newer and better driver (performance and quality wise) won't give it to you. 3) And, as a special gift for ATI users: Whether your "Catalyst Control Center" will work or not, is just trial-and-error. So, you can't rely on advices based on some alterations you could make in CCC - if it's simply not available to you.

    Hence, my only recommendation is: Try whatever driver that seems to be suited to your card (older and newer), until you find one that doesn't show you the "black bars" problem. Don't tell me that could be a lengthy process. It is.


    "I think there is a world market for maybe five computers.” (Thomas J. Watson, Sr.)

    Wednesday, September 01, 2010 10:14 PM
  • Open up regedit

    HKLM\System\ControlSet001\Control\GraphicsDrivers\Configuration

    Click on display listed, should see 00 subkey and if multiple displays 01. Click those and change scaling to 3

    Reboot.

     

    No need for ati control panel. I use this at college I work for.

     

    A guy made a program that does this for  you, but only works on the first display listed in the registry.  Search agentgod  ati fix

    this answer is also very valid, this one works if you are using an awkward combo of ati graphics integrated in a notebook where the display is not oficially detected

     

    i was not allowed to configure my display through CCC and i there was no 'notebook display' settings available to me

     

    the registry fix has solved my problem, whereas all other solutions could not, thanks

    Thursday, September 02, 2010 8:22 PM
  • Hi all. Still trying to find a solution to this problem.  I have attempted some of the above instructions, but the problem is is that my laptop was upgraded from windows vista to windows 7 32 bit and when installing these programs for the drivers.. i get error message "cannot find compatible driver" something along those lines.  I still have the black bars.  Any other options? 
    Saturday, April 16, 2011 5:39 PM
  • Dan_Aykroyd,

    You can make your game stetch to full screen. You said that you are using ATI graphic Card which will always have problem with the scaling in windows 7. What is the problem? The Scaling Option is GREYED in windows 7. :) The only way to make it enable is to lower your Monitor resolution ... for example from 1900x1600 to 1024x768. The option should be availabe to you.

    If you cant find the tabs for the scaling option in ATI Catalyst Control Centre,

    >>> Go to this blog for full guide with picture >>> http://laptop-problem.blogspot.com/2011/12/games-windowsscreen-not-fully-stretch.html

    This blog also have a guide for those with the same problem but using INTEL Graphic Accelerator

    >>> http://laptop-problem.blogspot.com/2012/01/games-not-full-screen-on-laptop-with.html

    Hope this Helps!!!

    Thursday, January 12, 2012 6:28 PM
  • You'll need to install a driver and a Catalyst Centre or NVidia Control Panel first then you can do the above guide.

    Come see this guide here for Intel Graphic Accelerator with the black bar problem > >> http://laptop-problem.blogspot.com/2012/01/games-not-full-screen-on-laptop-with.html

    For ATI or NVIDIA >>>> http://laptop-problem.blogspot.com/2011/12/games-windowsscreen-not-fully-stretch.html

    Thursday, January 12, 2012 6:33 PM
  • Been looking for a solution to the ATI/Black Bars problem everywhere, and finally found the best possible and easiest solution here.

    Unbelievable that all you have to do to fix the problem is change one number using regedit.

    HKLM\System\ControlSet001\Control\GraphicsDrivers\Configuration\

    expand the bunch of numbers and letters you find there, then expand \00

    click on the 00 that appears, and in the right pane change scaling from whatever it is (in my case 4) to 3, reboot, and the problem is gone.

    Games that didn't have black bars still play fine, and games that had black bars (or were even centered in a 'black box') now play full screen without distortion.

    Easiest solution to a problem ever. This thread should be easier to find though. ;)

    Wednesday, March 07, 2012 9:03 PM
  • Yeah, one question. Where the heck is the supposed 'Catalyst Control Center'? It doesn't seem to exist at all.
    Monday, September 10, 2012 5:38 PM
  • if you have this problem open your catalyst control center click desktop management click desktop properties click 1080p and apply next click my digital flatpanel and make sure gpu scaling is enabled if not enable and apply next click scaling options to fit your screen and apply this will fix your problem
    Sunday, May 19, 2013 10:49 AM
  • Same issue and this worked!  Thanks Schmutli!
    Thursday, June 27, 2013 2:24 AM
  • Open up regedit

    HKLM\System\ControlSet001\Control\GraphicsDrivers\Configuration

    Click on display listed, should see 00 subkey and if multiple displays 01. Click those and change scaling to 3

    Reboot.

     

    No need for ati control panel. I use this at college I work for.

     

    A guy made a program that does this for  you, but only works on the first display listed in the registry.  Search agentgod  ati fix

    Here is your answer. 6910p user here. Worked like a charm, first try. 

    PS, registered just to let everyone know this was the solution. 

    Thursday, October 31, 2013 12:21 PM