none
Win7 x64 Command & Conquer Generals does not work in any compatability mode or with XP virtual machine

    General discussion

  • Win7 x64 Command & Conquer Generals does not work in any compatability mode or with XP virtual OS

    Others had reported this working but I could not get it to work at all both games just crash at startup with a Technical Difficutlites dialog box displayed.  I think it may have something to do with graphics mode switching problems, but can't really tell.

    SPECS:
    Alienware Area51 m15x  4Gb Ram, 200Gb 7200RPM internal hard-disk.  8800GTX graphics card.
    Processors: Intel(R)Core(TM)2 Extreme CPU X7900 @ 2.8 GHz

    Note: Command & Conquer III Tiberium wars works fine in Win7 x64 no compatability mode required.

    UPDATE:  I got the game working by using XP SP3 compatability mode and running as administrator.  Re-installed the game again.
    apparently it gets confused sometimes if you have more than one CD drive, picked the correct drive this time and it is working now.
    Wednesday, July 01, 2009 12:45 AM

All replies

  • Hi,

     

    This issue should not related to Windows 7. I suggest you take a clean boot to test if it is a software conflict issue.

     

    1. Click Start, type "MSCONFIG" (without the quotations) in the Search Bar and Press "Enter" to start the System Configuration Utility.

    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3. Click the "Startup" tab, click "Disable All" and click "OK".

    4. Restart the computer and test this issue in Clean Boot.

     

    Note: Clean Boot is a troubleshooting step. If some programs have been disabled, we can re-enable them later. If you see the System Configuration Utility, check the box of "Don't show this message" and then click "OK".

     

    If the issue still persist, could you please let me know the detail error message?

     

    Thanks.

    Wednesday, July 01, 2009 3:08 AM
  • hi, I'm still having problem. I did as you sad but it was the same...

    after i'm running the cd and clicked in on start game it says Generals.exe has stoped working! ............

    so damn angry.

    I've got Win7 64x  i7 prosessor cpu, 




    going crazy here

    Update: now I have repaird the game (re-install) and when I run the game it say's put in the right CD... My friend said that I could crack the game and still come online?! I won't do it unless someone give's me a good anwer why I coulden't.    I then the game as admin and in windows sp3.
    Tuesday, February 16, 2010 2:21 PM
  • I have similar specs, i7 processor and win7 Pro 64-bit. Can't get the game to start up, and it always crashed right after the splash graphic with the technical difficulties dialogue box. Has anyone figured out a way to fix that yet? I've tried various suggestions, from compatibility to mode to installing as admin, to modifying the permissions on the game folder, etc, nothing worked so far.


    I feer your pain and I'm also mortified by the fact that I have this computer which I can't play my favorite game on.

    Sunday, March 28, 2010 8:28 PM
  • I have a core i5 laptop running windows 7 home premium 64-bit with an ATI graphics card and I had exactly the same problems getting C&C Generals and Zero Hour to work.

    Good News - Have just  successfully managed to get it working, and it IS Windows 7 that causes the problem, specifically it's to do with access permissions to folders - Windows 7 blocks access to folders that Generals uses to run.

    The way I fixed it was:

    In 'My Documents' (usually at C:\users\YOURNAME\documents) there should be a folder named 'Command and Conquer Generals Data' or 'Command and Conquer Generals Zero Hour Data', which was put there when you installed the game.  You need to create a text file using notepad and save it into this folder.  However, you must click 'save as' and change the type drop-down box  from text file (.txt) to 'all files'.  Then save the file as 'options.ini'

    Before you save, paste this text into the file to get you started:

    AntiAliasing = 1
    BuildingOcclusion = yes
    DrawScrollAnchor =
    DynamicLOD = no
    ExtraAnimations = yes
    GameSpyIPAddress = 0.0.0.0
    Gamma = 50
    IPAddress = 0.0.0.0
    IdealStaticGameLOD = High
    LanguageFilter = true
    MaxParticleCount = 5000
    MoveScrollAnchor =
    MusicVolume = 55
    Resolution = 1024 768
    Retaliation = yes
    SFX3DVolume = 79
    SFXVolume = 71
    ScrollFactor = 50
    SendDelay = no
    ShowSoftWaterEdge = yes
    ShowTrees = yes
    StaticGameLOD = Custom
    TextureReduction = 0
    UseAlternateMouse = no
    UseCloudMap = yes
    UseDoubleClickAttackMove = no
    UseLightMap = yes
    UseShadowDecals = yes
    UseShadowVolumes = yes
    VoiceVolume = 100

    This is simply how the game remembers what options you picked (music volume, brightness and the like) and  you can change them once the game is running using the options menu.

    Now the key bits - firstly, make sure that you have full read/write permissions for the Command and Conquer Generals Data folder - do this by right clicking on the folder, then  properties then the security tab and change the permissions for all users.  It might also be worth making sure no files are "Read-Only" in that folder.

    Then change the game's compatibility mode by right clicking on the game in the start menu, clicking on properties and then the Compatibility tab.  I used the "Change settings for all users" button at the bottom and changed to Windows XP (SP3), as well as checking the "Run as administrator box".

    Hey presto! It worked, debunking the myth that C&C Generals will not run on 64 bit systems (as some people have been saying).  In fairness, I haven't tried online multiplayer yet, just a few skirmishes.

    Good Luck!

    Wednesday, March 31, 2010 11:03 PM
  • @PieEater

     

    Your a lifesaver! This worked for me in win7 x64

     

    Thanks.

    Thursday, April 01, 2010 12:32 AM
  • Yep, I got it to work a couple of days ago using a similar approach. Needless to say, I was so very happy :)
    Thursday, April 01, 2010 1:58 AM
  • I couldn't run it on my win7 64bit not because of the OS, but because my screen was too big.

    I hooked up a smaller LCD and made that my primary screen, and it ran first try.  I was having the "you need directx 8.1, check vid card reqs" errors btw. 

    All I had to do is lower my screen's resolution in windows before launching the games, and now it will play on my big screen.

     

    Friday, April 09, 2010 3:59 PM
  • @PieEater

     

    You seriously, just saved me from going insane!! Thank you very much for figuring this out AND for shareing it with the rest of us.

     

    Cheers!

    Saturday, April 17, 2010 4:31 PM
  • Glad to help.

    I was so frustrated by it not working (new operating systems are supposed to be a step FORWARD, not back... ;-) ) and so happy when it did work that it was definitely worth letting everyone know.

    Saturday, April 17, 2010 5:21 PM
  • So, just to conclude... if we're struggling with the annoying, less-than-useless error message at game startup then we should use the options.ini file to specify a screen resolution of about 1024 x 768, yes?

    thanks for the help!

    Jon

    Tuesday, April 20, 2010 12:56 PM
  • Yes, change the .ini file, if that doesnt work try setting the resolution of your desktop as well.
    Tuesday, April 20, 2010 2:33 PM
  • @JonathanAMoore - Not quite.  The screen resolution has little to do with the problem - C&C will set it to the maximum the game can run when you start it up.

     

    The solution is all about access permissions, and making sure that Windows 7 does not deny access to files that C&C needs to run.  My earlier post lists the method that worked for me to make sure that C&C can do everything it needs to.

     

    N.B The text in my earlier post to be copied into the new 'options.ini' file doesn't directly fix the game - it is just there so that you have something in the options file to start with.  As soon as C&C works, you can change all your resolution, volume, graphics settings etc using the in-game options menu as usual.

    Good Luck.

    Tuesday, April 20, 2010 6:30 PM
  • @PieEater - I found that both changing the screen resolution in the .ini file solved my problem as I was running the game in administrator mode anyway, but thanks for the added insight!

     

    Thanks for everyone's help, its all working now which has put paid to my social life once again.

    Tuesday, April 27, 2010 1:55 PM
  • So glad you posted this fix. Worked like a charm! Thank you!!

    Sunday, May 02, 2010 12:14 AM
  • man I was just signed up for this site just to say thank you! it worked! omg it worked!
    Friday, May 21, 2010 7:18 AM
  • For me it does not work under Windows 7 @ 64 bits... Don't know what to do, get the same technical error all the time...
    Monday, June 21, 2010 9:30 PM
  • Man, PieEater, what a life saver, I am running windows 7 32 bit, and the options.ini file worked like a charm on both generals and zero hour, thanks again.
    Tuesday, June 29, 2010 9:24 PM
  • m8 i had the same problem... here is what you are doing wrong... when you make a text file and name it options.ini it does not change the file type...

    so:

    make a text file>open it>click save as>type options.ini>and select all file types>click save

    when you do this, your file should be named just options and have a gear on type of the piece a paper as an icon... this means its an actually ini file type. now copy what they wrote, and CHANGE THE RESOLUTION TO MATCH YOURS!! run service pack 3 as administrator, and tell it to show a maximum window... should be good after that m8. gl

    Thursday, July 01, 2010 3:06 AM
  • Worked like a dream, thanks!

     

    Sunday, July 04, 2010 11:07 AM
  • it is working people do you know at the first it wont work iwas putting OPTION instead of OPTIONS   this s was my prob  thnx people very much :)

    Wednesday, July 28, 2010 10:31 PM
  • I am experiencing a similar error. a few minutes out in the game it crashes to desktop with the classic "serious error " message.

    i have been reading forums for 1 week now and still not found a solution working for me.

    even contacted EA support. and all they could tell me in the end was that my ati hd58050 was not compatible with the game.

    checked the crash info file and this is what it says:

    Release Crash at Thu Aug 05 23:12:13 2010
    ; Reason Uncaught Exception in GameEngine::update

    Last error:
    Exception is access violation
    WinMain at 401700
    Error code: EXCEPTION_ACCESS_VIOLATION
    Description: The thread tried to read from or write to a virtual address for which it does not have the appropriate access.
    Access address:0000000C was read from.

    Stack Dump:
      <Unknown>(-1) : <Unknown> 0x00841839
      <Unknown>(-1) : <Unknown> 0x009677CC
      <Unknown>(-1) : <Unknown> 0x009668F0
      <Unknown>(-1) : <Unknown> 0x0081D330
      <Unknown>(-1) : <Unknown> 0x9090C300

    Details:
    Register dump...
    Eip:00841839    Esp:0018F914    Ebp:21162D38
    Eax:00000000    Ebx:0A985A34    Ecx:0AACFC40
    Edx:0018F7B8    Esi:0AACFBE4    Edi:00000000
    EFlags:00010206
    CS:0023  SS:002b  DS:002b  ES:002b  FS:0053  GS:002b
    EIP bytes dump...

    Bytes at CS:EIP (00841839)  : 8B 57 0C A1 F0 7E A4 00 8B 08 6A 00 52 8B 53 0C 6A 00 6A 00 52 50 FF 51 70 8B 0D 40 7F A4 00 41

     

    if anyone is interested in helping me i can provide dxdiag file as well if needed.

    we are 3 friends trying to play this game.

    managed to get it work on both the other computers,

    one of them just worked right out of the box,

    the other computer needed the option ini to start the game and then i worked like a charm.

    my install works right out of the box as well expect from the crash to desktop mid game,

    its not a heat problem/all drivers up to date / DirectX up to date. etc etc

    so im out of options here.

     

    edit: tried running in xp mode sp2/sp3  and "run program as administrator"

    also tried the option ini file in the tread above with no luck.

     

     

     

    • Edited by Elah Thursday, August 05, 2010 9:28 PM edit
    Thursday, August 05, 2010 9:25 PM
  • "C:\Program Files (x86)\EA Games\Command and Conquer Generals\options.ini
    You don't have permission to save in this location.
    Contact the administrator to obtain permission.

    Would you like to save in My Documents folder instead?"


    Hey, I've tried saving the file but end up with this message above.
    If I could have any pointers on how to resolve this issue would be Amazing!

    Thanks in advance !
    Saturday, September 04, 2010 2:09 AM
  • Every time I try to launch the game it says insert the correct CD and restart the application.  How do I get it to recognize an alternate drive?

     

    As for creating this file that is easy with Notepad++ when you do a save as you can select .ini file from the dropdown menu.

    Friday, October 08, 2010 7:20 PM
  • PIEEATER YOU ARE A LEGEND. After following steps on other sites like changing general.exe and compatabiltiy mode etc etc.. which i did not understand one bit and some with the same idea as you but with a different options.ini contents i failed miserably.Your steps were way easier to follow and worked a bloody treat. I cant thank you enough mate. THANK YOU!! 

    Thursday, October 14, 2010 8:04 PM
  • That's a fisical RAM failure or could be also Hard Drive

    Saturday, October 30, 2010 7:13 PM
  • I get the same msg HELP PLZZZZ i just wasted 10 pound on this game if it doesnt work!!
    Thursday, November 04, 2010 5:55 PM
  • i get a msg saying insert correct dvd-disk and restart application!!! this didnt happen untill i did wot u said?? and ideas!!

    befour i did what u said it would load but i just got a black screen could hear sound but no picture then it would crash the whole computer and i would have to do a force shutdown!!

    Thursday, November 04, 2010 6:14 PM
  • Ok Andy, same thing happened to me in one of my games called global agenda. It could be a direct x issue (to be more simple) what u need to do is update your direct x. I will give u the link, all you have to do is download the update. And it shuld work. Otherwise i dont think i can help you.

     

    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=2da43d38-db71-4c1b-bc6a-9b6652cd92a3&displaylang=en

     

     

    If the link doesnt work then i will figure it out. Just click download haha.

    Sunday, November 14, 2010 10:38 PM
  • There is something within the Direct X download (which i dont know what it is) that will probably allow you to play. Just make sure youve done what Elah said to do before you download the direct x.
    Sunday, November 14, 2010 10:40 PM
  • Hello. I'm running Win7 Home Premium 64bit intel core i3 inside processor Intel GMA HD graphics. I have done this, and now I get a different error. "Please insert correct DVD-ROM and restart" PLEASE HELP! MUST HAVE COMMAND AND CONQUER . . . . . MUUUUST

    Saturday, December 04, 2010 12:55 AM
  • @Pie Eater,

    Thanks a lot for this!! I had actually downloaded C&C Generals as well as C&C Generals zero hour together.. the steps suggested by you worked perfectly with C&C generals but it is not working with C&C generals zero hour..I m using a Intel Core i5 64bit win 7 with a ATI radeon graphics...

    I tried all possible ways suggested but when I start the application it flashes and then crashes..

    Did any one had this issue..please help

     

    Saturday, December 11, 2010 10:20 PM
  • Thanks for all the surpport idears so far but im still hitting a wall with both cnc generals & cnc generals zero hour.

    i also have windows 7 64 bit. i have a computer more than capible to run cnc but these two games just arnt wanting to co-operate.

    first i got the message pop up saying "cant run due to technical diffulcalties" ive tried all the recomandations you guys have given such as update patches, and the options.ini file but it still doesnt work.

    i am now getting the "insert correct cd in the cd rom" message even though the cd is in the drive.

    when i install the latest patch all the games run without the disk. however generals & zero hour show the splash screen for about 2 secs then the screen goes black for another 2 secs before returing back to the windows screen.

    i had hoped that choosing window 7 would save me from these sorts of problems but its depressing to see windows vista run these games on an old laptop, when windows 7 on a much more powerfull michine cannot. (sorry for the jumbled sentence)

    does anyone have any other idears or is there something i am missing??

    lots of people world wide seem to be having similer problems. what i want to know is... is there an update that can sucsessfully deal with these problems, and are these two games the only games to experience this flaw with window 7, or are there more games with similer premission problems??

    thanks

    luke

    Update: i also have a mod for zero hour. and when trying to activate that i get a pop up massage saying cannot find generals.exe. also my sicurity when not disabled flags generals.exe  messege follows "c:\..|generals.exe behavior similer to pdm.keylogger"

    however ive tried turning of my sicurity and i just get the same result. splash screen followed by a black screen followed a return to windows. this is getting annoying.

    Wednesday, December 22, 2010 5:11 PM
  • Thanks so much for this fix - it worked first time (win 7 64 bit home prem).
    Friday, December 24, 2010 3:22 AM
  • Thank You!  Solved my win 7 64 bit problem too!
    Wednesday, December 29, 2010 5:19 AM
  • PieEater, YOU ARE A GENIUS!!! Thank you for being super easy in your instructions. Cnc Generals and Zero Hour are two of my favorite games of all time and you showed me how to overcome the Microsoft incompetency  of Win 7 and their bs!  Thank you again!
    Friday, December 31, 2010 6:14 AM
  • You're the man! Was having the same problems, after following your steps it is working for me with Windows 7 64 bit. Thanks dude.
    Saturday, January 01, 2011 10:27 PM
  • Thanks, I got the game to work. But whenever i start a game online it never connects with other players.

    Specs

    Alienware, M17x 64 bit win7

    Saturday, January 15, 2011 2:38 PM
  • does anyone know how to get the game to stop makin your base blow up after a few minutes on the challange and skir. and how to get the damn thing to go past the 1st mission in any of the factions??????????
    Friday, February 18, 2011 4:48 AM
  • I have the same problem. i have found nothing that fixes it. if you do find a fix please message me as i would love to get my game up and running again.
    Tuesday, February 22, 2011 2:27 AM
  • I am also having a problem where you instantly lose seconds into any match, regardless if the enemy ever got near you.

     

    My Specs are:

    Windows 7 Pro 64-bit

    Intel Core i5-460M 2.53Ghz

    4GB DDR3 RAM

    1GB nVidia GeForce GT 420M

    Friday, February 25, 2011 3:24 AM
  • Unbelievable! "creating options.ini and disabling read-only option for all files in Command and Conquer Generals Data directory" worked flawless.

    Now i can play my favorite games on win7 x64, thanks PieEater

    Monday, February 28, 2011 3:34 PM
  • I am experiencing a similar error. a few minutes out in the game it crashes to desktop with the classic "serious error " message.

    i have been reading forums for 1 week now and still not found a solution working for me. ive done it all somebody please help me i cant stand it its the worst ahhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhhh thank you for your time

     

    Thursday, March 10, 2011 2:20 AM
  • HI

     I am not computer friendly at all I tried understanding your description on how to make command and conquer work on windows 7 but I can't figure it out, I have a HP Pavilion dv7-4280us Entertainment PC and I just wanna figure out how I can play the game I tried EA support but they pretty much told me I was SOL. HELP PLEASE! I bought the game command and Conquer the first decade if it makes any difference.

    Wednesday, March 16, 2011 10:35 PM
  • This worked for me also, Win 7 x64 - The error I was receiving was that I did not have Direct X 8.1, or that my Graphics Card was incapable (or message to the effect) I actually am running direct X 11. Simply changing the resolution to 1024 768 from 1400 by something in the ini as mentioned fixed the problem.
    Saturday, March 19, 2011 7:18 PM
  • If you do this and then start getting the no cd/dvd error. Easy fix!

    Just set the compatibility to vista instead of xp and it should work. I did it for the root .exe's under the install directory for generals and zero hour. Not for the main launcher (maybe that would do it, idk).

    By the way. For zero hour you need to do the same thing with the options.ini file as generals. Just copy the one you put in generals data folder under my documents.

    win 7 x64

    Wednesday, March 30, 2011 9:17 PM
  • I've done what you said, but it still ain't working for me...  Anyone know what could be wrong? The crashinfo follows

     

    Release Crash at Sun Apr 03 21:28:11 2011; Reason Uncaught Exception during initialization.

    Last error:
    Exception is access violation
    WinMain at 4017f0
    Error code: EXCEPTION_ACCESS_VIOLATION
    Description: The thread tried to read from or write to a virtual address for which it does not have the appropriate access.
    Access address:06A0E000 was written to.

    Stack Dump:
    <Unknown>(-1) : <Unknown> 0x0075D209

    Details:
    Register dump...
    Eip:0075D209 Esp:0018EFE0 Ebp:00000001
    Eax:06A0E000 Ebx:069EF1A8 Ecx:0000004C
    Edx:FFFE21D4 Esi:0000005B Edi:0002337B
    EFlags:00010202
    CS:0023 SS:002b DS:002b ES:002b FS:0053 GS:002b
    EIP bytes dump...

    Bytes at CS:EIP (0075D209) : 89 38 83 C0 04 49 75 F5 4E 75 ED 5F 5E C3 90 90 90 90 90 90 90 90 90 B8 B4 4F 00 00 E8 B6 17 0E


    Current stack:
    <Unknown>(-1) : <Unknown> 0x77279ED5

    Sunday, April 03, 2011 7:29 PM
  • Thanks PieEater I have just done as you said and it looks like it is now working. Thanks Again
    Thursday, April 07, 2011 8:34 PM
  • I did the vista compatibility thing as well and it now works! yay. thanks peeps.
    Friday, April 08, 2011 5:00 AM
  • I did everthing is said here , but didnt work. the game opens , then black screen then it terminates without an error message , pls help me
    Saturday, April 09, 2011 12:41 PM
  • thanks mate it worked for me soo happy now no more frustration.
    Sunday, April 10, 2011 8:46 AM
  • yes its work for me too .. my system Win7 x64 with ATI video card .

    this is how i do .. just a little bit different compare to the above for C&C Generals :P same way goes to Zero Hour ~

    1. Install the game

    2. Patch the game to v1.07

    3. apply the Crack if wanna protect your CD => http://m0001.gamecopyworld.com/games/pc_cc_generals.shtml

    4. change generals.exe compatibility to "vista or sp1 or sp2" and "run as an administrator" (change settings for all user)
       or Windows XP SP3 if you like .

    5. open a folder name "Command and Conquer Generals Data" to "C:\Users\name\Documents" with options.ini inside
       with settings like below (slighty different with PieEater version)
     
       AntiAliasing = 1
       BuildingOcclusion = yes
       CampaignDifficulty = 2
       DynamicLOD = no
       ExtraAnimations = yes
       GameSpyIPAddress = 192.168.137.1
       Gamma = 50
       IPAddress = 192.168.137.1
       IdealStaticGameLOD = High
       LanguageFilter = true
       MaxParticleCount = 5000
       MusicVolume = 92
       Resolution = 1024 768
       Retaliation = yes
       SFX3DVolume = 91
       SFXVolume = 82
       ScrollFactor = 50
       SendDelay = no
       ShowSoftWaterEdge = yes
       ShowTrees = yes
       StaticGameLOD = High
       TextureReduction = 0
       UseAlternateMouse = no
       UseCloudMap = yes
       UseDoubleClickAttackMove = no
       UseLightMap = yes
       UseShadowDecals = yes
       UseShadowVolumes = yes
       VoiceVolume = 100

       I already make a backup for the folder so i basically just copy and paste the folder to that location with the
       options.ini inside if i reinstall.

    6. right click the "Command and Conquer Generals Data" folder properties and make sure its not "read only"
       (not sure if its necessary though cause i didnt do that the next few times when i reinstall and already delete the old
        folder)

    7. Play !!

       Thanx to PieEater again for the great solution and hope every one can play without problem with Win7 . (or may be
       edit the security settings to allow all user have full control of the generals.exe & game.dat if still cant run
       the game . right click -> properties -> security -> edit .

      
    Tuesday, April 12, 2011 9:08 AM
  • Hi every1 and especially PieEater.

    I just signed up to say thank u so much for the instructions u posted and the ease of use. I tried several other suggestions from ppl who, as it seems, know shit about solving probs with win7.

    You on the other hand are D MAN!

    Thank u and god bless u all!

    :))

    Friday, April 15, 2011 6:35 PM
  • I have a core i5 laptop running windows 7 home premium 64-bit with an ATI graphics card and I had exactly the same problems getting C&C Generals and Zero Hour to work.

    Good News - Have just  successfully managed to get it working, and it IS Windows 7 that causes the problem, specifically it's to do with access permissions to folders - Windows 7 blocks access to folders that Generals uses to run.

    The way I fixed it was:

    In 'My Documents' (usually at C:\users\YOURNAME\documents) there should be a folder named 'Command and Conquer Generals Data' or 'Command and Conquer Generals Zero Hour Data', which was put there when you installed the game.  You need to create a text file using notepad and save it into this folder.  However, you must click 'save as' and change the type drop-down box  from text file (.txt) to 'all files'.  Then save the file as 'options.ini'

    Before you save, paste this text into the file to get you started:

    AntiAliasing = 1
    BuildingOcclusion = yes
    DrawScrollAnchor =
    DynamicLOD = no
    ExtraAnimations = yes
    GameSpyIPAddress = 0.0.0.0
    Gamma = 50
    IPAddress = 0.0.0.0
    IdealStaticGameLOD = High
    LanguageFilter = true
    MaxParticleCount = 5000
    MoveScrollAnchor =
    MusicVolume = 55
    Resolution = 1024 768
    Retaliation = yes
    SFX3DVolume = 79
    SFXVolume = 71
    ScrollFactor = 50
    SendDelay = no
    ShowSoftWaterEdge = yes
    ShowTrees = yes
    StaticGameLOD = Custom
    TextureReduction = 0
    UseAlternateMouse = no
    UseCloudMap = yes
    UseDoubleClickAttackMove = no
    UseLightMap = yes
    UseShadowDecals = yes
    UseShadowVolumes = yes
    VoiceVolume = 100

    This is simply how the game remembers what options you picked (music volume, brightness and the like) and  you can change them once the game is running using the options menu.

    Now the key bits - firstly, make sure that you have full read/write permissions for the Command and Conquer Generals Data folder - do this by right clicking on the folder, then  properties then the security tab and change the permissions for all users.  It might also be worth making sure no files are "Read-Only" in that folder.

    Then change the game's compatibility mode by right clicking on the game in the start menu, clicking on properties and then the Compatibility tab.  I used the "Change settings for all users" button at the bottom and changed to Windows XP (SP3), as well as checking the "Run as administrator box".

    Hey presto! It worked, debunking the myth that C&C Generals will not run on 64 bit systems (as some people have been saying).  In fairness, I haven't tried online multiplayer yet, just a few skirmishes.

    Good Luck!

    Good job man! This works! Win 7 x64 here...
    Sunday, May 08, 2011 3:34 PM
  • I friggin love you! Thanks a billion, man! <3
    Saturday, May 28, 2011 9:47 AM
  • I have a core i5 laptop running windows 7 home premium 64-bit with an ATI graphics card and I had exactly the same problems getting C&C Generals and Zero Hour to work.

    Good News - Have just  successfully managed to get it working, and it IS Windows 7 that causes the problem, specifically it's to do with access permissions to folders - Windows 7 blocks access to folders that Generals uses to run.

    The way I fixed it was:

    In 'My Documents' (usually at C:\users\YOURNAME\documents) there should be a folder named 'Command and Conquer Generals Data' or 'Command and Conquer Generals Zero Hour Data', which was put there when you installed the game.  You need to create a text file using notepad and save it into this folder.  However, you must click 'save as' and change the type drop-down box  from text file (.txt) to 'all files'.  Then save the file as 'options.ini'

    Before you save, paste this text into the file to get you started:

    AntiAliasing = 1
    BuildingOcclusion = yes
    DrawScrollAnchor =
    DynamicLOD = no
    ExtraAnimations = yes
    GameSpyIPAddress = 0.0.0.0
    Gamma = 50
    IPAddress = 0.0.0.0
    IdealStaticGameLOD = High
    LanguageFilter = true
    MaxParticleCount = 5000
    MoveScrollAnchor =
    MusicVolume = 55
    Resolution = 1024 768
    Retaliation = yes
    SFX3DVolume = 79
    SFXVolume = 71
    ScrollFactor = 50
    SendDelay = no
    ShowSoftWaterEdge = yes
    ShowTrees = yes
    StaticGameLOD = Custom
    TextureReduction = 0
    UseAlternateMouse = no
    UseCloudMap = yes
    UseDoubleClickAttackMove = no
    UseLightMap = yes
    UseShadowDecals = yes
    UseShadowVolumes = yes
    VoiceVolume = 100

    This is simply how the game remembers what options you picked (music volume, brightness and the like) and  you can change them once the game is running using the options menu.

    Now the key bits - firstly, make sure that you have full read/write permissions for the Command and Conquer Generals Data folder - do this by right clicking on the folder, then  properties then the security tab and change the permissions for all users.  It might also be worth making sure no files are "Read-Only" in that folder.

    Then change the game's compatibility mode by right clicking on the game in the start menu, clicking on properties and then the Compatibility tab.  I used the "Change settings for all users" button at the bottom and changed to Windows XP (SP3), as well as checking the "Run as administrator box".

    Hey presto! It worked, debunking the myth that C&C Generals will not run on 64 bit systems (as some people have been saying).  In fairness, I haven't tried online multiplayer yet, just a few skirmishes.

    Good Luck!


    This Man is brilliant worked Perfect.......
    Friday, June 10, 2011 11:44 PM
  • DUDE! YOU ARE THE MAN!!! I'm so happy it's running now. Thank you Thank you Thank you Thank you!!!
    Wednesday, June 22, 2011 5:05 AM
  • Alright, I've tried setting compatibility mode, changing the options.ini file, and changing read only permissions, AS WELL AS:
    -Changing the installation folder
    -Changing ownership of folders under the advanced tab in security (Yes, all subfolders as well)
    -Changing to all compatibility modes

    -Running as Admin, etc.

     

    I'm currently reinstalling to see if it's a fouled registry entry, but I'm stumped.

    What's funny is I had a downloaded copy not long ago, to play while I waited for the game I bought to arrive, and it worked fine.

    I get my LEGIT copy, and it won't work.

     

    My computer can most definitely run it, I was running it on full performance.
    Any ideas?
    Any help is much appreciated, thank you :)


    -Update
    WIN!
    Another tip to add for win 7 users if your fix does not work.
    In addition to your fix, under the Compatibility tab, Make sure to disable visual themes, as I changed it, and bam, worked.
    Sunday, June 26, 2011 2:36 PM
  • does anyone know how to get the game to stop makin your base blow up after a few minutes on the challange and skir. and how to get the damn thing to go past the 1st mission in any of the factions??????????
    i have a same problem with this guy. can anybody help us to solve this problem? im getting bored with this eror.
    Sunday, July 03, 2011 11:25 AM
  • does anyone know how to get the game to stop makin your base blow up after a few minutes on the challange and skir. and how to get the damn thing to go past the 1st mission in any of the factions??????????
    i have a same problem with this guy. can anybody help us to solve this problem? i want to plaaay cnc zero hours :(
    Sunday, July 03, 2011 11:29 AM
  • Need help please..

    I already have added options.ini but I'm still unable to launch the game. When I click the icon, it tries to open the game and an image of the game displays for a sec then it flashes then it closes.. 

    can anyone please help me.. 
    Sunday, July 10, 2011 5:58 AM
  • Hey there!

    I installed it on my 2nd hardware, (F:\). Is it any difference?

    Cause it didn't work. I did everything you said. 

     

    I got a AZUS laptop, with Windows 7, x64 and I5 Core.

    I have Norton, and I KNOW that my PC is virus free for now, still, Why does it says that I got some kind of virus?

    Nether General or general zero hour (which is great games ;D) work. 

    The "menu" pops up and then the error message pops up AGAIN!

    Renegade and red alert 2/YR work just fine.

    P.S. srry for bad english.

    P.S.S It would be amazing if you could slove (or help) my problems! :D

    Thursday, July 21, 2011 11:56 PM
  • just created an account just to say thanks... youre the MAN dude!!! THANKA AGAIN for sharing!!!
    Friday, July 29, 2011 9:35 AM
  • I did exactly what Pie said and it still doesn't work. I'm running windows XP. My normal Generals works but Zero Hour doesn't. Sometimes it displays an error saying I don't have Directx 8.1 or a good enough video card, but usually it just exits after the splash screen. Is there anything else I can try?
    Monday, August 01, 2011 4:43 AM
  • Just as many others, I must thank you. The best C&C of all time is once again alive.

     

    I know im nit picking now, but is there any way to alter the resolution so that it will 1366 X 768. I seem to be having issues with this.

     

    Thanks again dude, epic save


    Update: got it working!!! SO happy
    Tuesday, August 16, 2011 12:22 PM
  • Hello,

    i have a different problem, im not sure if its linked to windows 7 or something.

    I installed command & conquer first decade. I didnt had to change anything to make it work.

    Only when i go online it says I have a different version. But my version is 1.04 and i saw this is the latest version.

    Anyone formiliar with the problem?

     

    Wednesday, September 14, 2011 10:55 AM
  • the problem is in zero hour btw
    Wednesday, September 14, 2011 11:05 AM
  •  try installing it to the program folder and not the program folder(x86) and the generals.exe the the start or where ever else and start it.  I found this out after beating my head on my desk for 4 hours installing and uninstalling it  then it came to me put it in regular program folder and it started
    Tuesday, January 24, 2012 10:44 AM
  • "copy the generals .exe"
    Tuesday, January 24, 2012 10:45 AM
  • I installed it on an winxp computer and copied the progam file over to my win7 (x86) program folder and it worked like a charm.
    Monday, February 20, 2012 12:58 AM
  • Life Saver!

    works now and you explained how to do it perfectly. 

    thanks

    Tuesday, April 17, 2012 11:46 PM
  • I just wanted to say you are awesome and thank you :)

    Sunday, April 29, 2012 2:31 AM
  • FANTASTIC. Solved my 'insert correct DVD error' on Win7 64bit. LOVE IT.

    Tuesday, November 06, 2012 9:56 AM
  • Do you have the right CD?
    Thursday, November 29, 2012 8:59 PM
  • Pie eater I just want to tell you that you are the best! I had some issues at first with following the steps but this is what I did and it worked!

    My computer specs are: Windows 7 Ultimate

                                       Intel Quad Core I7

                                       16 gb Ram

                                        512 ssd

    My issue was when I changed the options.ini I couldn't update the program. (remember to install direct x) 1. I needed to do a clean Reinstall of command and conquer generals. 2. Updated the Command and Conquer game with it's patches (and dont play the game yet). 3. got rid of the read only and Changed the compatibility to Windows XP service pack 3 and always run as administrator (make sure all users can make changes). 4. opened the options.ini, then pressed the Save as button to All Files. Then typed in options.ini

    Was good to go after that thank you! and to all the others that are skepticle. keep trying you are doing something wrong!

    PS the internet and networking worked great and I can play against everyone! Thank You!

    Sunday, December 30, 2012 1:22 AM
  • timass did u find a fix for this problem because im having the same issue :)

    i cant join multiplayer games because it says i have a different version but i dont know why. I have opened ports and reinstalled but nothing helps.

    im running windows 7 too

    Saturday, January 05, 2013 4:28 PM
  • is this the fix for the "gamer version is different" error?

    Saturday, January 05, 2013 4:31 PM
  • just like to say thankyou for this ,saved my life and sanity.only thing i done wrong.
    Tuesday, February 26, 2013 10:48 PM
  • This was a great help, as I had forgotten about the screen resolution, I am using a 26" screen on 1920x1080 and changed the setting to the BOLD info below.

    AntiAliasing = 1
    BuildingOcclusion = yes
    DrawScrollAnchor =
    DynamicLOD = no
    ExtraAnimations = yes
    GameSpyIPAddress = 0.0.0.0
    Gamma = 50
    IPAddress = 0.0.0.0
    IdealStaticGameLOD = High
    LanguageFilter = true
    MaxParticleCount = 5000
    MoveScrollAnchor =
    MusicVolume = 55
    Resolution = 1920 1080
    Retaliation = yes
    SFX3DVolume = 79
    SFXVolume = 71
    ScrollFactor = 50
    SendDelay = no
    ShowSoftWaterEdge = yes
    ShowTrees = yes
    StaticGameLOD = Custom
    TextureReduction = 0
    UseAlternateMouse = no
    UseCloudMap = yes
    UseDoubleClickAttackMove = no
    UseLightMap = yes
    UseShadowDecals = yes
    UseShadowVolumes = yes
    VoiceVolume = 100

    Good Luck!


    • Edited by amckayceng Saturday, March 23, 2013 10:42 PM
    Saturday, March 23, 2013 10:42 PM
  • PIE eater ur a beast!!

    After days of searching watching useless vids ur Comment saved me really thanks :)

    Saturday, May 18, 2013 11:42 AM
  • that's it , i give up , i tried everything you and others suggested.....i just can't make it past launching the application , it freezes with 25% of my cpu using it and around 60meg of ram loaded in the working set memory and memory private working set columns of my task manager , and after waiting for 15 seconds it will bring up the error window saying "sorry , a serious error has occurred"

    it did this when i first tried to play the game without doing anything extra and still after going through all that shit to try and get it to work , fuck everything.....

    Sunday, October 27, 2013 3:34 AM
  • I have a core i5 laptop running windows 7 home premium 64-bit with an ATI graphics card and I had exactly the same problems getting C&C Generals and Zero Hour to work.

    Good News - Have just  successfully managed to get it working, and it IS Windows 7 that causes the problem, specifically it's to do with access permissions to folders - Windows 7 blocks access to folders that Generals uses to run.

    The way I fixed it was:

    In 'My Documents' (usually at C:\users\YOURNAME\documents) there should be a folder named 'Command and Conquer Generals Data' or 'Command and Conquer Generals Zero Hour Data', which was put there when you installed the game.  You need to create a text file using notepad and save it into this folder.  However, you must click 'save as' and change the type drop-down box  from text file (.txt) to 'all files'.  Then save the file as 'options.ini'

    Before you save, paste this text into the file to get you started:

    AntiAliasing = 1
    BuildingOcclusion = yes
    DrawScrollAnchor =
    DynamicLOD = no
    ExtraAnimations = yes
    GameSpyIPAddress = 0.0.0.0
    Gamma = 50
    IPAddress = 0.0.0.0
    IdealStaticGameLOD = High
    LanguageFilter = true
    MaxParticleCount = 5000
    MoveScrollAnchor =
    MusicVolume = 55
    Resolution = 1024 768
    Retaliation = yes
    SFX3DVolume = 79
    SFXVolume = 71
    ScrollFactor = 50
    SendDelay = no
    ShowSoftWaterEdge = yes
    ShowTrees = yes
    StaticGameLOD = Custom
    TextureReduction = 0
    UseAlternateMouse = no
    UseCloudMap = yes
    UseDoubleClickAttackMove = no
    UseLightMap = yes
    UseShadowDecals = yes
    UseShadowVolumes = yes
    VoiceVolume = 100

    This is simply how the game remembers what options you picked (music volume, brightness and the like) and  you can change them once the game is running using the options menu.

    Now the key bits - firstly, make sure that you have full read/write permissions for the Command and Conquer Generals Data folder - do this by right clicking on the folder, then  properties then the security tab and change the permissions for all users.  It might also be worth making sure no files are "Read-Only" in that folder.

    Then change the game's compatibility mode by right clicking on the game in the start menu, clicking on properties and then the Compatibility tab.  I used the "Change settings for all users" button at the bottom and changed to Windows XP (SP3), as well as checking the "Run as administrator box".

    Hey presto! It worked, debunking the myth that C&C Generals will not run on 64 bit systems (as some people have been saying).  In fairness, I haven't tried online multiplayer yet, just a few skirmishes.

    Good Luck!

    thankssss!!!! you are the best!
    Tuesday, November 12, 2013 9:36 PM
  • For anyone who is having this problem with Origin downloaded Generals or Zero Hour, go to the "C:\Program Files (x86)\Origin Games\Command and Conquer Generals Zero Hour\Command and Conquer Generals" and  Zero Hour folders and delete or rename the dbghelp.dll file. Works every time 100% of the time.
    Sunday, December 29, 2013 6:01 AM
  • Mine worked fine under 64 bit windows, until I got my new xfx 7870. SOmething about its drivers. I had no issues with a 64 bit Windows running any C&C game until I just got  abrand new card previous was a 5770 Power color. But thanks, this let me run it again. Did not think that some new drivers for my card may not work with old games. I have played every game i got under windows 7 64 bit all the way back to 80's games on PC... got new card playing SWTOR, tried to run generals like what? Why isnt is working just worked the other day. Said it was direct x version like mine is too high for the 8.1 required. THis fixed it though.
    Wednesday, January 29, 2014 2:13 PM
  • I am experiencing a similar error. a few minutes out in the game it crashes to desktop with the classic "serious error " message.

    i have been reading forums for 1 week now and still not found a solution working for me.

    even contacted EA support. and all they could tell me in the end was that my ati hd58050 was not compatible with the game.

    checked the crash info file and this is what it says:

    Release Crash at Thu Aug 05 23:12:13 2010
    ; Reason Uncaught Exception in GameEngine::update

    Last error:
    Exception is access violation
    WinMain at 401700
    Error code: EXCEPTION_ACCESS_VIOLATION
    Description: The thread tried to read from or write to a virtual address for which it does not have the appropriate access.
    Access address:0000000C was read from.

    Stack Dump:
      <Unknown>(-1) : <Unknown> 0x00841839
      <Unknown>(-1) : <Unknown> 0x009677CC
      <Unknown>(-1) : <Unknown> 0x009668F0
      <Unknown>(-1) : <Unknown> 0x0081D330
      <Unknown>(-1) : <Unknown> 0x9090C300

    Details:
    Register dump...
    Eip:00841839    Esp:0018F914    Ebp:21162D38
    Eax:00000000    Ebx:0A985A34    Ecx:0AACFC40
    Edx:0018F7B8    Esi:0AACFBE4    Edi:00000000
    EFlags:00010206
    CS:0023  SS:002b  DS:002b  ES:002b  FS:0053  GS:002b
    EIP bytes dump...

    Bytes at CS:EIP (00841839)  : 8B 57 0C A1 F0 7E A4 00 8B 08 6A 00 52 8B 53 0C 6A 00 6A 00 52 50 FF 51 70 8B 0D 40 7F A4 00 41

     

    if anyone is interested in helping me i can provide dxdiag file as well if needed.

    we are 3 friends trying to play this game.

    managed to get it work on both the other computers,

    one of them just worked right out of the box,

    the other computer needed the option ini to start the game and then i worked like a charm.

    my install works right out of the box as well expect from the crash to desktop mid game,

    its not a heat problem/all drivers up to date / DirectX up to date. etc etc

    so im out of options here.

     

    edit: tried running in xp mode sp2/sp3  and "run program as administrator"

    also tried the option ini file in the tread above with no luck.

     

     

     

    If your using Windows 7 64bit do this:

    1. Go to C:\Program Files (x86)\Origin

    2. delete IGO32.dll

    tip: before deleting it, make a backup of it

    Monday, March 03, 2014 5:14 PM
  • hey guys does any one know how to fix the login failed error i installed generals and went to go online it then sais to download update so i click yes then it says connecting but then comes up error saying login failed can any one help with this im running win 7 btw game works but just cant connect online
    Saturday, March 08, 2014 3:30 PM
  • And what about 32-bit is it the same story? I've benn trying on and on and it doesnt work. 

    Wednesday, April 09, 2014 1:29 PM
  • <3 Thanks bro <3 <3 Thanks bro <3 <3 Thanks bro <3 <3 Thanks bro <3 <3 Thanks bro <3 <3 Thanks bro <3 <3 Thanks bro <3 <3 Thanks bro <3 <3 Thanks bro <3 <3 Thanks bro <3 <3 Thanks bro <3 <3 Thanks bro <3 <3 Thanks bro <3 <3 Thanks bro <3 <3 Thanks bro <3 <3 Thanks bro <3 <3 Thanks bro <3 <3 Thanks bro <3
    Sunday, April 20, 2014 3:34 PM
  • HI 

    PLEASE TRY THIS WAY

    DOWNLOAD THE FOLLOWING LINK

    http://www.sendspace.com/file/28h50y

    AFTER FINISHED DOWNLOAD;

    1.DELETE C:\DOCUMENT\COMMAND AND CONQUER GENERAL DATA FOLDER

    2.UNRAR THE DOWNLOADED FOLDER

    3.COPY & PHASE  DOWNLOADED ATTACHED FOLDER TO C:\DOCUMENT\

    NOW,I ALREADY SOLVED BY THIS METHOD.

    BYE BYE ALL MY FRIENDS.

    Monday, May 19, 2014 2:55 PM