none
System wide proxy setting in windows7

    Question

  • I use a windows 7 operating system.I need a proxy to access the internet through my network.The problem I face is that,certain applications like hp update,nokia pc suite which does not have option to set proxy manually cannot connect to the internet. I require a solution for this so that these applications can access internet some how.pls help me with this.
    Sunday, February 21, 2010 7:11 AM

Answers

  • Hi Niyas,

     

    After configuring the proxy in Internet Explorer, Internet will be accessed on the machine and usually, you need not configure proxy settings on certain application. To troubleshoot the issue, I suggest you manually assign the Proxy settings or use automatic detecting to check the result.

     

    For more information, please refer to the following article:

     

    Using Automatic Configuration, Automatic Proxy, and Automatic Detection

     

    Thanks,

    Novak

     

     

    • Marked as answer by Novak Wu Tuesday, March 02, 2010 2:48 AM
    Tuesday, February 23, 2010 6:21 AM

All replies

  • While you could use Network Monitor to gather some information about this problem, I'd like to move you question over to a more approiate forum.

    Paul
    Monday, February 22, 2010 6:26 PM
  • You setup the proxy info in I.E. all programs should use that.
    If this is not the case you need to provide more info
    Monday, February 22, 2010 7:20 PM
  • BubbaPcGuy is right, the only problem you run into is if you have allowed multiple browsers to be installed on your users' PCs. Then it is a matter of which is the default, or setting it up on all.
    If you need extra help, you can reach us at: InitialAssist@cbfive.com See my blogs at http://www.cbfive.com/blog - Jared Crandall
    Tuesday, February 23, 2010 12:37 AM
  • Hi Niyas,

     

    After configuring the proxy in Internet Explorer, Internet will be accessed on the machine and usually, you need not configure proxy settings on certain application. To troubleshoot the issue, I suggest you manually assign the Proxy settings or use automatic detecting to check the result.

     

    For more information, please refer to the following article:

     

    Using Automatic Configuration, Automatic Proxy, and Automatic Detection

     

    Thanks,

    Novak

     

     

    • Marked as answer by Novak Wu Tuesday, March 02, 2010 2:48 AM
    Tuesday, February 23, 2010 6:21 AM
  • Setting the IE proxy setting is not enough. You also have to set the WinHTTP proxy setting via command line.

    netsh winhttp set proxy <YOUR PROXY SERVER>:<PORT> "<EXCLUSION LIST>"

     

     

    edit: Be sure to run cmd.exe as administrator, when you set the winhttp proxy settings!

    Wednesday, June 09, 2010 8:54 AM
  • Ritter,

    what if an authentication is required?

     

    Tuesday, July 26, 2011 1:24 PM
  • Hey vineel gr, use the netsh to setup the proxy, and then use CMDKEY to setup your credentials.

    Tim

    Monday, February 25, 2013 2:26 PM
  • you fixed this issue means ,,help me .. me also having the same trouble.. plz

    Saturday, November 02, 2013 9:08 AM