none
c:windows\system32\comdlg32.ocx failed to load

    Question

  • well most of the treads i see about this are in spanish and needless to say i don't speak another language i only know english so regretably i am asking how i can go about getting comdlg32.ocx to load correctly on windows 7?  every time i try to load it through a commnd prompt or through the file search on the start up menu i get the same failed to load error.  and that goes for trying to load the file as an administrator.  any help with getting this file to load properly on windows 7 would be most appreciated.
    Sunday, May 10, 2009 10:23 AM

Answers

  • To those who still have this problem. Here's the solution. It is pretty simple. The reason the .ocx file is showing up as incompatible, is because it was put in the wrong folder. I assume most of you placed the .ocx in the System32 folder. But if you are using Vista and/or Win7 64-bit, the .ocx must be placed in the SysWOW64 folder instead, which, just so happens to be right next to the System32 folder :D.

    After that, just follow the same instructions, but simply change to the corresponding path in the CMD. Like this:

    1. Move comdlg32.ocx to c:\Windows\SysWOW64
    2. Open a command line window and run following command:

      regsvr32 c:\Windows\SysWOW64\comdlg32.ocx

      b) For Vista/Win7 users with UAC turn on, the above command needs to be run from elevated command prompt.

    3. Once comdlg32 is registered successfully, following message will prompt: "DllRegisterServer in C:\WINDOWS\SysWOW64\comdlg32.ocx succeeded."
    4. Now launch the application again and you should not see the file missing error.
    Hope it helped.
    Monday, June 28, 2010 10:45 PM
  • I found a solution ronnie it was posted on a different tech website but i will post it here and i got the comdlg32.ocx to work this way.  here is the link for the solution i found:  http://gbatemp.net/lofiversion/index.php/t147412.html and i hope posting this link doesn't get me in any kind of trouble.  I don't condone or endorse this website i just found the solution for the particular file on it.  It was the only working solution i was able to find so if i am in the wrong for posting the link for this solution please forgive my error.
    Tuesday, May 12, 2009 12:26 AM

All replies

  • Hi Tim

    Maybe you can give us some details about the original problem?

    Is this the result of trying to load a software program in W7?

    Let us know.

    Thank You for testing Windows 7

    Ronnie Vernon MVP
    Sunday, May 10, 2009 12:22 PM
    Moderator
  • yes it is the software requires the file comdlg32.ocx and i've been trying to load it into the windows 7 registry so that i can use the software but the file won't load into the registry and i am not sure what else to do to get the software to run without this file. the software is basicaly a save game converter for one of my pc games.
    Sunday, May 10, 2009 1:43 PM
  • i know it's probably still a bit to soon but would nobody know of a fix or solution to get this file loaded into the registry? 
    Monday, May 11, 2009 12:58 AM
  • Hi Tim

    You just need to register that file on the system.

    If you have verified that the comdlg32.ocx file is in the windows\system32 folder, perform the following.

    First, you must be logged onto windows with an administrator account.

    Go to Start / All Programs / Accessories.

    Right click on the Command Prompt and select Run As Administrator in the menu.

    If you see a UAC popup, select the Yes button.

    Type the following command carefully, including the space.

    regsvr32 comdlg32.ocx

    Press ENTER

    You should see a message saying the command succeeded.

    Close the command window.

    Try the game converter program.

    Hope this helps.

    Thank You for testing Windows 7


    Ronnie Vernon MVP

    Monday, May 11, 2009 3:35 AM
    Moderator
  • nope still get a the module "com32dlg.ocx" may not be compatible with the version of windows that you are running.  check if the module is compatible with x86 (32bit) or x64 (64 bit) i'm using the x64 bit version of release candidate 1 so that may or may not be the case.  if it is the case where can i find a x64 (64 bit) version of this file?
    Monday, May 11, 2009 5:57 AM
  • <sigh> i guess i'm sol on getting this file added to the registry and every web search i've done for a x64 bit file of com32dlg.ocx has come up negative.  oh well i tried is all i can say i guess. :-(
    Tuesday, May 12, 2009 12:04 AM
  • Hi Tim

    Sorry for the late reply.

    That file is not a part of the Windows 7 installation. It was probably loaded when you installed that game converter program.

    I would go to the website of that software and ask about compatibility with Windows 7 64-bit. If they do support this installation, they should have a compatible version of that file.

    Hope this helps.

    Thank You for testing Windows 7


    Ronnie Vernon MVP

    Tuesday, May 12, 2009 12:09 AM
    Moderator
  • I found a solution ronnie it was posted on a different tech website but i will post it here and i got the comdlg32.ocx to work this way.  here is the link for the solution i found:  http://gbatemp.net/lofiversion/index.php/t147412.html and i hope posting this link doesn't get me in any kind of trouble.  I don't condone or endorse this website i just found the solution for the particular file on it.  It was the only working solution i was able to find so if i am in the wrong for posting the link for this solution please forgive my error.
    Tuesday, May 12, 2009 12:26 AM
  • Hi Tim

    No problem with that website.

    I'm very glad you found a solution for this problem. :)

    I'll mark your post as the answer.

    Enjoy the beta.


    Thank You for testing Windows 7

    Ronnie Vernon MVP
    Tuesday, May 12, 2009 1:05 AM
    Moderator
  •    Well thats nice exept for the fact that the link no longer leads anywhere.... perhaps someone would enlighten me as im having a similar problem.

     

    when I entered the command in command prompt I received the message:

     

    The module "comdig32.oxc" failed to load

     

    Make sure the binary is stored at the specified path or

    debug it to check for problems with the binary or

    dependent .DLL files.

     

    The specified module could not be found.

     

     

    this is the 3rd program Ive tried to run where Ive encountered this error.

    Saturday, May 01, 2010 2:23 AM
  • The file comdlg32.ocx already exist, so I don't think it's a good idea to replace it.

    Instead of replacing the ocx file, just put a copy in the same folder as the executable you want to run and then:

    1. open cmd from start menu as an admin

    2. type in regsvr32 [YOUR APPLICATION PATH]\comdlg32.ocx

    you can get comdlg32.ocx from http://windowsxp.mvps.org/comdlg32.htm

    Monday, May 03, 2010 6:55 PM
  • Hi, what do you mean [YOUR APPLICATION PATH]

    I'm trying to use Idoser and it keeps telling me im missing the comdlg32.ocx

    thanks.

    Wednesday, June 02, 2010 9:24 PM
  • There is a sequence the OS is following to look for a dll file or a linked ocx file with the program you are trying to use. This sequence starts as follows:

    1. The same directory as the running application
    2. The system32 directory on winnt based OS like windows XP or 7
    3. The windows directory

    If the .exe you are trying to run couldn't find the dll/ocx file in these locations, then it will fail to launch.

    So, one thing you can do is to put a copy of the ocx file in the same directory and run regsvr32 to register this file in that location.

    For example

    If your application directory is

    C:\Program Files\Idoser

    Then you can do the following

    1. Copy comdlg32.ocx after you download from the link http://windowsxp.mvps.org/comdlg32.htm into the directory C:\Program Files\Idoser
    2. open cmd from start menu as an admin
    3. type in regsvr32 "C:\Program Files\Idoser\comdlg32.ocx" in the cmd window and hit enter

    This will register this copy of the ocx in this path and keep the windows original one intact

    Thursday, June 03, 2010 11:14 AM
  • To those who still have this problem. Here's the solution. It is pretty simple. The reason the .ocx file is showing up as incompatible, is because it was put in the wrong folder. I assume most of you placed the .ocx in the System32 folder. But if you are using Vista and/or Win7 64-bit, the .ocx must be placed in the SysWOW64 folder instead, which, just so happens to be right next to the System32 folder :D.

    After that, just follow the same instructions, but simply change to the corresponding path in the CMD. Like this:

    1. Move comdlg32.ocx to c:\Windows\SysWOW64
    2. Open a command line window and run following command:

      regsvr32 c:\Windows\SysWOW64\comdlg32.ocx

      b) For Vista/Win7 users with UAC turn on, the above command needs to be run from elevated command prompt.

    3. Once comdlg32 is registered successfully, following message will prompt: "DllRegisterServer in C:\WINDOWS\SysWOW64\comdlg32.ocx succeeded."
    4. Now launch the application again and you should not see the file missing error.
    Hope it helped.
    Monday, June 28, 2010 10:45 PM
  • You sir, are a god

    I don't come to this site but i've been searching for a solution to this problem for a while now, and you Lawfer, have just been given the medal for the guy who has the best solution for this problem on the entire internet. To praise you Lawfer, is the only reason i've bothered to start an account.

    Everyone who has had this problem, follow Lawfer's solution

    Friday, July 16, 2010 11:58 PM
  • This worked like a charm, i thank you Lawfer, this is the best solution on the entire internet for this problem

    Oh and btw, i was also looking for a solution to be able to open IDoser and now it lets me

    Friday, July 16, 2010 11:59 PM
  • But I have windows 7 ultimate 32 bit, there is no folder in the windows directory with the name SysWOW, SysWOW32 or SysWOW64.

    Do you mean this works for windows 64 bit or vista

    Saturday, July 17, 2010 5:35 AM
  • This Solution worked for me!  The file I couldnt get registered was: roc.ocx. 

     

    This was the ONLY way I could get the fild to register.  Thanks!

     

    "type in regsvr32 [YOUR APPLICATION PATH]\comdlg32.ocx"

     

     

    Tuesday, July 27, 2010 5:08 PM
  • Lawfer,  your answer on the comdlg32.ocx was right on the money.  I tried tons of other forums and got the wrong answer.   Thanks a ton.

    Saturday, August 28, 2010 8:38 PM
  • I followed the instructions above, but am receiving this error:

     

    The module "c:\Windows\SysWOW64\comdlg32.ocx" was loaded but the call to DllRegisterServer failed with error code 0x8002801c.

     

    Any help will be appreciated. Thank you!

    Friday, November 05, 2010 3:14 AM
  • Has Microsoft supplied a simple fix for this issue as yet? 

    Or is there a Windows Update that one can apply which will get Windows 7 64 bit to run applications which require Comdlg32.ocx ?

    Like: http://www.microsoft.com/downloads/details.aspx?FamilyId=CB824E35-0403-45C4-9E41-459F0EB89E36&amp;displaylang=en

    You cannot the average person to attempt the solutions provided so far !

    What does "For Vista/Win7 users with UAC turn on, the above command needs to be run from elevated command prompt." mean anyway?  And how do you do that.


    Most importantly, why would or should you need to do that?  Is Windows 7 that bad !

    Friday, April 01, 2011 9:13 PM
    1. Put the file (Comdlg32.ocx) in the same folder as your application (if it isn't already).
    2. Run your application as an administrator (right click, then choose "Run as Administrator"). 

     

     That should be enough :) Sadly, such problems will occur when using old applications on new operating systems.

    Thursday, April 07, 2011 2:01 PM
  • Hey, I'm having the same problem. I did everything that Lawfer said in his post, but get this error when I press ENTER after typing the command:

     

    The module "c:\Windows\SysWOW64\cmdlg.ocx" failed to load.

     

    Make sure the binary is stored at the specific path or debug it to check fro problems with the binary or dependent .DLL files.

     

    The specific module could not be found.

     

     

     

    Help?

    Friday, April 15, 2011 2:52 AM
  • Just a quick note to thank Lawfer for the Windows 7 answer, but also to note that I was searching for this file because I got an error when I tried to run a VBA macro in my new Microsoft Office Excel 2010 (it didn't like "Application.GetOpenFilename").  It said it Could not load an object because it is not available on this machine”, followed by "Compile Error: Can't load project or library". 

    I confirmed that comdlg32.ocx existed in my Windows\SysWOW64 directory, and then went into the VBA screen in Excel, selected Tools/References/Browse, and pointed it to that file.  Now my macro works the same as it used to in Office 2007!!  (Didn't need to register it as described in previous posts.)


    Wednesday, April 27, 2011 4:42 PM
  • Please try to change the compatibility mode of the application you are running to windows xp. Then try to run the application again.

    thanks

    k francis

    Saturday, May 28, 2011 7:19 PM
  • To those who still have this problem. Here's the solution. It is pretty simple. The reason the .ocx file is showing up as incompatible, is because it was put in the wrong folder. I assume most of you placed the .ocx in the System32 folder. But if you are using Vista and/or Win7 64-bit, the .ocx must be placed in the SysWOW64 folder instead, which, just so happens to be right next to the System32 folder :D.

    After that, just follow the same instructions, but simply change to the corresponding path in the CMD. Like this:

    1. Move comdlg32.ocx to c:\Windows\SysWOW64
    2. Open a command line window and run following command:

      regsvr32 c:\Windows\SysWOW64\comdlg32.ocx

      b) For Vista/Win7 users with UAC turn on, the above command needs to be run from elevated command prompt.

    3. Once comdlg32 is registered successfully, following message will prompt: "DllRegisterServer in C:\WINDOWS\SysWOW64\comdlg32.ocx succeeded."
    4. Now launch the application again and you should not see the file missing error.
    Hope it helped.
    I tried all of that and still cant get it to work. I get cannot open output file C:/windows/sysWOW64/Comdlg32.ocx
    Wednesday, June 29, 2011 2:47 PM
  • regsvr32 c:\Windows\SysWOW64\comdlg32.ocx worked fine for me

    I made sure that the file was available in c:\Windows\SysWOW64 before

    Thanks for the advice

    Thursday, September 01, 2011 4:32 PM
  • Thanks Lawfer.....worked for me ! ! !
    Thursday, March 08, 2012 7:18 PM
  • thanks simple but accurate.

    thanks again

    Monday, May 28, 2012 11:47 AM
  • Thanks man this is the best Answer for how to register .OCX files. i preffer u please make a video about that and upload it into youtube. there are many peoples who can't do the googling. just only try to find in youtube :P

    anyway thanks for this help ^^

    Friday, June 08, 2012 8:12 PM
  • thanks a lot really helped me
    Tuesday, September 25, 2012 10:07 AM
  • You're just FRIGGING awesome!  This is amazingly simple and truly amazing to know!  It will sort out other issues as well!  THANK YOU DUDE! lol
    Saturday, November 24, 2012 9:26 PM