none
Windows 7 time sync returns Access Denied error

    Question

  • I have recently configured my AD PDC Windows 2008 Server to syncronize with time.windows.com.  I am trying to get my AD Windows 7 Pro clients to sync with the server, however anytime I run w32tm /resync, net stop w32tm or net start w32tm I get an Access Denied error on the client.  I have tried it logged in as both the domain admin and the local admin.  For some reason I can start and stop the W32 Time Service from the Services console, but it doesn't resync the time when it restarts.  Why am I being denied access when logged in as the domain administrator?  
    Monday, May 09, 2011 5:16 PM

Answers

  • Hi,

     

    Did you set any group policy to prevent client from changing the services?

     

    I suggest you take the ownership of %WINDIR%\System32\W32TM.EXE, disable the security software and firewall on both side to check the result. Also re-configure the group policy related to Windows Time Service and re-apply them.

     

    In addition, I suggest contacting Server Forum to confirm with the issue.

     

    Win Server Forum

    http://social.technet.microsoft.com/Forums/en-US/category/windowsserver

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, May 11, 2011 8:21 AM

All replies

  • Hi,

     

    Did you set any group policy to prevent client from changing the services?

     

    I suggest you take the ownership of %WINDIR%\System32\W32TM.EXE, disable the security software and firewall on both side to check the result. Also re-configure the group policy related to Windows Time Service and re-apply them.

     

    In addition, I suggest contacting Server Forum to confirm with the issue.

     

    Win Server Forum

    http://social.technet.microsoft.com/Forums/en-US/category/windowsserver

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, May 11, 2011 8:21 AM
  • This is an issue with Windows 7 that has to do with the new "security" features in the OS. So far there are 2 ways that I have found that Windows 7 will allow me to successfully run this.

    1st. Right click cmd.exe and choose "run as administrator" and then run w32tm /resync. You need to do this even if your account is a local admin.

    2nd. Set it up to run under the scheduler using the administrator credentials.

    Also there are a lot of people out there that are under the wrong impression that it will automatically sync with the domain controller. This is true if it was Windows XP or earlier but with Windows 7 this is not the case due to the new "security" features within the OS.

    The 2nd option would be your best bet.

    Regards,


    • Edited by limbo66 Friday, May 04, 2012 2:03 PM
    Friday, May 04, 2012 2:00 PM
  • yes ,the same problem happened with me 

    but when I run CMD as admin.  ,the problem resolved .

    good luck

    Thursday, January 09, 2014 7:21 AM