none
Unable To Access Windows 8 Store - Domain to blame... help!

    Question

  • Unable to connect to the Windows Store on a Domain.

    Hello, I normally try not to cross post but my other post didn't get any attention from MS.  Please forgive me but to not have access to the Win8 store really makes me question Windows 8 at all..

    Ok - The basic story:

    1. Windows 7 Ultimate -> Upgrade to Windows 8 Pro (both x64)

    2. After upgrade, Windows 8 Store worked great.

    3. Logged into VPN for an afternoon, at some point it did a GPUPDATE and then.. voila. Windows 8 store is dead (see error below

    4. After messing around for several hours trying to fix it, I did a restore to a previous system state using Windows System Restore.  At that point, it worked again.  Then I did NOTHING except connect to the VPN and do a GPUPDATE /FORCE.  And instantly -> no Windows 8 Store.

    I have done the following trying to resolve it:

    • Triple (or possibly more) validated the system clock, time zone and proxy settings (no proxy)
    • Uninstalled McAfee VirusScan Enterprise (need to reinstall soon after I get this resolved)
    • Validated / Turned off AT&T Global Network Firewall
    • Disabled Microsoft Defender (which turned on once I uninstalled McAfee VSE)
    • Disabled Microsoft Firewall
    • Updated all drivers (specifically video drivers), updated Windows 8, checked Registry settings as best I could
    • My Resolution is 2x 1920x1080
    • UAC is on and functioning fine
    • I am logged into a domain account that is linked to my MS account.  I firmly believe it is not account related as it worked before GP.
    • I checked every setting I could find on the Local Security Policy after the GPUPDATE and reverted them to default, nothing.
    • Downloaded the App tool and Profile took for Win8 from MS - Ran both as admin.

    I am hoping a MS engineer can look at the logs below and help me isolate what the heck is causing this.  After that I can get the GP updated.

    Please & thank you.

    Nick

    Error symptoms: 

     

    Pre issue: Windows Store worked - all functionality with Win 8 apps is fine

    Issue cause: Logged into the domain and gpupdate script occurred

     

    Issue details:

    When I goto the store app: I get either:

     

    We weren’t able to connect to the Store. This might have happened because of a server problem or the network connection timed out. Please wait a few minutes try again.

     

    OR

     

    Your PC isn’t connected to the Internet. To use the Store, connect to the Internet and then try again.

     

    Desired Resolution:

    I NEED TO IDENTIFY WHICH GP Policy / Reg Key IS BREAKING Windows 8 Store.  This is an inherited GP from previous manager. The details from the winstore log are below.  

     

    2012-11-06 09:09:17.324, _Info_                WS   [00004036:00004928] navigateUI: Navigating 'WS' iframe to https://wscont.apps.microsoft.com/winstore/6.2/615/WW/en-us/0/70/Home.htm

    2012-11-06 09:09:17.325, _Info_                WS   [00004036:00004928] navigateUI: Creating 'WS' iframe with https://wscont.apps.microsoft.com/winstore/6.2/615/ww/en-us/0/70/frame.htm

    2012-11-06 09:09:17.481, _Info_                WS   [00004036:00004928] navigateAjax: Loading file: https://wscont.apps.microsoft.com/winstore/6.2/615/WW/en-us/0/70/Home.htm

    2012-11-06 09:09:17.481, _Info_                WS   [00004036:00010896] WinStoreCache::DoQuery:  Provider 5: Cache miss for https://wscont.apps.microsoft.com/winstore/6.2/615/WW/en-us/0/70/Home.htm.

    2012-11-06 09:09:17.481, _Info_                WS   [00004036:00010896] CHttpRequest::_CreateConnectionAndSendRequest: Server: wscont.apps.microsoft.com, URL /winstore/6.2/615/WW/en-us/0/70/Home.htm

    2012-11-06 09:09:17.481, _Info_                WS   [00004036:00010896] CHttpConnectionCache::GetSession: Reusing session handle 0x00000024A2CFC3D0

    2012-11-06 09:09:17.482, _Info_                WS   [00004036:00010896] CHttpConnectionCache::GetConnection: Reusing handle 0xa2eaf7b0 for wscont.apps.microsoft.com:443

    2012-11-06 09:09:17.482, _Info_                WS   [00004036:00010896] CHttpRequest::_CreateConnectionAndSendRequest: hRequest 0xa61bcef0 is for GET /winstore/6.2/615/WW/en-us/0/70/Home.htm

    2012-11-06 09:09:17.484, _Warning_             WS   [00004036:00010896] CHttpRequest::_GetProxyInfoForUrl: Autoproxy failed: 0x80072f94

    2012-11-06 09:09:17.484, _Info_                WS   [00004036:00010896] Proxy list = (null), Proxy bypass = (null), Proxy access type = 0

    2012-11-06 09:09:17.484, _Info_                WS   [00004036:00010896] CHttpRequest::_SendRequest: Calling WinHttpSendRequest, hRequest 0xa61bcef0 attempt 1

    2012-11-06 09:09:17.613, _Error_               WS   [00004036:00007152] Request 0xa61bcef0 failed, error 5 for result 5

    2012-11-06 09:09:17.613, _Info_                WS   [00004036:00010896] CHttpRequest::_SendRequest: WinHttpSendRequest hRequest 0xa61bcef0 (1) result: 0x80070005, proxy time: 0

    2012-11-06 09:09:17.613, _Error_               WS   [00004036:00010896] CHttpRequest::FetchResource: _CreateConnectionAndSendRequest failed: 0x80070005

    2012-11-06 09:09:17.613, _Info_                WS   [00004036:00010896] CHttpRequest::_CreateConnectionAndSendRequest: Server: wscont.apps.microsoft.com, URL /winstore/6.2/615/WW/en-us/0/70/Home.htm

    2012-11-06 09:09:17.613, _Info_                WS   [00004036:00010896] CHttpConnectionCache::GetSession: Reusing session handle 0x00000024A2CFC3D0

    2012-11-06 09:09:17.613, _Info_                WS   [00004036:00010896] CHttpConnectionCache::GetConnection: Reusing handle 0xa2eaf7b0 for wscont.apps.microsoft.com:443

    2012-11-06 09:09:17.613, _Info_                WS   [00004036:00010896] CHttpRequest::_CreateConnectionAndSendRequest: hRequest 0xa61bcef0 is for GET /winstore/6.2/615/WW/en-us/0/70/Home.htm

    2012-11-06 09:09:17.617, _Warning_             WS   [00004036:00010896] CHttpRequest::_GetProxyInfoForUrl: Autoproxy failed: 0x80072f94

    2012-11-06 09:09:17.617, _Info_                WS   [00004036:00010896] Proxy list = (null), Proxy bypass = (null), Proxy access type = 0

    2012-11-06 09:09:17.617, _Info_                WS   [00004036:00010896] CHttpRequest::_SendRequest: Calling WinHttpSendRequest, hRequest 0xa61bcef0 attempt 1

    2012-11-06 09:09:17.762, _Error_               WS   [00004036:00004832] Request 0xa61bcef0 failed, error 5 for result 5

    2012-11-06 09:09:17.763, _Info_                WS   [00004036:00010896] CHttpRequest::_SendRequest: WinHttpSendRequest hRequest 0xa61bcef0 (1) result: 0x80070005, proxy time: 0

    2012-11-06 09:09:17.763, _Error_               WS   [00004036:00010896] CHttpRequest::FetchResource: _CreateConnectionAndSendRequest failed: 0x80070005

    2012-11-06 09:09:17.763, _Info_                WS   [00004036:00010896] CHttpRequest::_CreateConnectionAndSendRequest: Server: wscont.apps.microsoft.com, URL /winstore/6.2/615/WW/en-us/0/70/Home.htm

    2012-11-06 09:09:17.763, _Info_                WS   [00004036:00010896] CHttpConnectionCache::GetSession: Reusing session handle 0x00000024A2CFC3D0

    2012-11-06 09:09:17.763, _Info_                WS   [00004036:00010896] CHttpConnectionCache::GetConnection: Reusing handle 0xa2eaf7b0 for wscont.apps.microsoft.com:443

    2012-11-06 09:09:17.763, _Info_                WS   [00004036:00010896] CHttpRequest::_CreateConnectionAndSendRequest: hRequest 0xa61bcef0 is for GET /winstore/6.2/615/WW/en-us/0/70/Home.htm

    2012-11-06 09:09:17.772, _Warning_             WS   [00004036:00010896] CHttpRequest::_GetProxyInfoForUrl: Autoproxy failed: 0x80072f94

    2012-11-06 09:09:17.772, _Info_                WS   [00004036:00010896] Proxy list = (null), Proxy bypass = (null), Proxy access type = 0

    2012-11-06 09:09:17.772, _Info_                WS   [00004036:00010896] CHttpRequest::_SendRequest: Calling WinHttpSendRequest, hRequest 0xa61bcef0 attempt 1

    2012-11-06 09:09:17.908, _Error_               WS   [00004036:00007152] Request 0xa61bcef0 failed, error 5 for result 5

    2012-11-06 09:09:17.908, _Info_                WS   [00004036:00010896] CHttpRequest::_SendRequest: WinHttpSendRequest hRequest 0xa61bcef0 (1) result: 0x80070005, proxy time: 0

    2012-11-06 09:09:17.908, _Error_               WS   [00004036:00010896] CHttpRequest::FetchResource: _CreateConnectionAndSendRequest failed: 0x80070005

    2012-11-06 09:09:17.908, _Info_                WS   [00004036:00010896] CHttpRequest::_CreateConnectionAndSendRequest: Server: wscont.apps.microsoft.com, URL /winstore/6.2/615/WW/en-us/0/70/Home.htm

    2012-11-06 09:09:17.908, _Info_                WS   [00004036:00010896] CHttpConnectionCache::GetSession: Reusing session handle 0x00000024A2CFC3D0

    2012-11-06 09:09:17.908, _Info_                WS   [00004036:00010896] CHttpConnectionCache::GetConnection: Reusing handle 0xa2eaf7b0 for wscont.apps.microsoft.com:443

    2012-11-06 09:09:17.908, _Info_                WS   [00004036:00010896] CHttpRequest::_CreateConnectionAndSendRequest: hRequest 0xa61bcef0 is for GET /winstore/6.2/615/WW/en-us/0/70/Home.htm

    2012-11-06 09:09:17.920, _Warning_             WS   [00004036:00010896] CHttpRequest::_GetProxyInfoForUrl: Autoproxy failed: 0x80072f94

    2012-11-06 09:09:17.920, _Info_                WS   [00004036:00010896] Proxy list = (null), Proxy bypass = (null), Proxy access type = 0

    2012-11-06 09:09:17.921, _Info_                WS   [00004036:00010896] CHttpRequest::_SendRequest: Calling WinHttpSendRequest, hRequest 0xa61bcef0 attempt 1

    2012-11-06 09:09:18.041, _Error_               WS   [00004036:00004832] Request 0xa61bcef0 failed, error 5 for result 5

    2012-11-06 09:09:18.042, _Info_                WS   [00004036:00010896] CHttpRequest::_SendRequest: WinHttpSendRequest hRequest 0xa61bcef0 (1) result: 0x80070005, proxy time: 16

    2012-11-06 09:09:18.042, _Error_               WS   [00004036:00010896] CHttpRequest::FetchResource: _CreateConnectionAndSendRequest failed: 0x80070005

    2012-11-06 09:09:18.042, _Warning_             WS   [00004036:00010896] WinStoreCache::DoQuery: Provider 5 returned failure for https://wscont.apps.microsoft.com/winstore/6.2/615/WW/en-us/0/70/Home.htm, hr=0x80070005

    2012-11-06 09:09:18.042, _Info_                WS   [00004036:00004928] navigateAjax: Response received; href = https://wscont.apps.microsoft.com/winstore/6.2/615/WW/en-us/0/70/Home.htm

    2012-11-06 09:09:18.042, _Error_               WS   [00004036:00004928] CWinStore::_NavigateToErrorPage: We weren’t able to connect to the Store. This might have happened because of a server problem or the network connection timed out. Please wait a few minutes and <a id='linkRefresh'>try again</a>.

    2012-11-06 09:09:18.153, _Warning_             WS   [00004036:00004928] navigateAjax: WS-open not received; showing connection error message.

    2012-11-06 09:09:18.153, _Error_               WS   [00004036:00004928] CWinStore::_NavigateToErrorPage: Your PC isn’t connected to the Internet. To use the Store, connect to the Internet and then <a id='linkRefresh'>try again</a>.

    2012-11-06 09:09:18.209, _Info_                WS   [00004036:00004928] visibilityState changed to: hidden

    2012-11-06 09:09:29.907, _Info_                WS   [00004036:00004928] CWinStore::_OnSuspendEvent: Suspending.

    2012-11-06 09:09:29.907, _Info_                WS   [00004036:00004928] CWinStore::_PrepareToSuspend: flushing data to prepare for suspend

    2012-11-06 09:09:29.912, _Info_                WS   [00004036:00004928] CInstallProgressManager::PrepareToSuspend: unregistered CInstallProgressManager with cookie 11

     

    Original title : Windows 8 Store App BROKEN by Domain GP (We weren’t able to connect to the Store. This might have happened because of a server problem...)


    Nicolas

    Monday, November 12, 2012 3:38 PM

Answers

  • Thanks for trying.  I gave up on Win8 for now and went back to Win7. 

    During that process, I finally figured out what Win8 should be like.

    Take Windows 8, make it boot directly into the desktop, make the start menu come back and the windows button can be configured to do either the metro UI or start...

    THEN if you want to access Metro UI, make IT an App in the taskbar, next to the darn start orb. 

    Or you could have it (to be tablet friendly) swipe from the edge to "roll" to the Metro UI.  The coolest would be a double swipe to emulate "close a double door" motion with the Metro UI coming along with your fingertips, however I doubt you could execute that given the variety of tablets you need to support and that it would be impossible to do one handed.

    Anyway, thanks all for your help.  I surrender.



    Nicolas


    • Edited by brunnern Tuesday, November 20, 2012 4:47 PM typo
    • Marked as answer by Niki HanModerator Friday, November 23, 2012 7:35 AM
    Tuesday, November 20, 2012 4:46 PM

All replies

  • We had a similar case before. It could be proxy issue. Please chekc this case colelctions:

    Unable to access Store: proxy server requires authentication

    - http://www.chicagotech.net/netforums/viewtopic.php?f=3&t=16453&p=27171#p27171


    Bob Lin, MVP, MCSE & CNE Networking, Internet, Routing, VPN Troubleshooting on

    http://www.ChicagoTech.net

    How to Setup Windows, Network, VPN & Remote Access on

    http://www.howtonetworking.com


    • Edited by chicagotech Monday, November 12, 2012 11:22 PM
    Monday, November 12, 2012 11:21 PM
  • Sadly - that is not the issue.  No proxy here and settings are blank.  Even verified no proxy using the similar steps in this link.  At this point I have refreshed the system.  Will reload VPN and do gp update to see if it is still failing.


    Nicolas

    Tuesday, November 13, 2012 3:22 AM
  • if it is not proxy issue, then try to disable use default gateway in remote network on the vpn.

    routing issues on vpn

    Can't access the Internet while using VPN Can't access the remote network after
      unchecking "Use default gateway on Remote Network" Destination not ...

    www.chicagotech.net/routingissuesonvpn.htm

    Bob Lin, MVP, MCSE & CNE Networking, Internet, Routing, VPN Troubleshooting on

    http://www.ChicagoTech.net

    How to Setup Windows, Network, VPN & Remote Access on

    http://www.howtonetworking.com

    Tuesday, November 13, 2012 5:13 PM
  • Adding Hyper-V feature to the computer fixed the issue. I can now access store and add also interact with Modern (Metro) apps.
    Wednesday, November 14, 2012 4:26 PM
  • Thanks for trying.  I gave up on Win8 for now and went back to Win7. 

    During that process, I finally figured out what Win8 should be like.

    Take Windows 8, make it boot directly into the desktop, make the start menu come back and the windows button can be configured to do either the metro UI or start...

    THEN if you want to access Metro UI, make IT an App in the taskbar, next to the darn start orb. 

    Or you could have it (to be tablet friendly) swipe from the edge to "roll" to the Metro UI.  The coolest would be a double swipe to emulate "close a double door" motion with the Metro UI coming along with your fingertips, however I doubt you could execute that given the variety of tablets you need to support and that it would be impossible to do one handed.

    Anyway, thanks all for your help.  I surrender.



    Nicolas


    • Edited by brunnern Tuesday, November 20, 2012 4:47 PM typo
    • Marked as answer by Niki HanModerator Friday, November 23, 2012 7:35 AM
    Tuesday, November 20, 2012 4:46 PM
  • I am having the same issue, went through the entire list of as you did. I also get a similar error when trying to connect my domain account to my Microsoft account. It is easy to see why all my small business customers are choosing the downgrade to Win7 option on all the workstations and networks I setup.

    Tuesday, November 12, 2013 10:46 PM
  • This is work for me.

    powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.xml


    Sharkrit

    Friday, November 15, 2013 3:44 AM