none
OEMBackground resets back to 0

    Question

  • Hi,

    Someone else mentioned this problem here

    Basically, we are setting this registry value so we can see a custom welcome screen background:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\Background]
    "OEMBackground"=dword:00000001

    At apparently random intervals, Windows resets this back to a 0 and the custom background no longer shows.

    I can't find a pattern to this. Sometimes, it lasts for days, but eventually it will reset on any PC it's set to a 1 on.

    It is possible that sometimes when running Windows Update and then rebooting it does this.

    I'm just logging this to see if it can be fixed, please.

    Cheers,

    Rob

    • Edited by Rob.Ford Thursday, November 05, 2009 6:37 PM typo
    Thursday, November 05, 2009 6:37 PM

Answers

  • Hi,

    For anyone who don't want the Logon-Screen reset to default on every theme change, just use police key.

    "HKLM\SOFTWARE\Policies\Microsoft\Windows\System" "UseOEMBackground" "1"

     

    NOT

     

    "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\Background" "OEMBackground" "1"

    Delete this one if it exist!

    • Proposed as answer by Brian Saltz Wednesday, September 28, 2011 10:54 PM
    • Marked as answer by Rob.Ford Wednesday, September 28, 2011 11:12 PM
    Thursday, April 08, 2010 11:08 AM
  • This key gets reset when choosing a different theme. It's odd, as the theme gets processed in HKCU (and under user mode, not elevated), and the logon background key is in HKLM. When choosing a theme no UAC popup appears, is this possibly a 'too wide permissions' issue? 

    kind regards,

    Ward Jongbloed

    Edit: It appears 'authenticated users' receive 'set value' permissions on the background registry keys, removing that permission appears to fix the problem.
    • Proposed as answer by Ward J Saturday, November 07, 2009 7:35 PM
    • Edited by Ward J Saturday, November 07, 2009 7:37 PM added solution
    • Marked as answer by Linda Yan Monday, November 09, 2009 2:38 AM
    Saturday, November 07, 2009 7:06 PM
  • Hi Rob,

    I have reported this issue to related team and they will look into it.

    Thank you very much for your time and efforts. :-)

    Regards,
    Linda

    • Marked as answer by Rob.Ford Sunday, December 13, 2009 6:02 AM
    Monday, November 09, 2009 2:54 AM

All replies

  • Hi Rob,

     

    This issue does not occur on my Windows 7 Ultimate x32 version.

     

    It is possible certain third party software is changing the registry key. Let’s disable all startup items and third party services when booting. This method will help us determine if this issue is caused by a loading program or service. Please perform the following steps:

     

    1. Click the Start Button type "msconfig" (without quotation marks) in the Start Search box, and then press Enter.

     

    Note: If prompted, please click Continue on the User Account Control (UAC) window.

     

    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3. Click the "Startup" tab, click "Disable All" and click "OK".

     

    Then, restart the computer. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System Configuration Utility when Windows starts" box and click OK.

     

    Please test this issue in the Clean Boot environment, if the issue disappears in the Clean Boot environment, we can use a 50/50 approach to quickly narrow down which entry is causing the issue.

     

    Hope this helps.

     

    Regards,

    Linda

     

    Friday, November 06, 2009 6:48 AM
  • This key gets reset when choosing a different theme. It's odd, as the theme gets processed in HKCU (and under user mode, not elevated), and the logon background key is in HKLM. When choosing a theme no UAC popup appears, is this possibly a 'too wide permissions' issue? 

    kind regards,

    Ward Jongbloed

    Edit: It appears 'authenticated users' receive 'set value' permissions on the background registry keys, removing that permission appears to fix the problem.
    • Proposed as answer by Ward J Saturday, November 07, 2009 7:35 PM
    • Edited by Ward J Saturday, November 07, 2009 7:37 PM added solution
    • Marked as answer by Linda Yan Monday, November 09, 2009 2:38 AM
    Saturday, November 07, 2009 7:06 PM
  • Ah, yes, well done, Ward, switching to the Windows 7 classic or basic themes resets this to 0 every time for me. The Aero themes don't appear to reset it, though.

    Ward, yep, removing those rights solves the problem and at home (as I am local admin of my home PC) I have denied myself "set value" and now it persists.

    Linda, this happens on my home PC and all PCs at work running both 32bit and 64bit Professional and Enterprise editions of Windows 7. A small fix might be required otherwise you'll have Dell and HP, etc complaining that the backgrounds they inflicted, I mean installed, for their customers aren't sticking :)
    • Edited by Rob.Ford Saturday, November 07, 2009 8:20 PM typo
    Saturday, November 07, 2009 8:13 PM
  • Hi Rob,

    I have reported this issue to related team and they will look into it.

    Thank you very much for your time and efforts. :-)

    Regards,
    Linda

    • Marked as answer by Rob.Ford Sunday, December 13, 2009 6:02 AM
    Monday, November 09, 2009 2:54 AM
  • Hello

    I see this thread is a month old, but I give my $.05 (about NOK 0.30, hehe) anyway. I do not get this error when changing from one theme to another, but I do get it if I download from Microsoft.com's theme pages. Maybe the themepack install app does something?
    Tuesday, December 15, 2009 6:02 PM
  • Sometimes I love these forums...been dealing with this all day, and it took a minute, but I got the answers! Thanks!!!


    J

    Jon
    Thursday, February 11, 2010 8:48 PM
  • Hi,

    For anyone who don't want the Logon-Screen reset to default on every theme change, just use police key.

    "HKLM\SOFTWARE\Policies\Microsoft\Windows\System" "UseOEMBackground" "1"

     

    NOT

     

    "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\Background" "OEMBackground" "1"

    Delete this one if it exist!

    • Proposed as answer by Brian Saltz Wednesday, September 28, 2011 10:54 PM
    • Marked as answer by Rob.Ford Wednesday, September 28, 2011 11:12 PM
    Thursday, April 08, 2010 11:08 AM
  • It does occur on my win 7 Ultimate x86...

    & I'm sure it is not 3rd party application.

    It happens when I switch from Aero to Classic theme

    &

    on windows update & reboot(only some updates)

    &

    on Cold Shutdown(blue screen, power off etc).

    Is there a way by which I can keep the value of OEMBackground always 1(Eg now the default is 0, so it keeps goin back to 0, similarly can the default be 1?)

    Thanks

    CDan H

    Thursday, May 06, 2010 10:31 PM
  • hello, pls help, iv got no visual of OEMBackground on my regedit, it disapear during changing my logon picture...
    Sunday, August 22, 2010 11:42 PM
  • http://tweaks.com/software/tweakslogon/

    try this out, it will help u to change Ur logon background to whatever u like!!!!

    Tuesday, August 24, 2010 12:06 PM
  • SYMPTOMS

    You are setting this registry value so that you can see a custom welcome screen background:

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\Background]

    "OEMBackground"=dword:00000001

    However, this registry key resets back to zero after you click, select or create a different theme in the "Personalization" control panel, hence the custom background no longer shows.

    CAUSE

    When you change the theme in the personalization control panel, it will change OEMBackground to match the value stored in the theme ini file.

    RESOLUTION

    Windows 7 has new Group Policy options to control it. Please use the following steps to enable custom welcome screen background:

    1. Run "gpedit.msc" in a command window.

    2. Navigate to "Computer Configuration" -> "Administrative Templates" -> "System" -> "Logon".

    3. Enable the policy "Always use custom logon background".

    • Proposed as answer by grebnetiew Thursday, June 07, 2012 7:42 AM
    Saturday, May 26, 2012 5:11 AM
  • Hi,

    I have set the registry entries. Also enabled the option in gpedit.msc.

    On a regular basis the registry entries are changed back automatic (by domain policy?).

    Also when I change C:\Windows\System32\oobe\info\backgrounds\backgroundDefault.jpg it is put back to original.

    What can I do to prevent the automatic chang of these items?

    Gr,

    Maurice

    Friday, June 22, 2012 10:16 AM
  • This suggestion by NoIdea2k worked for me.  The 3rd party apps people recommend (tweakslogon and Win7LogonBackgroundChanger) didn't work for me because when I changed my desktop it also changed the logon screen back to the windows default.  Thank you so much for posting!!!

    Friday, December 14, 2012 5:12 PM
  • I know this is quite old, but I have been setting up our Windows 7 images for the department and created a default background that I could not get to stick.

    I took the advice of hamdx with policy settings and applied it on our AD policy.  It worked.  After adding the policy to use custom backgrounds it supplied the necessary registry key that NoIdea2K stated above.

    So in essence they both helped me solve our issue.

    Thanks

    Monday, May 20, 2013 7:24 PM