none
Num lock key off in start up

    Question

  • "Num lock" key is off whenever I log off windows. I'm using Windows 7 RC and I know that I have to edit the registry. Could anyone help me with this issue? Thanks in advance

    alfredpine
    Monday, May 25, 2009 8:05 PM

Answers

  • Hi,

     

    To do it, please take the following steps:

     

    1. Run Registry Editor.
    2. Move to HKEY_USERS\.Default\Control Panel\Keyboard.
    3. Change the value for InitialKeyboardIndicators to 2.

     

    Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

     

    322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

     

    Hope it helps.

    Wednesday, May 27, 2009 6:49 AM

All replies

  • I think most BIOS allow you to have number lock turned on or off at startup. Are you able to get into your BIOS settings okay?
    Regards from the Valley of the Sun.
    Monday, May 25, 2009 9:49 PM
  • Hi,

     

    To do it, please take the following steps:

     

    1. Run Registry Editor.
    2. Move to HKEY_USERS\.Default\Control Panel\Keyboard.
    3. Change the value for InitialKeyboardIndicators to 2.

     

    Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

     

    322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows

     

    Hope it helps.

    Wednesday, May 27, 2009 6:49 AM
  • Thank you very much for your help. I have another problem. Maybe you can help me.  My D-Link® DWA-130 network adapter only allows me to connect at 150 Mbps, but specifications say 300 Mbps. I'm using the DIR-655 Extreme router.My computer is running Windows 7 RC. Could
    you help me with this? Thank you
    Thursday, August 13, 2009 3:55 PM
  • Thank you again Robinson. I got another one. My D-Link® DWA-130 network adapter only allows me to connect at 150 Mbps, but specifications say 300 Mbps. I'm using the DIR-655 Extreme router.My computer is running Windows 7 RC. Could
    you please help me with this? Thank you
    Monday, August 24, 2009 12:03 AM
  • I have a similar problem.  When I turn on my computer the number lock is always on.  I would like it always off.  I read your post and followed along OK until I got to changing the number.  My initial Keybouard Indicator is not a single number, it is 2147483648.  Any ideas?  I am afraid to change it to just 0 in order to turn off the caps lock...

    I am not sure what BIOS is either. Thanks in advance to any help!

     

    Wednesday, July 28, 2010 2:19 AM
  • I was actually trying to reply to Robinson Zhang.  I am trying to change my computer to have the number lock OFF when I turn it on.  I read the post my Robinson on how to do it, but had trouble at the end.  Where I should have a one didgit number I have the  number 2147483648.  I am sure a delightful person in Dallas owns this number, but I am not about to call it.  Hahaha  So any ideas on how to change my start up to have the number lock off?
    Wednesday, July 28, 2010 2:47 AM
  • I've found an interesting forum discussion on the numlock setting. 

    http://www.technologyquestions.com/technology/windows-vista/133492-numlock-key-not-active-after-start-up.html

    "2147483648" is 0x80000000 in hex.  It means something like 'leave states alone'.  You can enable numlock at the login screen with "2147483650", which is 0x80000002 in hex, but you'll enter the decimal version as a string. Note that the HKU\.Default registry area is only for the System user or the login screen.  You'll also have to change it in every user's ntuser.dat, or the Default ntuser.dat for new users.

     

     

    Wednesday, September 15, 2010 3:45 PM
  • i can't get numlock to be active by changing the number ind regedit, and there isn't the option in bios, anyone who has and solution to my problem it would help me alot, i use and acer laptop
    Thursday, October 14, 2010 4:29 PM
  • i can't get numlock to be active by changing the number ind regedit, and there isn't the option in bios, anyone who has and solution to my problem it would help me alot, i use and acer laptop

    I have the same problem on an HP laptop. It is strange that HP seems to just ignore this problem.
    Sunday, November 14, 2010 12:02 PM
  • My acer laptop has its number lock on at startup, despite it being off when it was shut down. I want it to always start with the lock off, but to be able to switch it on as required. As far as I can understand, JS2010's answer doesn't provide a solution to specifically this question. Or. at least, not one I understand.

    I can't solve this in the BIOS. I know how to edit the registry, but would be grateful for step-by-step advice on where to do this and in what way.

    Thank you for any help you can give.

    • Proposed as answer by Renars2 Monday, April 02, 2012 9:14 AM
    Thursday, April 14, 2011 6:54 PM
  • I would think num lock would be off by default:

    [HKEY_CURRENT_USER\Control Panel\Keyboard]
    "InitialKeyboardIndicators"="0"

     

    Thursday, April 14, 2011 7:00 PM
  • I just solved this problem for my wife on her laptop Eee PC from ASUS. Turns out that she must have pressed the Fn key while hitting the Num LK key. Amazingly, this just affected her user profile on that laptop and did not affect mine. Unfortunately, it is very difficult to type Regedit when you have the number lock on. Anyways, best to give that a try first (logged on as the user with the issue). Otherwise, you will hopefully have another user account that you can use for the registry editing. Then, of course, you would have to go to the HKEY profile for that user to modify the keyboard settings.
    Tuesday, August 02, 2011 5:46 PM
  • Found a solution on the support.microsoft.com site:

    http://support.microsoft.com/kb/154529

    This page has a MS "FixIt" program, which when you run it, automatically changes the Registry setting for the Num Lock to "on."  I am running Windows 7, and it worked.  It says it's for an older version than I have (doesn't say which one), but it worked.  I recommend doing a regedit backup beforehand though. 

    To do this, open Start, then type "regedit" in your search, then when the registry editor opens, go to "File" then "Export". Change the Export Range option at the bottom to "All", and put it in a safe place.  If you blow something up, you can use this file to re-import and restore your Registry back to where it was before the change was made.

    Just for extra info, here's Microsoft's version of how to back up and restore the registry: http://support.microsoft.com/kb/322756

    Have fun...

    Tuesday, January 10, 2012 7:04 AM
  • Hello,

    i'm sorry, I remount this topic but I've the same problem. I've try to change the different InitialKeyboardIndicators to 2, I have install the patch of Callmechristian, but nothing change. At the beginning the numlock key is activated, but after multipoint server detect station, numlock key turn off and the login page appears.

    someone was there a solution to have the numlock activated on login page ?

    Thank's,

    Wednesday, May 09, 2012 1:28 PM
  • Setting HKEY_USERS\.Default\Control Panel\Keyboard\InitialKeyboardIndicators to "2147483650" (string value) worked for me for the login screen.  (It is 0x80000002 in hex.)


    • Edited by JS2010 Wednesday, May 09, 2012 2:00 PM
    Wednesday, May 09, 2012 1:58 PM
  • My reg entry displays 2147483648 against the InitialKeyboardIndicators entry. Is it safe to change it to 2 directly. I'm using Windows 7 Ultimate.
    Saturday, June 16, 2012 3:26 AM
  • Yes it is safe to change it to 2.

    Friday, August 31, 2012 6:33 AM
  • My reg entry displays 2147483648 against the InitialKeyboardIndicators entry. Is it safe to change it to 2 directly. I'm using Windows 8.

    Saturday, December 15, 2012 5:17 PM
  • alfred,

      you might not have to edit the registry.  

    1.  Re-boot(boot) your sys.  Hit the appropriate key to enter the BIOS.

    2. Squirrel through the various panels until you find the "num lock" key setting and if not set, set it to "enable" at startup.  

    3. Save and exit the BIOS.  

    This said, if that is not the problem, you're gonna have to edit the reg.

    horatio

    Saturday, December 22, 2012 2:23 PM
  • Thanks, I had the same problem and your instructions solved my problem.

    1. Run Registry Editor.
    2. Move to HKEY_USERS\.Default\Control Panel\Keyboard.
    3. Change the value for InitialKeyboardIndicators to 2.

  • Run Registry Editor.
  • Move to HKEY_USERS\.Default\Control Panel\Keyboard.
  • Change the value for InitialKeyboardIndicators to 2.
  • Run Registry Editor.
  • Move to HKEY_USERS\.Default\Control Panel\Keyboard.
  • Change the value for InitialKeyboardIndicators to 2.
  • Run Registry Editor.
  • Move to HKEY_USERS\.Default\Control Panel\Keyboard.
  • Change the value for InitialKeyboardIndicators to 2.
  • Wednesday, August 28, 2013 2:08 PM