none
Windows XP mode - typing slow to show on screen

    Question

  • Using XP Mode, when I type, it seems to fall behind me and then catches up and then falls behind.
    It's as if typing on a terminal window over a network with high packet loss...  It seems similar if I move things around the screen.

    I have the latest nVidia video drivers. I tried lowering screen resolution and color depth. I tried raising the VM memory from 512MB to 1 GB, to no avail.  I have a Core 2 Duo T8100 @ 2.10 gHz. 3 GB of RAM and an nVidia GeForce 8400M GS.  (HP 9700)


    Any ideas?
    Tuesday, November 24, 2009 10:42 PM

Answers

  • Fixed!

    I had the problem described by several of the posters here.  XP Mode stutters, was intermittently unresponsive and sometime even dropped characters while typing.  I'm running Win7x64 Pro on a Dell Latitude D630 laptop. 

    The fix was simply to go to the settings of the XP Mode virtual machine, and disable "Auto Publish" (clear the checkbox).  I did shutdown the VM first (not hibernate) before making the change.

    I use XP Mode in full screen, and so I don't really care if it publishes shortcuts to the Win7 Start Menu (never really work right for me anyway).

    I hope this helps you all as well.

    Wednesday, May 05, 2010 2:04 PM

All replies

  • You are typing over terminal services. That is the technology behind XP Mode. How does the XP Mode virtual machine perform when you run it as a virtual machine in a window instead of as XP Mode?
    Tuesday, November 24, 2009 10:54 PM
  • "How does the XP Mode virtual machine perform when you run it as a virtual machine in a window instead of as XP Mode?"

    Do you mean a window, versus full screen? It's the same thing.  Is this a "known issue" that everyone has?


    I do NOT see such an issue using Remote Desktop over a VPN to a remote machine...running RD on the same machine.

    Thanks
    Tuesday, November 24, 2009 11:28 PM
  • XP Mode is the publishing of an application in the XP virtual machine to the Windows 7 machine. If you are running in a window or full screen, you aren't running in XP Mode, you're just running the XP virtual machine without terminal services routing the application to the Windows 7 physical machine.

    This is not a known issue and I've never seen it.
    Wednesday, November 25, 2009 1:02 AM
  • ok - any recommendations where to go from here?
    Thanks
    Wednesday, November 25, 2009 1:27 PM
  • ok - after re-reading what you said and doing more research about  "XP Mode" etc, I realized that in the mode I was using, I still was using Terminal Services. I then had Windows  "publish" the programs  I needed (one was a networking program, so I needed to create a batch file to call it - otherwise I was getting errors with files not found).   I don't see the fast>wait>fast>wait behavior... but I'm not sure if things are now overall slower. I'll need to experiment some more... but your response got me headed in the right direction.

    Thanks!
    Thursday, November 26, 2009 1:55 AM
  • Is this a notebook? You can try to disable power optimization. Also if any media file is playing on host does it make any difference?
    Thanks, -Vinod -- "This posting is provided "AS IS" with no warranties, and confers no rights. You assume all risk for your use."
    Tuesday, December 01, 2009 4:49 AM
  • I am having the same issue on several new laptops too. We run the XP-mode virtual machine by starting it directly. The virtual machine is not running full screen, but in a window. It presents the desktop as if I am connecting through remote desktop. I understand that part.

    When typing in a text box of a running program, editing a text with notepad.exe, typing in a URL in the browser sometimes the keys hit are showing up immediately and then they suddenly don't. After waiting a few seconds sometimes they are showing after that, most of the times they don't. Retyping the missing characters again mostly have to be done several times after each before they show up again. As sudden as this happens it goes away and you can continue typing your text for a while.

    I found out that if the characters typed don't show up and I start moving the mouse around while typing the reponse to typing improves a bit.

    I agree that it feels like an overloaded remote connection.

    For your information I'll give you some more information on the hardware and software used.
    Hardware: Dell Studio XPS 16 laptop with dual core processor 2,54 Ghz, 4 GB RAM, 500 GB harddisk, external USB (wired) keyboard, external USB (wired) mouse
    Software: Windows 7 Enterprise, Microsoft Dynamics NAV 5.0 SP1, Microsoft Dynamics NAV 2009 SP1, Microsoft OFfice 2007 Professional

    Again, those laptops are brand new and fresh installed.


    Hope that you have a clou were to start searching for the solution!
    Tuesday, January 05, 2010 8:54 PM
  • I'm also experiencing the same problems as Theo on two fresh HP notebooks (2.4 GHZ).  One notebook with 32 bit Windows 7 Ultimate (2 GB RAM) and one with 64 bit Windows 7 Ultimate (4 GB RAM).  Like Theo when the characters dont appear (or are taking a long time to appear) if I move the cursor they suddenly appear.

    Does anyone know if there is anything that will solve this problem?
    Friday, January 08, 2010 8:45 PM
  • This all sounds like it's power scheme related.  The host OS is lower CPU speed until you're doing something else, then it raises the speed back up and catches up.  Try the steps below.
    See this post: http://blogs.msdn.com/virtual_pc_guy/archive/2005/09/19/471612.aspx

    "It seems that people are constantly running into problems running Virtual PC on laptop systems with advanced power management.  The reason for this is that Virtual PC is very demanding on hardware and has very strict timing requirements - and as each new revision of laptops comes along these systems perform more and more complex power management.

    Problems start happening when these laptops tweak with things that we rely on.  This can either be caused when the laptop changes the CPU frequency too often, or when the laptop actually powers down sections of the system that we are dependant on in order to conserve power.  When this happens the user can see a variety of problems; ranging from sporadic pauses and bursts, virtual machines running too fast or too slow, repeated keystrokes or missing keystrokes to other timing related problems.

    If you are seeing these problems you should:

    1. Install the laptop manufacturer’s power management tools.  Sometimes using these to change the power settings can resolve the problem (though not always).

    2. Check for any bios updates available for your laptop.  From time to time we work with laptop manufacturers to address issues we encounter as part of a BIOS update.

    3. If nothing else works - you can almost always solve these problems by installing Seti@home (or folding@home).  These programs use 100% CPU running at idle priority, which means that they do not affect any other programs running on your computer - but they effectively stop the laptop from performing any power management."
    Friday, January 08, 2010 8:51 PM
  • I'm having this issue on a desktop computer. It's intermittent, sometimes I have the problem, other times it works perfectly fine. Watching the Win7 Resource Monitor, I see just simple typing raises the CPU usage on the vpc.exe all the way up to the 40-50 range (I have a dual core 2.17 GHz Intel CPU and 4 GB of RAM).

    The weird part is I'm a heavy multitasker and sometimes XP Mode works just fine even with two full rows of other programs running, and sometimes not. Sometimes like now, it will do the laggy thing even when I have virtually nothing else open except firefox, msn and outlook.
    Saturday, January 09, 2010 7:37 PM
  • Try raising the amount of memory devoted to virtual XP, I found 256 mb too little. (To do this, go to the settings of the virtual machine)
    Sunday, January 10, 2010 12:24 AM
  • My XP Mode is running with 512 MB of memory.  I have tried increasing the allocation of memory but it makes no difference to the problem.
    • Proposed as answer by PaulBowd Monday, January 11, 2010 5:01 PM
    Monday, January 11, 2010 9:21 AM
  • I believe that smjain is correct in that the problem of stuttering whilst typing is because of power management.  Unfortunately HP do not provide their own power managment tools and I am running the latest BIOS.  I've not tried the seti@home solution because I've found another solution that does not require installing software.  I now have XP Mode running without the stuttering on the HP Notebook running 32 Bit Windows 7 by following the Ben Armstrong's last resort option described here http://blogs.msdn.com/virtual_pc_guy/archive/2007/03/27/last-resort-for-performance-issues-with-virtual-pc-on-laptops.aspx

    Monday, January 11, 2010 5:19 PM
  • I will check if there are power management tools available from the manufacturer. If this is the case I'll install them and check if the problem has been solved. As far as I know the laptops are running on the latest bios available. Installing something like seti@home is not the kind of solution I am searching for. It would be much better if the problem could get solved in the powemanagement (if this is really the cause of the problem).

    Let me get back to this once I've checked for the management tools and bios version.
    Monday, January 11, 2010 9:55 PM
  • I tried with 512 MB and even 1 GB but this was not the solution.
    Monday, January 11, 2010 9:56 PM
  • As mentioned in an earlier reply of me I'll check the existance of the power management tools for my laptops and will also check the BIOS version again.
    The last resort solution is not the kind of solution I prefer. This will drain the battery much faster. I am still hoping for a real solution such as a fix in the power management or something. However it worth a try to see if the power management is the real problem. I will get back to this.
    Monday, January 11, 2010 10:01 PM
  • I have the exact same problem :-(
    Friday, January 22, 2010 6:10 PM
  • We have a T61P and have allocated 512, 1024, 2048 and now 3072 to the XP window VM. Using the VB5 IDE the typing is so slow as to be painful and non-productive. Noted that even at idle, the CPU jumps to 100% with no apparent hog except RDPCLIP which we End. We have also set the VB5.exe to Priority 'Above normal' with little of no improvement. The only thing we see is two sessions of CSRSS.exe and WINLOGON.exe in Session ID 2 or 3 which seems to be a phantom Session, as our apps appear in Session 0. We have run two different virus scans for trojans, virus and none becomes reported.

    We are seriously looking at reverting to - gasp - Vista 32-bit.

    Tuesday, February 02, 2010 12:00 AM
  • Fixed!

    I had the problem described by several of the posters here.  XP Mode stutters, was intermittently unresponsive and sometime even dropped characters while typing.  I'm running Win7x64 Pro on a Dell Latitude D630 laptop. 

    The fix was simply to go to the settings of the XP Mode virtual machine, and disable "Auto Publish" (clear the checkbox).  I did shutdown the VM first (not hibernate) before making the change.

    I use XP Mode in full screen, and so I don't really care if it publishes shortcuts to the Win7 Start Menu (never really work right for me anyway).

    I hope this helps you all as well.

    Wednesday, May 05, 2010 2:04 PM
  • Dear Glade Creek

    Thank you for your solution . I tested it and my problem solved.(just by disabling the Auto publish).

    Good luck

    Mohsen

    Saturday, May 08, 2010 1:31 PM
  • This only happens to me when I'm running off the battery so I agree that's its probably APM related.  I'm going to try turning off Auto-Publish and setting the Minimum Processor State to 100 while running on battery (by default it was set to 5% while on battery and 100% plugged in).
    Thursday, May 20, 2010 3:45 PM
  • No, in my case this is not the fix! We already tried turning off the 'Auto Publish' option without a positive result. Thanks for all your replies though.

    On this moment I am using Windows 7 Ultimate x64 on my Dell laptop as I mentioned in my first post. On my desktop (Acer Aspire M3641) I am using Windows 7 Home x64 and on this desktop I am experiencing similar problems. Not only in XP Mode with 'Auto Publish' on but also when using Remote Desktop connections and once in a while even when not using XP Mode or Remote Desktop but just Word, Outlook, Internet Explorer or another program. And my desktop does not work on batteries, so powermanagement is no suspect either.

    I must say that I have quite a bit of experience of Windows 7 now because I am using Windows 7 daily on at least one of both machines. On both the machines the problem is an issue and that is why I have stopped believing that this problem is only related to Windows XP Mode (Virtual PC) or Remote Desktop. I guess that the problem lies a bit deeper in the Windows 7 system. I suspect that it has something to do with the handling of the keystrokes in Windows 7 in combination with the other programs running in the background. Programs losing focus or something.

    When I am using Remote Desktop to connect to the office I have some other programs running as well. The most important ones are Windows Live Messenger, Skype, Internet Explorer 8 and Outlook 2007. This set of programs are causing the problem on my desktop quite often. It feels like the program I am using at that moment on the remote connection (for instance an editor or notepad) temporary looses the focus for keystrokes to another program such as Outlook or IE8 and once I move my mouse it immediately gets the focus back. The keys I am typing are shown again, sometimes stuttering first.

    I am convinced that if I manage to get this problem solved on my desktop I will have the solution for the laptops too.

    More help or suggestions is highly appreciated!

    Thursday, May 20, 2010 8:41 PM
  • I am axperiencing the same issue...cpu usage at %100 and slow typing. To see where the resources where being used, I installed cacheman on the xpmode side which is an optomization and system information program and it seems that (at least on my machine hp laptop dual core 4 gig ram windows 7 64 bit) windows xp mode is only running on one core.

    Has/can anyone else verified this as it might explain why xp mode is soooooo sluggish.

     

     

     

    Sunday, June 06, 2010 9:25 PM
  • XP Mode is only running on one core, Windows Virtual PC only exposes one core to the VM.  it still shouldn't be that sluggish, I suspect a power management issue...
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    Sunday, June 06, 2010 9:33 PM
  • If I have a 2GHz dual core cpu and xp mode only uses one core, would I not now have a 1ghz single core system to run xp? I believe they were making a 1ghz processor back in 2000..., that's 10 years ago. Now I am trying to run current or close to current software a system effectively 10 years old and you think that the "bottleneck" in not the cpu????

    Am I missing something here?

     

     

     

    Sunday, June 06, 2010 10:01 PM
  • Actually no, XP has a 2Ghz core, you don't split the Ghz in half as each core runs at the stated rate.  Ghz is a real weird indicator anyway, as you can only compare like cores to each  by Ghz.  (A 3.4 Ghz P4 CPU is not faster than a 2Ghz modern CPU...
     
    I most certainly think it's not the CPU as I run it on lesser hardware and it's not sluggish at all, and my laptop has the same symptom of sluggish performance without a performance management "tweak".
     
     
    (Yes, it says it's for VPC2007, but it still works in Windows VPC.)
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    Sunday, June 06, 2010 11:25 PM
  • Alright, this tweak involves editing some power options for virtual pc. I did the edit and restarted and lo and behold the cpu utlization dropped from 90%+ when idle to beween 5% to 15% when idle. This definately disabled some power saving feature as I can hear the cpu fans running full time now when they were not before. A very small price to pay for the increase in performance!

    BOB HAS ANOTHER FAN, BOB IS THE MAN!

    Monday, June 07, 2010 12:32 AM
  • Glad to help! 
     
    The fans running is a drawback, especially on my rather hot running laptop, but at least the VM works well.
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    Monday, June 07, 2010 2:03 AM
  • Worked for me!

    Disabling "Auto Publish" fixed the issue of delayed typing and sluggish performance.  Thanks Glade.

    Monday, July 05, 2010 2:25 AM