none
Error message 401.3: You do not have permission to view this directory or page using the credentials you supplied (access denied due to Access Control Lists). Ask the Web server's administrator to give you access to 'C:\inetpub\wwwroot'.

    Question

  • On Windows7 Pro,  trying to run IIS.  The way I am used to execute is  on the browser "localhost".  I used to have the code in the directory  C:\inetpub\wwwroot.   Even before I copy,  I am hoping to see the image IIS welcome page.  Once it is successful, want to copy the code as that was the way I used to do in Window XP.    However I am getting the following message.  I have administrator access to the machine and gave full permissions to the folder  'C:\inetpub\wwwroot'.  Still the same message. 

    Error message 401.3: You do not have permission to view this directory or page using the credentials you supplied (access denied due to Access Control Lists). Ask the Web server's administrator to give you access to 'C:\inetpub\wwwroot'.

    Can someone help me to address this issue.  Thanks a lot in advance. 


    Thursday, August 16, 2012 9:35 PM

Answers

All replies

  • You should be able to fix this by giving your account read / execute permissions to 'C:\inetpub\wwwroot'.
    Friday, August 17, 2012 12:41 AM
  • Nigel,

    Thank you for your respone.  Already there is full control, modify, read & execute, list folder .  I see full contol, read, write, etc.  Still did not help.

    Satish.


    SatishDavaluri

    Friday, August 17, 2012 1:49 AM
  • Can you confirm if you are you using anonymous authentication for the default site?
    Friday, August 17, 2012 1:54 AM
  • How to use anonymous authentication for the default site.  Can you please give steps.  I log in with my id into the computer, which has  administrator  privileges. 

    SatishDavaluri

    Friday, August 17, 2012 2:51 PM
    • Proposed as answer by Nigel Finn Tuesday, August 21, 2012 2:27 PM
    Friday, August 17, 2012 3:59 PM
  • I did verify it is already anonymous authentication  enabled.  When I click on edit, found  specific user  : IUSR.   Changed it to the id with which I log in and set the password.  Then when went to the browser  and typed in   defaulthost, slightly better.  I get the logon page of my application(this application built log page).   

    When I click on it,  

    HTTP Error 405.0 - Method Not Allowed

    The page you are looking for cannot be displayed because an invalid method (HTTP verb) is being used.

    <legend>Detailed Error Information</legend>
    Module StaticFileModule
    Notification ExecuteRequestHandler
    Handler StaticFile
    Error Code 0x80070001
    Requested URL http://localhost:80/<name of  the asp>
    Physical Path C:\inetpub\wwwroot\<name of  the asp>
    Logon Method Anonymous
    Logon User

    Anonymous

    For a minute that problem solved.  I am wondering why Microsoft had to make it so difficult from XP to Windows 7, or if that is how it is, should have given instructions -  step by step.    Appreciate very much if any one can help here. 

    Thanks Nigel for your input.  Please see if you can help further.


     Further, I have updated back the IUSR.   Still the same.   Able to get the log on page,  when I click it, it gets to the above. 


    • Edited by satish081612 Friday, August 17, 2012 9:59 PM
    • Proposed as answer by Nigel Finn Tuesday, August 21, 2012 2:27 PM
    Friday, August 17, 2012 9:51 PM
  • A bit of searching online and I found the following IIS forum post by vdogra77 (http://forums.iis.net/t/1176772.aspx)

    This is typical to IIS 7.5 which has WebDAVModule installed by default which is causing this behavior and not recognizing PUT (and also DELETE) as valid Http verbs.

    Solution is to modify your web.config file with following and removing this module in the process.

     <system.webServer>
    <modules>
    <remove name="WebDAVModule" />
    </modules>
    </system.webServer>

    Please try this and let me know if this works. If it doesn't, can you tell me a little about your application? Is it something you've created or is it part of a commercial product? Also, can you please enable logging and post anything you find that you think might help? A good guide can be found here http://learn.iis.net/page.aspx/579/advanced-logging-for-iis---custom-logging/

    Saturday, August 18, 2012 12:03 AM
  • What is the path of   web.config , I am not able to find  from C:,  it is  custom built, not  commercial product.

    SatishDavaluri

    Saturday, August 18, 2012 2:57 AM
  • Generally you need to either create the web.config file in the root of your application or website directory, or alternatively, let IIS create it for you by making some arbitrary configuration change with the configuration editor - the former option is more straightforward I think.

    Saturday, August 18, 2012 12:25 PM
  • How's everything going satish? Any progress?
    Sunday, August 19, 2012 10:27 PM
  • Thank you Nigel for following it up.  I was looking to where (path) the  web.config to be created and  what else to be in if the content you mentioned to be removed.  I wish Microsoft  provide direct help or  step by instructions to upgrade from XP to Windows 7 for IIS.  As essentially there is no change to the code and just this permission issue. 

    SatishDavaluri

    Monday, August 20, 2012 3:12 AM
  • Hi,


    For IIS related question, it is recommended to post the thread in IIS Forums.


    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us. Thank you for your understanding.


    Regards,


    Vincent Wang

    TechNet Community Support

    Monday, August 20, 2012 4:06 AM
  • Vincent,

    Can you please give linkto IIS forum.  I am assuming it is within   microsoft site.   Thank you for your advice.


    SatishDavaluri

    Monday, August 20, 2012 5:10 AM
  • Hi,


    You can click the IIS hyperlink in my previous post or using this one

    http://forums.iis.net/


    Regards,


    Vincent Wang

    TechNet Community Support

    Monday, August 20, 2012 8:24 AM
  • Hi Satish,

    When it says to remove the module, that really means you need to add the section:

     <system.webServer>
        <modules>
        <remove name="WebDAVModule"/>
        </modules>
      </system.webServer>

    If that doesn't work, definitely go for the IIS forums suggested by Vincent.

    Monday, August 20, 2012 9:56 AM
  • HTTP Error 405.0 - Method Not Allowed
    The page you are looking for cannot be displayed because an invalid method (HTTP verb) is being used.


    Detailed Error InformationModule StaticFileModule
    Notification ExecuteRequestHandler
    Handler StaticFile
    Error Code 0x80070001
    Requested URL <a href="http://:80/mypage.asp">http://<computerName>:80/mypage.asp
    Physical Path C:\inetpub\wwwroot\mypage.asp
    Logon Method Anonymous
    Logon User Anonymous

    Anyone, only if you know the solution to the above problem, please provide.  Please do not redirect with general answers such a look into web.xml etc,  not specifying exactly where that file exists.   Same thing works in  Windows XP. Only issue in Windows 7. Which means Microsoft had changed something related to IIS in Windows 7 and I am looking forward to precisely what to change  please.


    SatishDavaluri

    Tuesday, September 04, 2012 10:48 PM
  • I was facing the same issue and after going round and round on my webserver and firewalls it turned out it was just the port mapping on my router that was messed up

    Monday, September 09, 2013 9:14 AM
  • It works fine, thanks a lot.
    Friday, October 18, 2013 9:42 AM