none
Windows 8 Hyper-V Networking Problem

    Question

  • Hi,

    after I installed the Hyper-V Feature on my Windows 8 RTM machine, my plan was to install a Win7 virtual machine via network-install.

    The problem is after configuring the virtual switch, my host-system has no connection to the network anymore and the network-boot isn't possible too.

    After configuring the virtual switch a new network adapter appears in the networkadapter management. The physical adapter has no properties activated except the virtual switch-property. The new adapter is configurerd like the old physical adapter. The adapter is configured to use DHCP. Even changing it to a static IP doesn't change anything. There are also no changes (for the guest-machine) if I disable the shared use of the network-card in the virtual switch management.

    If I use my WLAN-Adapter instead of my Ethernet-Adapter it is the same except there is a network bridge in the networkadapter management more compared to my Ethernet-Adapter (so there are two more adapters).

    Configuring the virtual switch with my UMTS-Card is like the Ethernet-Card.
    The Ethernet-Driver is updated to the newest driver by Microsoft.

    Has anyone an idea what is happening there and how to solve that issue?


    www.krifi-ware.de www.nless.de


    • Edited by Hunv Wednesday, September 05, 2012 7:33 AM
    Wednesday, September 05, 2012 7:00 AM

Answers

  • Hi,

    I solved it.

    Unbelievable but you have to disable the new Hyper-V-Adapter and enable it again solved it. This is the Adapter, that is named "vEthernet (New virtual Switch)".
    That there is no network bridge seems to be irrelevant.

    • Marked as answer by Hunv Thursday, September 06, 2012 7:20 AM
    Thursday, September 06, 2012 7:20 AM

All replies

  • Hi,

    I solved it.

    Unbelievable but you have to disable the new Hyper-V-Adapter and enable it again solved it. This is the Adapter, that is named "vEthernet (New virtual Switch)".
    That there is no network bridge seems to be irrelevant.

    • Marked as answer by Hunv Thursday, September 06, 2012 7:20 AM
    Thursday, September 06, 2012 7:20 AM
  • Hi,

    I have the same problem with Windows 8 RTM Enterprise, and Hyper-V. I tried disabling and enabling the virtual adapter, but this not worked for me. Any other idea???

    Thanks

    Friday, September 07, 2012 2:31 AM
  • Hi,

    before I solved it, I reinstalled Hyper-V (without any changes) and disabled and enabled the physical adapter. Did you already tried this?

    Friday, September 07, 2012 5:27 AM
  • Hi, 

    I did the reinstallation, but the problem persists. Any other idea?

    Thanks !

    Friday, September 07, 2012 9:58 PM
  • Ensure the virtual switch has been configured to allow the host machine to use the chosen network connection.

    Go into the Virtual Switch Manager and select the virtual switch that you have created. It sounds like you have created "External network" connections. Ensure there is a check beside "Allow management operating system to share this network adapter." If this is not checked off the host machine will not be able to use the chosen adapter.


    • Proposed as answer by stuinz3 Thursday, April 11, 2013 11:18 AM
    • Unproposed as answer by Hunv Thursday, April 11, 2013 11:27 AM
    Saturday, September 08, 2012 5:44 AM
  • Thanks Andrew, but that's not the problem. The option is checked. The problem appears when I create Internal, External, and Private Virtual Switches. I think could be a bug from the RTM version, because I used Hyper-V in the Realease Preview version, and always it worked fine.

    Thanks again.

    Saturday, September 08, 2012 2:55 PM
  • Hi Andrew,

    as Rodrigo said: That is not the problem. Everything is configured correctly and the configuration works on each other Windows Server 2008 R2. It is definitely a bug.

    There is just one thing, that would be interesting: Does the bug exists even after a reinstallation of Windows 8. I will not test it, because I have my working workaround.

    Monday, September 10, 2012 5:39 AM
  • First, I have not tried running Hyper-V on Windows 8 yet. I do VM's on the server ... but this might be my chance :o)

    However, to do network boot with Hyper-V you would previously have had to use the Legacy Network Adapter. I guess it's still so. Go to you WM's settings and select - Add New Hardware to find the Legacy Network Adapter.

    Corcerning VM's in Windows 8 - including the use of the Legacy Network Adapter (for Network Boot I assume) - I retrieved this post from Google (have not read that - just peeked throught it to reconfirm the use of the Legacy Network Adapter is still around for Windows 8 on issues concerned with network deployment of an OS):

    http://www.eightforums.com/tutorials/5078-hyper-v-create-linux-virtual-machine-windows-8-a.html




    Tuesday, September 11, 2012 4:23 PM
  • Hi Computermensch,

    the booting from network is just the scenario. It is not a problem.
    I am Microsoft-certified in virtualisation and I know how to configure Hyper-V. It is a BUG! It is not a missconfigured setting or something else. It is a bug!

    As I already wrote:
    Disabling an Enabling the virtual Hyper-V network-Adapter is a workaround for me that finally works. That would not work, if something is configured the wrong way I think!

    Wednesday, September 12, 2012 6:32 AM
  • I just had the same problem with Win 8 RTM,  I had to disable both the vEthernet adapter and the base ethernet adapter.....then reboot..and re-enable the vEthernet adapter...

    Definitely a bug.

    Tuesday, September 18, 2012 3:06 AM
  • Maybe we can figure out who are the people with that problems.

    I think it could maybe the Networkdriver.
    I have a Toshiba R700 with a Intel 82577LM Gigabit Network Adapter.

    The driver-information from the device manager are the following:
    Provider: Intel
    Date: 2012-07-12
    Version: 12.1.77.0
    Signature: Microsoft Windows Hardware Compatibility

    Tuesday, September 18, 2012 5:23 AM
  • It looks like the DHCP Client for vEthernet is not working.  Always picks up 169.254.x.y address
    Sunday, October 14, 2012 5:57 PM
  • Have same issue :( restarting did not help at all, on my Windows 2012 Server External Network work just fine:( No more clues at the moment.


    michal.furmankiewicz (MCS Poland)

    • Proposed as answer by Guillaume O Thursday, November 08, 2012 6:13 PM
    • Unproposed as answer by Guillaume O Thursday, November 08, 2012 6:14 PM
    Sunday, November 04, 2012 8:05 AM
  • I have exactly the same issue on my machine when adding a external network interface plugged connected to my Wifi network adapter. Once created, I get internet access on my VM but not on my host. Restarting the vEthernet adapter does not change anything for me. I had to reboot my machine to make the vEthernet adapter working again !


    • Edited by Guillaume O Friday, November 09, 2012 1:15 PM
    • Proposed as answer by Guillaume O Friday, November 09, 2012 1:15 PM
    • Unproposed as answer by Hunv Thursday, April 11, 2013 11:28 AM
    Thursday, November 08, 2012 6:17 PM
  • I had the same exact problem.  Created a virtual network switch, pointing it to my Network controller as an External (and gave management to the OS) and BAM--killed my host's ability to log on (The vbox works fine)  Tried disabling/enabling, no help.

    The process does create a second, vLan adaptor in network connections with all the original adapter's settings re: tcp ip and such. 

    What seems to happen is your old Lan adapter is reconfigured and now points to the new one (the old LAN adapter ONLY has the "virtual switch" protocol enabled now--kind of making it a pointer to the new one--and you can't turn on tcp or turn off the switch unless you uninstall the switch from the vswitch manager. 

    Really, really crappy job of letting you know what's happening, Microsoft.  When you add new adapters, and reconfigure old ones, there should be at least some help text on what's going on. I don't do this everyday, and not everyone lives and breathes this stuff.

    The fix that worked for me was to, in the NEW VEthernet LAN adapter in Network Connections, I turned off "Virtual Machine Network Services".  That was it--I may have had to disable/renable one more time, but killing that seemed to make the redirection work properly, and now the Host is online.  Who knows if this will hold forever, but it makes sense that that old Virtual Machine Network Services was getting in the way somehow.  I guess

    Sunday, November 11, 2012 6:35 PM
  • I've been hunting for a solution for this problem too, and I finally found one, but you are not going to like it.

    So after you set up Hyper-V with an external switch, you end up getting that extra adapter in your network settings.

    As has already been specified, this extra virtual adapter is supposed to connect the host machine through the physical adapter, and gain you network access.

    Broken.

    But, if you go into the PHYSICAL ADAPTER, which should only have the Hyper-V Extensible Virtual Switch checked, and check all those other checkboxes, you will get a nasty-gram saying IPv4 and IPv6 will be disabled (just click 'ok), then suddenly you will have network access on the host (as well as within Hyper-V).

    Sounds great, right?

    Until you reboot, at which time you must do this all over again.

    Tuesday, November 20, 2012 9:07 PM
  • I am having this exact same issue, however none of the suggestions above have remedied this situation for me.

    Here's my setup: NIC with (4) GB connections, port 1 for host system, port 2 for VM1, I have setup the virtual switch to external and connected to port 2 of my NIC. 

    The vEthernet adapter that is created is stuck in Unidentified network with no network connectivity. My VM shows only one network adapter called Ethernet. This adapter is stuck with a 169. IP, and even assigning a valid static address is not working. 

    Any other ideas??

    Wednesday, November 21, 2012 5:42 PM
  • In case anyone else has this issue, and a disable/enable cycle on the adapter doesn't work, try opening the vEthernet adapter properties > Configure button > Advanced tab. Change any setting in there - I recommend disabling both Large Send Offload V2 options.

    That should return the adapter to a working state.

    Edit: If the vEthernet adapter is AWOL, reinstall your physical adapter's drivers, then recreate the virtual switch using Hyper-V Virtual Switch Manager. The vEthernet adapter should then appear, but will still be broken. You'll then be able to configure that adapter's properties to restore your connection, as described above.

    • Edited by SSonik Wednesday, December 12, 2012 4:59 AM
    Wednesday, December 12, 2012 4:54 AM
  • What about trying to not use the virtual switch? I ran into what may be the same issue with sharing the physical connection. Anyone doing this:

    1. Make sure the physical/host OS can connect to the internet

    2. Create an INTERNAL virtual switch in the guest, make sure DHCP is on, automatically optain IP address

    3. Go back to host machine and in the adapter config, select the "sharing" tab and allow the guest to share the connection.

    I had this working just fine. I shutdown the machine, came back the next day and it wasn't working. Nothing I did would allow the guest to connect. It was like DHCP wasn't working. I also get the bogus 169.254.x.x address.

    Interestingly, it also seemed to break my network connection on the host. After every turn on from a shutdown, I have to open the network and sharing center and find my "wifi" adapter, disable it and enable it. I unshared the adapter finally and it seems to connect as it should after a restart. So at the moment, I can't network into my VM.

    Thursday, December 13, 2012 11:32 PM
  • Also, can Windows 8 Hyper-V work in any configuration with a wifi adapter? I saw clear notes from 2010 and Windows 2008 Server that you can NOT use a wireless network card with Hyper-V. You have to use a wired connection. But since Windows 8 comes on laptops, I was hoping this requirement was abandoned.
    Friday, December 14, 2012 12:45 AM
  • Hi,

    I solved it.

    Unbelievable but you have to disable the new Hyper-V-Adapter and enable it again solved it. This is the Adapter, that is named "vEthernet (New virtual Switch)".
    That there is no network bridge seems to be irrelevant.


    worked for me, Windows 8 enterprise , thanks
    • Proposed as answer by Evan S. Tallas Wednesday, January 22, 2014 7:25 AM
    • Unproposed as answer by Evan S. Tallas Wednesday, January 22, 2014 7:25 AM
    Tuesday, December 18, 2012 9:40 AM
  • Can any of you guys using Hyper-V confirm corruption of some system files after! disabling Hyper-V?

    >SFC /VERIFYONLY (will leave all untouched but lists errors found.)

    Test sequence:

    Windows 8 Pro before enabling Hyper-V - SFC finds no errors

    Windows 8 Pro with Hyper-V enabled - SFC finds no errors

    Windows 8 Pro after disabling Hyper-V - SFC finds errors


    2012-11-24 14:57:30, Info                  CSI    00000409 [SR] Repairing corrupted file [ml:520{260},l:82{41}]"\??\C:\Windows\System32\driverstore\en-US"\[l:30{15}]"wvms_mp.inf_loc" from store
    2012-11-24 14:57:30, Info                  CSI    0000040a [SR] Repairing corrupted file [ml:520{260},l:82{41}]"\??\C:\Windows\System32\driverstore\en-US"\[l:34{17}]"wvms_vspp.inf_loc" from store
    2012-11-24 14:57:31, Info                  CSI    0000040b [SR] Repairing corrupted file [ml:520{260},l:74{37}]"\??\C:\Windows\System32\drivers\en-US"\[l:32{16}]"vmswitch.sys.mui" from store
    2012-11-24 14:57:31, Info                  CSI    0000040c [SR] Repairing corrupted file [ml:520{260},l:82{41}]"\??\C:\Windows\System32\driverstore\en-US"\[l:30{15}]"wvms_pp.inf_loc" from store
    Thursday, December 20, 2012 4:24 PM
  • Hi

    Fully agree with Hunv this is a bug

    I found I need to disable the VNetwork interferace and reenable it after every reboot/boot up.

    I have bought a second network card just for the VM's. I am running this on my desktop I7/16GB Ram machine with Intel Motherboard with Intel Gigabit LAN adaptor.

    G

    Wednesday, January 02, 2013 8:48 AM
  • Hi,

    I had the same issue and Hunv's solution worked for me but I had to disable and reenable the vEthernet adptor after each reboot till I realized that my problem was solved by unchecking the "VirtualBox Bridged Network Driver"  in vEthernet.

    • Proposed as answer by ViktorLevi Thursday, January 03, 2013 7:32 AM
    • Unproposed as answer by Hunv Thursday, April 11, 2013 11:28 AM
    • Proposed as answer by DataCruncher Tuesday, June 04, 2013 11:40 PM
    Thursday, January 03, 2013 7:30 AM
  • My symptoms were the same, except I found that if I am actually using the wireless network adapter on my laptop, then setting the Hyper-V virtual Extensible network switch connected to my Physical RJ45 Adapter it works (or vice-versa), but if I use my Hyper-V Virtual Extensible Network Switch connected to the same adapter/connection that I am actually using on the Host, it fails (but the virtual computers intermittently work).

    It seems that the Hyper-V Virtual Extensible Network Switch must be connected to the same adapter that is physically connected to the network for the Virtual Machines to work (though my office network shows intermittent pings fail (60+ of the time), but be connected to another adapter than the host intends to use for the Host to connect to the network.

    It looks like a bug that both the virtual switch and the host cannot use the same NIC. The Host reports it is not even connected, not just APIPA (169.254....)

    Windows 8 Enterprise.
    Thursday, January 10, 2013 5:39 AM
  • Hi

    select your Hyper-V machine, right click and choose Virtual Switch Manager. Click on New Virtual network switch and on right hand side pan, click on External and then click on create Virtual Switc.

    Name your Virtual switch and select your physical External network card and tick the box "Allow Management Operation xxxxxxxxxxxxxxxxxxx"

    this will enable virtual switch on your vm.

    Hope this will resolve your issues.

    Monday, January 14, 2013 5:05 PM
  • From reading other posts, and this forum it seems to me that if you are using a wireless network adapter you are going to hit a lot more problems with this.  I've more or less given up trying to get it to work reliably - for me it seems that Hyper V under windows 8 is unusable against a wireless connection until Microsoft fixes it.

    Would love to know if Microsoft are acknowledging any problems with it and working on a solution.

    Friday, January 25, 2013 11:18 AM
  • I just wanted to add my 2 cents to this thread aswell.  I am experiencing this issue.  Trying to network boot 2 VM's on Windows 8 Hyper-V blats the networking.  Works fine on a single network card in Windows 2008 R2 and Windows Server 2012 (with hyper-v roles installed).  It just seems to be an issue that is Windows 8 specific.  I am also doing this on a desktop PC that has no wifi network card.  However, I can replicate the same problems on my laptop with has both Ethernet and wifi. 

    +1 for bug  (will attempt to remedy the situation now using some of the fixes suggested in this thread)


    http://www.dreamension.net

    Wednesday, January 30, 2013 3:25 AM
  • Hi, same issue here,
    HP8560W Laptop Win 8 Enterprise x64 w. Intel(R) Centrino(R) Advanced-N 6205
    and Intel(R) 82579LM Gigabit Network Connection.

    Issue can be reproduced with both NIC's, so in my case it is not about the Wi-Fi only.
    I can work around thist creating a network bridge, but after reboot host
    network is dead again - until I remove the network bridge.
    Clearly a bug.


    -Ville

    Wednesday, February 13, 2013 3:46 PM
  • Hi

    I solved mine by first deleting the NIC in the VM settings and adding it back. This is done by first powering off the VM.

    Be sure to experiment with Network Adapter and Legacy Network adapter.

    Also remember to add the Integration services disk.

    - Andre


    Regards Andre Thompson

    Wednesday, February 20, 2013 4:40 AM
  • Maybe its a bit too late, but try enabling the IPv6.

    That worked for us.

    Monday, March 04, 2013 9:55 PM
  • Thank you. I found that disabling and re-enabling did the trick on my physical nic (haven't tested yet with my wifi connection)

    Something else to watch out for is the VLAN setting in the Virtual switch manager (not the virtual machine). In a simple scenario you should NOT be using it.


    PS. Please remember to mark your question as answered if you got good advice.

    Tuesday, March 05, 2013 10:02 AM
  • I have the same problem in Windows 8 pro desktop. I have to disable and re enable Hyper-V adapter every time I reboot the computer. I even updated the Realtek network driver. Problem is still there. disabling and enabling is not a solution. I have to use my Windows 7 pro  VM under Hyper-V
    Friday, March 22, 2013 4:49 PM
  • I played with this for a couple of hours each day until I got the pattern down.

    If you go to the top of this article, I believe the original author is correct.

    I had attempted several solutions.  The key to this is after you get your HOST OS working with the INTERNAL or EXTERNAL adapter or both do the following:

    a) Delete the "VIRTUAL Adapter" in the "Virtual Switch Manager" one more time

    b) Re-create it after the you have the correct IP.

      My local host IP was 192.168.1.55 / 255.255.255.0 / 192.168.1.1 (and add a DNS)

    c) Now, that we have that, delete and try the Legacy adapter in the "Settings" for the VM.  I got success first with the Legacy Adapter but after a few updates and service packs, my Legacey Adapter would not work so, I used the regular Networking Adapter

    d) Make sure after you start or restart you VM to ENABLE and DISABLE you VIRTUAL ADAPTER

    Once the VM restarts it should come back online with a good internet connection.

    • Proposed as answer by dtate222 Monday, March 25, 2013 9:21 PM
    Monday, March 25, 2013 9:21 PM
  • I have the same problem in Windows 8 pro desktop. I have to disable and re enable Hyper-V adapter every time I reboot the computer. I even updated the Realtek network driver. Problem is still there. disabling and enabling is not a solution. I have to use my Windows 7 pro  VM under Hyper-V

    One vote from here as well. The physical NIC what I have is: "Intel(R) 82579V Gigabit", but behavior is equal. Every reboot and I have to disable/enable Hyper-V's virtual NICs. And then I get the internet connection.

    Petri

    Sunday, April 07, 2013 7:30 PM
  • I have the same problem in Windows 8 pro desktop. I have to disable and re enable Hyper-V adapter every time I reboot the computer. I even updated the Realtek network driver. Problem is still there. disabling and enabling is not a solution. I have to use my Windows 7 pro  VM under Hyper-V


    One vote from here as well. The physical NIC what I have is: "Intel(R) 82579V Gigabit", but behavior is equal. Every reboot and I have to disable/enable Hyper-V's virtual NICs. And then I get the internet connection.

    Petri

    Same here... Windows 8 Pro, HyperV enabled, I have VirtualBox installed too though.  But without disabling and re-enabling the two NICs it will not allow for host networking to work.  Most definitely a bug.
    Wednesday, April 10, 2013 5:22 PM
  • I had tried all the enabling a disablings, rebootings etc suggested here, and it was only when I read this post and remembered I'd also fiddled with that checkbox in the Hyper-V Virtual Switch Manager too, that I remembered to uncheck it, and it worked.

    So if disabling / re-enabling isn't working, try unchecking that box (if it is checked).

    That's 90 mins of my life I ain't getting back...

    Sunday, April 14, 2013 12:14 PM
  • David, are you saying to uncheck the 'Allow management operating system to share this network adapter' checkbox? The problem I get is the same as Hunv I think. I can have been connected for a while, then suddenly I lose both my wifi and wireless connections but I see a network bridge in the Network Adapter list. When I delete the network bridge and reconnect my problem is gone. But I'm not sure why this keeps happening.
    Wednesday, April 17, 2013 11:30 AM
  • In case anyone else has this issue, and a disable/enable cycle on the adapter doesn't work, try opening the vEthernet adapter properties > Configure button > Advanced tab. Change any setting in there - I recommend disabling both Large Send Offload V2 options.

    That should return the adapter to a working state.

    Edit: If the vEthernet adapter is AWOL, reinstall your physical adapter's drivers, then recreate the virtual switch using Hyper-V Virtual Switch Manager. The vEthernet adapter should then appear, but will still be broken. You'll then be able to configure that adapter's properties to restore your connection, as described above.

    This worked for me - thanks SSonik
    Monday, May 20, 2013 7:55 PM
  • I am in basic agreement that Microsoft has failed in a major way with this virtual switch configuration and I would very much like to have back the many hours that I have spent trying to figure out why this seemingly simple thing does not work as expected. 

    I followed the instructions I saw from a Microsoft employee on a youtube video for setting up a virtual switch on his laptop.  It just so happens that the desktop I am using to run Windows 8 with Hyper-V has on-board Ethernet and I added a PCI wireless NIC that I had laying around (not for use with Hyper-V, but because I was thinking about re-locating the desktop).  Needless to say, after following youtube guy's instructions, I discovered that both the wired and wireless connections have to be connected in order for the host and the VMs to function.

    So how you can make this work with a single NIC is still beyond me.  I started this whole exercise while prepping for exam 70-646 (Windows Server 2008) because I would like to set up multiple virtual machines to complete the exercises in the Microsoft exam prep book.  This issue, while interesting, has been an extra delay in achieving my training goal.

    And here is a dumb question:  Why must the virtual switch have an IP address of 192.168.137.1?  I should be able to give this virtual switch any address that I choose.  Not that it is a big deal, but it just seems weird and like a really strange restriction.

    Also, even with the two-NIC setup, and following the exact instructions provided by Mr. Microsoft Employee on youtube, I notice some odd symptoms on the Windows 8 host now.  Sometimes the browser takes longer to bring up sites than it should.  And here is something really interesting, the Windows 8 Store now thinks that I have no internet connection, so I cannot install any apps from the store now.  I suppose I cannot update any apps, either.

    With two NICs to work with, you would think that Hyper-V would at least leave me with one working NIC, but instead, it appears to break both of them. 


    • Edited by joeweaver Wednesday, May 29, 2013 1:23 AM
    Wednesday, May 29, 2013 1:21 AM
  • Hi,

    I solved it.

    Unbelievable but you have to disable the new Hyper-V-Adapter and enable it again solved it. This is the Adapter, that is named "vEthernet (New virtual Switch)".
    That there is no network bridge seems to be irrelevant.

    I'm running Windows 8 Pro and Hyper-V with this exact issue.  Disabling and enabling the vEthernet switch instantly solved this, even while the guest VM was running.

    Thanks for the post. This was a REAL pain and is an obvious bug for sure.

    Friday, May 31, 2013 3:17 AM
  • Hi,

    I solved it.

    Unbelievable but you have to disable the new Hyper-V-Adapter and enable it again solved it. This is the Adapter, that is named "vEthernet (New virtual Switch)".
    That there is no network bridge seems to be irrelevant.

    I've got a similar problem, tried this solution but it didn't work, but maybe my problem is different.

    Basically when I install Hyper-V on the client, it no longer appears in the network browser.  I can still ping it, there is still a network connection, I just can't see it on the network anymore.  As soon as I uninstall Hyper-V it instantly appears again.

    It's obviously something to do with the virtual switch but I'm damned if I can figure it out, I've tried all the obvious stuff, poking around in the network settings and so on.  The adapter on my test machine is also an Intel one, I tried updating the driver, no luck, been through all the link layer stuff.

    I can manage without seeing it in the network browser but it is annoying.

    Based on this thread I think I might try putting a different brand of NIC in it and see if that works.

    Wednesday, July 03, 2013 2:46 PM
  • I just have the same problem on Windows 2012 with NIC Teaming.

    Because I lost the communication with the AD Server I had to connect using the local administrator password. When I removed the problematic virtual switch and recreated it using the local computer administrator all worked at first time. That is really strange because I am a Domain Administrator. 

    I hope it can help someone.


    Sunday, July 21, 2013 11:17 AM
  • This was exactly what was my problem! IPv4 offloading. Turn it off, everything works fine!
    Tuesday, July 23, 2013 8:04 PM
  • Hi,

    I have W8 Pro and same problem appears.

    I downloaded Server 2012 R2 vhd image from MS site and struggling to make virtual switch to work with no success. 

    I tried every solution posted here with no luck....

    MS, please investigate and fix this!

    BTW, I have Intel(R) 82577LM Gigabit Network Connection


    • Edited by TURNSKIN85 Wednesday, July 31, 2013 1:24 PM
    Wednesday, July 31, 2013 1:21 PM
  • Hi,

    If Disabling and Enabling doesn't work please take a look at the internet connection sharing. It could well be disabled by (a central) policy. Disabling this policy did the trick for me.

    Kind Regards,

    Monday, September 09, 2013 7:20 AM
  • Hi.

    I’ve been struggling with disabling and enabling of adapters both at the Win8-host and at many simultaneous VMs. After a while I could make each one work but only one at a time. Never all simultaneously.

    Then I realised that our company switch (CISCO ESW 540) was configured to only allow one “standard desktop” on the ethernet port connected to my Win8-PC-host. This is a security feature in the switch. In other words, the switch does not let the network traffic through from more than one computer. Cisco ESW-540-24

    I simply moved my Ethernet cable from port no: 1 at the switch (configured for single desktop), to port no: 24 at the switch (configured for up-link to other switches) and suddenly everything works perfectly. All VMs and also the Win8 host receives IP-addresses dynamically and connects to internet without problem.

    In other words, check your switch (or router) and verify that the ethernet port you are connected to allows multiple computers.



    • Edited by PG Sweden Wednesday, September 11, 2013 11:53 AM
    Wednesday, September 11, 2013 11:39 AM
  • Wednesday, October 09, 2013 12:10 AM
  • I had the same problem under 8.1 with 8.1 Ent VMs connected to an External Virtual Switch.  This also solved the problem for me.

    This is definitely a reproducible bug.


    Wednesday, January 22, 2014 7:29 AM