none
Internet Explorer 8 window on top (z order) issues in system running Windows XP SP3

    Question

  • Link to Original Question in IE8 Forums

    I had asked this question in the IE8 Forums but was directed by the Moderator to ask this in the TechNet forums for a better response.

    My environment:

    IE8 on Windows XP Prof SP3 with all latest updates installed (Windows XP Mode)


    Issue:

    Open 2 or 3 windows (maximzed; 1 notepad, 1 IE and 1 MS word or any other application )
    Go to Help->Internet Explorer Help in IE.
    Switch to the "Search" tab and search for anything.
    Double click to select any of the "Topics to display"
    Close the help screen.  I would expect to go back to the Internet Explorer window from where you opened the help.
    But some other window (whichever was next in the "z order") is displayed.


    Additional Info:

    The issue is happening in all the virtual XP machines that we have that have IE8 installed (not just the Windows XP Mode machine).
    No one has noticed this probably because it does not happen that often (that you open a 2nd window from the 1st window and then open a 3rd window from the 2nd window etc.).
    I even checked a basic install (just XP SP3 with IE8) and it happens there too (without any 3rd party stuff installed).

    It is even more glaring in the Spy++ tool that comes with Visual Studio (tried in VS 2005, 2008 and 2010).

    Run Spy ++ in maximized mode.  Open 2 or more other windows (also in maximized mode; say File Explorer, notepad, MS Word etc.)
    Go to Help -> Help Topics in the Spy++ application.
    Switch to the search tab and search for "z order" (or anything at all)
    Double-click on any of the topics that were found.
    Close the help window.

    Friday, February 17, 2012 2:35 PM

Answers

All replies

  • I have seen many z-order problems in WVPC seamless windows, and I know
    of nothing to help the situation.
     
    Since you have a specific scenario, you might want to turn it into
    Microsoft Product support directly as an example of the problem.
     

    Bob Comer - Microsoft MVP Virtual Machine
    Friday, February 17, 2012 2:46 PM
  • I have seen many z-order problems in WVPC seamless windows, and I know
    of nothing to help the situation.
    Since you have a specific scenario, you might want to turn it into
    Microsoft Product support directly as an example of the problem.

    Bob Comer - Microsoft MVP Virtual Machine

    Hi Bob,

    Thanks for the tip.  This issue is also happening in a stand alone XP machine with IE8 (not Windows XP mode, not VDI; just a plain old Dell Optiplex system with Windows XP SP3 with all latest updates).  So I am not sure if this is related to Virtual PC environment.  My initial feeling was this was an IE8 issue so I had posted in the IE8 forum but they felt the TechNet forum would be the appropriate place.  I have another standalone PC running Windows XP SP3 with IE7 (just a test machine) and it does not happen there.  This machine (running IE7) does not have Visual Studio installed so cannot test the Spy++ scenario on this machine.  Maybe when I have some time I might try and install Visual Studio on this machine and try how Spy++ behaves with IE7.

    Friday, February 17, 2012 5:33 PM
  • Something really similar happens when I uninstall a program too.  I had IE open, and couple of other windows (all maximized).  I launch the Add/Remove programs from control panel.  Then maximize it.  Remove an installed program.  This launches the uninstaller.  When the uninstaller is done with the uninstall, instead of going back to the Add/Remove programs screen, it takes me to another window that I have open.  Totally bizzare.
    Friday, February 17, 2012 6:08 PM
  • That really sounds more like a Windows Shell problem now, though I
    really don't know the domain of where you might get help on it.
     

    Bob Comer - Microsoft MVP Virtual Machine
    Friday, February 17, 2012 10:00 PM
  • Hi,

    Since this also happens on the stand-alone Windows XP, I also assume that this is related to Explorer Shell or the mechanism of choosing active Window.

    I find this is a known issue. Maybe there will be an update for this in the near future. If you find have any inconveniences or suggestions, please also submit your feedback to our Product Feedback Team : http://mymfe.microsoft.com/Windows%20%207/Feedback.aspx?formID=195

    Juke Chou
    TechNet Subscriber Support
    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedbackhere.


    Juke Chou

    TechNet Community Support

    Monday, February 20, 2012 9:29 AM
  • Hi,

    Since this is a known issue, I will mark this thread, this will make the other viewers that have the same issue know this situation. If you have futher questions on this, please feel free to let me know. You may also choose to unmark the thread.


    Juke Chou

    TechNet Community Support

    Wednesday, February 22, 2012 10:13 AM