none
Can't start Peer Name Resolution Protocol

    Question

  • I can't start the service 'Peer Name Resolution Protocol' which is required for HomeGroups.

    There are 3 Peer services on my machine. One is running (Peer Networking Identity Manager). The other one (Peer Networking Grouping) is not because it depends on 'Peer Name Resolution Protocol' which fails to start.

    Both Homegroup services are started and I have IPV6 enabled on my NIC and in my LAN properties.

    The event log has this:

    'The Peer Name Resolution Protocol cloud did not start because the creation of the default identity failed with error code: 0x80630801.'

    Using the Event ID web search it leads me to this:

    Event ID 102 — PNRP Protocol

    I tried what they suggested (it's for Vista) but to no avail.  Perhaps some Permission got borked.  Is there a way to recreate the RSA folder and sub-folders with correct Permissions or perhaps it's some other type of problem?

    I do notice I have a lot of entries in "C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys"

    Any help in getting this Service started will be appreciated.
    Wednesday, October 14, 2009 3:06 PM

Answers

  • Researched the problem and found the solution. A file was corrupted and deleting it got the PNRP service running.  The file was recreated correctly when the PNRP service started up.  Here's the file for future reference:

    "C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking\idstore.sst"
    • Marked as answer by Novak Wu Friday, October 16, 2009 3:12 AM
    Thursday, October 15, 2009 6:45 PM

All replies

  • Hi,

     

    This issue can occur by corrupted PNRP service. You can perform the following steps to troubleshoot the issue.

     

    1. Please download the correct Network Connection registry file from the link below:

     

    http://cid-6df3bca839e981ef.skydrive.live.com/self.aspx/.Public/PRNP.txt

     

    2. There will be the PRNP.txt file. Please right click it and rename it to PRNP.reg file.

    3. Double click the PRNP.reg file and click Yes to import the file.

     

    Note: To avoid unexpected situation, please back up the computer registry before importing the registry file.

     

    4. Then, please verify the Peer Name Resolution Protocol service and other failure service again.

     

    a. Click "Start", go to run, type "services.msc" (without quotation marks) in the open box and press Enter.

     

    Note: If you are prompted for an administrator password or confirmation, type your password, or click Continue.

     

    b. Right click the "Peer Name Resolution Protocol" service and choose Properties.

    c. Click on the "Log On" tab, please ensure the option "Local System account" is selected and the option "Allow service to interact with desktop" is unchecked.

    d. Click on the "General" tab; make sure the "Startup Type" is "Automatic". Then please click the button "Stop" under "Service Status" to stop the service.

    e. Then please click the button "Start" under "Service Status" to start the service.

    f. Click OK.

     

    What's the result?

     

    If the issue persists, please also perform the suggestions from the following article.

     

    Home Group Issues

     

    Thanks,

    Novak

    Thursday, October 15, 2009 6:34 AM
  • Researched the problem and found the solution. A file was corrupted and deleting it got the PNRP service running.  The file was recreated correctly when the PNRP service started up.  Here's the file for future reference:

    "C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking\idstore.sst"
    • Marked as answer by Novak Wu Friday, October 16, 2009 3:12 AM
    Thursday, October 15, 2009 6:45 PM
  • Thank you thank you thank you! I spent countless hours researching this problem, and finally that was the issue. Thanks again.
    • Proposed as answer by danny yeh Sunday, February 26, 2012 2:18 AM
    • Unproposed as answer by danny yeh Sunday, February 26, 2012 2:19 AM
    Saturday, February 13, 2010 8:17 PM

  • THANK YOU SOOOO MUCH


    I was all over the place trying to figure out what was wrong, I deleted the file and that solved the problem
    Wednesday, April 28, 2010 9:45 PM
  • Hello all.

    Deleting the file is ok but after a while (the hole day) the machine reboots and the problem re-appears.

    Any one?

    Thank you.

    Telmo Sá


    Web Developer
    Tuesday, August 10, 2010 10:52 AM
  • Tried all the above and deleting the files a couple of times and places as suggested but nothing worked. The PNRPSvc still refuses to run. The only service in the group that starts for me is the "Peer Network Idenity Manager.

     

    Anybody got anything new here?? Does MS have a patch for this yet?? Anybody???

     

    Harry C.

    Tuesday, October 05, 2010 5:09 PM
  • Thanks sorted the problem.
    Thursday, October 14, 2010 10:59 AM
  • thanks a ton!!
    Sunday, October 24, 2010 1:17 PM
  • There is no obvious sympton of my pc, but there are a lot of error messages in the event log. Search for it and found your fast-and-easy solution.

    Thanks streetwolf! :)

    Thursday, March 03, 2011 3:20 AM
  • Worked as advertised first time. Just copy this guy's link into the search, when the file (idstore) pops up in the search, select and delete it. Then just go back and restart the service. It will create a new-uncorrupted copy. Man, you rock!
    Sunday, March 20, 2011 9:17 PM
  • THANKS!!!!!!
    • Proposed as answer by RSA86 Thursday, November 07, 2013 12:03 PM
    Sunday, May 08, 2011 6:47 PM
  • my result is windows could not start the peer name resolution protocol service on local computer.

    Error 1079: the account specified for this service is different from the account specified for other services running in the same process.

    Sunday, May 15, 2011 4:15 PM
  • my result is windows could not start the peer name resolution protocol service on local computer.

    Error 1079: the account specified for this service is different from the account specified for other services running in the same process.

    Same here!
    • Proposed as answer by Capiz83 Tuesday, October 18, 2011 7:00 PM
    • Unproposed as answer by Capiz83 Tuesday, October 18, 2011 7:00 PM
    Saturday, September 17, 2011 5:03 PM
  • my result is windows could not start the peer name resolution protocol service on local computer.

    Error 1079: the account specified for this service is different from the account specified for other services running in the same process.

    Same here!
    Me too.
    • Proposed as answer by flashjh Wednesday, January 25, 2012 2:39 AM
    • Unproposed as answer by flashjh Wednesday, January 25, 2012 2:39 AM
    Monday, September 19, 2011 3:05 PM
  • That was super!!!! nothing less. thanks a million times
    Monday, September 26, 2011 3:40 PM
  • Remember to download and install the reg file in the first post !!

     

    That did the trick for me :-)

    Tuesday, October 18, 2011 7:00 PM
  • Remember to download and install the reg file in the first post !!

     

    That did the trick for me :-)

    Tuesday, October 18, 2011 7:00 PM
  • I have the same problem now.

    I've deleted below files from my computer. 

    Then restart my computer.

    "C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking\idstore.sst"

    But, Peer Name Resolution Protocol can't start showing error 0x806320a1.

    Is somebody have the experience to solve this situation?

    Thanks in advance.

    Thursday, November 10, 2011 8:02 AM
  • I have tried everything and nothing is working.  I cannot locate the files in the c drive.  what else can I do?
    Thursday, November 10, 2011 6:48 PM
  • Followed Novak Wu and Streetwolf suggestions, but no joy. Rebooted PC etc. Went back to the three services related to Peer Networking opened properties and went to the logon tab, clicked the Logon on as This account (second radio button), browse and select ADVANCED / Find, select "Local Service", OK, blank out the dots against the password and password confirm, click apply. Do the Peer Networking Identity Manager first, you have to stop and restart the service for it to take effect, then repeat the logon process for the other two services. Set all three to automatic. Hope it works for you.
    • Proposed as answer by Andres224 Tuesday, March 27, 2012 6:25 PM
    Wednesday, November 16, 2011 9:50 PM
  • Followed Novak Wu and Streetwolf suggestions, but no joy. Rebooted PC etc. Went back to the three services related to Peer Networking opened properties and went to the logon tab, clicked the Logon on as This account (second radio button), browse and select ADVANCED / Find, select "Local Service", OK, blank out the dots against the password and password confirm, click apply. Do the Peer Networking Identity Manager first, you have to stop and restart the service for it to take effect, then repeat the logon process for the other two services. Set all three to automatic. Hope it works for you.

    Yes, it does. Thanks. Question remains what have I done here? Have I compromised the security on my machine or is it supposed to be

    this way to begin with? In any case, It works and that's all that matters, for now. Thanks a million.

    Friday, December 09, 2011 6:08 AM
  • THIS WAS AN IMMEDIATE AND ELEGANT FIX FOR ME TOO. THANKS FOR THE POST.

    Friday, December 30, 2011 9:00 PM
  • Ok, deleting the "C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking\idstore.sst" file worked to get me past error 1068, but then I was getting error 1079.

    To fix the 1079 error, go back into the Peer Name Resolution Protocol service properties, select 'Log On' and then select 'This account' then use 'Local Service'.  Your computer's administrator account password is the password for Local Service.

    I finally have HomeGroup again after months of troubleshooting.  Thanks!

    Wednesday, January 25, 2012 2:47 AM
  • Thank you fixed my issue!

     

    Thursday, February 02, 2012 4:59 AM
  • Man, thnk you. Exactly as it is.
    Thursday, March 15, 2012 10:48 AM
  • Thanks!!! that worked great!
    Monday, April 02, 2012 1:22 AM
  • This worked for me. Thanks for adding it! 
    Sunday, April 22, 2012 7:49 PM
  • thank you!
    • Proposed as answer by roox4444 Thursday, December 20, 2012 6:06 PM
    • Unproposed as answer by roox4444 Thursday, December 20, 2012 6:06 PM
    Sunday, May 13, 2012 6:41 PM
  • If you are using VMware workstation, disable the 2) virtual networking adapters it installs and follow above listed steps.  It allowed me to finally delete

    the existing Homegroup.  Kudos for the excellent assistance.

    Thursday, December 20, 2012 6:15 PM
  • Worked as advertised first time. Just copy this guy's link into the search, when the file (idstore) pops up in the search, select and renamed it to *.bak. Then just go back and restart the service. It will create a new-uncorrupted copy. Man, you rock!

    Bitte Danke!

    Saturday, April 06, 2013 10:52 PM
  • I tried the other fixes and they did not work for me. I tried this one and it worked. Got all three Pnrp services started and set to automatic. Hopefully that takes care of my homegroup issues. What the heck is wrong with Microsoft not releasing a patch for this. Looks like it's been a know issue for quite some time. I download their updates and still have issues with this! Get on it!
    Saturday, June 22, 2013 5:38 PM
  • Yes, why hasn't Microsoft created a patch for this??? I don't even have a homegroup--it's just me, no password involved--and this is the second time in a month I've had to go through this procedure of getting all 3 Peer Networking services started. It is maddening. Takes 4 restarts to get my 64-bit Windows Home Premium going in the morning. Why is this an issue at all for me?  Thanks very much, Philj, for the fix above.
    Sunday, July 14, 2013 10:19 PM
  • I dont have appdata folder what should i do?
    Saturday, October 12, 2013 10:18 AM
  • Just learned Appdata is a hidden folder, enable the viewing of hidden folders in Windows Explorer.
    Saturday, October 12, 2013 8:19 PM
  • I was able to get all 3 Peer Networking services running, I also deleted the ROAMING folder, but I am still not able to leave the homegroup. Is there anything else I can do?
    Thursday, October 31, 2013 6:33 AM
  • any fixes for this one, i can not leave or change the homegroup, I need to use it so my wife can get her Christmas music.
    Friday, January 03, 2014 10:00 PM
  • Your the man!!! This did correct my HomeGroup problem too! That old file was created when I first installed Windows 7 Ultimate from day one. If I was to guess this problem is because all the people who bought Ultimate bout the OEM system builder Pack, (intended for system builders ONLY) I suspect anyone with the audacity to not buy the full version with the one year HELP services included deserved this problem. I don't know if this was intentional but possibly this copy had a few bugs in it and anyone with any system builder credentials should be able to solve any bugs anyways. Cheers! and Thank you!!!                                                                                   

    Now I have a problem that is the real reason I wanted this HomeGroup to work in the first place, my PANASONIC DMP-BD75 Blu-Ray player has LAN connectivity. It automatically connects to my Cable Linksys Router and has a Plv4 address assigned to it and recognizes the router and my Motorola Modem. It does connect to the internet for Firmware updates and Netflicks. The problem is the DSL is supposed to connect to my computer files with windows 7 HomeGroup and the Windows Media Player. I have followed all protocols necessary for setup, streaming and sharing settings. Went to Panasonic web site and followed standard procedure for setup; so far nothing is helping.

    Saturday, February 22, 2014 8:40 PM
  • Deleting worked for me too!
    Saturday, July 05, 2014 4:22 AM
  • Thanks for the post. Worked on my Win 7 Ult Sp1
    • Proposed as answer by Steven Atkins Sunday, September 14, 2014 5:26 PM
    Sunday, September 14, 2014 5:26 PM