none
C:\ is not accessible Access is denied

    Question

  • I am not able to access my hard drive. When I try to manage any part of the drive the Microsoft Management Console tells me that the function is not supported on the system. I have read various other threads with this problem but every solution was just to Take Ownership which would work except Windows Security refuses to grant me access to anything with a security symbol next to it. Mind you I have enabled the administrator account using the command prompt and I am doing all this on safe mode. Any suggestions?
    Tuesday, July 19, 2011 8:35 AM

Answers

  • Hi,

    Please try the following steps:

    1) If you can access cmd, you can reset the security settings in Vista/Windows 7 with the following command: "secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose" (no quotes.) To see what this command does, go here: How do I restore security settings to the default settings?
     
    NOTE: If you can't access cmd when logged in, use this guide System Recovery Options. You can get to the command line when you access the System Recovery Options screen.
     
    2) This command seems to give the ownership issue a kick up the backside, even though it seems nothing has changed. Go to Explorer, right click on C: and go to Properties.
     
    3) Go to the Security tab and then Advanced.
     
    4) Go to the Owner tab. Now you should be able to click Edit.

    5) If you don't have Administrators in the list under where it says "Change owner to:" then go to "Other users or groups". If you do, go straight to step 7.
     
    6) On Others users or groups type in "Administrators" (no quotes) in the bottom box. Click Check Name and then OK.
     
    7) Click Administrators and then OK. You've now given yourself ownership of C:! (As long as your account is an Administrator, that is.)
     
    8) Click OK on the "Advanced Security Settings..." window to get back to the Properties window. You should now have a list of the Permissions and so on where before you only had something about how you couldn't view permissions. Progress, eh?
     
    9) You may need to add in the Adminstrators group to edit their permissions. To do this, click "Edit" and then "Add" and type "Administrators" (no quotes) in the bottom box. Then hit Check Name and then OK.
     
    10) Click Administrators in the list and tick the box in the Allow column next to "Full control".
     
    11) Click Apply, you'll likely get a bunch of error messages about how this can't be applied to some files and folders. Just OK through them all. Once done, you should have access to your C: drive once more!

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, July 22, 2011 10:45 AM

All replies

  • Hi Ifeanyiboy, you said..

    enabled the administrator account using the command prompt and I am doing all this on safe mode.

     

    I guess really you'll have to take a step back and explain a bit more as to how you found yourself in need of SAFE mode initially. Was there something you installed or changed that has blocked your access to the drive? Have you created a restore point recently you could go back to?

    can you open Task Manager and go to the processes screen and select & then click 'End Process' on any user/system processes that might be causing you this problem. Try stopping any firewall/antivirus programs especially - also see if you can open Defender (called MSASCui.exe [located at C:\program files\Windows Defender] - try finding it from the search bar at the start button) and run a scan of the drive for viruses/malware if you can.

    All the best, pkn2011

     


    If my post was helpful - give it a Vote. If it helps solve your problem - then propose it as an Answer.
    • Edited by pkn2011 Thursday, July 21, 2011 8:18 PM added info
    Thursday, July 21, 2011 7:56 PM
  • Hi,

    Please try the following steps:

    1) If you can access cmd, you can reset the security settings in Vista/Windows 7 with the following command: "secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose" (no quotes.) To see what this command does, go here: How do I restore security settings to the default settings?
     
    NOTE: If you can't access cmd when logged in, use this guide System Recovery Options. You can get to the command line when you access the System Recovery Options screen.
     
    2) This command seems to give the ownership issue a kick up the backside, even though it seems nothing has changed. Go to Explorer, right click on C: and go to Properties.
     
    3) Go to the Security tab and then Advanced.
     
    4) Go to the Owner tab. Now you should be able to click Edit.

    5) If you don't have Administrators in the list under where it says "Change owner to:" then go to "Other users or groups". If you do, go straight to step 7.
     
    6) On Others users or groups type in "Administrators" (no quotes) in the bottom box. Click Check Name and then OK.
     
    7) Click Administrators and then OK. You've now given yourself ownership of C:! (As long as your account is an Administrator, that is.)
     
    8) Click OK on the "Advanced Security Settings..." window to get back to the Properties window. You should now have a list of the Permissions and so on where before you only had something about how you couldn't view permissions. Progress, eh?
     
    9) You may need to add in the Adminstrators group to edit their permissions. To do this, click "Edit" and then "Add" and type "Administrators" (no quotes) in the bottom box. Then hit Check Name and then OK.
     
    10) Click Administrators in the list and tick the box in the Allow column next to "Full control".
     
    11) Click Apply, you'll likely get a bunch of error messages about how this can't be applied to some files and folders. Just OK through them all. Once done, you should have access to your C: drive once more!

    Regards,


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Friday, July 22, 2011 10:45 AM
  • i m not able to access my security settings till now......its not working plzzzzzz help me

    • Proposed as answer by puya tabriz Wednesday, October 30, 2013 9:23 PM
    • Unproposed as answer by puya tabriz Wednesday, October 30, 2013 9:23 PM
    Friday, June 01, 2012 5:53 PM
  • i have the same problem but i can resolve it...here is the site which helps me...it works 100%.....

    http://www.reclaime.com/library/fix-access-denied.aspx
    Wednesday, October 30, 2013 9:24 PM
  • Can you be more clear about how to do it with cmd command pls. I did this to because I wont my brother t can get in side of (C) but not that wanted this to do..I just wanna get back please just tell me step by step how can I do it with CMD. Thanks
    Monday, January 20, 2014 3:16 PM