none
windows 7 freezes when using internet

    Question

  • I have 2 computers running different versions of windows 7, they both started to freeze completely when accessing the internet. This has only happened recently. I have a new laptop with win7 home premium, which I use for the internet everyday, this was the first one to have this problem, it does the same with various web browsers, ive tried ie8, seamonkey, opera 9 and safari. the desktop/tower has just started to do the same but it was only ever connected to the internet once before and then again yesterday, when it started with the same problem. i have just updated everything on the laptop, and it still does the same. i think the problem has to be with win7 updates or microsoft's built in spyware programs.the only similarity is that they are both 64bit systems. I would like microsoft to sort this problem out quickly, as the only way to close down the systems is by pulling the plug, which can severely damage the hard drive (and i will then hold microsoft fully responsible for replacement),  i have now reverted back to good old trusty xp on my 6yr old laptop to write this.
    Sunday, January 24, 2010 8:20 PM

Answers

  • Hi Jonnyretro,

     

    According to the problem description, this issue can be caused by one of the following factors:

     

    Ø  The network card driver is not up to date.

    Ø  The advanced network card features conflict.

    Ø  Third party software conflicts.

     

    I still would like to confirm the question: What are the models of the computers and the network cards?

     

    Based on the current situation, I would like to provide the following troubleshooting suggestions:

     

    Ø  Update the network card driver

    Ø  Disable the advanced network card features

    Ø  Test the issue in Clean Boot

     

    To troubleshoot the issue, please try the detailed steps below:

     

    Update the network card driver

    =====================

    Please refer to the network card manufacturer’s official website to install the latest version of the network card driver. This one should be newer than the one Windows Update offers.

     

    Disable the advanced network card features

    =====================

    1.    Click Start, type Devmgmt.msc into Search bar and press Enter.

    2.    Expend Network adapters, right click on the network controller and click Properties.

    3.    Switch to Advanced tab and disable the advanced features one by one to check the result.

     

    Test the issue in Clean Boot

    =====================

    1.    Log on to the computer by using an account that has administrator rights.

    2.    Click Start, type msconfig.exe in the Start Search box, and then press ENTER to start the System Configuration Utility.

     

    If you are prompted for an administrator password or for confirmation, type your password, or click Continue.

     

    3.    On the General tab, click Selective Startup, and then click to clear the Load startup items check box. (The Use Original Boot.ini check box is unavailable.)

    4.    On the Services tab, click to select the Hide all Microsoft services check box, and then click Disable all.

     

    Note: Following this step lets Microsoft services continue to run. These services include Networking, Plug and Play, Event Logging, Error Reporting, and other services. If you disable these services, you may permanently delete all restore points. Do not do this if you want to use the System Restore utility together with existing restore points.

     

    5.    Click OK, and then click Restart.

     

    If it works fine in Clean Boot, I would like to suggest you follow Step 2 to Step 7 in the following article mentioned to narrow down the possible cause:

    How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7

     

    Regards,


    Arthur Li - MSFT
    Tuesday, January 26, 2010 7:24 AM