none
Drivers for Netgear WG311 v3

    Question

  • Unortunately for me I have a desktop Netgear wireless PCI adaptor which in no circumstances in Win 7 beta 64 bit and 32 bit versions allows the drivers for my card to be installed. Have tried compatibility mode on half a dozen occasions so far without any Joy. Does any one with this card have a workaround or link to working drivers or do all thee netgera card owners have the same difficulty that I have - no way of connecting to the internet.

    1okmackem@sky.com
    Sunday, February 08, 2009 12:46 PM

Answers

  • Hello,

     

    Please understand that Windows 7 is a new operating system (only the beta version) and whole driverstore has been reprogrammed; some old driver is not compatible with new OS. I suggest that you should wait for another period of time till the retail version is released and push the vendor company to upgrade their device driver. Thanks for your time and understanding!

     

    For more details, please look at the first Sticky thread at the top of this forum.

    What can I do if my hardware does not work?

     

    This will give you some guidelines.


    Good Luck!

    Tuesday, February 10, 2009 10:04 AM

All replies

  • have you tried connecting to your wireless router with an ethernet cable and then seeing if windows update can find drivers for the card?
    Sunday, February 08, 2009 6:45 PM
  •   NETGEAR WG311v3 54Mbps Wireless PCI Adapter

    I have the same card. Windows update will install the drivers if you are connected using a wired connection.
    • Proposed as answer by aceall3 Saturday, November 14, 2009 3:20 AM
    Monday, February 09, 2009 3:00 AM
  • Hello,

     

    Please understand that Windows 7 is a new operating system (only the beta version) and whole driverstore has been reprogrammed; some old driver is not compatible with new OS. I suggest that you should wait for another period of time till the retail version is released and push the vendor company to upgrade their device driver. Thanks for your time and understanding!

     

    For more details, please look at the first Sticky thread at the top of this forum.

    What can I do if my hardware does not work?

     

    This will give you some guidelines.


    Good Luck!

    Tuesday, February 10, 2009 10:04 AM
  • I have been having problems trying to get tmy Netgear WG834G wireless router and my Netgear WG311 PCI wireless card to connect with the XP drivers from Netgear.

    Finally downloaded the Marvell drivers from here:-
    http://www.station-drivers.com/page/marvell.htm

    Scrolled down to this section here:-
    Libertas 802.11a/b/g Wireless (MRV-8335)
    and selected Version 3.1.1.7 , Marvell.

    Netgear software was uninstalled which disabled the card.

    Marvell file was unzipped and installed. Now uses Windows Zero Configuration to setup WPA-PSK where I copied the wireless PSK value directly from my router and installed it in the Windows setup. I had an ethernet cable to access the router to retrieve the PSK value.

    In Control Panel → System → Hardware → Device Manager → (and from the Toolbar ), I scanned for hardware changes. The device is now recognised.
    Selected the device, “Marvell Libertas 802.11b/g Wireless(8335)”, right click properties.
    Selected “Advanced”, changed Adhoc mode to “Adhoc G Mode”,
    Preamble to “Auto”, SSID from “MarvellAP3x”

    Thursday, May 27, 2010 3:49 PM