none
Cursor jumps around while typing in word (corrected) - Cursor jumpsing in Word around while typ (not corrected)

    Question

  • The Cursor is jumping around while I type. This is very frustrating. I only just upgraded to Windows 7, it was a clean install, b.c I had been having so many troubles with Vista (it kept crashing).

    I seem to have a Microsoft curse.

    This is very frustrating - I am seriously questioning whether my next major purchase will involve Windows, as reliability seems to be a problem!

    Monday, June 06, 2011 2:18 PM

Answers

  • Hi,

     

    Before going further, would you please let me know if the issue only occurs when trying in Word? What about notepad or other software? What is your mouse model? Does it have the driver? Did you install any mouse related software?

     

    First, make sure your computer model is supported Windows 7. If so, update the latest mouse and touchpad driver from manufacture's site. Also, go to Mouse Properties -> Pointers Options tab -> clear the option for Enhance pointer precision.

     

    If the issue persists, I suggest performing a Clean Boot or Safe Mode to check the result.

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, June 09, 2011 8:38 AM

All replies

  • Is your computer a laptop ? if it is there are known issues with the cursor pad being very sensitive and even hovering over it can cause it to jump around. You can either mess around with the sensitivity to see if that helps or you can install something like touchfreeze that automatically disables the mousepad when typing and reenables when you stop without you doing anything. you can find the program under additional tools using the link below.
    Free Support Tools
    Tuesday, June 07, 2011 2:39 PM
  • Hi,

     

    Before going further, would you please let me know if the issue only occurs when trying in Word? What about notepad or other software? What is your mouse model? Does it have the driver? Did you install any mouse related software?

     

    First, make sure your computer model is supported Windows 7. If so, update the latest mouse and touchpad driver from manufacture's site. Also, go to Mouse Properties -> Pointers Options tab -> clear the option for Enhance pointer precision.

     

    If the issue persists, I suggest performing a Clean Boot or Safe Mode to check the result.

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, June 09, 2011 8:38 AM
  • There has been recent extreme solar activity throwing out a G1 magnetic storm. Wait until the June 11.

    Thursday, June 09, 2011 10:43 AM
  • I'm having this same issue.  It happens when my system is docked and I'm using a normal mouse and keyboard.  The weird thing is it just started happening - I've been using Win7 for a long time and never had this problem.  I'm think it's something related to recent updates. It happens in word and other office apps like power point or outlook.  I'll be typing and the cursor will jump to a different part of a document and highlight a bunch of stuff - so as I keep typing it erases what was just highlighted.  Some times the cursor jumps out of the app I'm using, goes to another and grabs a window handle.

     

    Very weird.

    Thursday, June 23, 2011 8:21 PM
  • just an update... I'm attempting windows update and saw there were updates for mouse, keyboard, and others.  I'll see if this helps.
    Thursday, June 23, 2011 8:32 PM
  • LOADS and loads of people have this problem and Microsoft has not offered a fix. 

     

    I’VE FOUND A SOLUTION, though NOT a "FIX"!  After you place the cursor where you want to type, move it down to the bottom of the screen, without clicking.  This takes an extra second or two but is worth it. 

     

    I figured out that the typing cursor jumped to the place where the touchpad cursor was, and figured maybe if the touchpad cursor was below the entire typing window, the typing cursor might just stay where it belongs, just ahead of the typing. 

     

    Makes keyboard shortcut even more valuable, as you’ll want to leave that darn cursor at the bottom of the screen.  Until you need it. 

    LET ME KNOW IF THIS WORKS FOR YOU.  BEST THING I'VE FOUND SO FAR. No downloads, no reboots.  Just an annoying second to “park” the cursor below all the typing.


    AND BY THE WAY, THE CURSOR JUMPED EVEN IF I TYPED WITH ONE FINGER AND WITH WRISTS HELD HIGH ABOVE THE KEYBOARD.  SO NO, *NO* ABSOLUTELY NO IT IS NOT THAT WE ARE ACCIDENTALLY TOUCHING THE TOUCHPAD.  WAY TO BLAME THE VICTIM, Microsoft...!  It’s definitely a software problem.  It didn’t happen on my old laptop, which also had a touchpad. 

     

    Wednesday, October 05, 2011 10:48 PM
  • I have used this program in the past with a few of my clients. It seems to do the job. This issue is DEFINITELY not a touchpad issue. However, it is very random in what computers are affected by this (laptops) even though they are all the exact same brand and type. Try Touchfreeze:

    http://code.google.com/p/touchfreeze/

    • Proposed as answer by garveyk659 Thursday, October 06, 2011 4:41 AM
    Thursday, October 06, 2011 4:41 AM
  • This is a REALLY annnoying problem.

    I need to use a computer and this problem costs me a lot of time and therefore money

    I have searched and searched for a solution to no avail. Lots of people suggest its a touch pad problem. Others say it has to do with the charger. Still others say it has to do with drivers for the mouse. 

    The product I have is not fit for purpose and I will have to get a new computer as a result.

    Needless to say I will never buy another dell/windows product- i'm switching to apple

    Friday, October 21, 2011 4:13 PM
  • Did you try try Touchfreeze yet? It has worked in every situation so far in our company. 
    Friday, October 21, 2011 4:28 PM
  • Is your computer a laptop ? if it is there are known issues with the cursor pad being very sensitive and even hovering over it can cause it to jump around. You can either mess around with the sensitivity to see if that helps or you can install something like touchfreeze that automatically disables the mousepad when typing and reenables when you stop without you doing anything. you can find the program under additional tools using the link below.
    Free Support Tools

    no ..no.. this type issues caused also in desktops... pls advice
    Saturday, November 05, 2011 11:59 AM
  • I recently had this same problem.  I realized that the problem began shortly after installing Google Toolbar.  After uninstalling the toolbar and doing a system restore the problem went away.  Hope this helps.
    Sunday, April 15, 2012 6:16 PM
  • I have the same issue.  Been using the same system and software for quite some time without a problem and suddenly have the problem.  My husband has been having the same issue on his system for quite some time and I chalked it up to a mouse sensativity issue, but my just started occuring and does not seem to be particular about what program I am in.

    me

    Thursday, August 09, 2012 2:26 PM
  • It is amazing that this Windows bug is not fixed after so many years!

    This problem recently happened on my Asus laptop with Windows 7 that I bought spring 2012. It happens when I use Microsoft word 2010, Microsoft outlook 2010 and sometimes on Internet forums.


    This has nothing to do with the touchpad. I rarely use my touchpad. I use an external mouse and an external keyboard.I definitely don't have any viruses ortrojans. This happens only when using the mentioned Windows software. It didn't happen until recently. I guess it must have something to do with a Microsoft update of my Windows software.It is very frustrating! I cannot station my pointer outside the document/window because I use a software for automatic clicking. I'm disabled so I depend on that program.


    My pointer slowly move while I'm typing in e.g. Microsoft word. Suddenly I find myself typing in the middle of the word. Without me touching the computer mouse at all. Because my computer mouse is external, it is not hard to know when I'm touching it and when not.

    Saturday, November 24, 2012 3:47 PM
  • I've been going mad as well!  I've a Dell laptop Win 7 with touchpad plus a Trust wireless mouse (from my old Win XP laptop).  The mouse pointer would not work. Then suddenly 2 days ago it started working! BUT the dreaded pointer-dance started in all programmes.

    I wondered - should I update the mouse driver?  So: Start > Control panel > View Devices and Printers > USB Input Device > Properties > Hardware > Highlight HID-compliant mouse (Mice and other pointing devices) > Properties > Driver > Update Driver 

    It worked!  When I now go Start > Control panel > View Devices and Printers > USB Input Device > Properties > Hardware > Highlight HID-compliant mouse (Mice and other pointing devices) > Properties > Driver > Update Driver > Driver Details. 

    I see :

    Provider: Microsoft Corporation
    Reversion: 6.1.7600.16385(win7_rtm.090713-1255)
    Copyright: © Microsoft Corporation. All rights reserved.
    Digital Signer: Microsoft Windows

    I'll come back if it starts pointer-dancing again. Until then ... hope this might help someone.

    Tuesday, November 27, 2012 4:50 PM
  • LOADS and loads of people have this problem and Microsoft has not offered a fix. 

     

    I’VE FOUND A SOLUTION, though NOT a "FIX"!  After you place the cursor where you want to type, move it down to the bottom of the screen, without clicking.  This takes an extra second or two but is worth it. 

     

    I figured out that the typing cursor jumped to the place where the touchpad cursor was, and figured maybe if the touchpad cursor was below the entire typing window, the typing cursor might just stay where it belongs, just ahead of the typing. 

     

    Makes keyboard shortcut even more valuable, as you’ll want to leave that darn cursor at the bottom of the screen.  Until you need it. 

    LET ME KNOW IF THIS WORKS FOR YOU.  BEST THING I'VE FOUND SO FAR. No downloads, no reboots.  Just an annoying second to “park” the cursor below all the typing.


    AND BY THE WAY, THE CURSOR JUMPED EVEN IF I TYPED WITH ONE FINGER AND WITH WRISTS HELD HIGH ABOVE THE KEYBOARD.  SO NO, *NO* ABSOLUTELY NO IT IS NOT THAT WE ARE ACCIDENTALLY TOUCHING THE TOUCHPAD.  WAY TO BLAME THE VICTIM, Microsoft...!  It’s definitely a software problem.  It didn’t happen on my old laptop, which also had a touchpad. 

     


    Capslock issues as well?
    Monday, April 29, 2013 10:43 AM
  • Seems like it worked and I am able to to type this review but while doin this again the cursor jumped to another place.

    But definaletly there is improvement.

    Monday, June 24, 2013 7:05 AM
  • This forum only lets you "vote" once apparently. My problem is with Windows 7, Student Office 2013 and an older Dell Inspiron. Clean install of Windows 7. I have only a handful of apps running on this computer. I started noticing the same behavior with the cursor immediately--the first time I used Word. I've also seen it now in Excel 13. 

    This is not a "touch pad" related issue. I can actually move the cursor around with the touch pad and type at the same time: the typing does not follow the cursor. But strangely, when I'm typing and the cursor is no where to be found, it jumps only to a previous location. If it were just the cursor, it could jump to a new location where there was no typing. But it doesn't--only to previous locations. Clearly it's a bug. It's been going on for 3 years now. I know this because people have been complaining about it on MS forums since 2010. Clearly it's not a priority, which is baffling, because Word and word processing are essential to users every day.

    The reason I am writing this now is to put my experience down as just another number--how many people have to complain before there's a fix?--to draw attention to this very irritating and time consuming problem that should have been fixed in 2010 when it was first reported.

    I hope that soon there will be some silent fix installed with an update and I will no longer have to deal with a DEFECTIVE program. If this were some other "object" such as a watch or something and it didn't work right, I would return it or exchange it. But we don't do that with computers--we seem to be okay with our very expensive computer equipment and software not working properly and we scramble to create a work-around to get through the day-- (cause that's just the way it is, right?) 

    Tuesday, July 16, 2013 4:22 PM
  • I did not try TouchFreeze as I am convinced that the issue is not by TouchPad being activated and also because I want to have only very necessary softwares on my machine.
    My issue was fixed by changing the "Hide Pointer while typing" option in Windows Mouse Properties.
    The steps are explained well here: http://it-solutions-windows.blogspot.com/2013/07/mouse-jumping-problem-while-typing.html
    Thursday, July 18, 2013 6:26 AM
  • This has at least reduced the frequency of my jumps from ~1/min to ~1/>5min. 

    Note: I do not have to have an app open and typing. With all apps closed I have observed the cursor periodically jump and occasionally select an icon and open it.

    • Proposed as answer by liamdevlin Tuesday, September 03, 2013 5:57 AM
    • Unproposed as answer by liamdevlin Tuesday, September 03, 2013 5:57 AM
    Saturday, August 10, 2013 7:26 AM
  • Hello,

    I just wanted to say thank you! I am not familiar with this type of communication, but tested what you said and this worked. I was compelled to say thank you and that this does work. Thank you for your advice and confirming that there are still teachers out there and not predators.

    Sunday, September 15, 2013 6:01 PM
  • If you think this is just a Microsoft/Dell issue, you obviously aren't very wise.  This is a laptop issue, and has happened many times on my macbook air.  It is just the sensitivity of the touchpad. 
    Thursday, October 17, 2013 11:27 PM
  • IT4Dummies, if you are saying it's a touchpad issue, you obviously aren't very wise. If you had read  the comments above you would have found many people saying that disabling the touch pad does not stop the cursor from jumping around (in fact, it just happened again while I was typing this exact sentence, with the touchpad disabled!).

    Unfortunately the above solution regarding unchecking the  "hide pointer while typing" option in Windows Mouse Properties did not fix the problem for me.

    I never had this problem on this laptop until my hard drive died and i had to reinstall the OS and Office etc on the new drive. Perhaps that is a clue that the answer lies with drivers?

    Wednesday, October 23, 2013 12:38 AM
  • OK, here is a summary of my experience as well as others mentioned above:

    1 - The cursor jumps about at random while using the computer.

    2 - This happens in Word, Excel, playing solitaire and other applications.  It happened numerous times while I was writing these paragraphs.

    3 - This has been happening since June 2011.  See first post.  Strange that MS has not dealt with it.  They've had over two years.

    4 - It happens on laptops and desk tops.  Mine is a Dell XPS desktop.  The mouse that came with it didn't work so I replaced it with an MS IR that was lying around at work.  I did not replace any drivers.

    5 - It has nothing to do with touch pads or their sensitivity.  I don't have one.

    6 - The fix suggested in some forums. i.e. uncheck hide pointer while typing seems to make it happen less often but does make it go away.  In time it seems to get worse again.

    7 - The problem sometimes occurs on new machines but mostly on ones at least a year old.

    Monday, October 28, 2013 3:00 AM
  • try just disabling tapping option from touchpad

    http://www.ehow.com/how_8678356_fix-cursor-jumping-backwards-typing.html


    Friday, November 01, 2013 10:37 AM
  • Was going crazy for over a year by this annoying problem.

    Downloaded Touch Freeze.   Problem solved!

    Takes 20 seconds


    • Edited by Wolfstar99 Friday, November 22, 2013 1:20 PM
    Friday, November 22, 2013 1:19 PM
  • Hi...my PC is an ACER, and I had this same issue.  There's an icon on the bottom of the screen which when clicked shows "Acer Device Fast Lane".  TouchPad Lock is an option within that.  I now have it marked as 'ON' and the issue is resolved (for me). 
    Tuesday, November 26, 2013 2:11 PM
  • My laptop is a Dell and has been happening since new (but only very occasionally). Now all the time and so frustrating. I thought I was the only one, but in a way glad to know that it is happening to others. I can't find an equivalent "device fast lane" but will make enquiries. Glad it fixed yours - thanks for this tip.
    Thursday, November 28, 2013 10:01 PM
  • this is absolutely rediculous. Does noone at Microsoft monitor these sort of sites for these problems? as others hv already mentioned this has been going on for years but there appears no solution has been suggested that really works. This jumping of the point at which typed keys are being entered or shading whole paragraphs and if you do not notice it immediately the shaded part is deleted. Why on earth is there no solution?

    It happens to me on any text entry (WORD, EXCEL, OUTLOOK, even in Skype). I tried updating drivers, tried unchecking the hide-cursor-when-typing. I agree with prev posts that it seems to hv nothing to do with the touchpad. in my case the jump seems to be irrelgularly triggered by particular letters. "r" definitely and sometimes also "a". But does not happen every time, it is irregular. I even changed my keyboard; no improvement.

    Many posts hv mentioned DELL. Is it perhaps a DELL/MS/WIN7 problem? Extremely annoying & frustrating...........

    DELL XPS M1330

    WIN7 Ultimate SP1

      

    Thursday, January 16, 2014 5:13 PM
  • Two days ago, my Dell Inspiron laptop Windows 7 cursor started jumping all over in any program for typing text, especially Office programs and online forms :X It's making me want to break something. This happened a little over a year ago and I installed Touchfreeze, which helped... Touchfreeze is still working and this time it seems far more random and worse than the jumping that I had happen before. Anyone else having issue??? Better yet... is there a FIX???
    Monday, February 03, 2014 2:23 AM
  • I'm going to put the cat amongst the pigeons. I have a dual boot Windows 7/Linux laptop. It happens when I'm using Linux (Ubuntu) just as often as when I'm using Windows. In fact more so. It just happened as I typed this reply!

    So either it has nothing to do with Windows or Ubuntu is using the Windows drivers. It even happens on my netbook which doesn't have Windows at all!

    Comments?

    Thursday, February 06, 2014 7:28 AM
  • It happens on my mac with a trackpad and a Logitech keyboard , so it can't be a MS issue . 

    It's happened for years and I've never found why .

    Also happens on my Dell laptop with win8 incidentally .

    Sunday, February 09, 2014 7:56 PM
  • In my opinion, you could be watched, by NSA or whoever. Maybe a hacker of some sort. I have a laptop without a touch pad (has an eraser instead, but I use a mouse) so don't have a problem with the touch pad issue described by others. I have tested this out by putting this on another computer I have that never goes on the internet (I use it only for writing and analysis that does not require internet access). To my surprise, the non-internet-access computer does not do this. On the laptop on which my cursor movement is a problem, I have on occasions stepped away from my computer and when I cam back see that the cursor is moving of "its own volition." Once, I stepped away and when I came back the computer had been completely shut down --- even though it was plugged in. A year or two ago I reported a couple people to FBI/Homeland Security, one for trying to launder money through me on a high-priced item I had on Craigslist, and another who was, so I discovered, from the middle east wanting to buy a laptop I had on Craigslist, with the way he wanted to pay and the way he wanted me to ship leading me to believe I might have been dealing with some kind of terrorist cell. Anyway, after I had reported these two people, both in the same year, I noticed my computer doing strange things. So I'm guessing I'm being watched in case others of doubtful intentions try to contact me. Who knows anymore these days?

    - Good luck, and may the force be with you!

    MB

     
    Sunday, February 09, 2014 8:09 PM
  • Interesting ,  but sounds like a mix of paranoid drivel and coincidence .:-)
    Sunday, February 09, 2014 8:31 PM
  • The Cursor is jumping around while I type. This is very frustrating. I only just upgraded to Windows 7, it was a clean install, b.c I had been having so many troubles with Vista (it kept crashing).

    I seem to have a Microsoft curse.

    This is very frustrating - I am seriously questioning whether my next major purchase will involve Windows, as reliability seems to be a problem!

    Fix this by going to Control Panel/Mouse and select Pointer Options tab, clear the  Hide mouse pointer while typing selection.

    • Edited by Lester Carib Wednesday, February 12, 2014 10:03 PM changed word for clarity.
    Wednesday, February 12, 2014 10:02 PM
  • Clearly not a Dell hardware issue.  I have a brand new Lenovo Thinkpad T440 for work and this issue is driving me CRAZY.  I've been trying to type a short email for about 45 mins now (typing this on my iMac).  When typing, if you pause for second the cursor moves to where ever you left the mouse and you continue to type in random places in your document.  It does not happen when docked at work, just when using the laptop keyboard.  I checked the "Hide mouse pointer while typing" box and it was already checked.  Still happening.  
    Saturday, February 22, 2014 1:32 PM
  • Supa,

    You should have the "hide mouse pointer" box Unchecked.

    Try that. It helped me and it only took me 20 secs to type this ;-)

    I know, I'm slow typer... hahaha

    Sunday, February 23, 2014 1:48 PM
  • Finally, I have the solution. It really helps. Thanks a lot :)

    Wednesday, February 26, 2014 12:26 PM
  • Go to Dell.com and install drivers for- mouse, keyboard and input devices..... I feel so much better. Had this problem for over 6 months.

    Tuesday, April 22, 2014 5:45 PM
  • I have a new Dell inspiron and it happened on my old one too.  now it is impossible.  Got help from Dell but did not solve the issue.  For me the cursor goes and shows the scroll symbol. if I turn off scrolling it solves it but that is not convenient to then not have scrolling options for other times.  I will try this Touch Freeze option and report back.  will also keep on with Dell and see if they come up with a solution that really works.

    Sunday, June 22, 2014 12:45 AM
  • I have been trying to find a fix for this and an auto-scroll issue.There are no fixes for the auto-scroll according to many who have posted on the subject. It is caused by issues in the scroll wheel in a mouse or the up/down, and vertical scroll features of pads. I thought that the jumping cursor might be related to this problem but based on what I've read here, I don't expect a solution. This issue is on horizhttp://answers.microsoft.com/en-us/windows/forum/windows_vista-performance/my-cursor-jumps-while-typing/9de98945-525a-45fe-a74c-741fb42d2069ontal They have locked the site to stop more posts on the subject. I see this as proof that Microsoft knows about the problem and either can't find a fix or don't want to.

    Keyboards, mouses, and touchpads are made by many different manufacturers. Maybe if you purchase a Microsoft computer instead of a compatible, the keyboards and mouses will work right and Microsoft wants you to buy their product instead of cheaper clones. I don't know, but both of my computers that have these problems have been restored to factory specs because of systemic problems. It was, as others have said, after the restores that the problem came up.

    It is frustrating when one company gets so big and powerful that they don't have to provide services for their customers any longer.

    Wednesday, July 09, 2014 3:36 PM
  • So, I have more information that might help. It appears that I was right about the touch pad scroll areas being a problem. There is a field (strip) on the right side of the touch pad and one at the bottom. The one on the right causes vertical scrolling. The one on the bottom, horizontal scrolling. If one barely touches these areas of the pad the cursor will jump. If you touch both fields, a dot with an up and a down arrow will appear and the page will scroll up and down. I believe there are features in a mouse wheel which will cause similar jumps and auto scrolling.

    As far as I can learn, it isn't possible to deactivate the scroll features.

    There may be other ways to get the cursor to jump, but even the heat from your hand getting close to the pad may be enough to cause a jump. No way to desensitize it even.

    Keep your fingers and hands clear of the pad. It's difficult and the feature is useless from my perspective, but it isn't correctable as far as I can tell.

    Wednesday, July 09, 2014 10:29 PM
  • I covered the edges of the touchpad with card stock. No help. Any tap anywhere on the touchpad will cause the cursor to jump. Taps by two fingers at once anywhere on the pad will initiate the scroll feature. The problems have something to do with sensitivity to touching the pads (taps). Taps on the left clicker cause the jumps too. Touching both clickers doesn't cause the scroll feature.
    Wednesday, July 09, 2014 10:48 PM