none
Apps Internet connectivity through VPN connections

    General discussion

  • This surely is a known issue, but I would like someone to confirm that this IS a problem in Windows 8 that NEEDS to be fixed. It's a simple as that: when I connect to my corporate network through a VPN connection that becomes the default gateway, all Windows 8 UI apps report that there is no Internet connectivity and therefore do not work. Obviously the apps do not check for Internet connectivity and depend on the status of the network adapter that is provided by Windows - when the VPN connection is active, the status of the underlying Internet connection reads "Limited" or "No Internet access". This was not the case in Windows 7 - when the VPN connection was active, both connections reported "Internet access".

    Please do not advise me to disable the "Use default gateway on remote network" option in the VPN adapter. I need all traffic to be routed through the VPN and what happens now is a BUG in Windows 8, not in other products. And a bug needs an acknowledgment and a fix, right?

    Monday, October 15, 2012 8:27 PM

All replies

  • I just check my Windows 8 tablet with "Use default gateway on remote network" checked in VPN. It works fine. Can you use tracert command to check where the traffic stop? Or post the results of ipconfig /all and nsllokup here.

    Bob Lin, MVP, MCSE & CNE Networking, Internet, Routing, VPN Troubleshooting on

    http://www.ChicagoTech.net

    How to Setup Windows, Network, VPN & Remote Access on

    http://www.howtonetworking.com

    Monday, October 15, 2012 10:31 PM
  • Hi, Bob.

    The problem is only with some of the Windows 8 UI apps (previously known as "Metro" apps), e.g. Weather, Maps and other third-party apps. No real network connectivity problem exists - these apps just don't "see" that there is an Internet connection through the VPN just because the state of the underlying Internet connection is shown as "Limited":

    For example, here is how Bing Weather appears when the VPN connection is active:

    You can see that the app reports "OFFLINE" in the upper right corner, although there IS Internet connectivity through the VPN. I think the problem is that the Network Connections component of Windows erroneously reports "Limited" connectivity through this connection when all traffic is routed through the VPN:

    No actual problems exist with the Internet connection - browsers work OK, e-mail clients, Skype, streaming... These apps just won't even try to access the Internet through the VPN, just because they are being told that the Internet connection is "Limited" whereas it is not.

    Monday, October 15, 2012 11:03 PM
  • Hi Yordan ,

    I jus tried my another Windows 8 running on HP laptop. I don't have any issues with Metro apps. This is my VPN connection staus. Can you try different VPN server?

    windows8 vpn


    Bob Lin, MVP, MCSE & CNE Networking, Internet, Routing, VPN Troubleshooting on

    http://www.ChicagoTech.net

    How to Setup Windows, Network, VPN & Remote Access on

    http://www.howtonetworking.com


    • Edited by chicagotech Wednesday, November 28, 2012 3:42 AM
    Tuesday, October 16, 2012 1:08 AM
  • I have exactly the same issue as the original poster, tested on two completely different machines with Wi-Fi.

    Not only to the metro apps show "offline" in the top corner, they are indeed apparently unable to access the internet (i.e. their content doesn't update, they can't access streaming servers, etc)... so it seems a critical issue.

    It's not possible to diagnose the problem using tracert, etc, because the VPN works perfectly fine at the Desktop, it's only metro apps that are unable to connect.

    Based on the above comments, two theories come to mind

    - a bug related to VPN over Wi-Fi (rather than Ethernet), possibly even certain Wi-Fi chipsets/drivers??

    - a bug or fundamental restriction related to the "network isolation" features of Metro apps??
    http://technet.microsoft.com/en-us/library/hh768193(v=vs.110).aspx

    • Edited by tomdjpn Tuesday, October 16, 2012 7:02 AM
    Tuesday, October 16, 2012 6:54 AM
  • Bob, I tried this with PPTP and SSTP VPN - the first one created manually, the second using a Connection Manager profile. The result is the same. The idea of Tom is interesting - it might be a problem with the Wi-Fi stack since the same issue appears when I am using Mobile Broadband which appears as an SSID in the list of networks. I haven't tested this using a cable connection yet.


    Tuesday, October 16, 2012 9:19 AM
  • Hi Tom, thank you for your input. After switching to wireless, I can see the problem. I will open a case with Microsoft and will post back.

    Bob Lin, MVP, MCSE & CNE Networking, Internet, Routing, VPN Troubleshooting on

    http://www.ChicagoTech.net

    How to Setup Windows, Network, VPN & Remote Access on

    http://www.howtonetworking.com

    Tuesday, October 16, 2012 1:35 PM
  • Exactly this problem for me on *cable ethernet* connection.
    Tuesday, October 16, 2012 8:11 PM
  • i am unable to find a solution to this since Windows 8 CR. There is quite a number of complaints but no useful help as far as I may gather from the web.

    I believe this is someting by design. Windows Apps (or Metro) have limited authority to use Windows resources. This is necessary to provide an additional layer of security as these apps are available in Windows Store and Microsoft wants to be damn sure that these apps will have no chance to mess up its Windows resources. I don't know if "authorization" can be individually altered using Visual Studio 2012 but it certainly won't be difficult to allow these Windows Apps to use VPN. I believe this is not a bug but a policy issue regarding Apps available from the Windows Store.


    • Edited by usb0 Sunday, October 21, 2012 9:51 PM
    Sunday, October 21, 2012 9:50 PM
  • I think the problem is not in the Metro apps - they are just consumers of the status that is being shown by the networking components of Windows, NLA maybe. Previous versions of Windows did not set the adapter's status to LIMITED when a VPN connection was active. Exactly that causes the behaviour with the Metro apps (or should we say "Windows 8 UI apps"). They just rely on what Windows reports on the status of the connection - if it was not LIMITED, but "Local and Internet", the problem would not be experienced. But that's just my speculation on the issue, I am not into Windows development at all.

    Another problem with this status can occur when e.g. the DHCP server assigns a default domain suffix on the connection, but for some reason the status of the network connection hangs on "Identifying" in stead of listing the suffix. In this case, if I try to RDP a server without entering its FQDN, but only it's name and the RDP client has also a Remote Desktop Gateway server configured in its properties, the RDP client tries to connect using the configured Remote Desktop Gateway in stead of connecting directly to the server, although there IS direct connectivity through this connection.

    In general - applications in Windows 8 seem to depend too much on what the network adapter reports in stead of trying to access the resource themselves.


    Sunday, October 21, 2012 9:56 PM
  • - a bug or fundamental restriction related to the "network isolation" features of Metro apps??
    http://technet.microsoft.com/en-us/library/hh768193(v=vs.110).aspx

    Related to this have you tried adding Fiddler2 plus its necessary new EnableLoopbackUtility to your testing?  Some have noted that in related scenarios that can act as a workaround.   In fact, I'm not sure exactly what is necessary for that workaround, just the new utility or both it and Fiddler.   ;  )

    FWIW here is a post from Mark Feetham about those diagnostics

    http://social.technet.microsoft.com/Forums/en-CA/ieitprocurrentver/thread/4aced618-135d-42e7-989f-17f39caa93ae#5cc1b14e-d974-4cd9-a511-9e97492109d1

     

    HTH

    Robert Aldwinckle
    ---

    Tuesday, October 23, 2012 7:25 AM
  • i have this issue do you know how metro app connect whith vpn ?  what i do :( ?     


    Thursday, October 25, 2012 1:10 AM
  • I'm experiencing this issue as well. Is this just a coding bug inherent to 8 or is there a fix? I haven't tried the gateway "checking" option, but I've been using VPN for years on vista and 7 and this has only started when I moved to 8.

    Friday, October 26, 2012 11:08 AM
  • I too am experiencing this issue. And the only "solution" listed anywhere is to untick Use Default Gateway, which completely negates the use of the VPN for my purposes. I have submitted several bug reports in the Apps mentioning this issue.
    • Edited by jeisurii Saturday, October 27, 2012 5:50 AM
    Saturday, October 27, 2012 5:11 AM
  • I also am having this problem. Is there any official resolution yet?
    Saturday, October 27, 2012 6:17 PM
  • If you are connecting to the corp network, I would turn off use default gateway on remote network in your vpn advanced network settings.  This will allow apps that do not need to route through your corp network to use your internet connection.  One, you'll notice faster connectivity on apps that do not need the tunnel, and two, you'll save bandwidth at your office by not routing all your traffic through the work network.

    Keep in mind that if your office has a firewall or other network restrictions, those can cause your apps to not work properly.  Unless you have multiple networks that you need to reach through the vpn connection (e.g. connect to VPN at office 1 to reach a computer/server at office 2) I wouldn't route any traffic other than what is necessary through the tunnel.  If you do need those other networks, you can write routing statements on your workstation that would allow certain networks to connect without having to force all your traffic through the tunnel.

    It's much more efficient, and a better experience if you tweak your network settings so that only the traffic that needs to go through the tunnel does.

    Saturday, October 27, 2012 8:07 PM
  • I spent some time looking deeper at this issue today. Here's the main points I found:

    - behaviour is exactly the same no matter whether the physical network connection is Ethernet or Wi-Fi

    - when a VPN is connected (in my case, using native Win8 VPN client), some (but not all) metro apps do not work properly

    - apps that work fine include Mail (the preinstalled app), Store (again, preinstalled), SkyDrive (metro client), Skype (download from store) and MusixMatch (download from store)

    - IE (metro browser) also works fine

    - Bing (the preinstalled app) reports being offline (icon in top right corner), but actually works completely normally

    - there are many apps that don't work - either reporting the PC is offline at launch, or some time later when try to access content not already cached. These non-working apps include Engadget, XBox Music and Video (they work ok for local content but say offline when try to access online content), Weather (preinstalled) and News (preinstalled)

    - in conclusion, I have three theories but to get a definite answer we will need feedback from an expert Metro app developer and/or Microsoft:

    (1) actually connectivity works fine on VPN, but some apps are checking the physical connection status (limited) and just refuse to go further [implies need fix by app developers and maybe guidance from MS regarding style guidelines]. Here is a very relevant link on how to correctly check connectivity:

    http://quawp.azurewebsites.net/2012/10/checking-connectivity-the-correct-way/

    (2) as above, but some app developers are implementing in this way on purpose so as to prevent them working on VPN, for whatever reason (e.g. restrictions imposed by content providers per region, DRM, etc)

    (3) there is some other specific functionality in the Metro API which allows apps developers to check whether VPN is being used or not, and some app developers are deciding to disallow use on VPN

    Anyway, for the many people who travel frequently and spend a lot of time with their PCs connected to their company's VPN, having many/most of the metro apps stop working is sure going to be inconvenient. (and constantly connecting/deconnecting from VPN when wanting to use a given app is hardly a suitable solution)

    Comments from anyone who can narrow this down further would be appreciated...





    • Edited by tomdjpn Sunday, October 28, 2012 5:43 AM
    Sunday, October 28, 2012 5:15 AM
  • I am not connecting to a corporate network. I use my VPN to pull a U.S. IP address to get around geo-fencing on apps like Netflix and Hulu Plus. Using the default gateway on the remote network is necessary and I cannot rely on my normal network otherwise I will be blocked. Here's to hoping Microsoft will fix this in the near future. I'm holding back from upgrading another win 7 box to windows 8 so I don't lose complete VPN usability.
    Sunday, October 28, 2012 3:54 PM
  • It only happens with Metro style apps, normal applications are unaffected by this. I almost don't use any, so it's not a big deal, but it is a bug that needs a fix. Microsoft went a step back with this behaviour - applications should always try accessing the network and if there is a problem with the connectivity, they would rely on the networking stack returning "no route to host" and not on some buggy status reported by the adapter. This breaks the whole idea of the OSI model in my opinion...

    Sunday, October 28, 2012 3:59 PM
  • I have absolutely the same issue. Are Microsoft going to address it somewhere in the nearest future? I'm really upset with Win8 now, I just saw that they killed Aero theme along with Start...
    Sunday, October 28, 2012 11:58 PM
  • I have been discussed this case with one Microsoft Engineer, but could not figure it out. I will report back if we have the fix.


    Bob Lin, MVP, MCSE & CNE Networking, Internet, Routing, VPN Troubleshooting on

    http://www.ChicagoTech.net

    How to Setup Windows, Network, VPN & Remote Access on

    http://www.howtonetworking.com

    Monday, October 29, 2012 2:52 AM
  • Same problem here. E-mail, Market, TuneIn (streaming radio) work, but Stocks, Weather do not. Funny thing is that Bing says it's offline, but i can search with it.
    Monday, October 29, 2012 12:10 PM
  • I have the exact same issue, some metro apps work, some like Weather or NYTimes cannot get the connection and it keeps saying "OFFLINE".
    I tried wifi and with cable, both no success. I am connected to my VPN and surf through it as I'm in a country with blocked access, everything else works fine.
    Monday, October 29, 2012 4:46 PM
  • Same problem here on win 8 pro 64bit
    Monday, October 29, 2012 11:55 PM
  • Do we have official Microsoft support somewhere? I want to write/call them about this problem but don't know how to communicate with them.
    Tuesday, October 30, 2012 11:06 AM
  • Tweetro does not work too. Launch the app and there is even no authentication screen, just dots round and round. I think it's with something how Metro apps access internet with API. When main connection is "Limited" (i.e does not provide internet connection in itself)  certain apps consider there is no internet connection at all (they "don't see it" or can't access data) , even it is, via VPN.
    Tuesday, October 30, 2012 11:13 AM
  • Same problem. Incredibly annoying. Thanks for the info above.
    Tuesday, October 30, 2012 4:25 PM
  • I think it is the case. My connection shows "Limited" as well, the VPN shows "Connected".
    Wednesday, October 31, 2012 2:24 AM
  • I'm having a similar problem but I believe I've traced it down to there being no IPv6 Network Protocol installed for my mobile broadband device, an issue caused by my ISP. Its the only difference I've found between a connection that works and one that doesn't! I believe these apps receive their updates through IPv6 networks and will not work without that connection. Check for IPv6 connectivity @ www.test-ipv6.com
    Wednesday, October 31, 2012 3:42 AM
  • I'm having a similar problem but I believe I've traced it down to there being no IPv6 Network Protocol installed for my mobile broadband device, an issue caused by my ISP. Its the only difference I've found between a connection that works and one that doesn't! I believe these apps receive their updates through IPv6 networks and will not work without that connection. Check for IPv6 connectivity @ www.test-ipv6.com

    Hmm... I just found out my ISP not provide Ipv6 support. Nevertheless I don't think It's the cause. It would be strange, if Metro apps rely on ipv6 so heavily, ipv6 is not so common nowadays, I believe.

    To solve the problem you can try to configure you router (if you have one) to connect to VPN automatically. Thereby you will have only one connection on you PC, which provides Internet. Check your router manual and your provider's site how to do it.
    • Edited by iZerw Wednesday, October 31, 2012 10:06 AM
    Wednesday, October 31, 2012 7:51 AM
  • I have the same problem with the metro apps but in my case i am not using a VPN connection.

    In my case I am using a DNS filter (forward to Opendns).

    And it also happens when I use TMG 2010 proxy server.

    The problem disappears when I trun of the DNS filter or not use the TMG.

    I also had a second problem that is a popup of bing.com page which I posted in:

    http://social.technet.microsoft.com/Forums/en-US/w8itpronetworking/thread/4cc88d7c-dbca-457b-8960-0a3e9253f92b

    To me it looks like that the mechanism to determine in which network the PC is connect is using a read of a webpage. And when that page is not found the result is offline.

    With fiddler a noticed that this page was queried http://rssgov.windows.microsoft.com /usagovrssfeed.rss

    Maybe this helps to find the solution.

    Wednesday, October 31, 2012 8:11 PM
  • If you are connecting to the corp network, I would turn off use default gateway on remote network in your vpn advanced network settings.  This will allow apps that do not need to route through your corp network to use your internet connection.  One, you'll notice faster connectivity on apps that do not need the tunnel, and two, you'll save bandwidth at your office by not routing all your traffic through the work network.

    Keep in mind that if your office has a firewall or other network restrictions, those can cause your apps to not work properly.  Unless you have multiple networks that you need to reach through the vpn connection (e.g. connect to VPN at office 1 to reach a computer/server at office 2) I wouldn't route any traffic other than what is necessary through the tunnel.  If you do need those other networks, you can write routing statements on your workstation that would allow certain networks to connect without having to force all your traffic through the tunnel.

    It's much more efficient, and a better experience if you tweak your network settings so that only the traffic that needs to go through the tunnel does.


    This temporary solution worked for me. Obviously this is not a complete solution as doing this might cause issues as Josh points out in this post.

    In order to do the change Josh is pointing out do the following:

    1. Go to "Network and Sharing Center" in control panel or by right clicking the network icon in the notification area in desktop mode.

    2. Click on the VPN connection link "Connections: 'VPN Connection Name'". This should open the VPN connection status dialog.

    3. Click on properties button.

    4. Click on networking tab.

    5. Select on Internet Protocol Version 4 option on list, then click properties button.

    6. Click on advanced button.

    7. Uncheck "Use default gateway on remote network" option.

    8. Click OK on all the open dialogs to save this.

    -Restart the VPN connection if it was already connected.

    As Josh mentions: This will change your internet access to go through your local network rather than through the VPN network. You can test it by going to a website that shows what your IP address is before and after the change to verify that your routing has changed.

    Thursday, November 01, 2012 4:20 PM
  • OK, but we are not discussing here HOW to get these Metro apps working - not using the default gateway of the VPN obviously does the trick, but it is not a solution, just a workaround. Most people that do not use split tunneling usually have a good reason of doing so. A solution would be to enable the apps to work through the VPN, something that to the best of my knowledge so far would need a software fix from Microsoft.

    Thursday, November 01, 2012 4:25 PM
  • By accident, I've found a workaround, of sorts.

    I installed Visual Studio Express on my PC including the WP8 emulator. This emulator is based on Hyper V (Microsoft's software for hosting VMs on Windows). When Hyper V is installed, it creates a couple of virtual network adapters and a bridge to the physical network interfaces (you can see them in Network & Sharing Center) which allow the virtual machine to connect to the internet.

    Now, it turns out that, with these Hyper V virtual adapters installed, Windows still shows the physical interface as "Connected" (not "limited") even when you connect to some other VPN.

    (Note it's not necessary for Hyper V to be running - just for the virtual adapters and bridge to be installed).

    Once I had both the VPN and the physical interface reported as "Connected", I found that all the Metro apps (at least all those I tried) started to work perfectly!

    So tentative conclusion is that the problem is indeed that app developers are checking for connectivity in a way that is incorrect when VPN is connected, and that installing Hyper V is a sort-of workaround.

    But I'd appreciate if anyone else can verify this.

    Friday, November 02, 2012 12:43 AM
  • Well, yeah I can verify that "workaround" for installing WP8 SDK works. All metro apps are working perfectly now. But I hope MS fixes the issue via Windows8 update for those who do not require WP8 SDK.

    Thanks for sharing, it really saved my day.

    Friday, November 02, 2012 7:48 AM
  • By accident, I've found a workaround, of sorts.

    I installed Visual Studio Express on my PC including the WP8 emulator. This emulator is based on Hyper V (Microsoft's software for hosting VMs on Windows). When Hyper V is installed, it creates a couple of virtual network adapters and a bridge to the physical network interfaces (you can see them in Network & Sharing Center) which allow the virtual machine to connect to the internet.

    Now, it turns out that, with these Hyper V virtual adapters installed, Windows still shows the physical interface as "Connected" (not "limited") even when you connect to some other VPN.

    (Note it's not necessary for Hyper V to be running - just for the virtual adapters and bridge to be installed).

    Once I had both the VPN and the physical interface reported as "Connected", I found that all the Metro apps (at least all those I tried) started to work perfectly!

    So tentative conclusion is that the problem is indeed that app developers are checking for connectivity in a way that is incorrect when VPN is connected, and that installing Hyper V is a sort-of workaround.

    But I'd appreciate if anyone else can verify this.

    When I change my modem settings from PPPoE/PPPoA to Bridge mode and I setup the internet connection manually, Modern UI apps work fine though the status of the network card is still "Limited".
    Friday, November 02, 2012 11:32 AM
  • By accident, I've found a workaround, of sorts.

    I installed Visual Studio Express on my PC including the WP8 emulator. This emulator is based on Hyper V (Microsoft's software for hosting VMs on Windows). When Hyper V is installed, it creates a couple of virtual network adapters and a bridge to the physical network interfaces (you can see them in Network & Sharing Center) which allow the virtual machine to connect to the internet.

    Now, it turns out that, with these Hyper V virtual adapters installed, Windows still shows the physical interface as "Connected" (not "limited") even when you connect to some other VPN.

    (Note it's not necessary for Hyper V to be running - just for the virtual adapters and bridge to be installed).

    Once I had both the VPN and the physical interface reported as "Connected", I found that all the Metro apps (at least all those I tried) started to work perfectly!

    So tentative conclusion is that the problem is indeed that app developers are checking for connectivity in a way that is incorrect when VPN is connected, and that installing Hyper V is a sort-of workaround.

    But I'd appreciate if anyone else can verify this.

    Oh thank you. This is finally a good solution to this wierd problem. Shame on you Microsoft...
    Friday, November 02, 2012 7:49 PM
  • I have VyprVPN, and apparently Metro apps do not work via their service, too. I worked with both Windows 8 support, and VyprVPN support, and both seem to point to the other guy as the one who needs to fix whatever is wrong. MS support simply said that 'your VPN provider needs to make some group policy changes to their service' but would not clarify or explain what changes would need to be made. It seems comical since I allowed the MS person to remote my PC, check settings, look around, etc - all while on a public WiFi hotspot and connected to my VPN account - all of which the tech could do and had no issues doing, nor could he even explain what it was about the Metro apps that did not like about the VPN tunnel. It was a typical 'Level 1 Support' sort of scenario where he was following a script. I find the whole thing very strange, since I often work at remote public open WiFi locations (coffee shops, etc), and so I have always run a VPN client to secure all of my traffic. This has never been an issue with any other applications or connection protocols, so to see that Microsoft ships a product, touting their new Metro interface and applications, only to find that most of them will not work when connected thru a VPN connection, a bit disappointing. Simply showing a status of 'Offline' or 'You Are Not Connected To the Internet' is not at all helpful, too, nor does it seem valid, as IP4 connectivity always shows 'Internet' on the VPN connection. Also, I find it odd that not a single tech site managed to stumble across this issue during all the early Windows 8 previews, nor the reviews of the shipped product.
    Tuesday, November 06, 2012 10:12 PM
  • This surely is a known issue, but I would like someone to confirm that this IS a problem in Windows 8 that NEEDS to be fixed. It's a simple as that: when I connect to my corporate network through a VPN connection that becomes the default gateway, all Windows 8 UI apps report that there is no Internet connectivity and therefore do not work. Obviously the apps do not check for Internet connectivity and depend on the status of the network adapter that is provided by Windows - when the VPN connection is active, the status of the underlying Internet connection reads "Limited" or "No Internet access". This was not the case in Windows 7 - when the VPN connection was active, both connections reported "Internet access".

    Please do not advise me to disable the "Use default gateway on remote network" option in the VPN adapter. I need all traffic to be routed through the VPN and what happens now is a BUG in Windows 8, not in other products. And a bug needs an acknowledgment and a fix, right?


    I have this problem too.it ran me into crazy
    Saturday, November 10, 2012 7:36 AM
  • By accident, I've found a workaround, of sorts.

    I installed Visual Studio Express on my PC including the WP8 emulator. This emulator is based on Hyper V (Microsoft's software for hosting VMs on Windows). When Hyper V is installed, it creates a couple of virtual network adapters and a bridge to the physical network interfaces (you can see them in Network & Sharing Center) which allow the virtual machine to connect to the internet.

    Now, it turns out that, with these Hyper V virtual adapters installed, Windows still shows the physical interface as "Connected" (not "limited") even when you connect to some other VPN.

    (Note it's not necessary for Hyper V to be running - just for the virtual adapters and bridge to be installed).

    Once I had both the VPN and the physical interface reported as "Connected", I found that all the Metro apps (at least all those I tried) started to work perfectly!

    So tentative conclusion is that the problem is indeed that app developers are checking for connectivity in a way that is incorrect when VPN is connected, and that installing Hyper V is a sort-of workaround.

    But I'd appreciate if anyone else can verify this.


    you're the one ! microsoft please correct this as i want to use vmware not Hyper-V...
    Sunday, November 11, 2012 9:39 PM
  • Same problem with VPN here, confirmed both with ethernet and wifi, and different VPNs.

    I cannot install the Hyper-V role because I'm using vmware and I don't want to mess up things. I hope that a fix will appear very soon...


    I think that apps need an update, not the os, because some metro apps work perfectly, some others no... So maybe it's not a fault from the os, but as someone already said, it's a problem in the connectivity checkings done by some apps (some even first party...)
    • Edited by cenit Tuesday, November 20, 2012 5:12 AM
    Tuesday, November 20, 2012 5:11 AM
  • similar issue with windows 8 enterprise x64 Solved!!!

    make sure both services -

    "Network Location Awareness"

    and

    "Network List Service"

    are started and running!

    Friday, November 23, 2012 11:54 PM
  • Hi

    Just do this steps:

    1) Go to Windows Features

    2) Turn on Hyper-V and save

    enjoy!

    Sunday, November 25, 2012 6:34 PM
  • Unfortunately this is not a universal solution. It will only work on systems with CPUs that support SLAT which is a requirement for Hyper-V in Windows 8.

    Sunday, November 25, 2012 8:09 PM
  • of course, but it is a auxiliary method that can solve this problem temporarily. I think this is a BUG in windows 8, and we must wait for a update for completely solving.
    Sunday, November 25, 2012 10:13 PM
  • I agree with Yordon as I am testing with a PC that does not support SLAT...

    And I know for a fact it is an issue on Microsoft's side.  This is not a solution, but the following proves my point:

    When I installed Fiddler2 and the windows 8 addy for UIs "metro apps" work with the VPN, but so do sights that are suppose to be blocked on our network (NOT EVEN A WORK AROUND) in my mind.

    I am one of the lucky ones as I am the one that setup our current network...  Late one evening I logged into our ASA 5510 and decided to allow split tunneling for AnyConnect users.  Guess what, most of the "metro" apps went back to working while on the VPN although some still did not.  Once I disabled Split-tunneling for ANyconnect users again, bang none worked.

    Our setup does not allow a user to change there VPN settings, and no it doesn't really matter as most of the proggies they will use will work through the desktop, but what Microsoft needs to understand is that this can cost a company money that they don't need to spend.  For example, why would I want to by a CAL to install outlook when "metro mail" works great (when not on the VPN).

    We are looking at going to Umbrella by OpenDNS and although I haven't tested it yet, I see this being a issue with windows 8 "metro apps"

    Wednesday, November 28, 2012 2:12 AM
  • Well, I have exactly the same bug as described by many other people here, I have Win8 pro x64. It's really strange that the bug was reported more than 1.5 months ago, and there's still no information about what's going on and whether it's going to be fixed. Disabling default gateway in vpn connection properties isn't a solution, because I need all my traffic to be forced through VPN connection - I often use public wireless networks and I don't want other people to see all my http data/cookies/etc, so I connect to my VPN server. It's really frustrating that I have to disable VPN in order for metro apps to work with internet. It's also strange that while most of the metro apps can't use internet while connected to VPN, some of them, like Store/Skype/SkyDrive still can use it.

    Wednesday, December 05, 2012 7:54 PM
  • Any update? I am still having this issue and it is killing me.
    Thursday, December 06, 2012 9:09 PM
  • Well the problem is that Microsoft refuse to provide solution for us because they think it's not massive issue. Tho it really drive me nuts. I already uninstalled Windows 8 and came back to Windows 7 with UI tweaks, which looks amazingly similar to Windows 8 one, so I'm happy with that. I was really crazy about getting Windows 8 ASAP, but Microsoft with their awful support killed all enthusiasm within me, so I probably wont use their products until I check them thousand times first.
    • Edited by MrGuard Thursday, December 13, 2012 9:51 AM
    Thursday, December 13, 2012 9:51 AM
  • Same Problem Here, is there any official fix for this ?!
    Sunday, December 16, 2012 10:53 PM
  • I had the same issue, after reading some of the forums about this issue and finding no answer I was able to resolve the issue.  Try the following - disconnect from the VPN, open Network and Sharing Center, open the properties of the VPN connection, Network tab, uncheck IPv6 - reconnect to the VPN and test.  Connection is working like a champ - everything is now working as it is supposed to as well as connection to all my Servers on my work network.

    JBGeek76

    IT Manager

    Wednesday, December 19, 2012 9:41 AM
  • I tried unchecking the IPv6 and I still shows that I am not connected when I try and use certain apps such as xbox video and hulu. I am experiencing this issue on both my windows 8 pro laptop as well as my surface RT. It is extremely annoying and makes my machines almost unusable since I depend heavily on the availability of a VPN connection. I wish Microsoft would acknowledge the issue and fix it.
    Wednesday, December 19, 2012 6:20 PM
  • I had the same issue, after reading some of the forums about this issue and finding no answer I was able to resolve the issue.  Try the following - disconnect from the VPN, open Network and Sharing Center, open the properties of the VPN connection, Network tab, uncheck IPv6 - reconnect to the VPN and test.  Connection is working like a champ - everything is now working as it is supposed to as well as connection to all my Servers on my work network.

    JBGeek76

    IT Manager

    So, I tried this. No go. Also tried turning on Hyper-v. Again. nada. Not that it matters if these apps are working or not. But it would be nice if everything worked with the vpn like it's supposed to.
    Sunday, December 23, 2012 5:05 AM
  • I guess this is because of the network isolution enforced in all windows store apps by default.

    It is possible to add some exemption to the policy.

    E.g., CheckNetIsolation.exe LoopbackExempt –a –p=S-1-15-2-4125766819-3228448775-2449327860-2490758337-1264241865-3581724871-2122349299 (app ID)

    Please refer to this article for details.

    http://msdn.microsoft.com/en-us/library/windows/apps/Hh780593.aspx

    Hope this helps.

    Friday, December 28, 2012 6:30 AM
  • Still an on-going problem here, and all the googling in the world can't save me.
    Sunday, January 20, 2013 3:50 PM
  • same problem,but strangely some metro app works fine. where goes wrong?
    Monday, January 21, 2013 10:18 AM
  • Is there no one that has a solution to this?
    Tuesday, January 29, 2013 10:04 AM
  • I have a solution for the problem.

    Just try to find somewhere a Cisco Anyconnect Client. I got one from my University and it works really good with Microsoft App Store in W8 x86.

    Hope this information could help most of you.

    Cheers

    Wednesday, January 30, 2013 6:31 PM
  • I use Cisco AnyConnect and I have the same problem.  I tried turning off IPV6 but no-go.  Have not tried turning on hyper-v but I somehow doubt it will help (as someone above noted that it made no difference for them).

    If sounds like (reading all these posts) the behavior is inconsistent across machines/networks.  Very strange.

    I would really like this to work properly so I can use my Metro UI apps while tunneled into work.

    Monday, February 04, 2013 4:31 PM
  • I got similar problem, but it actually got bigger :(

    First I got Windows 8 Pro x64 on my desktop.

    As in your case when I connected to VPN server my local connection showed "limited" status (connection to router is via lan cable)

    This meant that some of the Modern UI apps did not work (reported no active connections) but some did.

    Luckily most of the ones I wanted to use (Netflix) had no problem.

    What's more, browsers in Desktop Mode worked just fine.

    Yesterday I bought Asus TF810c (tablet/hybrid) with Windows 8 32bit on board.

    VPN connection has been setup the same way as on desktop (or Windows 7 previously).

    Problem is that ALL apps in both modes do not work :-(

    All apps in Modern UI as well as (and this is much worse!!!) browsers in desktop mode.

    I really do not know what to do :-(. This also means that I have lost a lot of usability for this device and system - it was supposed to replace my old iPad. 

    No it can not :-( any ideas what I can do about it? 

    I was hoping by now MS will fix this problem as it is reported by (all???) a lot of people that use VPN in Windows 8.

    Any progress on this??? Please, have some good news! I need at least browsers to work...

    Regards,

    Tom

    Wednesday, February 06, 2013 8:34 AM
  • Dear all ,

    I have been working to solve this issue like 2 month ago , and I was sure that this is somehow of a miss-configuration, Managed to solve my problem by checking what I have installed as software and such .

    I Wasn't pretty sure what is the software or what was the software causing all the issues , but in my case it was Antamedia DHCP server which wasn't even compatible with Win 8 yet 

    now please this is only for professional IT users , those who cannot handle this kind of configuration don't do it , as it may damage your whole system , our work will be in the Registry editor , 

    Run --> regedit --> locate the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-

    08002BE10318}

    now the trick is to backup this file by exporting it and saving it somewhere ,and after you have to browse the keys for the one installed by your software and causing all the issues .

    any one not abling to locate the key just send me the export file or post it here as a reply and maybe I can help him fix it , I know how annoying this issue is and that's why I'm offering my help , and in case of non professional users I may be able to help them remotely when ever I'm online just send me an email on moustafac@softflow.com.lb

    Please remember to mark this as answer if it works thank you and hope it helps you all from all over the world

    Moustafa Chouraiki

    Infrastructure Engineer

    Softflow , Lebanon , Microsoft Partners .

    (ActiveDirectory , Win 7 ,Win 8 , TMG  , Lync 2010, SEP ,Exchange Server 2010 )



    Sunday, February 17, 2013 11:56 PM
  • It seems that the most recent Windows Updates have solved the problem! :)
    Monday, February 18, 2013 6:49 AM
  • Ariana really?
    Could you send me the name of the update?

    Moustafa Chouraiki

    Infrastructure Engineer

    Softflow , Lebanon , Microsoft Partners .

    (ActiveDirectory , Win 7 ,Win 8 , TMG  , Lync 2010, SEP ,Exchange Server 2010 )


    Monday, February 18, 2013 5:51 PM
  • yes it seems so!

    Finally it works, at least for now, at least on my computer, without any tool to connect and without any trick!

    Monday, February 18, 2013 6:53 PM
  • I dont know exactly which one is the update needed for the matter, but this is a list of updates which were downloaded on 2/14/2013



    • Edited by Ariana2008 Monday, February 18, 2013 7:18 PM
    Monday, February 18, 2013 7:17 PM
  • The February security bulletins have indeed resolved the problem. The underlying connection still shows "Limited", but the apps seem to get Internet access successfully. It is though unclear which update exactly addressed the issue. The two KBs for the non-security updates listed above (KB2795944 and KB2793210) do not icnlude any information regarding this problem. It may be part of a security fix applied by any of the other updates.
    Monday, February 18, 2013 8:33 PM
  • I have all the updates above and the problem is not resolved for me.
    Tuesday, February 19, 2013 2:53 AM
  • This is a known issue. Fix for this is available at http://support.microsoft.com/kb/2797356

    Please install the fix, and see if it works for you.


    Friday, February 22, 2013 8:19 PM
  • kb2797356 is installed, but I see the same in metro interface. some metro apps can't see the internet connection, but some like Mail, skype, icq works normally.

    i don't beleive that you guys can't reproduce this problem on your tablets. several months after release. shame on you

    Thursday, February 28, 2013 4:34 PM
  • some metro apps can't see the internet connection, but some like Mail, skype, icq works normally.

    What does Fiddler4 see?   Note that inserting Fiddler or even just using its EnableLoopback tool might act as a workaround for you anyway.

    Otherwise you could try tracing with NetMon and trying to interpret any anomalies.  Similar but even more obscure traces could be obtained simply by running ProcMon and looking at its Network event records.

     
    HTH

     
    Robert
    ---

    Thursday, February 28, 2013 6:54 PM
  • This fixed it for me! Thanks!

    As reported above: http://support.microsoft.com/kb/2797356

    • Edited by MobileSteve Monday, March 04, 2013 10:05 PM Added Link
    Monday, March 04, 2013 10:04 PM
  • this fix solved the "limited connectivity" issue  but Modern UI apps still shows the same behavior as before and some of them lose internet connectivity while connecting to a VPN.   
    Thursday, March 21, 2013 5:23 PM
  • I work for a VPN company and just had to diagnose this exact problem with our VPN.  The problem that our customer reported was that Metro/Modern/Tiled (whatever they are called now) apps would not download data from the Internet, and the Metro version of IE would report an error that said something like "msn.com is not enabled in the Private profile".  In some configurations of our VPN, there was no default gateway on our virtual adapter (gateway address was equal to the IP address of the interface), and this apparently was the source of the problem.  You can tell if you have no gateway address by running "ipconfig" at a command prompt.  The default gateway for the adapter will be listed as 0.0.0.0.  We were able to fix the problem in our VPN configuration by adding the ability to specify a default gateway address, but for others who are having the problem, you might want to specify a default gateway for your VPN adapter in advanced IPv4 properties for the adapter.  Open "Network and Sharing Center", client "Change adapter settings" in the left pane, right click the adapter used by your VPN, click Properties, highlight the IPv4 protocol, click Properties, Advanced, and add a default gateway.  You may need to reboot the machine after adding the gateway address.  It apparently does not even have to be the address of an actual machine; as long as a default gateway is specified for the adapter, then Metro apps should work.  If that does not work, then try using a static IP address instead (if that will work with your VPN), and be sure to specify the gateway address when doing so.  Good luck!

    • Edited by JoeSo Thursday, July 18, 2013 1:18 AM update2
    Thursday, July 18, 2013 12:44 AM
  • I had a similar issue and found that this Answers post had the solution that worked for me - turning sharing off on the VPN connection.

    Friday, August 02, 2013 6:40 AM
  • This do the trick for me, thx ! (services was running, but restart do the job)

    In my case problems start to shows up, when I installed Hyper-v (8.1 64 bit). Some Times Apps from MS store wont get access to internet (all of them). VM in Hyper-v connecting to internet thru WiFi (external connection), an hyper-v adding vEthernet adapter and making Bridget connection with W-Fi. If some one got solution (restarting services every single time isn't :P), post it here :)

    Friday, January 10, 2014 5:48 AM
  • As mentioned above, this issue is already fixed with updates released in February 2013.

    Friday, January 10, 2014 1:35 PM
  • Not in my case. I don't use VPN.

    Desktop application can access internet but Windows Store Apps can't, untill one of services mentioned by MyPC8MyBrain is restarted ("Network Location Awareness" and "Network List Service").

    Edited: System is up to date.

    • Edited by Mirek_MS Monday, January 13, 2014 5:21 PM
    Monday, January 13, 2014 5:21 PM
  • I am surprised you report Skype as working for you. I am using Cisco Systems VPN Client Version 5.0.07.0440. When I open Skype, it claim to be offline, but not immediately. No messages ever get delivered and I never receive any messages until the connection is closed. When I check “Allow Local LAN Acess” in the cisco VPN client, which is the closest I can find to allowing non-VPN routing, that doesn’t help.

    So, why does the “Modern” Skype app work for everyone other than me? ;-) I do know that all of the “Modern” Windows apps work fine when I connect to another place using Cisco AnyConnect.

    Tuesday, April 08, 2014 3:26 PM