none
Windows 7 - Authenticated WebDAV over HTTPS...

    Question

  • I've got a relatively simple WebDAV file share set up for a variety of users at distributed locations who work for many different companies.  In case someone at Microsoft is actually interested in making the WebDAV client in their newer operating systems (Vista, Windows 7) work properly with things other than SharePoint / IIS, here is how my WebDAV server is set up: the web server is Apache 2.2 (mod_dav) running on CentoOS 5.3 (nothing real special there). We authenticate users against an LDAP repository using their email address and a password (mod_ldap; again, nothing really special going on here).  The site is only accessed via https so authentication and such are reasonably secure.

    My question is this:  since I can easily use this WebDAV file sharing mechanism with every single WebDAV client I've ever used, including the built-in mechanisms in most modern operating systems (MacOS, various flavors of Linux, and even Windows XP), why on earth is it so hard to get this to work "built-in" in Windows 7? Vista seems to have problems with it as well and Windows 7 doesn't even seem to try properly (i.e., if I look at the access logs on the server, the initial request doesn't even ever show up even though Windows reports there was an authentication problem).  I suspect it is a combination of the SSL and / or authenticating using an email address, but can't really tell for sure.  Does anyone else use WebDAV like this?  I can't imagine I'm the only one since it is such a useful tool (and not all of us out here use Windows / IIS / SharePoint because they're so much more expensive than "free" solutions).  Don't get me wrong, I fully understand that there are many organizations that already have sharepoint and such and that that is the main target for "Web Folders", but some small businesses and tech-savvy (but broke) users such like to do things themselves.  Not really trying to beat down on the folks building Windows 7 or anything --- just frustrated and trying to get someone to fix this little "problem" since it's something that works in Windows XP and many other operating systems out of the box.

    Thanks . Also any success stories with similar uses of WebDAV / https / with authentication are appreciated as well.

    Kendal.
    Tuesday, October 20, 2009 4:26 PM

Answers

  • I know it's been a long time since I posted this, but I finally found an answer:  You can use the following URI to map the drive:

     

    net use * "\\<servername>@SSL\folder-name" /User:<username> <password>

     

    this seems to do the trick for me as long as windows already knows about the Self-Signed SSL cert and it's been put in the trusted ca certs certificate store.

     

    I hope this helps someone else.

     

    Kendal.


    • Marked as answer by theWizK Thursday, March 31, 2011 2:25 AM
    Thursday, March 31, 2011 2:25 AM

All replies

  • I think i have the same problem.  Have you solved it yet by chance?
    Jeff V
    Friday, October 23, 2009 8:36 PM
  • I have the exact same thing and haven't found a clue at all yet. It does work at home, but behind a corporate firewall all fails.
    Thursday, October 29, 2009 6:12 AM
  • I am still battling with this issue as well...has anyone come up with any working solutions aside from having to install a local webdav client?
    Thursday, January 14, 2010 5:41 PM
  • Webfolders works fine from win7 pro to webdav (desknow.com) running on centos 5.x

    Thursday, January 14, 2010 6:56 PM
  • For what my two cents are worth:

    I'm having the same problem. I've set up several webDAV shares on a linux server (unknown flavor @ hostgator through cpanel) that work flawlessly from Windows XP Professional. I access one public folder via http and one private folder via https. I haven't mapped them to a drive, just put a shortcut on my desktop. But from Windows 7 Professional, it asks me for credentials, then tells me, "Folder does not appear to be valid." A netbook with Win7 Home gives me the same behavior. The server side obviously works. The Win7 client obviously doesn't.

    Same frustration... I write software and understand that sometimes necessary changes break other things, but I'm pretty disappointed that Win7 can't do webDAV. It seems like such a simple and straightforward thing to build and test.

    Please fix this and stick in a Windows Update package.

    Wednesday, April 21, 2010 4:44 PM
  • I'm dealing with authorization problems on Windows 7's WebDAV client as well.

    Basic authorization does not seem to be supported at all, changing the registry as mentioned in several forums and microsoft solutions has no effect at all. The Mini-Redir WebDAV client sends a Negotiate Authorization no matter what www-authenticate I'm sending in my 401 responses.

    What I've read in some other forum was to download the certificate if using ssl and importing it in certmgr.msc. That didn't fix my problems, maybe it'll be helpful to you guys tho.

    Best regards

    Susanne

    Thursday, June 17, 2010 1:06 PM
  • 1.5 years after this bug was identified, and it still goes unaddressed. How did this get fixed in Vista and the fix dropped in Windows 7?

    Here is the MS fix for Vista: KB907306

    Could someone please tell us when you expect this bug to get fixed?

    Monday, June 28, 2010 9:01 PM
  • I have been having the same issue on a windows 7 32 bit client connecting to MS BPOS hosted Sharepoint but I noticed that a particular service seemed to be controlling this on the PC.

    The service in question is called "WebClient" on the machine I had the problem it was set to manual start and the service was stopped I could not access files via webdav.

    I restarted this set it to automatic and refreshed My computer and I could then access the folder again on Webdav.

    Does this fix it for anyone else?

    • Proposed as answer by rewind54 Tuesday, April 17, 2012 2:36 PM
    • Unproposed as answer by rewind54 Tuesday, April 17, 2012 2:36 PM
    Wednesday, June 30, 2010 3:19 PM
  •  

    I am also having this issue.  My setup is a RHEL 5.4 server running Apache 2.2.3 with Web Dav configured with basic authentication but using LDAP.  The authentication must be done over SSL.  I have a wildcard certificate setup and it includes all the necessary Root and intermediate certificates and works find in other browsers.  While I can successfully connect to this service with Linux, Mac OS X, Windows XP, and even Windows Vista I can't get this to work well under Windows 7.

    Don't know if this will help but I went through all sort of posts and have tried many things and so far the only thing that leads to any sort of success is to change the following registry entry:

     


    HKLM\SYSTEM\CurrentControlSet\Services\WebClient\Parameters\ServerNotFoundCacheLifeTimeInSec = 0

    This allows me to setup the shortcut and use it until I either log off or restart.  Once I restart and click on the shortcut created I just get prompted to authenticate that fails with a "Windows cannot access ..." error.  The funny thing is if I create another shortcut then both of the shortcuts work during that login session.

    This is beyond frustrating and I can't understand why it's not fixed yet.

    Edit:  I just noticed that if I  use the Computer->Map network drive method to create the shortcut then that yields the above results.  If I use 
    net use * https://www.somedomain.edu/dav/demo1
    to make the shortcut, it fails to reconnect on login but if I double click on it it prompts for my password and I can access it without having to re-setup the whole shortcut/connection.

    This might be a workable workaround/solution?
    • Edited by Chaos 51 Wednesday, November 24, 2010 7:04 PM wanted to clarify and also found out something new relating to the net use command
    Wednesday, November 24, 2010 6:54 PM
  • Since I also have this issue with my provider based webdav storrage over https, i was wondering if there is fix or a workable work around for this (one that outlives the rboots).

     

    Any pointers welcome!

     

    Thanks in advance,

    Michel

    Friday, January 07, 2011 3:55 PM
  • I know it's been a long time since I posted this, but I finally found an answer:  You can use the following URI to map the drive:

     

    net use * "\\<servername>@SSL\folder-name" /User:<username> <password>

     

    this seems to do the trick for me as long as windows already knows about the Self-Signed SSL cert and it's been put in the trusted ca certs certificate store.

     

    I hope this helps someone else.

     

    Kendal.


    • Marked as answer by theWizK Thursday, March 31, 2011 2:25 AM
    Thursday, March 31, 2011 2:25 AM
  • I know it's been a long time since I posted this, but I finally found an answer:  You can use the following URI to map the drive:

     

    net use * "\\<servername>@SSL\folder-name" /User:<username> <password>

     

    this seems to do the trick for me as long as windows already knows about the Self-Signed SSL cert and it's been put in the trusted ca certs certificate store.

     

    I hope this helps someone else.

     

    Kendal.


    First of all, where do you do this? In a command window (as admin). I get "The operation being requested was not performed because the user has not been authenticated." I presume this is on the server. I used the correct UID/pwd. This is so easy on a Mac. Why is everything so strange and difficult in Windows?
    Wednesday, April 13, 2011 8:54 PM
  • Has this now been resolved?
    Wednesday, May 04, 2011 8:18 AM
  •  Nope, I think this is just silly, these groups are full of this webdav issue, I mean really... I have a full signed cert and can't get a https mapping to work via BasicAuthLevel = 1 or two.
    Until later .... Brett
    Monday, June 06, 2011 8:38 AM
  • I solved this problem after I imported the server certificate in Control Pannel -> Internet Options -> content -> certificates -> import. The certificate was issued by a trusted authority (one .pem file). After import it was added in "Other People" tab. Before that I was imported the certificate of the root CA authority in .pem format but I don't know if this is necessary. Now I think that it is possible to work also with self signed certificates if you import them also in win. Before all these imports when I tried to connect with map network drive it was asked me username and password a couple of times an then give me the message: "The folder you entered does not appear to be valid. Please chose another." PS: by the way I am on win 7 sp1, 64 bit, and I am connecting with https to owncloud v2.
    Wednesday, January 18, 2012 5:59 PM
  • Hi all,

    Tried all of the above with no success. Searched for an alternative WebDAV client and tried BitKinex.

    BiKinex also returned an error, but this one was understandable and gave me a clue on how to solve the Windows issue!

    My setup:
    I run an apache webserver and I want to acces my files using WebDAV https.

    I run serveral https sites on the same server, eg. 'secure.site.com' and 'dav.site.com'. dav.site.com is the url I want to access using WebDAV, secure.site.com is another site.

    In my apache config secure.site.com is loaded before dav.site.com and I use virtual hosts.

    The error:
    As it turns out the WebDAV clients have a different way of checking the ssl keychain! When accessing dav.site.com using Bitkinex it returned a "non-matching hostname" error for the SSL certificate of "secure.site.com" (?!?).

    The solution:
    I changed my Apache config to first load dav.site.com and then secure.site.com and BitKinex connected just fine. Tried Windows WebDAV and it also connected without problems.

     

    Sunday, February 05, 2012 10:52 AM
  • I am using Open Text Content Server (Livelink 9.7.1) and the drag & drop feature quit working when I upgraded to windows 7.  I enabled this service and now all is well.  Thanks for the post! 
    Tuesday, April 17, 2012 2:38 PM
  • Here's a valuable tip I learned after trying for two days to setup a WebDAV connection on my Win 7 machine, which is Win 7 Pro 64-bit.  Apparently, WebDAV Redirector defaults to looking for port 80, even if you're using a secured connection (HTTPS).  So, even though I knew I was entering the proper credentials, I kept getting authentication failures.  Just as I was about to give up, I found this tip.  Change your url to direct the Redirector to port 443, the default for HTTPS/

    If you're given a link that looks like this:

    https://www.example.com/webdav/home   and you keep getting authentication failures, try entering the link as follows:

    https://www.example.com:443/webdav/home

    I did that and I was home free.

    Good luck,

    MGP

    Wednesday, November 28, 2012 10:56 PM
  • Also, FWIW, and I didn't know this, the "Install Certificate" button is not available if the site is not Trusted, regardless of the certificate status. but this is probably customizable.
    Saturday, November 23, 2013 8:18 AM