none
Keyboard typing wrong characters in windows 7 home premium

    Question

  • Hello.. i was using windows 7 pro till 4th nov 2011.. at that time my keyboard was working properly... than i reinstalled my windows 7 HOme premium 32 bit on 5th nov 2011. now the issue is that mykeyboard is typing the wrong letters.. for example when i press "SHIFT + 2" it should write @ but its writing inverted commas " ..... and when i press inverted commas button it is writing @.. and some more buttons are doing the same thing. I have updated my windows and installed service pack1 but the issue is not resolved! plz help on this issue..
    Sunday, November 06, 2011 7:05 AM

Answers

  • "Mohsin Bukhari" wrote in message news:9a7c1c35-9255-4725-891c-a6d8f6ffd87f...
    Hello.. i was using windows 7 pro till 4th nov 2011.. at that time my keyboard was working properly... than i reinstalled my windows 7 HOme premium 32 bit on 5th nov 2011. now the issue is that mykeyboard is typing the wrong letters.. for example when i press "SHIFT + 2" it should write @ but its writing inverted commas " ..... and when i press inverted commas button it is writing @.. and some more buttons are doing the same thing. I have updated my windows and installed service pack1 but the issue is not resolved! plz help on this issue..
     
    You’re using the wrong Keyboard set – which probably means that your Language option is set wrong.
    Go to Regional settings in Control panel, and correct the Language and Keyboard options there.
     

    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth
    • Marked as answer by Mohsin Bukhari Sunday, November 06, 2011 8:28 AM
    Sunday, November 06, 2011 7:10 AM

All replies

  • "Mohsin Bukhari" wrote in message news:9a7c1c35-9255-4725-891c-a6d8f6ffd87f...
    Hello.. i was using windows 7 pro till 4th nov 2011.. at that time my keyboard was working properly... than i reinstalled my windows 7 HOme premium 32 bit on 5th nov 2011. now the issue is that mykeyboard is typing the wrong letters.. for example when i press "SHIFT + 2" it should write @ but its writing inverted commas " ..... and when i press inverted commas button it is writing @.. and some more buttons are doing the same thing. I have updated my windows and installed service pack1 but the issue is not resolved! plz help on this issue..
     
    You’re using the wrong Keyboard set – which probably means that your Language option is set wrong.
    Go to Regional settings in Control panel, and correct the Language and Keyboard options there.
     

    Noel Paton | Nil Carborundum Illegitemi | CrashFixPC | The Three-toed Sloth
    • Marked as answer by Mohsin Bukhari Sunday, November 06, 2011 8:28 AM
    Sunday, November 06, 2011 7:10 AM
  • Sir, change your Keyboard language to United states (US).

     

     

     

  • Click Start 
     Start button
    , type intl.cpl in the Start Search box, and then press ENTER.
  • On the Keyboards and Language tab, click Change keyboards.
  • Click Add.
  • Expand the language that you want. For example, English (United States).
  • Expand Keyboard list, select the United States-International check box, and then click OK.
  • In the Default input language list, click <var>Language name</var> - United States-International (where<var>Language name</var> is the language that you selected in step 4), and then click OK two times.
  • In the Regional and Language Options dialog box, click OK

    Notice that the Language bar appears on the taskbar. When you position the mouse pointer over it, a ToolTip appears that describes the active keyboard layout.
  • Click the Language bar, and then click United States-International on the shortcut menu that appears.

    The United States-International keyboard layout is selected.

     

     

    Regards,

     


  • MCP | MCTS | MCITP
Sunday, November 06, 2011 8:10 AM
  • Thanx. Now problem is solved! :)
    Sunday, November 06, 2011 8:29 AM