none
RDP not working on 8.1. Worked fine on 8.0

    Question

  • When trying to use the remote desktop it just loads the initializing screen for half a second, and it disappears with no errors. When configuring the RDP and trying to connect for the second time, I get the following error:

    This computer can't connect to the remote computer.

    The problem might be due to low virtual memory on your computer. Close your other programs, and then try connecting again. If the problem continues, contact your network administrator or technical support.

    I tried the RDP app released in the store. It worked ONE TIME. Then after I try the connection again, it shows the initialziing screen for half a second, and it disappears without doing anything.

    Any ideas?
    Monday, October 21, 2013 5:56 AM

Answers

  • Hi,

    The above registry only help to resolve problem for RDP Client (mstsc.exe) not for RDP App.

    To fix issue for RDP App you need to search for that <USERNAME> and make it change in the registry.

    It will under HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppContainer\Storage\.............\Software\Microsoft\Terminal Server Gateway\Messages\<Domain>\<USERNAME>\UserPreferenceOption

    set value from 1 to 0.

    Hit F3 and find all keys end with that perticular user for RDP App and set UserPreferenceOption to 0 if it's not.

    Software\Microsoft\Terminal Server Gateway\Messages\<Domain>\<USERNAME>\UserPreferenceOption

    The problem is the option "Do not ask again unless changes to policy occur" in the "LogOn Message".

    If you want to avoid this issue then Go to your Terminal Gateway Server and Open the Property for your Terminal Gateway server and on Messging Tab remove check mark from Logon Message if you can remove as per your company policy. It will give you big relief from this issue. It will not come that message and user will not get that open to select and it will not change above Registry key any more.

    It's look like bug in Windows 8.1 which need to fix by Microsoft. There is no problem in Windows 8 for RDp client or RDP App.

    Give me update if this help you.


    Tej Shah

    Thursday, October 24, 2013 1:47 PM

All replies

  • The issue is solved - Open regedit and go to:

    HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Gateway\Messages\<Domain>\<USERNAME>\UserPreferenceOption

    Set the value from 1 to 0

    Monday, October 21, 2013 10:32 PM
  • Hi,

    The above registry only help to resolve problem for RDP Client (mstsc.exe) not for RDP App.

    To fix issue for RDP App you need to search for that <USERNAME> and make it change in the registry.

    It will under HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppContainer\Storage\.............\Software\Microsoft\Terminal Server Gateway\Messages\<Domain>\<USERNAME>\UserPreferenceOption

    set value from 1 to 0.

    Hit F3 and find all keys end with that perticular user for RDP App and set UserPreferenceOption to 0 if it's not.

    Software\Microsoft\Terminal Server Gateway\Messages\<Domain>\<USERNAME>\UserPreferenceOption

    The problem is the option "Do not ask again unless changes to policy occur" in the "LogOn Message".

    If you want to avoid this issue then Go to your Terminal Gateway Server and Open the Property for your Terminal Gateway server and on Messging Tab remove check mark from Logon Message if you can remove as per your company policy. It will give you big relief from this issue. It will not come that message and user will not get that open to select and it will not change above Registry key any more.

    It's look like bug in Windows 8.1 which need to fix by Microsoft. There is no problem in Windows 8 for RDp client or RDP App.

    Give me update if this help you.


    Tej Shah

    Thursday, October 24, 2013 1:47 PM