none
Slow Shutdown of Windows 7 64 bit computer

    Question

  • My Windows 7 64 bit computer is very slow shutting down.  Does anyone know of changes that I can make to it to speed up the shutdown?

    Monday, June 27, 2011 6:37 PM

Answers

  • Have a look at the following registry location (note that you need to invoke regedit.exe with administrative privileges in order to make any changes in this location) and ensure that the value ClearPageFileAtShutdown is set to 0 (if it is set to 1, change the value to 0).

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

    • Proposed as answer by Dwarf63 Tuesday, June 28, 2011 6:05 PM
    • Marked as answer by CindyKF Tuesday, June 28, 2011 7:36 PM
    Tuesday, June 28, 2011 5:59 PM

All replies

  • Please provide more details, and I will help you. You can try reinstalling Windows, but it is best to give me details and there could be better options.
    Remember to mark this as an answer as this will help everybody!
    Tuesday, June 28, 2011 11:38 AM
  • There are really no other details I can provide.  When I choose the shutdown, the computer, it just takes a very long time sitting on the shutting down screen before it actually shuts down.
    Tuesday, June 28, 2011 4:26 PM
  • How to enable verbose startup, shutdown, logon, and logoff status Messages in the Windows Server 2003 family

    http://support.microsoft.com/kb/325376

    (works in Windows 7 too)

     

    Tuesday, June 28, 2011 5:52 PM
  • Have a look at the following registry location (note that you need to invoke regedit.exe with administrative privileges in order to make any changes in this location) and ensure that the value ClearPageFileAtShutdown is set to 0 (if it is set to 1, change the value to 0).

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

    • Proposed as answer by Dwarf63 Tuesday, June 28, 2011 6:05 PM
    • Marked as answer by CindyKF Tuesday, June 28, 2011 7:36 PM
    Tuesday, June 28, 2011 5:59 PM
  • Thank you Dwarf63.

     

    Your solution solved my problem immediately.  The laptop shutdown perfectly until I went to Service Pack 1.  It must have changed that setting.  It was taking about 10 - 15 minutes to shutdown, now bang.  I had searched this problem many times and nothing worked.

     

    Good troubleshooting.

     

    David

    Saturday, July 16, 2011 2:41 PM
  • Thank you Dwarf63.

     

    Your solution solved my problem immediately.  The laptop shutdown perfectly until I went to Service Pack 1.  It must have changed that setting.  It was taking about 10 - 15 minutes to shutdown, now bang.  I had searched this problem many times and nothing worked.

     

    Good troubleshooting.

     

    David

    I am having the same problem but when I followed up on this suggestion I found ClearPageFileAtShutdown was already set to 0. I hope someone can suggest an alternative as this is driving me crazy!!
    Sunday, July 31, 2011 11:10 AM
  • Have a look at the following registry location (note that you need to invoke regedit.exe with administrative privileges in order to make any changes in this location) and ensure that the value ClearPageFileAtShutdown is set to 0 (if it is set to 1, change the value to 0).

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

    It worked Great! Thanks for the tip.
    Sunday, November 27, 2011 12:20 AM
  • I can't thank you enough for solving this problem for me.  This really worked for me.  Merry Christmas  Bob 
    Wednesday, December 07, 2011 8:35 PM
  • Have a look at the following registry location (note that you need to invoke regedit.exe with administrative privileges in order to make any changes in this location) and ensure that the value ClearPageFileAtShutdown is set to 0 (if it is set to 1, change the value to 0).

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management


    Worked like a charm for me to.  Hats off.  I wouldnt have thought of that one on my own.
    Tuesday, December 20, 2011 4:44 PM
  • I did exactly as suggested by Dwarf63 and my Laptop with Windows7 professional started shutting down fairly fast. With  a recent windows update the ClearPageFileAtShutdown value reverted back to 1 and the slow shut down recurred. I repeated the previous steps and it worked again, this is very interesting. I learnned something new and I am very thankful to Dwarf63, Hats Off!

    tramarao

    Thursday, December 22, 2011 12:41 AM
  •  
    If a recent windows update set that registry key then this will become
    a huge problem for lots of people.
     
    Are you sure it was an update? If you are on a Domain you might be
    getting that via a Group policy. Try this to be sure:
     
    Verify that the ClearPageFileAtShutdown is set to 0.
     
    At a command prompt, type "GPUPDATE /FORCE"
     
    Refresh registry and see if the setting is still 0. If it is now 1
    then you are getting this via GPO.
     
    HTH
     
    tramarao wrote:
     
    >
    >
    >I did exactly as suggested by Dwarf63 and my Laptop with Windows7 professional started shutting down fairly fast. With a recent windows update the ClearPageFileAtShutdown value reverted back to 1 and the slow shut down recurred. I repeated the previous steps and it worked again, this is very interesting. I learnned something new and I am very thankful to Dwarf63, Hats Off!
    >
    >tramarao
     

    Ha®®y
    Thursday, December 22, 2011 2:48 PM
  • I did exactly as suggested by Dwarf63 and my Laptop with Windows7 professional started shutting down fairly fast. With  a recent windows update the ClearPageFileAtShutdown value reverted back to 1 and the slow shut down recurred. I repeated the previous steps and it worked again, this is very interesting. I learnned something new and I am very thankful to Dwarf63, Hats Off!

    tramarao

    Hmmm, I like the idea of the page file clearing during every reboot.  That is good security in case there is malware that reads the pagefile.  Perhaps you have some security software that likes the idea of clearing your pagefile as well.  My reboots take 4 - 5 minutes which is ok if it means being safer.
    Tuesday, January 10, 2012 11:23 PM
  • What if my HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management value is already set to 0 but it still takes 2 to 3 minutes to shutdown my Acer Aspire Laptop with Windows 7 Home Premium SP1?

    Thursday, March 08, 2012 12:40 AM
  • I have a desktop with Win 7 Professional 64 bit and mine started taking Four Minutes and Twenty Six Seconds to shut down. I had done some updates, so I restored to the oldest restore point, which was only three days, but that did not help. I check the registery and the Memory Management was already set to one. I also would love to find an answer to a very vexing problem
    Thursday, March 08, 2012 6:08 PM
  • The value should be set to 0 not 1, but I do believe there is a service pack, if installed, that sets it to 1.
    Thursday, March 08, 2012 6:43 PM
  • Hit the nail on the head. Thanks Dwarf63!
    Thursday, March 15, 2012 1:47 AM
  • Thanks...worked perfectly.
    Wednesday, July 11, 2012 6:36 PM
  • i found a similar question on the web  that i think you may help you fix your shutdown problems: Windows Slow Shutdown.

    - I hope this helps :)

    Tuesday, October 09, 2012 2:17 AM
  • Top marks to Dwarf63..this had been bugging me for a long time!
    Saturday, October 27, 2012 11:42 AM
  • Terrific. It is the answer I've been looking for. Thank You !!
    Friday, November 09, 2012 9:37 PM
  • Please provide more details, and I will help you. You can try reinstalling Windows, but it is best to give me details and there could be better options.
    Remember to mark this as an answer as this will help everybody!
    Reinstal is your only option at this point? Lame. Save your answers for ones where you actually have a fix in mind.

    Raub

    Sunday, June 09, 2013 1:52 PM
  • Nice response, Dwarf63. 

    I remember this entry from when there was actually a check-box in prior Windows versions (before XP) that allowed you to change it from the Control Panel. Clearing the page file is really only good for a little added security. Good job.


    Raub

    Sunday, June 09, 2013 2:02 PM
  • "Remember to mark this as an answer as this will help everybody!"? With your "answer"? Give us a break. If you can't be part of the solution, at least don't be part of the problem.
    Thursday, June 27, 2013 12:15 PM
  • Thank you for a precise piece of  advice - it worked fine with at least my Windows 7 machine.

    Tuesday, July 09, 2013 1:23 PM
  • Worked perfectly. Thank you Dwarf63.

    Can you also let us know what are the implications of resetting this registry key.

    -manju

    Tuesday, July 23, 2013 6:52 AM
  • Thanks, you fixed it!
    Friday, July 26, 2013 11:44 PM
  • I envy those of you whose computers take all of two or three or four minutes to shutdown. Mine takes around 45 minutes to shut down! Often, I can't stand it any more and I just hit the power button to force it to reboot (which it then does normally). When I restart, I get the usual message about things being open., but whether I cancel the restart, close everything, and then restart again or chose force shutdown makes no difference. The "Windows is Shutting Down" message and spinning wheel will stay there forever--30 minutes, 45 minutes--I'm not exaggerating.

    This has been going on for a long time. Once before I tried to fix this and I followed the advice given above to change the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management value to 0. I just checked it, and it's still set at 0.

    I'd really appreciate any help. (I've got Windows 7 64 bit on an HP Pavilion dv7 laptop)

      
    Tuesday, August 06, 2013 8:07 AM
  • POSSIBLE SOLUTION - for some. Are you that some ?

    OS: Window 7 - 64

    Problem: Extremely long shutdown.

    Had this problem too long. Tried all the above posts and others without success. For reasons other than long shutdown I decided to install alternative security. This required uninstalling PANDA CLOUD ANTIVIRUS. The new product was not suitable and was uninstalled. However, while testing the new product I noticed that the computer shut down immediately. Tried another AV which is presently installed on the computer. Here's the upside. The computer continued to shut down immediately.

    After a week of immediate shutdowns hit the same old problem. The waiting gamer had returned ! Rebooted the computer to check if it was a one-off, but no, the slow shutdown was back. Then remembered that  had I had been online researching Future Derivatives (financial trading instruments). Ran an Adware-Spyware Cleaner which solved the problem - back to immediate shutdowns. With the original AV I had run the same Adware-Spyware Cleaner many time but it had not resulted in a faster shutdown. The computer continues to shutdown immediately and I definitely have a snappier PC. 

    The internet is now so full of junk that even the most mundane surfing requires a virtual environment.

    The above chance discovery has saved me time and labor and avoided a serious technical quest for solution.. If the preceding posts and registry hack do not bring relief, a removal of the present AV followed by a thorough Adware-Spyware clean up may do the trick. It could be any AV and any program. If that fails it may be time to get seriously technical. Have fun !











    • Edited by Atomictop Saturday, August 24, 2013 9:23 PM
    Friday, August 23, 2013 10:27 AM