none
Windows 7 wireless capability turning off every few minutes

    Question

  • I'm on windows 7 (32bit) on a lenovo x301 laptop. I recently noticed that the wireless internet connection keeps shutting off. The hardware switch is set to "on", but for some reason, the connection keeps getting shut off every few minutes. When you run the connection diagnostics utility, it turns the connection back on, but it shuts off again a few minutes later. I've tried installing the latest hardware driver for the wireless card, but that doesn't seem to have helped. Any ideas would be greatly appreciated.

    Thanks, Art

    Tuesday, June 22, 2010 3:02 AM

Answers

  • Please download the wireless LAN driver for Windows 7 from the following website.

    Lenovo Support & downloads - Drivers and software - ThinkPad X301 

    Important Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

    After downloading, please remove the existed driver from Device Manager and Control Panel\All Control Panel Items\Programs and Features. Then, install the downloaded driver.


    Arthur Xie - MSFT
    Wednesday, June 23, 2010 2:37 AM

All replies

  • Check your Power Options to see when the wireless device is being turned off.  Set it to Never if you want it to stay on always.
    Tuesday, June 22, 2010 10:51 AM
  • Please download the wireless LAN driver for Windows 7 from the following website.

    Lenovo Support & downloads - Drivers and software - ThinkPad X301 

    Important Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

    After downloading, please remove the existed driver from Device Manager and Control Panel\All Control Panel Items\Programs and Features. Then, install the downloaded driver.


    Arthur Xie - MSFT
    Wednesday, June 23, 2010 2:37 AM
  • This should solve the problem, if you have a Lenovo ThinkPad T510 on Windows 7 like me.

    1. Click the blue "ThinkVantage" button at the top of your keyboard. This should launch your ThinkVantage Toolbox.
    2. Click the "Network" box in the lower left corner of the toolbox.
    3. Under the "Internet Connection" header, click the "Access Connections" button.
    4. Select the "Tools" tab.
    5. Click the "Global Settings" button.
    6. Uncheck the option for "Allow the wireless LAN radio to be turned off when inactive."
    Friday, January 24, 2014 9:32 PM