none
Cannot Remove Offline Files from Sync Center

    Question

  • I believe I have searched the history of Sync Center issues enough that this is an issue that has not yet been addressed.  If so, please point me to the proper article.  Thanks!

    I was making folders available for offline use in my Win 7 Ultimate edition.  We are in the process of moving to NAS servers (with new network names) and I know syncing with NAS servers is not working correctly right now.

    So I have unchecked all the folders to make then unavailable for offline.  I have also gone to "Manage Offline Files" and tried deleting all offline files for the network drive.  However, there is one Network Drive that I cannot get to delete no matter what I try.  I have tried Deleting Offline Copy for the drive (which it says is successful), but the network drive and a folder hierarchy remain when I view Offline Files.  Also, when I view this folder path in Windows Explorer, it gives a status of "Offline Availability: Available".  I find this odd since the Make Available Offline box is not set for any of the files or folders in this path.  Also, this message seems odd to me since the only valid messages I have found for this status are "Always Available" or "Not Available".

    I have also tried making all of these files and folders available offline again and removed and deleted, but I still have the same problem.  I have also tried the registry key to reset the cache for offline files and that did not work either.

    Please help me get rid of this because it is driving me nuts!

    Thanks.
    Tuesday, January 05, 2010 8:42 PM

Answers

  • Had the same problem few months back . In the end had to reinitialize the offline files cache all together:

    1. Open up registry editor (WARNING: Only for Advanced Users)
    2. Browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Csc
    3. Add a new key (folder) called Parameters
    4. Under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Csc\Parameters, add a new DWORD called FormatDatabase and set its value to 1

    You will need to reboot the PC afterwards.

    • Marked as answer by Novak Wu Monday, January 11, 2010 2:53 AM
    Friday, January 08, 2010 3:03 PM

All replies

  •  

    Hi,

     

    Please refer to the following article to disable Offline Files

     

    How to Properly Disable Offline Files in Windows Vista

     

    Thanks,

    Novak

     

    • Proposed as answer by Rajithag Friday, October 08, 2010 4:24 PM
    Thursday, January 07, 2010 7:23 AM
  • I have noticed the same problem and also have not been able to resolve.  The issue is not disabling offline file sync in general but rather rather removing file sync for an individual network file folder once it has been selected for offline sync.
    Thursday, January 07, 2010 2:49 PM
  • Had the same problem few months back . In the end had to reinitialize the offline files cache all together:

    1. Open up registry editor (WARNING: Only for Advanced Users)
    2. Browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Csc
    3. Add a new key (folder) called Parameters
    4. Under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Csc\Parameters, add a new DWORD called FormatDatabase and set its value to 1

    You will need to reboot the PC afterwards.

    • Marked as answer by Novak Wu Monday, January 11, 2010 2:53 AM
    Friday, January 08, 2010 3:03 PM
  • Thanks for this, it resolved my problem!  I had tried the other method of using the command line to add a registry setting to reset the database, but that did not work.  I just tried this method of using REGEDIT and the above steps and it resolved my problem!  Thanks again!
    Thursday, January 14, 2010 9:27 PM
  • I also was unable to get a offline sync to go away, it would 'delete' then resync them back every chance it got.

    the regedit method bricked my machine
    you didn't mention to use a 32bit or 64bit dword, I used the 64bit.  Never booted again = BSOD

    reinstalling the os now
    Sunday, January 24, 2010 6:48 PM
  • I used the method on Windows 7 64 bit, DWORD not QWORD and my laptop survived.

    The problem I have is that, occasionally, Microsoft Access 2007 databases get screwed. The version on my Windows 7 64 bit desktop (no Synchronisation) and my Windows 2008 SP2 server remain perfect but the version on my laptop (also Windows 7 64 bit and probably at the same KB level as my desktop) suddenly claims to be zero bytes.

    At least I can follow the above steps to fix the issue

    Tuesday, February 23, 2010 8:40 PM
  • You must create this as a 32-bit DWORD, not 64-bit. I learned this the hard way as well.

    If you create the 64-bit DWORD, you will get a BSoD when you reboot - Win7 x64 will then take you to the system recovery wizard (or whatever it's called), and it'll spend 15 minutes churning before telling you it couldn't find anything wrong. If you reboot, you'll end up in a BSoD reboot cycle - just enter safe mode by hitting F5 or F8 (I just it them alternately when booting b/c I can never remember which it is). Then you can open regedit and delete the 64-bit key and add the 32-bit key, do a reboot and it'll work.

    Good luck. Cheers

    Thursday, April 08, 2010 6:59 PM
  • Will Windows see this DWORD value only once? Is it necessary to remove this DWORD after a reboot? I don't want it to keep clearing the database, obviously.
    Wednesday, May 19, 2010 2:18 PM
  • The value is deleted after the reboot so you don't have to worry about it resetting all the time.
    Wednesday, May 19, 2010 7:13 PM
  • Hello, I have a problem with offline files in windows vista business. It doesn't delete the files when I go through "view your offline files" in 'offline files' in the control panel and select "delete online copy".

    Can you tell me how to remove them?

    Friday, October 08, 2010 4:32 PM
    1. Hi, Ive got the same problem with one of our users. When im in the registry, i have browsed to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Csc and i already have a folder called properties in there. Am i to delete that, or use it and insert a new DWORD called FormatDatabase and set its value to 1?? There are other DWORD's in there already.
    Thursday, November 04, 2010 10:08 AM
  • Thank you very much.

    I had the problem of not being able to delete sync files and followed your instructions, which solved the problem.

    Best Regards

     

    Mark

    • Proposed as answer by Datawired Monday, October 29, 2012 1:14 PM
    Wednesday, March 23, 2011 9:32 PM
  • Worked like a charm, thanks.

    And here's a little bit of old school computer science knowledge for the forum...

    A Double Word (DWORD) is a piece of binary data that is 32 bits in length.

    A Quad Word (QWORD) is a piece of binary data that is 64 bits in length.  (And 8 bits is a byte, 16 bits is a word.)

    So there isn't really any such thing as a 64 bit DWORD.  Something which I think is actually reflected correctly in the regedit interface.  You just need to look carefully.

    Friday, August 12, 2011 3:18 AM
  • @BradyBunch said: "i already have a folder called properties in there"

    ...I think you meant to say "Parameters" correct?  If so, I too have a Parameters folder with values already in it.  For the record, the values in mine are "OnlineCachingLatencyThreshold" and "PeerCachingLatencyThreshold".  Since they are already there, do not delete them or the folder.  I just put the DWORD "FormatDatabase" into this existing Parameters folder (with a value of 1) and after rebooting my problem went away.  NOTE, as Kacenka states above, the "FormateDatabase" value disappears after the reboot, but in my case the folder is still there and so are the two previously mentioned values!

    HTH,

    Futile

    Wednesday, September 14, 2011 3:17 PM
  • Worked like a charm, thanks.

    And here's a little bit of old school computer science knowledge for the forum...

    A Double Word (DWORD) is a piece of binary data that is 32 bits in length.

    A Quad Word (QWORD) is a piece of binary data that is 64 bits in length.  (And 8 bits is a byte, 16 bits is a word.)

    So there isn't really any such thing as a 64 bit DWORD.  Something which I think is actually reflected correctly in the regedit interface.  You just need to look carefully.


    ...and based on a few posts above you MUST USE DWORD and do NOT use QWORD.  I had success on my 64bit system by using ONLY DWORD...hope everyone else does too!

    HTH,

    Futile

    P.S.  Thanks for posting this info.  As a new user to 64bit Windows I found myself wondering what D and Q meant...you've shed the light.  :)

    Wednesday, September 14, 2011 3:43 PM
  • This worked for me!  

    1. Open up registry editor (WARNING: Only for Advanced Users)
    2. Browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Csc
    3. Add a new key (folder) called Parameters
    4. Under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Csc\Parameters, add a new DWORD 32 called FormatDatabase and set its value to 1

    Parameters key may already be there.  Create the new value there. 

    You will need to reboot the PC afterwards.

     

    • Proposed as answer by CaptnMo Wednesday, April 11, 2012 7:21 PM
    • Unproposed as answer by CaptnMo Wednesday, April 11, 2012 7:22 PM
    Wednesday, October 12, 2011 1:55 PM
  • OMG!!!!THANK YOU SO MUCH!!!!You have no idea how long I've been trying to get rid of those files!I've had those files for about a year or longer & no one could tell me how to get rid of 'em,& plus I know a lot about computers(:/ I'm somewhat of a hacker too,you could say)so you(not you specifically,but people who are not knowledge based with computers)can only imagine how FRUSTRATING it is to not no the answer!I mean I had just short of 50GB eating up space/memory on my computer,just because the other computer was renamed,and placed under a new server & wireless network;so I couldn't re-sync them under the same partnership because the associated computer wasn't/couldn't be found,even though I had changed the computer name back & tweaked both the server & wireless network to match the original proportions or requirements for the partnership!I mean I was even thinking of removing my hard drive & mounting to another computers hard drive(proverbially the partnered computer)to get deep within the system files without causing any structural damage to the motherboard or operating system(kinda like the time I accidentally compressed the boot the boot drive!:'( That was not fun,it took me about a week to repair that thing!)by some sort of computer failure!So I made this new Windows Live account(I forgot my other one)just to say thank you!This really helped!:)
    Friday, April 27, 2012 6:20 PM
  • thanks that worked - much differnt than the way it was done in XP

    Dale Unroe

    Thursday, October 18, 2012 9:31 PM
  • This worked for me!  

    1. Open up registry editor (WARNING: Only for Advanced Users)
    2. Browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Csc
    3. Add a new key (folder) called Parameters
    4. Under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Csc\Parameters, add a new DWORD 32 called FormatDatabase and set its value to 1

    Parameters key may already be there.  Create the new value there. 

    You will need to reboot the PC afterwards.

     This also worked for me thanks so much. Also thank you for pointing out that Parameters key may already be there because mine was.


    Friday, December 14, 2012 10:34 PM
  • That's a ridiculous solution to an obvious problem that was never addressed in the first place.

    A user should never have to go into the registry to do something as simple as removing a folder. How hard is it to add a right-click option that says "Remove from cache" for offline folders?

    I'm baffled!

    Wednesday, January 09, 2013 1:15 PM
  • The OP used the "delete offline copy" option (Sync Center => Manage Offline Files => View Offline Files => choose folder/file and right click , "delete offline copy".) but didn't work.  Probably because the sync db was corrupted, as in my case I couldn't delete a couple user folders that were deleted from domain server resulting in kind of a persistent "ghost" folder on the network.  

    This registry method also worked for me to reset the sync (but also forced me redo any sync settings and re-transfer of files.), but I see what your getting to... a simple "reset and resync" button would be nice.


    Thursday, February 07, 2013 6:42 PM
  • We encountered another cause of a BSOD after setting FormatDatabase (and it was a correct DWORD). On one PC that had been joined to a domain, it was necessary to fish out files from the C:\Windows\CSC folder by resetting file ownership and permissions. As a result of this, only one user account had permissions to this folder (and not SYSTEM for example). In this state, setting FormatDatabase also caused a BSOD.

    The fix was to boot in Safe mode, and reset the permissions on the CSC and all sub-folders and files to match that of other folders in the Windows directory. I think key is to ensure SYSTEM has full rights, since that is what the CSC service runs as. Once that was done, FormatDatabase worked fine, and fixed Offline folders functionality that had stopped working.

    Thursday, August 15, 2013 11:15 AM
  • Years later, this answer is still relevant.  Thank you for the fix!

    If this many people are having the same issue, I have to wonder why this popped up for me 3.75 years later...and had the same fix.  Yes, I'm current on my updates.

    Friday, September 20, 2013 2:50 PM
  • I have an issue on a Win 8 Laptop for where it Syncs Fine but you cannot Manage anything. These registry fixes only result in blue screens. We are at the point where we are just going to reload the Laptop. This is related to a single machine though. It runs under a single domain with the same Policies as all the other Win 8 NB's. We enforce Offline Files via GPO. The user complained that he can access his files when opening them from MS Office or when he views them through Sync Center. But when he was off site all his Offline Files were greyed out. And now it just doesn't work at all. You can Sync a folder but can't get to it.

    I have removed the policy, disabled and restarted the Sync Center. Attempted to clear all offline copies. And none of the forums or MS KB sites have solid support for Win 8.

    All the fixes and methods work fine on my Win 7 notebook, as I test all my resolutions before I implement them. To add to that I can't find a KB where their fixes have been tested on Win 8 yet.

    We are patiently waiting for 8.1 to see if it resolves some of these issues.

    Unless someone has the same issue and a fix for it.

    Monday, September 30, 2013 10:23 AM
  • Thank you for the information, it helped me resolving the same situation.

    Flavio R.

     
    Tuesday, February 11, 2014 4:32 PM
  • thanks a ton. it worked for me!
    Thursday, March 13, 2014 3:19 PM
  • It worked for me too, thanks
    Monday, March 24, 2014 7:32 AM
  • A bit of magic that works a treat!   It removed all the ghost folders and freed about 50gigs on my tablet PC.

    Many thanks and kind regards.

    Jim

    Saturday, April 12, 2014 11:36 PM