none
How to startup Win7 without boot manager menu and without delay?

    Question

  • Hi,

    my dual-boot system changed to a single-boot system. I was able to edit the menu of boot manager to have a single entry only (Tool: EasyBCD). In Startup and Recovery both display options are unchecked (list of OSs is set to 0s, recovery option 30s, both greyed out).

    The System is running on one drive with only one Win7-64bit installed, all previously used drives are removed, all is doing well, except that the boot manager seems to delay the Win7 start-up. Right after BIOS post msgs at top left is a blinking cursor during 12s, then the boot manager menu flashes briefly for 0.5s then the four colored balls appear indicating windows starting. I'd rather have no boot manager menu delaying the startup at all.

    How can I get rid of the boot manager menu, so Win7 uses the drive to boot from according to the bios setting without delaying start-up (as it was on a clean install without such delay showing a blinking cursor ?

    Thanks for feedback,

    Hans.


    Dig-IT-all
    Tuesday, April 26, 2011 10:51 AM

Answers

  • Hi,

     

    Have you configured the BIOS settings on boot options?

     

    I suggest you confirm that you have set the disk drive as the first boot option.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by HansLoepfe Monday, May 02, 2011 3:58 PM
    Monday, May 02, 2011 9:37 AM
    Moderator

All replies

  • See if you find what you need using BCDedit (http://technet.microsoft.com/en-us/library/cc709667(WS.10).aspx)
    Tuesday, April 26, 2011 11:36 AM
  • Hi snahl,

    You may consider editing the boot menu with EasyBCD by NeoSmart Technologies should solve your problem, it provides a graphical front end to the BCDEdit Command line that makes it easy for you to define start-up settings and edit boot entries on the new Windows manager.

    http://neosmart.net/dl.php?id=1

    Hope it helps.


    Thanks and Regards
    Scorpio_Milo
    MCTS: Windows Vista | Exchange Server 2007
    MCITP: Enterprise Support Technician
    MCITP: Server & Enterprise Administrator
    Microsoft Infrastructure Consultant
    Enterprise Service: Solution Architect
    Microsoft Storage Team - File Cabinet Blog
    My Blog
    Tuesday, April 26, 2011 12:49 PM
  • Hi,

    Whenever I have removed linux boot options from my systems I used to use the fixboot and fixmbr commands in the XP boot disk. The Windows 7 boot disk does not have these but I have recently ran the startup repair a couple of times to bring my system startup back to its original condition.You can get to the startup repair by booting from your original installation media. There is a FAQ about startup repair here.

    Hope this helps.

    Cathal


    Cathal O'Brien BSc, PgDip, PhD . Techsmart | Laptop Repair | Computer Repair
    Tuesday, April 26, 2011 9:56 PM
  • thanks, unfortunately I did not find the solution with BCDedit.

    That does not mean that the solution is not there, it means that I just do not know the cause of the delay my setup is experiencing.

     


    Dig-IT-all
    Wednesday, April 27, 2011 12:22 AM
  • EasyBCD was the tool I used to get rid of the unused entries.

    I assume it must be the remaining properly functioning entry of the current one and only Windows Boot Loader.


    Dig-IT-all
    Wednesday, April 27, 2011 12:25 AM
  • Windows7 does have the fixboot and fixmbr functions.

    For example, boot form source install media (Win7 CD) and go to the command prompt.

    X:\source> bootsect.exe /nt60 C: /force
    X:\source> bootrec /fixmbr
    X:\source> bootrec /fixboot
    X:\source> bootrec /rebuildbcd
    X:\source> exit

    I did that but without change to get rid of the delay described in my initial msg (the system boots and runs well).


    Dig-IT-all
    Wednesday, April 27, 2011 12:42 AM
  • Hi,

     

    If you just want to get rid of the boot manager menu, try the following command:

     

    bcdedit /timeout 0

     

    Hope it helps.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, April 28, 2011 10:07 AM
    Moderator
  • Hi all,

    thanks for the many answers, sorry to say, but I haven't gotten that right answer yet.

    Let me recap:

    During a system cold-start, there are BIOS post messages BEFORE Win7 starts.

    Normally after a clean install (on a bare disk, without any other Win7 installations on other disks in the system), Win7 start immediately after BIOS post messages without delay.

    In this case there is a 12-15 sec delay between BIOS post messages and Win7 beginning to start.

    During tat delay there is only a blinking cursor.

    After the 12-15 secs delay, the boot manager flashes briefly (because the timeout is set to 0) and Win7 starts up properly.

    I wonder how to get rid of that delay?

    I wonder what causes the delay (presumably something in the BIOS, even though I also tried a reset to default values. No change)

    Any ideas suggestions?

    Thanks.


    Dig-IT-all
    Friday, April 29, 2011 1:27 PM
  • Hi,

     

    Have you configured the BIOS settings on boot options?

     

    I suggest you confirm that you have set the disk drive as the first boot option.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by HansLoepfe Monday, May 02, 2011 3:58 PM
    Monday, May 02, 2011 9:37 AM
    Moderator
  • If the delay had to do with Windows' boot options then you should have seen a countdown for the number of seconds left. As you only see the cursor then my guess is this is not due to a Windows configuration.

    Have you tried to boot on a Windows 7 media and run startup repair?

    Monday, May 02, 2011 11:48 AM
  • If the delay had to do with Windows' boot options then you should have seen a countdown for the number of seconds left. As you only see the cursor then my guess is this is not due to a Windows configuration.

    Have you tried to boot on a Windows 7 media and run startup repair?

    Countdown - was set to 0 already.

    BIOS - correct. I also assumed so.

     (presumably something in the BIOS)


    Dig-IT-all
    Monday, May 02, 2011 3:58 PM
  • The DVD/CD-ROM was set as first boot option.

    After selecting the boot-disk as first boot option the delay (induced by the DVD/CD-Rom) was no longer effective.

    Thanks Alex.


    Dig-IT-all
    Monday, May 02, 2011 4:00 PM
  • 1. Click Start Button

    2. Right Click Computer

    3. Click Properties

    4. Click Advance Tab

    5. Under Startup and Recovery.. Click Settings

    6. Startup and Recovery windows will popup.. then Uncheck "Time to display list of operating systems:"  then Click OK

    7. Restart the computer

    Tuesday, January 08, 2013 5:40 AM