none
Can't Eliminate the "Install Windows" Dialogs

    Question

  • I'm trying to set up an unattended installation of Windows 7 SP1 (x86) and I used the Windows System Image Manager to create my Sysrep answer file. My problem is that Windows Setup still prompts for user response on a few items.

    More specifics: Prompt for Language, Time & Currency Format and Keyboard/Input Method even though I specifed en-US for all 5 items in Windows-International-Core (oobeSystem pass). Prompt to select the OS to install even though Windows 7 is the only selection available in the list. Prompt to accept the EULA even though HideEULAPage is set to True in Windows-Shell-Setup > OOBE (oobeSystem pass). Prompt for Windows installation location (didn't find an answer file setting to hide that one).

    I also tried setting SkipMachineOOBE and SkipUserOOBE to True even though WIM says those settings are deprecated. I reverted those changes and tried the installation again, same problem.

     

    Wednesday, January 25, 2012 7:42 PM

Answers

  • Problem solved. I had to add this code. I don't understand why it has to be there but it works.

    <settings pass="windowsPE">
        <component xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
          <UILanguage>en-US</UILanguage>
        </component>
        <component xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
          <ImageInstall>
            <OSImage>
              <InstallToAvailablePartition>true</InstallToAvailablePartition>
            </OSImage>
          </ImageInstall>
          <UserData>
            <AcceptEula>true</AcceptEula>
          </UserData>
        </component>
      </settings>
    

     


    • Edited by TT-ICCSD Friday, January 27, 2012 8:33 PM
    • Marked as answer by TT-ICCSD Friday, January 27, 2012 8:33 PM
    Friday, January 27, 2012 5:20 PM

All replies

  • Post your Unattend.xml answer file here for me to examine. In order to skip past the OOBE phase, you need to assign the computer account you want to log into. You will also need to use the AUTOLOGON component in order to make the Unattended installation deploy correctly. 

     


    _JoeG
    Dell - Systems Integration Consultant
    Twitter: @8bits1byte 

    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, January 26, 2012 12:01 AM
  • Thanks for your help. Here's the unattend.xml file:

    <?xml version="1.0" encoding="utf-8"?>

    <unattend xmlns="urn:schemas-microsoft-com:unattend">

      <settings pass="specialize">

        <component xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" name="Microsoft-Windows-ErrorReportingCore" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">

          <DisableWER>1</DisableWER>

        </component>

        <component xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">

          <DisableFirstRunWizard>true</DisableFirstRunWizard>

          <Home_Page>http://www.***************************>

          <ShowMenuBar>true</ShowMenuBar>

        </component>

        <component xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">

          <ComputerName>*</ComputerName>

          <CopyProfile>true</CopyProfile>

          <RegisteredOrganization>Test</RegisteredOrganization>

          <RegisteredOwner>Test</RegisteredOwner>

          <ShowWindowsLive>false</ShowWindowsLive>

          <TimeZone>Central Standard Time</TimeZone>

        </component>

        <component xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">

          <RunSynchronous>

            <RunSynchronousCommand wcm:action="add">

              <Order>1</Order>

              <Path>net user administrator /active:yes</Path>

            </RunSynchronousCommand>

          </RunSynchronous>

        </component>

        <component xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" name="Microsoft-Windows-UnattendedJoin" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">

          <Identification>

            <Credentials>

              <Domain>*********</Domain>

              <Password>********</Password>

              <Username>*******</Username>

            </Credentials>

            <JoinDomain>****************</JoinDomain>

          </Identification>

        </component>

      </settings>

      <settings pass="oobeSystem">

        <component xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">

          <AutoLogon>

            <Password>

              <Value>NABUAGUAYwBoAHMAMgB1AHMAZQBQAGEAcwBzAHcAbwByAGQA</Value>

              <PlainText>false</PlainText>

            </Password>

            <Enabled>true</Enabled>

            <LogonCount>1</LogonCount>

            <Username>Acct1</Username>

          </AutoLogon>

          <Display>

            <ColorDepth>32</ColorDepth>

            <HorizontalResolution>1280</HorizontalResolution>

            <RefreshRate>60</RefreshRate>

            <VerticalResolution>1024</VerticalResolution>

          </Display>

          <OOBE>

            <HideEULAPage>true</HideEULAPage>

            <NetworkLocation>Work</NetworkLocation>

            <ProtectYourPC>3</ProtectYourPC>

          </OOBE>

          <UserAccounts>

            <AdministratorPassword>

              <Value>NABUAGUAYwBoAHMAMgB1AHMAZQBBAGQAbQBpAG4AaQBzAHQAcgBhAHQAbwByAFAAYQBzAHMAdwBvAHIAZAA=</Value>

              <PlainText>false</PlainText>

            </AdministratorPassword>

            <LocalAccounts>

              <LocalAccount wcm:action="add">

                <Password>

                  <Value>NABUAGUAYwBoAHMAMgB1AHMAZQBQAGEAcwBzAHcAbwByAGQA</Value>

                  <PlainText>false</PlainText>

                </Password>

                <Name>Acct1</Name>

              </LocalAccount>

              <LocalAccount wcm:action="add">

                <Password>

                  <Value>YwBlAGwAZQByAHkANgBQAGEAcwBzAHcAbwByAGQA</Value>

                  <PlainText>false</PlainText>

                </Password>

                <Name>Acct2</Name>

              </LocalAccount>

            </LocalAccounts>

          </UserAccounts>

          <TimeZone>Central Standard Time</TimeZone>

          <DoNotCleanTaskBar>true</DoNotCleanTaskBar>

          <TaskbarLinks>

            <Link0>%ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs\Microsoft Office\Microsoft Outlook 2010.lnk</Link0>

            <Link1>%ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs\Microsoft Office\Microsoft Word 2010.lnk</Link1>

          </TaskbarLinks>

          <RegisteredOrganization>Test</RegisteredOrganization>

          <RegisteredOwner>Test</RegisteredOwner>

          <ShowWindowsLive>false</ShowWindowsLive>

        </component>

        <component xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">

          <InputLocale>en-US</InputLocale>

          <SystemLocale>en-US</SystemLocale>

          <UILanguage>en-US</UILanguage>

          <UILanguageFallback>en-US</UILanguageFallback>

          <UserLocale>en-US</UserLocale>

        </component>

      </settings>

      <cpi:offlineImage xmlns:cpi="urn:schemas-microsoft-com:cpi" cpi:source="catalog://*****/*****/operating systems/windows 7 enterprise sp1 x86/sources/install_windows 7 enterprise.clg"/>

    </unattend>

     

    Thursday, January 26, 2012 3:44 PM
  • This should work for you... 

    I added the following lines to your unattend.xml answer file:

     <RunSynchronous>
                    <RunSynchronousCommand wcm:action="add">
                        <Order>1</Order>
                        <Path>net user administrator /active:yes</Path>
                    </RunSynchronousCommand>
                </RunSynchronous>
                <RunAsynchronous>
                    <RunAsynchronousCommand wcm:action="add">
                        <Description>Enable ACCT1 Account</Description>
                        <Path>Net user ACCT1 /active:YES</Path>
                        <Order>1</Order>
                    </RunAsynchronousCommand>
                    <RunAsynchronousCommand wcm:action="add">
                        <Description>Enable ACCT2 Account </Description>
                        <Order>2</Order>
                        <Path>net user ACCT2 /active:yes</Path>
                    </RunAsynchronousCommand>
                </RunAsynchronous>
    

     

    Full answer file:

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="specialize">
            <component name="Microsoft-Windows-ErrorReportingCore" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <DisableWER>1</DisableWER>
            </component>
            <component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <DisableFirstRunWizard>true</DisableFirstRunWizard>
                <Home_Page>http://www.***************************</Home_Page>
                <ShowMenuBar>true</ShowMenuBar>
            </component>
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <ComputerName>*</ComputerName>
                <CopyProfile>true</CopyProfile>
                <RegisteredOrganization>Test</RegisteredOrganization>
                <RegisteredOwner>Test</RegisteredOwner>
                <ShowWindowsLive>false</ShowWindowsLive>
                <TimeZone>Central Standard Time</TimeZone>
            </component>
            <component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <RunSynchronous>
                    <RunSynchronousCommand wcm:action="add">
                        <Order>1</Order>
                        <Path>net user administrator /active:yes</Path>
                    </RunSynchronousCommand>
                </RunSynchronous>
                <RunAsynchronous>
                    <RunAsynchronousCommand wcm:action="add">
                        <Description>Enable ACCT1 Account</Description>
                        <Path>Net user ACCT1 /active:YES</Path>
                        <Order>1</Order>
                    </RunAsynchronousCommand>
                    <RunAsynchronousCommand wcm:action="add">
                        <Description>Enable ACCT2 Account </Description>
                        <Order>2</Order>
                        <Path>net user ACCT2 /active:yes</Path>
                    </RunAsynchronousCommand>
                </RunAsynchronous>
            </component>
            <component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <Identification>
                    <Credentials>
                        <Domain>*********</Domain>
                        <Password>********</Password>
                        <Username>*******</Username>
                    </Credentials>
                    <JoinDomain>****************</JoinDomain>
                </Identification>
            </component>
        </settings>
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <AutoLogon>
                    <Password>
                        <Value>NABUAGUAYwBoAHMAMgB1AHMAZQBQAGEAcwBzAHcAbwByAGQA</Value>
                        <PlainText>false</PlainText>
                    </Password>
                    <Enabled>true</Enabled>
                    <LogonCount>1</LogonCount>
                    <Username>Acct1</Username>
                </AutoLogon>
                <Display>
                    <ColorDepth>32</ColorDepth>
                    <HorizontalResolution>1280</HorizontalResolution>
                    <RefreshRate>60</RefreshRate>
                    <VerticalResolution>1024</VerticalResolution>
                </Display>
                <OOBE>
                    <HideEULAPage>true</HideEULAPage>
                    <NetworkLocation>Work</NetworkLocation>
                    <ProtectYourPC>3</ProtectYourPC>
                </OOBE>
                <UserAccounts>
                    <AdministratorPassword>
                        <Value>NABUAGUAYwBoAHMAMgB1AHMAZQBBAGQAbQBpAG4AaQBzAHQAcgBhAHQAbwByAFAAYQBzAHMAdwBvAHIAZAA=</Value>
                        <PlainText>false</PlainText>
                    </AdministratorPassword>
                    <LocalAccounts>
                        <LocalAccount wcm:action="add">
                            <Password>
                                <Value>NABUAGUAYwBoAHMAMgB1AHMAZQBQAGEAcwBzAHcAbwByAGQA</Value>
                                <PlainText>false</PlainText>
                            </Password>
                            <Name>Acct1</Name>
                        </LocalAccount>
                        <LocalAccount wcm:action="add">
                            <Password>
                                <Value>YwBlAGwAZQByAHkANgBQAGEAcwBzAHcAbwByAGQA</Value>
                                <PlainText>false</PlainText>
                            </Password>
                            <Name>Acct2</Name>
                        </LocalAccount>
                    </LocalAccounts>
                </UserAccounts>
                <TimeZone>Central Standard Time</TimeZone>
                <DoNotCleanTaskBar>true</DoNotCleanTaskBar>
                <TaskbarLinks>
                    <Link0>%ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs\Microsoft Office\Microsoft Outlook 2010.lnk</Link0>
                    <Link1>%ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs\Microsoft Office\Microsoft Word 2010.lnk</Link1>
                </TaskbarLinks>
                <RegisteredOrganization>Test</RegisteredOrganization>
                <RegisteredOwner>Test</RegisteredOwner>
                <ShowWindowsLive>false</ShowWindowsLive>
            </component>
            <component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>en-US</InputLocale>
                <SystemLocale>en-US</SystemLocale>
                <UILanguage>en-US</UILanguage>
                <UILanguageFallback>en-US</UILanguageFallback>
                <UserLocale>en-US</UserLocale>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="wim:x:/sources/install.wim#Windows 7 PROFESSIONAL" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>
    
    



    _JoeG
    Dell - Systems Integration Consultant
    Twitter: @8bits1byte 

    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, January 26, 2012 8:27 PM
  • Thanks, Joe.

    Unfortunately, that didn't work. The installation ran without error but all the dialogs still pop up requiring user response.

    These prompts all occur right at the onset of the Windows installation routine, before any actual installation steps begin (even before Windows starts copying the installation files).

    Well, I'll keep looking for a solution. In the article where MS explains that SkipMachineOOBE and SkipUserOOBE have been deprecated they outline a whole series of other values that should be set instead. I double checked that all those were coverd but the user prompts still happen.

     

    Friday, January 27, 2012 3:15 PM
  • Problem solved. I had to add this code. I don't understand why it has to be there but it works.

    <settings pass="windowsPE">
        <component xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
          <UILanguage>en-US</UILanguage>
        </component>
        <component xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
          <ImageInstall>
            <OSImage>
              <InstallToAvailablePartition>true</InstallToAvailablePartition>
            </OSImage>
          </ImageInstall>
          <UserData>
            <AcceptEula>true</AcceptEula>
          </UserData>
        </component>
      </settings>
    

     


    • Edited by TT-ICCSD Friday, January 27, 2012 8:33 PM
    • Marked as answer by TT-ICCSD Friday, January 27, 2012 8:33 PM
    Friday, January 27, 2012 5:20 PM