none
Scheduled Task in Windows 8

    Question

  • I have just upgraded from Windows 7 to Windows 8 and have issues with scheduled tasks. I have the PC set to switch on at 1:50am and then at 2am it is supposed to run a batch file which in turn runs synctoycmd.exe -R. This should run all the folder pairs I have created. The scheduled task is set to run if I am not logged on and I have supplied my user credentials but the task fails every night. The SyncToy log is showing the following error:-

    SyncToy configuration file C:\Users\Default\AppData\Local\Microsoft\SyncToy\2.0\SyncToyDirPairs.bin not found.

    This would imply the task is being run as the "Default" user. If I look in the same folder structure under my user name "Mark" the bin file is there. If I run the task manually when logged in under my own account it works perfectly.

    I have been running this task for a couple years and it has always worked until I upgraded to Windows 8.

    Does anyone have any idea why the task is not running as the correct user?

    Sunday, November 25, 2012 7:36 PM

All replies

  • Hi,

    Seems your application wanna look for the bin file under Default user, which is wrong place for it. You may try to specify your user account which is used for running the task or change the action to specify the start in location. If no go, I think Windows 8 may change its way to run the application when user havenot logged in(I mean the default profile would be always loaded) or the applicaton you are using is not fully compatible with Windows 8.


    Juke Chou
    TechNet Community Support

    Tuesday, November 27, 2012 6:43 AM
  • The task is already set to run as my user "Mark" but seems to ignore this completely and run as "Default User", this same task runs perfectly under Windows 7 if setup exactly the same. This is clearly a Windows 8 issue.
    Sunday, December 02, 2012 3:21 PM
  • Hi,

    Either it is a Windows 8 issue or it is by design, anyway, I record this case.


    Juke Chou
    TechNet Community Support

    Tuesday, December 04, 2012 3:01 AM
  • Can't see why this would be by design as it works perfectly in Windows 7. I have managed to recreate the issue on two other Windows 8 machines so i'm inclined to think this may well be a bug in Windows 8. 

    Wednesday, December 05, 2012 8:01 PM
  • Is there any resolution to this issue? I'm experiencing the same.

    Vern Rabe

    Wednesday, February 13, 2013 11:22 PM
  • We're having the same issue, and its actually hurting our work at the office, since we run batched nightly builds on our products.

    Cheers

    Ulf

    Wednesday, November 13, 2013 12:08 PM
  • I was able to resolve the issue for our problem: Our task runs as a domain user, and it worked after I enabled the check at "Start only if the following network connection is available:" and set the connection to the domain connection.

    I also had the task set to "Run with highest privileges" and "Configure Task  for: Windows 7...", but that did not work, when I used it without setting the network connection, so it *may* not be necessary. But you should try setting these also it if the network does not work for you.

    Not sure why the network connection was problematic, it never was for Windows 7...

    Cheers

    Ulf

    Thursday, November 14, 2013 10:47 AM