none
Epson twain driver in XP Mode

    Question

  • I have a nice Epson 1660 scanner but, the Twain driver is not recognized in Windows XP Mode in Windows 7 OS x^4, and there are no twain drivers available for x64 Windows 7OS.  Is there a run around to this?  I have the drivers for XP OS but this twain driver is not working in XP Mode. Can you help

    Thank you

     

    Tuesday, May 10, 2011 1:08 PM

Answers

  • I am having the same problem.  The Twain driver on the CD that came with my Epson Perfection 1260 Series/1660 Photo scanner will not install on my new computer running Windows 7 Home Premium 64-bit.  There was no problem with my previous computer running Windows XP. Rick Dee, are you telling me there's no fix...that I have to go out and buy another scanner?



    Yes.  That is exactly right.  If Epson does not publish the drivers for your system, Windows 7 64-bit, there is absolutely nothing Microsoft can do about it.  That is the sole responsibility of Epson - it is Epson's decision on whether to publish 64-bit drivers or not.  And 32-bit drivers cannot be used on a 64-bit system.
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Proposed as answer by cwacwa Thursday, May 12, 2011 11:20 AM
    • Marked as answer by Niki HanModerator Monday, May 23, 2011 2:20 AM
    Wednesday, May 11, 2011 11:37 AM

All replies

  • Which TWAIN driver are you trying to install in XP Mode?  You must use the one for Windows XP in the XP Mode VM and not the one for Windows 7.  Does XP Mode recognize the scanner as being connected?

    There is no 64-bit driver at all for this scanner, so the TWAIN driver will not install in Windows 7 x64.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, May 10, 2011 3:05 PM
  • I am having the same problem.  The Twain driver on the CD that came with my Epson Perfection 1260 Series/1660 Photo scanner will not install on my new computer running Windows 7 Home Premium 64-bit.  There was no problem with my previous computer running Windows XP. Rick Dee, are you telling me there's no fix...that I have to go out and buy another scanner?


    Tuesday, May 10, 2011 9:40 PM
  • I am having the same problem.  The Twain driver on the CD that came with my Epson Perfection 1260 Series/1660 Photo scanner will not install on my new computer running Windows 7 Home Premium 64-bit.  There was no problem with my previous computer running Windows XP. Rick Dee, are you telling me there's no fix...that I have to go out and buy another scanner?



    Yes.  That is exactly right.  If Epson does not publish the drivers for your system, Windows 7 64-bit, there is absolutely nothing Microsoft can do about it.  That is the sole responsibility of Epson - it is Epson's decision on whether to publish 64-bit drivers or not.  And 32-bit drivers cannot be used on a 64-bit system.
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Proposed as answer by cwacwa Thursday, May 12, 2011 11:20 AM
    • Marked as answer by Niki HanModerator Monday, May 23, 2011 2:20 AM
    Wednesday, May 11, 2011 11:37 AM
  • Thanks very much, Mark.  Guess I'll go shopping.

    CWACWA

    Thursday, May 12, 2011 11:24 AM
  • OK, not sure if the solution to the problem was completely exhausted...mainly, in theory, if the correct 32 bit XP driver is installed on the Virtual PC in XP mode, the scanner should be recognized, right? Well what if the procedure has been followed (as in my case, running XP mode on Windows 7 Ultimate) and after several failed attempts, the Epson 1660 "Perfection" is still perfectly collecting dust on my desk? It is frustrating. I've taken the time to basically install a separate OS and I am still without a scanner! Should I run the setup as 'Administrator'? If so, I don't have the password. DUHR !!!!!!!!!!!!!!!!!!

    * addendum: i have tried installing the driver in XP Mode, AND tried installing the driver in the regular Windows 7 OS using 'compatibility mode' set for XP Service Pack 3 -- no luck!

    Wednesday, February 15, 2012 5:58 PM
  • BobCausedThis wrote:

    OK, not sure if the solution to the problem was completely exhausted...mainly, in theory, if the correct 32 bit XP driver is installed on the Virtual PC in XP mode, the scanner should be recognized, right? Well what if the procedure has been followed (as in my case, running XP mode on Windows 7 Ultimate) and after several failed attempts, the Epson 1660 "Perfection" is still perfectly collecting dust on my desk? It is frustrating. I've taken the time to basically install a separate OS and I am still without a scanner! Should I run the setup as 'Administrator'? If so, I don't have the password. DUHR !!!!!!!!!!!!!!!!!!

    You must install the drivers in the XP Mode.  They will not be of any use in Windows 7.

    You must have the Integration Features enabled.

    You must ensure the scanner is listed as Attached under the USB tab.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Wednesday, February 15, 2012 6:20 PM
  • >>>>>You MUST ensure the scanner is listed as Attached under the USB tab.<<<

    ...something of which i was obviously and grossly unaware.

    PURE GENIUS!

    Thank you for taking the time and effort to solve my problem!

    Scanner works "PERFECTLY' now.

    • Proposed as answer by BobCausedThis Wednesday, February 15, 2012 6:28 PM
    Wednesday, February 15, 2012 6:27 PM