none
"you don't have permission to save in this location. contact the administrator to obtain permission.”

    Question

  • I have been getting this error:  "you don't have permission to save in this location. contact the administrator to obtain permission.”

    I have partitioned my drive and cannot download images or save files to any of my drives.  I can open the files, but cannot save changes (any type of file, from Word to Illustrator).

     


    Specs:

    Windows 7, 64bit, new Dell

    Transferred - I transferred my files from a Vista machine, via W7's transfer tool.


    Admin - I am logged in as the Admin, but that doesn't matter (it appears).  

     

    Permissions/Security - if I change the permissions EVERYONE>Edit>Allow it will let me save files to this partition

     

    QUESTIONs: 

    Does this pose a security risk?  

    Why is this problem there - I have used Windows for 15 years and never had this type of error...?

     

     

    Thanks

    Tuesday, October 05, 2010 11:18 PM

All replies

  • Usually you get this prompt  if you are trying to save in system folders such as c:\windows or c:\windows\system32 or any folder with the +S attrib.

    go to the command prompt in an elevated level and type in

    attrib -s -r -a -h FolderName

    and press enter

    Then try to save again.


    CESabarre Free Tech Support
    Bad News: There really is no such thing as Free Tech Support.
    Good News: Oftentimes a simple thank you is the best form of payment!
    Wednesday, October 06, 2010 5:04 AM
  • Thanks for the reply.

     

     

    This is for ALL of my partitions and ALL of my folders (about 750gbs).

     

    How do I fix this for my computer?  

    Wednesday, October 06, 2010 10:19 PM
  • Hi - and thanks.  I've tried the attrib route and it helpfulyl tells me that Access is denied.

    For me I am just trying to save a Personal Workbook with all my macros into the correct directory to (XLSTART) on a new pc.

    It appears from a quick surf I'm not alone in thinking this change is a bit beyond...

    Wednesday, October 06, 2010 10:47 PM
  • Running Win7x64.

    Just wanted to piggy-back onto this thread with the same issue. I have an app that wants to save a *log.txt file in C:\Windows\Desktop (no options to change this default). Of course, there is no C:\Windows\Desktop\ directory so I created one. When I create and attempt to save the *log.txt file in my creation I get this infamous message as well. Given that I am logged on as THE administrator, it is, indeed, frustrating that no matter what I have tried, I am able to create the directory but cannot save my file to the directory. I find as JimmyBoy99, above, that a quick Google reveals this to be a ubiquitous issue.

    Also, similar to Design7712, above, on a large capacity HDD, I created three primary partitions and three logical drives on an extended partition. No matter what I do, I am denied access to one of the logical drives - even though I created all of the partition/drives at the same time following the same process. Why I can access the other partitions/logical drives but not the one is baffling.

     

     

    Thursday, October 07, 2010 12:05 AM
  • Hi,

     

    This problem could be caused by user permission confusion issue. Please check every drive’s security setting (except system drive), right click the disk – properties – security tab.

     

    Is the owner current Administrator? If not, please take owner of the disk.

     

    If there’s any abnormal user can be  found in the security tab, please post a screenshot for this.

     

    Hope it works.

    Regards,

    Miya


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, October 07, 2010 7:44 AM
  • This is a Windows 7 issue - I did not change anything on my end, it stated that way for ALL of my partitions.

     

    I cannot change the permissions to Admin, it just changes it back to EVERYONE.  I am logged in as the Admin.  It lets me select Admin, but just resets when you open it back up.

     

    This is the only solution I can find, but I do not know what the security risks are:

    Permissions/Security - if I change the permissions EVERYONE>Edit>Allow it will let me save files to this partition

     

    QUESTIONs: 

    Does this pose a security risk?  

    Why is this problem there - I have used Windows for 15 years and never had this type of error...?

     

     

    As others have noted, this seems to be a problem with Windows 7.  

     

    What should I do?

     

     

    Thanks

    Thursday, October 07, 2010 9:46 PM
  • No one?  I have to say, so far W7 is looking identical to Vista (and, sadly, is no faster even with a new computer, 8gigs of ram).

     

    Any suggestions??

     

    Thanks

    Monday, October 11, 2010 8:05 PM
  • Create a new user account, and try everything from that user account. make sure its an administrator. If everything is working, then all you have to do is change a user profile for your initial account. In addition try msconfig and remove all the start up applications.

     

    You could try safe-mode see how it goes for you.

    You can try to burn your recovery DVDs because you would eventually have to reformat if no trick will work.

    Try rootkit revealer from sysinternals, to see if your kernel is hooked by any bug.

    Try notepad to see if it can save normally. if it can then you can reinstall the faulty applications.


    Please do not forget to select the best answer if it helps you! The Ultimate computer newbie guide since the discovery of spoon feeding!
    Tuesday, October 12, 2010 12:41 PM
  • This is what I have for one of my partitions:

    CREATOR OWNER (all permissions are blank)

    SYSTEM (ALLOW for all)

    MyName-2 (this is the new user I made with Admin permissions - ALLOW for all)

    Admin (ALLOW for all)

    Users (Read& execute, List folder contents, Read)

     

    [I deleted the USER called EVERYONE, which I had set to ALLOW for all permissions and what letting me save files]

     

    I cannot change the user for the partition, I select one of the others, such as MyName-2, hit APPLY/OK, but it just goes back to the one at the top of the list (CREATOR OWNER on this partition, it is EVERYONE on the other partitions)

     

    Any suggestions?  This is not program specific (Excel, Word, Outlook, Illustrator, Photoshop, etc.), none can save if I don't change the permissions on the TOP most listed user.

     

     

    I deleted the other USERS, this is what is left:

     

    Admin

    Users

     

    Still no go.  I re-added EVERYONE with ALLOW for all and I can save to the partition again.

     

    Help!!  This is where all of my client work is at!!  W7 is really killing me with this!

     

    Thanks

     

     

    (this is a brand new computer, barely a week or so old, all programs and antivirus, etc., are current

     

    Did this happen because I used the W7 file transfer from my old/Vista computer?)

     

    Wednesday, October 13, 2010 5:24 AM
  • Did the computer have any problems before you transferred the files? I am not sure what you can do next.

    Im not sure if you tried to create an account and see if when you login to that account you have the same problems.

     

     

    Is it working now or not?

     


    Please do not forget to select the best answer if it helps you! The Ultimate computer newbie guide since the discovery of spoon feeding!
    Wednesday, October 13, 2010 3:26 PM
  • This was a brand new computer so I:

    1. Installed all my programs (Adobe CS4, Office, Misc. smaller programs I have been using (on Vista) for years)

    2. Transferred my files via Windows7 transfer (and Belkin's cable)

     

    All partitions were unable to save.  I could open, run programs, etc., but could not save.

     

    My solution (which I fear is not secure):

     

    EVERYONE > ALLOW for all permissions, for each partition

     

    This has allowed me to work as normal.

     

    Should I be concerned about my security?  I am the only one using this computer.

     

     

     

    Thanks for your help, it is much appreciated

    Thursday, October 14, 2010 4:47 AM
  • If you're the only person using that computer you shouldn't be worried about the security (unless you go to suspicious websites). Perhaps you should just give permission for your account to full control for the drives themselves.The see if you remove the everyone permission if you run in the same problem.

     

     

    Also my question was, if the saving problem started before or after you made the transfer of the files: "Transferred my files via Windows7 transfer (and Belkin's cable)"?

    Good Luck.


    Please do not forget to select the best answer if it helps you! The Ultimate computer newbie guide since the discovery of spoon feeding!
    Thursday, October 14, 2010 6:05 PM
  • Answer:  I didn't use this computer before transferring the files, it was brand new (nothing installed, no files - I installed Windows 7 upgrade from Vista, partitioned the drives, installed my software, transferred my files).

     

    EVERYONE - if I remove this USER, I can't save anything (even though I give ALLOW to the remaining USERS, it just keeps changing them back)

     

     

     

    I'll just keep my fingers crossed.  I am careful about visiting "questionable" sites, but you never know these days (type in a wrong letter in an url and you can get some crazy stuff!).

     

     

    Thanks again for your help

    Thursday, October 14, 2010 11:18 PM
  • I have the same problem.

     

    Win7 64 Bit.  Have been using this OS for around a year now with no problems.  My own account is an admin account.  In the past week all of a sudden I am required to provide admin permissions if I want to do anything on either the Desktop or Downloads folders (move, copy, etc).  I also can't save any files to those folders.  If I open a Word doc in either folder it will open in Read Only mode and won't let me save there.  If I right-click and run-as Administrator (e.g. Firefox) then I CAN save files to the Desktop and Downloads folders.  I have removed admin permissions from this account and re-enabled them, but that has not fixed it.  All folder Owners are set to the Admins group so there is no issue there.

    This problem is isolated to this profile only.  I have logged in under another profile with admin permissions and have no issues, also have created a new admin user and have no issues with that.  I'm reluctant to "move" to another profile as it takes ages to rebuild all settings and I also have a Windows Home Server accounts associated with this one that will cause problems with new account profile on this PC syncing with old account profile on WHS.

    On the WHS it's also worth noting that when I log in my WHS Connector tells me the passwords my my PC account and WHS account are different.  They are not.  To fix the issue I have changed both to ensure they are in sync, however I still get the same issue.

    Any ideas?

    Thursday, December 09, 2010 7:29 AM
  • Usually you get this prompt  if you are trying to save in system folders such as c:\windows or c:\windows\system32 or any folder with the +S attrib.

    go to the command prompt in an elevated level and type in

    attrib -s -r -a -h FolderName

    and press enter

    Then try to save again.


    CESabarre Free Tech Support
    Bad News: There really is no such thing as Free Tech Support.
    Good News: Oftentimes a simple thank you is the best form of payment!
    Thanks for the suggestion.  I tried this and unfortunately it didn't work for my issue. :(
    Thursday, December 09, 2010 7:36 AM
  • I figured out the solution to this problem in Windows 7. I assume this will work with other OS too.

    1.  Right-click on the drive that is causing the problem.

    2.  Left-click on Properties.

    3.  Click on the Security tab.

    4.  In the first window click on Administrators (your computer name-PC Administrators).

    5.  Just below the window click on Edit.

    6.  Click on Administrators (your computer name-PC Administrators) again.

    7.  Here's the key to making it work. If Apply is grayed-out, check a box in the Deny column. It will then bring up Apply. 

    8.  Check a box in the Allow column. It should check all of the boxes except the last one and uncheck all of the boxes in the Deny column.

    9.  Click Apply. It should run a scan of the files in the drive. When the scan is finished, click Ok. The first box should still be open.

    10. In the first window, click on Users (your computer name-PC\Users) and repeat steps 5-9, of course clicking on Users (your computer name-PC\Users) instead of Administrators (your computer name-PC Administrators).

    NOTE:  You may not have to click in the Deny column after the first scan is completed for step 10 as indicated in step 7.

    Tuesday, May 31, 2011 8:14 AM