none
Windows Clock sets always off 1 hour after reboot

    Question

  • Hello,

    i have a big problem with the notebook of one of my colleagues.

    Everytime he reboots the clock is set 1 hour off.
    So after 5 reboots it's 5 hour beyond the normal time.
    It's set to GMT+1 Amsterdam, Berlin ....
    With DST enabled. When he unchecks DST it's reenabled every time.

    Things i've tried/i discoverd:
    the windows time service was deactivated and after setting it to automatic and reboot it gets deactivated again (sync with DC)
    after w32tm unregister and register the same thing happens with the service (it's renamed from the german name to the english name)
    installed the latest DST patch (which is not necessary for germany)
    updated the BIOS
    afters setting the clock right (net time /set) and then reboot to BIOS setup the clock shows the right time there
    i exported the timezones and the timezoneinfo from my notebook and implemented it on his (mine works ;) )
    i exported the w32time service settings from my notebook and implemented it on his

    w32tm /tz shows me this:
    Zeitzone: Aktuell:TIME_ZONE_ID_STANDARD Bias: -60 Min. (UTC=Ortszeit+Bias)
    [Standardname:"Westeuropäische Normalzeit" Bias:0 Min. Datum:(M:10 T:5 DoW:0)]
    [Sommerzeitname:"Westeuropäische Sommerzeit" Bias:-60 Min. Datum:(M:3 T:5 DoW:
    0)]

    i also checked with autoruns for bad processes/services

    I have no more ideas what can go wrong. I now enabled debug logging for the time service. Getting the results later this day.

    Can anyone help me with this issue ? It all started with the DST in Germany.

    Greets
    Stephan
    Thursday, November 19, 2009 10:00 AM

All replies

  • Try resetting the W32Time service, "net stop w32time" "w32tm.exe/unregister" "w32tm.exe/register" "net start w32time" that helps sometimes when the service starts losing synch

    Thursday, November 19, 2009 3:01 PM
  • Already tried that. No difference.
    Thanks anyway.
    Thursday, November 19, 2009 7:19 PM