none
Cisco VPN Client: Reason 412 – The remote peer is no longer responding

    Question

  • I can't get my cisco vpn to work. But I keep running into documentation that tells me to change the, "Edit your profile with your editor and change ForceKeepAlive=0 to 1."  How do I do that?

    Thanking in advance.

    Tuesday, October 05, 2010 2:23 AM

Answers

  • Hi,

     

    Please take the following steps:

    1.     On the main drive of the PC, choose Program Files > Cisco Systems > VPN Client > Profiles.

    2.     Right-click the profile that you use, and choose Open With in order to open the profile in a text editor (such as Notepad). (When you choose the program to use, be sure to uncheck the box that says Always use this program to open these files.)

    3.     Locate the profile parameter for ForcekeepAlives, and change the value from 0 to 1, then save the profile.

     

    Hope it helps.

     

    Regards,

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, October 07, 2010 9:31 AM

All replies

  • Hi,

     

    Please take the following steps:

    1.     On the main drive of the PC, choose Program Files > Cisco Systems > VPN Client > Profiles.

    2.     Right-click the profile that you use, and choose Open With in order to open the profile in a text editor (such as Notepad). (When you choose the program to use, be sure to uncheck the box that says Always use this program to open these files.)

    3.     Locate the profile parameter for ForcekeepAlives, and change the value from 0 to 1, then save the profile.

     

    Hope it helps.

     

    Regards,

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, October 07, 2010 9:31 AM
  • A: I think it could be caused by network connection issue.

    You need to restart Cisco Systems,Inc. VPN Service.

    Right click "Computer" and choose "Manage".

    Go to Computer Management (Local)-> Services and Applications-> Services, locate "Cisco Systems,Inc. VPN Service" and restart it.

    Then open VPN client and log in again. You can try it twice or more if requires.

    • Proposed as answer by simon-jk Monday, July 30, 2012 2:31 PM
    Monday, July 30, 2012 2:29 PM
  • Hi,

    I was facing this problem in a Gigabyte gaming laptop which came pre-loaded with Windows 8. After one day of problem, I unchecked the 'Run as Administrator' checkbox, and it started to work right after that. I rechecked 'Run as Administrator' again (in the main vpngui.exe) and it would return the 'Remote Peer Not Responding' message; but uncheck and it would work again!

    Thought I would share it in this thread in case someone keeps facing this problem.

    - Monwar Hussain

    Sunday, July 07, 2013 5:06 PM
  • I had this problem recently myself and it turned out to be the ASA firewall that I was trying to VPN into was incorrectly configured. It caused the same 412 error, so it threw me off, as that is usually an indication of a problem on the VPN client side, not the firewall side. Hope this helps for people looking for other causes....

    http://supertekboy.com/2014/01/15/cisco-vpn-reason-412-the-remote-peer-is-no-longer-responding/


    Check out my latest blog posts on www.supertekboy.com A tech blog for I.T. Superheroes.



    Wednesday, January 15, 2014 8:41 AM
  • Our VPN guy says 412 means "the token is unsynchronized" ... however, three days later when we looked at it the token was "Active", not "Next tokencode mode". Also, the token (3 days later) was not locked due to wrong tokencode.

    For the problem I recently worked on it appears to have been intermittant internet connection somewhere along the line as VPN just started working a few hours later.

    Firewall/NAT issues are also reported as a cause, rebooting your modem and router, unblocking ports 500 and 10000 (but if it used to work that's likely not it).

    If you have one, try a VPN connection to somewhere else to see if it works. Try using another user's Username and their passcode/token.

    Our profile PCF files do not contain a ForceKeepAlives parameter. Does anyone know if there is a default for this parameter?

    Some of my info above and in this thread are summarized in a 412 post by L.A.M.N.K. (Just google for those two things.)


    • Edited by PAReinie Monday, March 03, 2014 9:13 PM Add more info.
    Monday, March 03, 2014 9:12 PM
  • Locate the profile parameter for ForcekeepAlives, and change the value from 0 to 1, then save the profile.

    but i cannot find

    ForcekeepAlives for changing value from 0 to 1

    in Profile

    Check

    [main]
    Description=
    Host=58.27.194.228
    AuthType=1
    GroupName=eobi-jauharabad
    GroupPwd=
    enc_GroupPwd=8AFC01679488F50AF1E879731A90405A1C1FC65F4C891DBD9F5D143E6227984F96D9C355D58C4AE12AF6C7669FB8A808
    EnableISPConnect=0
    ISPConnectType=0
    ISPConnect=
    ISPPhonebook=
    ISPCommand=
    Username=nadeemhayat
    SaveUserPassword=0
    UserPassword=
    enc_UserPassword=
    NTDomain=
    EnableBackup=0
    BackupServer=
    EnableMSLogon=1
    MSLogonType=0
    EnableNat=1
    TunnelingMode=0
    TcpTunnelingPort=10000
    CertStore=0
    CertName=
    CertPath=
    CertSubjectName=
    CertSerialHash=00000000000000000000000000000000
    SendCertChain=0
    PeerTimeout=90
    EnableLocalLAN=0

    Tuesday, March 18, 2014 9:08 AM
  • If you can't find the ForcekeepAlives entry then the app is using whatever the default is. In that case, create the entry and set it to whichever value you want (0 or 1).

    You'd probably have to contact Cisco to find what the default is set to, or if you have a Cisco VPN developer's manual that might tell you what the default is.

    Tuesday, March 18, 2014 2:50 PM