none
Windows 7: Windows Backup failed 0x81000031

    Question

  • Windows backup ran, and my once-pristine and empty backup drive now has something filling its space, so I assume some files were successfully backed up. Thing is, the Action Center icon has the red x on it and it comes up with one issue: Check, your backup (Important). Clicking this issue produces the following dialog:

    Windows Backup: Troubleshooting Options
    Check your backup
    Windows Backup failed while determining libraries location of one of the users included in the backup.
    Details: BitLocker Drive Encryption cannot be used because critical BitLocker system files are missing or corrupted. Use Windows Startup Repair to restore these files to your computer.
    Options:
    *Try to run backup again
    *Change backup settings

    Error code: 0x81000031


    Thing is, I'm using home premium. I don't see bitlocker as an option and I'm not terribly enthused about having to repair bitlocker when I can't use it to begin with. (Primarily, because I use Windows 7 Home Premium. Even if I used a version which supported bit locker, I'd never use it to begin with - I lack a TPM chip which means that anybody who has physical access to my machine could compromise my security regardless of bitlocker, it'd just take slightly longer for them if bitlocker were present.)

    I'm digressing, the point is I don't use bitlocker and I don't know how not having bitlocker prevents Windows 7 from copying files from one drive to another and making a note in a logfile that the files were backed up. I realize I simplify the method of backing files up but it doesn't get much more complex than copying them to a separate location and timestamping them.


    tl;dr: Windows Backup produced error code 0x81000031 because bitlocker drive encryption cannot be used. I don't want to use bit locker drive encryption I just want to back my files up to an external drive. Suggestions? Preferably ones that don't make me run Windows Startup Repair.
    Wednesday, December 30, 2009 5:35 AM

Answers

  • Reply to both bump the topic and mark an answer.
    As it turns out, the error occurred whenever I tried to back up any of my Libraries. By selecting "Let me choose", unselecting all the pre-selected libraries, and finally manually telling Windows Backup to back up my profile folder (C:/Users/Philbert), Windows Backup was able to successfully locate all my personal files for backup and then back them up.

    JUST TO CLARIFY FOR ANYBODY ELSE HAVING THIS ISSUE, IT WAS SOLVED IN THIS MANNER:
    First, start windows backup. This is accomplished by clicking start and then typing Backup and Restore into the start menu search box, then clicking the icon for windows backup.
    Second, make sure to select change settings in the backup and restore window.
    Third, the set up backup dialog box will open. Select the drive you wish to use for backups.
    Fourth, the what do you want to back up? dialog box will open. Make sure to select let me choose before clicking next.
    Fifth. Un-select any and all libraries which may start off selected. Additonally, unselect include system image. I'll just have to live with doing that manually from time to time.
    Sixth, pick-and-choose which files you wish to back up. Odds are you'll want to back up your profile folder (usually C:/Users/yourname), then click next.
    That's it! Everything else should work as expected.

    Big thanks goes out to Microsoft Customer Support, specifically Srinivas and Pradeep, the email support technicians who got me to this solution. Thanks guys!
    • Marked as answer by PhilbertHFZ Friday, January 01, 2010 4:16 AM
    Friday, January 01, 2010 4:16 AM

All replies

  • Hi,

    see microsoft solution here http://support.microsoft.com/default.aspx/kb/975692

    Regards from www.windowsadmin.info
    [If this answer helps you to resolve the issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. This will help others to find the answers faster]
    ManuPhilip
    • Proposed as answer by Calasan Marko Wednesday, August 10, 2011 8:46 PM
    Wednesday, December 30, 2009 5:39 AM
  • I have followed the steps in the linked article exactly, and still have no success. This accomplished nothing.

    I do not use bitlocker, it is not now and has never been a part of my windows boot process. Is there some way of telling windows backup to ignore this fact and back up anyway? I don't care about encrypting my hard disks or any of that nonsense, I just want to have my files stored in two places for safety.
    Wednesday, December 30, 2009 6:32 AM
  • Hi,

    I can't see any other solution.

    As stated in the kb: Error code: 0x81000031 is due to

    BitLocker Drive Encryption cannot be used because critical BitLocker system files are missing or corrupted.

    This problem occurs because the BitLocker Wizard moves Windows Recovery Environment (Windows RE) from the system drive to the external hard disk drive. Therefore, this prevents a backup on the external hard disk.

    Regards from www.windowsadmin.info [If this answer helps you to resolve the issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. This will help others to find the answers faster]
    ManuPhilip
    Wednesday, December 30, 2009 6:54 AM
  • I suspect that there is any VSS writer that was looking for the BitLocker Drive Encryption. All the writers are stored in the folder C:\Windows\Vss\Writers\. You can open Event Viewer, and open the following logs.

    Applications and Services logs\Microsoft\Windows\Backup\Operational
    Applications and Services logs\Microsoft\Windows\WindowsBackup\ActionCenter

    You may check related logs to try to find which writer encounter the issue. Also you can run the following command in command prompt window.

    vss admin list writers

    If you find which writer reports errors, please rename the writer from the source folder.


    Arthur Xie - MSFT
    Thursday, December 31, 2009 7:36 AM
  • C:\Windows\Vss\Writers contains only the following two folders:
    Application
    System

    The application folder is empty. The System folder has three cryptically named XML files,
    0bada1de-01a9-4625-8278-69e735f39dd2
    75DFB225-E2E4-4d39-9AC9-FFAFF65DDF06
    D61D61C8-D73A-4EEE-8CDD-F6F9786B7124

    The first one appears to be the writer for "Performance counters" and refers to .dat files somewhere in %systemroot%\system32
    The second one appears to be the writer for "WriterMetadataStore" and refers back to %systemroot%\Vss\writers
    The third one appears to be the writer for the Task Scheduler.

    Neither of the logs you suggested (Backup\Operational and WindowsBackup\Action Center) indicated any errors. Backup\Operational was completely blank and WindowsBackup\Action Center consisted only of information events.

    Finally, attempting to run the command
    vss admin list writers
    produces the output:
    'vss' is not recognized as an internal or external command, operable program or batch file.

    Do I have to be in a specific location to run the command?
    Thursday, December 31, 2009 4:34 PM
  • Not yours in particular, but why all these complaints about backup/restore? 

    I do only image backups to external for restore if needed with W. 7 Ultimate. I see no point in sync type of backup to external or anywhere. In backup menu Ultimate, the selection for Image backup is in upper left. Backup of Vista U.32, W. 7 U32 & W. 7U.64 on Disk 2 in this Mac Pro takes little time. Restoration if anything takes less time, if ever it is necessary.

    To my thinking, this is one of the best features of W.7.

    Thursday, December 31, 2009 7:23 PM
  • Perhaps. Image backups are indeed useful if I need to restore an entire disk to its previous state. The thing is, in many cases it is overkill. Yes, it gets the job done, but it does so in a round-about method. Sync-type backups are useful because:
    • I'm not making more than one image backup, conserving space
    • I'm only backing-up up the files which changed.
    • It is easier to have multiple versions of a file backed up.
    At any rate, I can not make ANY sort of backup using the built-in Windows Backup tool - image or otherwise. Presumably it succeeded in making an image backup at some point in time because one is there, but all later attempts at making any sort of backup fail with the given message.
    Friday, January 01, 2010 1:46 AM
  • Reply to both bump the topic and mark an answer.
    As it turns out, the error occurred whenever I tried to back up any of my Libraries. By selecting "Let me choose", unselecting all the pre-selected libraries, and finally manually telling Windows Backup to back up my profile folder (C:/Users/Philbert), Windows Backup was able to successfully locate all my personal files for backup and then back them up.

    JUST TO CLARIFY FOR ANYBODY ELSE HAVING THIS ISSUE, IT WAS SOLVED IN THIS MANNER:
    First, start windows backup. This is accomplished by clicking start and then typing Backup and Restore into the start menu search box, then clicking the icon for windows backup.
    Second, make sure to select change settings in the backup and restore window.
    Third, the set up backup dialog box will open. Select the drive you wish to use for backups.
    Fourth, the what do you want to back up? dialog box will open. Make sure to select let me choose before clicking next.
    Fifth. Un-select any and all libraries which may start off selected. Additonally, unselect include system image. I'll just have to live with doing that manually from time to time.
    Sixth, pick-and-choose which files you wish to back up. Odds are you'll want to back up your profile folder (usually C:/Users/yourname), then click next.
    That's it! Everything else should work as expected.

    Big thanks goes out to Microsoft Customer Support, specifically Srinivas and Pradeep, the email support technicians who got me to this solution. Thanks guys!
    • Marked as answer by PhilbertHFZ Friday, January 01, 2010 4:16 AM
    Friday, January 01, 2010 4:16 AM
  • Hi Guys,

    I'm encountering the same error as PhilbertHFZ with Error Code: 0x81000031.

    I'm running Windows 7 Professional and trying to back up to a Seagate 1tb Expansion drive (usb).

    I tried the all of the fixes in this thread but still no luck.  Although, I was able to successfully create a backup Image file.  It's just the backing up of the documents/libraries that the error persists.




    Any ideas would be greatly appreciated!

    Thanks!
    Saturday, January 02, 2010 5:38 AM
  • Hi,

    We have seen this error occur when locations on a CD/DVD drive on your machine have got included in one of your user libraries. This is not possible directly but there is a chance that you added locations from an internal/external drive to your library and the drive later got deleted/renamed and the driveletter now represents a CD/DVD drive. Please remove such locations from your library and re-run backup.

    For example, suppose F:\ is a CD/DVD drive on your machine. And, User John's Music library has some location under F:\ included in it. (Note: Launching the library and clicking on 'Locations' will give you the list of locations including in the library.) Remove F:\ locations from the Music library.

    This should fix your backup error. Please let us know if this helps.

    Thanks,
    Sneha
    [MSFT]
    • Proposed as answer by ath12345 Monday, February 01, 2010 10:30 PM
    Friday, January 08, 2010 6:25 AM
  • This fixed my issue.  I had the exact same issue with the "missing" bitlocker files.  Used Sneha's suggested answer.  Found that one of my DVD drives had been included in a library folder that I had created to my backup location.  Removed the DVD drive from the library, and now the backup works great!

    Thanks Sneha!!

    Here's what I did:

    Clicked "Start", then "Computer".
    Right clicked on the "Library" I wanted to modify, and selected "properties".
    Immediately saw that my DVD drive was an included folder in the library.
    Clicked on the drive in the list, and the Remove Button became active.
    Clicked on "Remove" and it removed the drive from the list.
    Clicked on "Incude Folder" and added in my real backup folder location (not required, I just want a libray connection to it).
    Clicked on "Ok".
    Tried my backup and everything works fine now.
     
    • Proposed as answer by ath12345 Monday, February 01, 2010 10:30 PM
    Thursday, January 21, 2010 7:11 AM
  • We have seen this error occur when locations on a CD/DVD drive on your machine have got included in one of your user libraries. This is not possible directly but there is a chance that you added locations from an internal/external drive to your library and the drive later got deleted/renamed and the driveletter now represents a CD/DVD drive. Please remove such locations from your library and re-run backup.

    For example, suppose F:\ is a CD/DVD drive on your machine. And, User John's Music library has some location under F:\ included in it. (Note: Launching the library and clicking on 'Locations' will give you the list of locations including in the library.) Remove F:\ locations from the Music library.

    Hi,

    that answer also helped me come up with a solution: I had the same issue with the root level of a (mounted!) TrueCrypt volume included in my libraries. Only after removing this I could start the backup.

    Thanks,
    Dennis
    Saturday, January 30, 2010 10:48 PM
  • I think I'm having the same problem as Dennis.

    I don't have BitLocker, but my Libraries are on a TrueCrypt volume Mounted at F:\.  If I include the Libraries, I get the 0x81000031 error, but if I remove the Libraries from the backup set, it runs fine.  However, most of the stuff I WANT to backup is on that volume, so removing that volume from the backup set is not a solution.


    Greg
    Saturday, February 06, 2010 6:50 PM
  • I'm also having trouble backing up to a Seagate hard drive. I've tried all the proposed fixes in this thread without any luck.
    My error message simply refers to the 0X18000031. It says nothing about Bitlocker. I've checked my libraries and they are not associated with the DVD drive. I do, however, notice that in each library there are two folders: My Music (C:\Users\omx) AND Public Music (C:\Users\Public). Could this be the problem?

    Why is such a vital procedure such a stumbling block?
    Wednesday, February 10, 2010 6:17 PM
  • Hi TrickPony,

    If you are sure that none of your users have a library that is pointing to a drive that was once a DVD drive, the other thing that you could check for is whether you have any libraries on a TrueCrypt volume.

    Thanks,
    Sneha
    [MSFT]
    Tuesday, February 23, 2010 2:48 PM
  • Hi guys,

    Would you be so kind to detailed the steps how you managed to get around this case?

    I don't understand much about TrueCrypt and those John's suggestion to check the music library to find out if there is an item may be that points to a CD/DVD drive....

     

     

    Wednesday, May 05, 2010 11:04 PM
  • Backing up from or to, Windows Backup just does not recognize TrueCrypt volumes.

     

    The way I got around it was to stop using Windows Backup and switched to Carbonite Backup instead.  


    Greg
    Thursday, May 06, 2010 6:25 PM
  • A couple of my Libraries included Invalid drive letter because I migrated the user with Windows Easy Transfer and on the machine I migrated from the drive letters were different than my current machine. I removed these invalid drive from the libraries and my backup was sucessful. Thanks Sneha!

    (I migrated multiple users, so had to clean up multiple libraries of all accounts)

    • Edited by KenA K Wednesday, June 09, 2010 2:55 AM Adding additional comment
    Wednesday, June 09, 2010 2:49 AM
  • I had the same problem, uninstalling MagicDisc solved the problem for me.
    Monday, August 16, 2010 9:29 AM
  • switch off UAC and try backup from  administrator account  
    Method 1: Disable and Turnoff UAC in Windows 7 from Control Panel
    1. Access User Control Panel from Start Menu -> Control Panel -> User Accounts and Family Safety -> User Account
    2. Click on User Account Control settings link.
    3. Move the Slider to Never Notify
    4. Click OK to make the change effective
    5. Reboot.

    For More Information and know how to resolve windows 7 backup error 
    Tuesday, August 17, 2010 6:00 AM
  • The connection between Backup and Bitlocker is the hidden partition - both use it.

    Are you able to hibernate with no problem?  What happens when you run "bcdedit" in a command window - does it find the bcd store?

    There seem to be a number of problems with Backup and Hibernate that originate from issues with the hidden partition of Windows 7.  In your case, the problem might be solved by using a partition manager to increase the size of your hidden partition (carefully!  there are threads on how to do this.  backup an image of your system first, if possible).  You can check this by seeing how full your hidden partition is - are there more than 60 GB or so free?  If not, then that's probably your issue.

    If bcdedit cannot find your bcdstore, and if you have problems with hibernation, then your problem is probably different.  That would be bad news for you, as I've been searching and posting from one end of the internet to the other, with no resolution.  You can see some of those threads here:

    http://social.technet.microsoft.com/Forums/en/w7itprogeneral/thread/d42f4d93-3bd3-4c89-aa86-d44719f266a6

    http://social.technet.microsoft.com/Forums/en-us/w7itprogeneral/thread/dbdf81da-8456-4f55-be38-bf4c9f00d0bc

    http://social.technet.microsoft.com/Forums/en/w7itprogeneral/thread/aa5a9a17-7fb1-4ff3-9a9e-0b90f9880ee0

    Tuesday, August 17, 2010 10:44 AM
  • Hi,

    We have seen this error occur when locations on a CD/DVD drive on your machine have got included in one of your user libraries. This is not possible directly but there is a chance that you added locations from an internal/external drive to your library and the drive later got deleted/renamed and the driveletter now represents a CD/DVD drive. Please remove such locations from your library and re-run backup.

    For example, suppose F:\ is a CD/DVD drive on your machine. And, User John's Music library has some location under F:\ included in it. (Note: Launching the library and clicking on 'Locations' will give you the list of locations including in the library.) Remove F:\ locations from the Music library.

    This should fix your backup error. Please let us know if this helps.

    Thanks,
    Sneha
    [MSFT]


    this worked for me.

    i had 'music' has an external then i took the drive away to another pc.

    apparently the backup couldn't find the path and mistook the music in my (C) instead.

    it took many, many  hours of searching around to find the answer but it is doing a backup now. 

    cheers.....

    • Proposed as answer by tatiana59 Monday, September 06, 2010 3:10 PM
    Monday, September 06, 2010 3:09 PM
  • Reply to both bump the topic and mark an answer.
    As it turns out, the error occurred whenever I tried to back up any of my Libraries. By selecting "Let me choose", unselecting all the pre-selected libraries, and finally manually telling Windows Backup to back up my profile folder (C:/Users/Philbert), Windows Backup was able to successfully locate all my personal files for backup and then back them up.

    JUST TO CLARIFY FOR ANYBODY ELSE HAVING THIS ISSUE, IT WAS SOLVED IN THIS MANNER:
    First, start windows backup. This is accomplished by clicking start and then typing Backup and Restore into the start menu search box, then clicking the icon for windows backup.
    Second, make sure to select change settings in the backup and restore window.
    Third, the set up backup dialog box will open. Select the drive you wish to use for backups.
    Fourth, the what do you want to back up? dialog box will open. Make sure to select let me choose before clicking next.
    Fifth. Un-select any and all libraries which may start off selected. Additonally, unselect include system image. I'll just have to live with doing that manually from time to time.
    Sixth, pick-and-choose which files you wish to back up. Odds are you'll want to back up your profile folder (usually C:/Users/yourname), then click next.
    That's it! Everything else should work as expected.

    Big thanks goes out to Microsoft Customer Support, specifically Srinivas and Pradeep, the email support technicians who got me to this solution. Thanks guys!


    this helped also, going into the files and unmarking programs that are no longer on the (C: )

    unmarking 'music' worked for me.

     

    i was so relieved when i saw that you had exactly the same trouble as i had.

    • Proposed as answer by tatiana59 Monday, September 06, 2010 3:13 PM
    Monday, September 06, 2010 3:13 PM
  • Concur. This solution worked perfectly

     

    Paul

    Sunday, February 20, 2011 3:18 PM
  • Worked like a charm! I just want to thank you for the clear and concise direction! I'm backing up as we Tweet! Peace
    Monday, February 21, 2011 9:13 PM
  • Hi,

     

    I had exactly the same problem. Followed all the various other suggestions but no luck. When I checked the "Pictures" folder under libraries (right click then choose properties) a library location had been specified for my E: drive which is my DVD drive. Removing it sorted the problem.

    Many Thanks

     

    Dave

    Friday, March 11, 2011 1:55 PM
  • Sneha

    You are fantastic! Of all the suggestions, you are not only correct in your diagnosis but have explained the process in an easy to understand and complete manner.

     

    Many thanks

    Steve

    Thursday, June 09, 2011 4:38 AM
  • thank you thank you thank you for posting your fix. I have been putting off this issue for 6+ months now..and I really didnt even know what bitlocker was till i read your first post, and since I don't allow incoming connections or file share or really anything except personal logs and storage and of course facebook...why would i give a bleeep about bitlocker either? thanks for the fix...i needed it.
    Sunday, July 03, 2011 7:54 PM
  • THANK YOU ALL!!!!!! I went 8 months without a backup.  I followed the advice step by step and it worked! THANK YOU!!!!!!!!!!
    Saturday, July 23, 2011 3:04 AM
  • Check if you have any unaccessible and/or non-existent folders in your libraries. I had a folder pointing to a location that no longer exists in my Documents library. Removed it and everything worked like a charm!

    Calasan Marko

    • Proposed as answer by Calasan Marko Wednesday, August 10, 2011 8:49 PM
    • Unproposed as answer by Calasan Marko Wednesday, August 10, 2011 8:49 PM
    Wednesday, August 10, 2011 8:49 PM
  • None of the above solved my issue. In fact, I've only tried to back up 1 folder of pictures that I knew was on my C:\ drive.

    The problem I'm facing now is I can't even get BitLocker to turn on, there's no "Turn On" link so I think the problem is deeper. All the posts above suggest checking libraries and stuff but I went directly to a C:\users\Myname\Pictures folder and tried backing it up, got the same issue.

    So now I'm reformatting. I believe Acronis TrueImage really screwed up my system upon uninstalling.

     

    Sunday, August 21, 2011 3:11 PM
  • well, i tried the above fix to no avail.  still get the 0x81000031 error message.  i've tried various solutions, nothing seems to be working.  did the chat thing w/ hp 3x to no avail.  any help would be appreciated. 
    Monday, September 05, 2011 5:45 PM
  • Hi,

    We have seen this error occur when locations on a CD/DVD drive on your machine have got included in one of your user libraries. This is not possible directly but there is a chance that you added locations from an internal/external drive to your library and the drive later got deleted/renamed and the driveletter now represents a CD/DVD drive. Please remove such locations from your library and re-run backup.

    For example, suppose F:\ is a CD/DVD drive on your machine. And, User John's Music library has some location under F:\ included in it. (Note: Launching the library and clicking on 'Locations' will give you the list of locations including in the library.) Remove F:\ locations from the Music library.

    This should fix your backup error. Please let us know if this helps.

    Thanks,
    Sneha
    [MSFT]


    Sneha, thanks a million :) what you said saved my time!

     

    I have the same issue and after some investigation i found that my external "eGo Iomega" USB drive is mounting an extra virtual CD-Drive which listed as one of my drivers. Once I unplugged the Iomega drive the Backup process went normally without any issue.

    my frustration that Windows Backup abort the process eventhough the Iomega drive was not pointed to any of my libraries and I can assume this as a design issue with teh Win backup that Microsoft should fix it.

     

    The error message is confused, but the bottom line that you need to make sure that no virtual CD/DVD Drive is listed under your computer and the backup will go smoothly.

     

    thanks Sneha again for the good and clear explanation of the issue root cause!

    Regards!

    • Proposed as answer by ehubail Wednesday, September 14, 2011 7:46 AM
    Wednesday, September 14, 2011 7:44 AM
  • Thanks, that was the solution for me as well.

    I use Cyberlink Power DVD 9.5 and I discovered that the dvd info was being added to my library. What was happening was that the dvd would end and prompt me to add the dvd info to my collection. I would click the star rating and say ok, and this is then added to my library and stopping the backup from running, due to the fact that the dvd's are no longer in the drive.

    I opened my power dvd, clicked configure settings, clicked DVD tab, then manage, select all, delete.

    This removes all the chapter titles from the library. I closed power dvd and ran the backup again and it worked.

    Thanks for your help.

    Tuesday, September 27, 2011 4:13 PM
  • Fuzo, you're suggestion worked perfectly..I'm in your debt as I had begun to get very frustrated with this problem..Much Thanks...
    Thursday, October 06, 2011 2:59 AM
  • thanks alot it worked perfectly.

    i had an external drive included in music library , i removed it and it work fine now.

    thanks again

    Friday, February 10, 2012 2:38 PM
  • Windows Backup failed while determining libraries location of one of the users included in the backup.
    Details: BitLocker Drive Encryption cannot be used because critical BitLocker system files are missing or corrupted. Use Windows Startup Repair to restore these files to your computer

    I have read the above and followed the suggestions about changing settings. Nothing works. This is a brand new PC and I want to select key documents to backup to an SD card. There is nothing on the card. How can I have corrupted files like this on a brand new PC when everything else works fine. I haven't tried Startup Repair because I am afraid to make something worse.

    What is causing this fundamental utility that I have used for years on previous PCs to fail?


    Friday, February 17, 2012 2:40 AM
  • Hi,

    see microsoft solution here http://support.microsoft.com/default.aspx/kb/975692

    Regards from www.windowsadmin.info
    [If this answer helps you to resolve the issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. This will help others to find the answers faster]
    ManuPhilip

    This does not help. neither of the two scenarios are applicable to me. I have tried backing up (some directories) to an SD card and an external drive. All attempts say there are missing Bitlocker files. This PC is brand new.

    This is now 2012 and the same problem has existed since 2009 without solution? Why can MS not simply provide a download for these files, whatever they are?

    Saturday, February 18, 2012 9:24 PM
  • I don't understand what "solution" is described here. This is just the normal process to run backup, which is not working for me.
    Saturday, February 18, 2012 9:29 PM
  • Hi,

    We have seen this error occur when locations on a CD/DVD drive on your machine have got included in one of your user libraries. This is not possible directly but there is a chance that you added locations from an internal/external drive to your library and the drive later got deleted/renamed and the driveletter now represents a CD/DVD drive. Please remove such locations from your library and re-run backup.

    For example, suppose F:\ is a CD/DVD drive on your machine. And, User John's Music library has some location under F:\ included in it. (Note: Launching the library and clicking on 'Locations' will give you the list of locations including in the library.) Remove F:\ locations from the Music library.

    This should fix your backup error. Please let us know if this helps.

    Thanks,
    Sneha
    [MSFT]
    What do you mean by clicking on "locations"? I see no such option.
    Saturday, February 18, 2012 9:46 PM
  • I went through hundreds of folders visually based on the above recommendations and eventually found one with a DVD reference. I removed that from the library and Backup started working.

    I didn't have that problem with the previous PC that I just recently transfered from with Easy Transfer, so it would seem that the transfer itself caused the problem, and one has to ask that if this has been a known problem since 2009 based on this thread, how difficult would it have been to fix Backup so it would ignore unavailable drives or at the very least give a meaningful error message?



    • Edited by Ulind Saturday, February 18, 2012 11:03 PM
    Saturday, February 18, 2012 11:02 PM
  • Hi, I had the same issue but the fix provided by Sneha fixed the issue for me. Thanks
    Tuesday, February 21, 2012 12:01 PM
  • Another solution which takes your solution a step further is if you have more than one user on your computer as I have, don't run the back up for the administrator libraries, only for the users libraries. (your sixth step)

    I have been struggling with this for hours and finally found the answer on another site and now can't find it again.  Sorry, I wish I could give credit.  Anyway that person had an administrater and two user accounts just as I have.   I unchecked the administrtor libraries and the backup is finally running now.  Why? Who knows?

    Thank you!

    Wednesday, April 25, 2012 1:16 AM
  • I followed everything you said and it worked but what a hassle initially , changing libraries to default as suggested by Microsoft didn't work.  
    Sunday, May 13, 2012 11:10 AM
  • Good job, PhilbertHFZ. Turning off the pre-selected options worked a charm as suggested. Another internet life saved!
    Monday, May 28, 2012 1:22 AM
  • These were very clear instructions, which I copied, and tried hard to follow.  My attempt at Backup still failed. Details:  "Windows Backup failed while determining libraries location of one of the users included in backup."

    In fact, I am the sole user; I changed settings, chose myself instead of "all users".  The failure and error messages are still the same.

    Obviously, I don't understand enough about what I'm trying to do!  In fact, my external hard drive (Elements) seeems to contain all the files up to last month that I would wish to find there, but the Error messages, and failure of backup, are worrying!

     

    Friday, November 08, 2013 9:41 PM
  • I had this problem. I was backing up to a USB drive. Unfortunately, the drive letters for these get shuffled around quite a bit when drives are removed, added and so on. The problem was because the drive letter of my backup USB drive had changed. I just re-assigned the drive letter to what it was when I set up the backup in the first place and everything was fine. Instructions for assigning drive letters in Windows 7 are at this link...

    http://windows.microsoft.com/en-us/windows/change-add-remove-drive-letter#1TC=windows-7
    Thursday, January 02, 2014 8:20 PM
  • Well 4 years later same problem simple fix, did every thing else as suggested by microsoft sys repair start up repair etc etc and just removing the drive that was included in library fixed the issue i have spent hours on

    now have to reinstall all that sys restore removed...SO EVERYBODY do what Sneha said first..

    Clicked "Start", then "Computer".
    Right clicked on the "Library" I wanted to modify, and selected "properties".
    Immediately saw that my DVD drive was an included folder in the library.
    Clicked on the drive in the list, and the Remove Button became active.
    Clicked on "Remove" and it removed the drive from the list.
    Clicked on "Incude Folder" and added in my real backup folder location (not required, I just want a libray connection to it).
    Clicked on "Ok".   thanks ath1234 for the process..Cheers

    Sunday, January 26, 2014 10:07 PM
  • Thanks!  This appears to have fixed my issue!
    Saturday, February 15, 2014 5:13 AM
  • This did it for me!  Noticed that one of my CD/DVD drives was listed in my Music Library; once I removed that, nothing but smooth sailing!  Thanks much!
    Friday, March 28, 2014 1:09 AM