none
Unattended Answer File - How do you set timezone to GMT?

    Question

  • Hi,

    I have another issue to do with .xml unattended answer files created in System Image Manager:

    I live and work in the UK and am trying to set the time zone to GMT, however if I enter GMT in my unattended.xml file I am prompted during setup to select my time zone. I've read the help file which says UTC has replaced GMT so I changed my unattended.xml to UTC and ran setup again, and that worked or so I thought it did.

    My problem came when I joined my new Windows 7 PC to the domain - I noticed it was one hour different to the rest of my PCs and Servers on my network (and our network has a time server which all PCs on the domain sync with).

    It's strange it's exactly one hour different - I'm sure it's something to do with daylight saving?

    Does anybody have any suggestions?

    Many Thanks,

    Matt Courtman, UK

    Thursday, April 29, 2010 8:41 PM

Answers

  • You'd better type the full name:

    <TimeZone>Greenwich Mean Time</TimeZone>

    Best Regards

    Dale

     

    No such animal

    Try using tzutil.exe to get the correct syntax from a working machine,  or just check this registry setting for a list of all working "Time Zones" as recognized by windows.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Time Zones

    <TimeZone>GMT Standard Time</TimeZone> = london

    or

    <TimeZone>Greenwich Standard Time</TimeZone>  = iceland

    • Proposed as answer by MrJinje Saturday, May 15, 2010 7:41 AM
    • Marked as answer by mcourtman Wednesday, June 09, 2010 8:08 AM
    Saturday, May 15, 2010 7:40 AM

All replies

  • Are you typing just GMT or Greenwich Mean Time? There is also an option to adjust for daylight saving.
    Friday, April 30, 2010 12:44 AM
  • You'd better type the full name:

    <TimeZone>Greenwich Mean Time</TimeZone>

    Best Regards

    Dale

     

    Friday, April 30, 2010 3:14 AM
    Moderator
  • Hi, thanks for your suggestions.

    I have tried entering both GMT and Greenwich Mean Time and both times during the Sysprep phase Windows prompts for the time zone to be selected.

    I'm sure UTC is right, however there are four UTC time zones to choose from:

    I need my unattended answer file to tell Sysprep to select (UTC) Dublin, Edinburgh, Lisbon, London. Currently it is just selecting (UTC) Coordinated Universal Time which causes my one-hour difference when I join my domain.

    Thanks again,

    Matt

    Friday, April 30, 2010 8:40 AM
  • You'd better type the full name:

    <TimeZone>Greenwich Mean Time</TimeZone>

    Best Regards

    Dale

     

    No such animal

    Try using tzutil.exe to get the correct syntax from a working machine,  or just check this registry setting for a list of all working "Time Zones" as recognized by windows.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Time Zones

    <TimeZone>GMT Standard Time</TimeZone> = london

    or

    <TimeZone>Greenwich Standard Time</TimeZone>  = iceland

    • Proposed as answer by MrJinje Saturday, May 15, 2010 7:41 AM
    • Marked as answer by mcourtman Wednesday, June 09, 2010 8:08 AM
    Saturday, May 15, 2010 7:40 AM
  • You'd better type the full name:

    <TimeZone>Greenwich Mean Time</TimeZone>

    Best Regards

    Dale

     

    No such animal

    Try using tzutil.exe to get the correct syntax from a working machine,  or just check this registry setting for a list of all working "Time Zones" as recognized by windows.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Time Zones

    <TimeZone>GMT Standard Time</TimeZone> = london

    or

    <TimeZone>Greenwich Standard Time</TimeZone>  = iceland


    Many thanks indeed for this!!! Have just tried it, and it works a treat

    "GMT Standard Time" is the solution.

    Thanks again,

    Matt

    Wednesday, June 09, 2010 8:10 AM