none
ATI TV-Wonder 650 PCI Won't Install

    General discussion

  • I've got an ATI TV-Wonder 650 PCI  card that I'm trying to install.  I've already installed the latest Vista Catalyst drivers for my AGP ATI Radeon HD 2600XT card and it seems to be working well.  I went to the ATI site and downloaded the latest Vista drivers for the capture card (says it covers 550, 600, and 650).  After install, it says everything went OK.  However, it never installs the card.

    So I went into device manager and tried installing the driver myself.  It doesn't find it automatically, and when I try to choose from a list of all drivers, I cannot find the TV-Wonder drivers anywhere. I've tried a couple that sounded like they MIGHT be the right thing, but to no avail ("Device couldn't start").

    This card worked flawlessly in XP.

    Has anyone had success with this specific card?  What drivers did you use? (I used Vista 32-bit ATI Theater 8.12).

    Thanks,
    -Ganouche

    Friday, January 23, 2009 8:19 PM

All replies

  • Welcome to the club. Mine works with VISTA, USB plugger. ATI TV Wonder 600 version.  So far no luck with loading drivers. Any one else out there, give us a shout. (My old TV Wonder loaded on XP AND VISTA, can kick myself for "upgrading" to the anywhere, anytime pitch for the usb device). So like you, still waiting or go back to my double boot and run VISTA.
    If I find a solution, will post here

    Leo
    Tuesday, May 26, 2009 3:53 PM
  • make compatible
    Works in win xp , vista and win 7

    if you have the files on your hard drive or
    if you have the files on a cd/dvd then look in windows explorer for the cd/dvd drive and right click on the setup file or
    Right click the program's icon and choose properties.
    When the properties dialog box appears,click the compatibility tab.
    Select the programs desired windows version from the compatibility
    mode's drop-down menu.
    Click OK and then try running your program again to see whether it's working better.
    if the program worked in xp or vista it should work in win 7

    Tuesday, May 26, 2009 5:34 PM
  • I have the same card (PCI 650) and I was able to install the drivers using this method (before you begin, uninstall the drivers for the 650 FIRST then reboot. If Win 7 attempts to automatically install the drivers after reboot cancel the auto discovery). I went to ATI's web page (http://support.amd.com/us/gpudownload/windows/Pages/tvtuner_vista.aspx?type=2.5.1&product=2.5.1.3.2.3.2&lang=English) and downloaded the drivers. Once I was finished I unziped files (default dirctory is C:\ATI\Support\) but I cancelled the installation of the drivers. I went to device manager found the driverless device (marked with a yellow triangle with red exclamation), right clicked on the device and clicked on install/update driver. When it asks for the drivers select I will install from a specific location. Find the C:\ATI\Support folder (if you let it unzip to the default directory, if not then find the directory you unziped the files to) and select the folder. It will find the driver and install all by itself. Once your done restart the computer. To test go into media center and try to set up you TV tuner. It should find it with no problem. The motherboard i'm using with the 650 is a Gigabyte GA-MA78GM-US2H. I also have another PC running Win 7 with the ATI 550 that works with no issue too. Hope this helped.
    Monday, June 01, 2009 6:50 PM