none
"Windows cannot set up homegroup on this computer"

    General discussion

  • Hi all.

    I got this problem with setting up a homegroup with my 2 computers. My laptop manages to create a homegroup, and I get the password for it.

    But when I try to Join homegroup on my other computer, i get the "Windows cannot set up homegroup on this computer" (Error code 0x80630801).

    I've also tried creating the homegroup from comp2, but same error pops up as soon as i hit the Create button.

    I've tried looking up the error message, but with no real results.

    Any ideas..?

    Thursday, January 29, 2009 9:57 PM

All replies

  • Both machines need to be running  W7. Home group will not work with any other OS and W7
    Thursday, January 29, 2009 10:07 PM
  • Dave____J said:

    Both machines need to be running  W7. Home group will not work with any other OS and W7


    I doubt he would be able to join a homegroup if he isn't running W7 on both systems.
    Thursday, January 29, 2009 10:09 PM
  • I can't reproduce this particular error, but I've also had my fair share of problems trying to set up a homegroup. Creating and joining one went without a hitch, but actually getting to share files and resources was apparently too much to ask. :-p

    I've reverted to bypassing homegroups and using the old fashioned manually shared folders - it works just fine.
    Thursday, January 29, 2009 10:15 PM
  • Yeah I am using W7 on both computers :)

    And I am able to share stuff the old-fashioned way with shared folders, i'm just curious about this W7 Homegroup thing :)

    If you google the error code you get this description:

    "The Identity Store has been corrupted. Delete idstore.sst from the %appdata%\peernetworking folder.

    Value: 0x80630801"

    I can't find the idstore.sst file it mentions. The closest one is the idstore.dll in the system32 folder, and windows won't really let me mess with that file... 

    Thursday, January 29, 2009 10:32 PM
  • It seems there are still a few bugs left iron out. Homegroups are an important new feature of the Windows 7 experience though, so Microsoft will have to fix it anyway before they can throw the final release out there.
    Thursday, January 29, 2009 10:42 PM
  • This is an old post but found file

    under ...windows\serviceProfiles\LocalService\AppData\Roaming\PeerNetworking

    Hope that helps
    Friday, February 20, 2009 7:53 AM
  • This is an old post but found file

    under ...windows\serviceProfiles\LocalService\AppData\Roaming\PeerNetworking

    Hope that helps
    Hey again. Haven't checked up on this thread before now. 

    Thanks Alot! I deleted the file, and the error was gone!
    Don't know why I couldn't find it myself, think it was because I needed some administrator rights somewhere...
    Monday, April 20, 2009 6:18 PM
  • You rock.

    I've been trying to fix this issue on Windows 7 RTM for hours now (including the proverbial "I give up let's reinstall" - LOL)

    Deleting the file  idstore.sst under windows\serviceProfiles\LocalService\AppData\Roaming\PeerNetworking fixed it.

    I didn't even need to start the services.. shazaam they started themselves!
    Sunday, November 08, 2009 2:04 PM
  • I'm having the exact same problem, only I don't have a folder named "AppData" under windows\serviceprofiles\localservice. Any other ideas?
    Thursday, December 03, 2009 9:53 PM
  • It's hidden. Try changing your settings so you can see hidden files then you should see it.Deleting the file didn't work for me. I still cannot conect my computers using the Homegroup feature. I've given up and just use regular network sharing.
    Gregory I. Hayes
    Thursday, December 03, 2009 11:07 PM
  • I changed the settings to show hidden files, but I only have "idstore" and "idstore.sst.new" in my PeerNetworking folder. I tried deleting both of them but they come back each time I try to join the network. I still cannot use Homegroups.
    Friday, January 22, 2010 6:08 AM
  • I gotta stop playing with this (not).  I have more trouble with my own pc than I have with any at work or even the wife's.
    Deleting the file  idstore.sst under windows\serviceProfiles\LocalService\AppData\Roaming\PeerNetworkingworked just great for me.
    I had to manually start the services but they started right up and didn't geive me either of the errors. (0X80630801 and the 1038)
    Finally a forum that actually has some answers.

    Dan Wireman
    IT Support Specialist
    Sunday, January 31, 2010 9:36 PM
  • I am having the same problem. I set up a homegroup on my laptop and my net book and they work just fine but when I try to add my new desktop I get that same error. Im new to all this networking stuff but was wondering if it has something to do with my laptop and netbook having 32 bit operating systems and the desktop having 64 bit.
    Thursday, February 04, 2010 1:28 AM
  • It's not a 32-bit / 64-bit issue. I've got 3 computers running 64-bit Home Premium and none can connect using Homegroups.


    Gregory I. Hayes
    Thursday, February 04, 2010 5:47 PM
  • Hey i have a problem with it, here is my sitch,

    laptop - win7 ultimate
    pc - win7 ultimate

    i create a homegroup (doesn't matter which one) and it sets up fine, password and everything,
    on the other machine i hit join, it searches for ages (it says it can join and reconizes it)

    but after a while it doesn't join or just says 'windows cannot set a homegroup on this compute' this is on both of them, running win7

    i've tried everything, firewall off, the homegroup password thing off,
    searching through loads of files and changing varibles, then back to normal after the didn't work.

    What am i doing wrong? can someone please solve my annoying family home pc problem, cuz i can reli use this for college work (printing, files etc)

    thanks,
    Rowan
    Monday, February 08, 2010 1:45 AM
  • i coundnt find the foleder PeerNetworking....what to do now...my hidden files setting are set to VIEW HIDDEN OR SYSTEM FILES...
    Monday, February 08, 2010 5:53 AM
  • Had similar problem,2 computers running win 7,could see files but could access only one way.Im running eset 4 and zonealarm.Eset has file protection,I excluted the drive Im shareing and now transfers work both ways.  I spent two days trying to configure router ,firewall ,folder permissions,ect,ect.HOPE THIS HELPS SOMEONE
    Monday, February 08, 2010 6:22 PM
  • So do yuo have Homegroup working, or just regular network sharing?
    Gregory I. Hayes
    Monday, February 08, 2010 8:00 PM
  • I gotta stop playing with this (not).  I have more trouble with my own pc than I have with any at work or even the wife's.
    Deleting the file  idstore.sst under windows\serviceProfiles\LocalService\AppData\Roaming\PeerNetworkingworked just great for me.
    I had to manually start the services but they started right up and didn't geive me either of the errors. (0X80630801 and the 1038)
    Finally a forum that actually has some answers.

    Dan Wireman
    IT Support Specialist

    I am having the same problem. First o f all I would like to thank IT Support Specialist, Dan Wireman for giving the exact location of the idstore.sst file. I also had tried to find it by “showing all hidden files” but, couldn’t find it. I couldn’t have found it without your help Dan, thanks again. I had to confirm Administrative Permission before I obtained access to the file. However, I am still not able to set up a homegroup on this computer. I have tried to set up a homegroup immediately and after a reboot. After I immediately try it when I just deleted the file I get the error, "Windows cannot set up homegroup on this computer." I checked the “PeerNetworking” folder again and the idstore.sst file is still not there. I rebooted the PC and looked in the “PeerNetworking” folder again and the idstore.sst file appeared in the same spot only bigger than the one in the recycle bin that I just deleted. I am still not able to set up a homegroup without success.  I also tried the Homegroup troubleshooter with no success.
    Thursday, February 18, 2010 7:38 PM
  • I am having the same problem. First o f all I would like to thank IT Support Specialist, Dan Wireman for giving the exact location of the idstore.sst file. I also had tried to find it by “showing all hidden files” but, couldn’t find it. I couldn’t have found it without your help Dan, thanks again. I had to confirm Administrative Permission before I obtained access to the file. However, I am still not able to set up a homegroup on this computer. I have tried to set up a homegroup immediately and after a reboot. After I immediately try it when I just deleted the file I get the error, "Windows cannot set up homegroup on this computer." I checked the “PeerNetworking” folder again and the idstore.sst file is still not there. I rebooted the PC and looked in the “PeerNetworking” folder again and the idstore.sst file appeared in the same spot only bigger than the one in the recycle bin that I just deleted. I am still not able to set up a homegroup without success.  I also tried the Homegroup troubleshooter with no success.
      All the normal File share settings are selected and still no go.
    Thursday, February 18, 2010 7:40 PM
  • i coundnt find the foleder PeerNetworking....what to do now...my hidden files setting are set to VIEW HIDDEN OR SYSTEM FILES...
    I would like to thank IT Support Specialist, Dan Wireman for giving the exact location of the idstore.sst file. I also had tried to find it by “showing all hidden files” but, couldn’t find it. I couldn’t have found it without your help Dan, thanks again. I had to confirm Administrative Permission before I obtained access to the file.

    windows\serviceProfiles\LocalService\AppData\Roaming\PeerNetworking
    Thursday, February 18, 2010 7:42 PM
  • I got it and it was simple!!!!

    All I had to do is "leave the homegroup" then set up each of the computers up individually with the same password of course (just as I was trying to do before). For some reason it wouldn't let me use the same password or any other password for that matter. Any how, I got the all the computers working together as a whole now. I can even print using one printer now.

    Now, if I could just figure out what I need to hook up my big screen TV wirelessly like the guy on the Windows 7 comercial did I'll be set. I think I got to get some kind of router like a Slingbox, wireless router (w/HDMI plug) or a Roku player. Why do the best things Windows 7 has to offer have to be so difficult? I had this question on Ask Yahoo for a montha and no response. I hope I have helped someone out there and Bill Gates, If you read this, just because you have cornered the market doesn't mean it's okay to forget about your customers after you take our money. I wish I could give this head acke to you and you will start to understand what I mean LOL. Just kidding, I wouldn't want to wish any harm on you. I think you have done great with Windows 7, now you can work on CUSTOMER SERVICE and a warantee.
    Thank You Everyone!!!!

    Thursday, February 18, 2010 9:52 PM
  • I managed to sort this, I deleted everything in the folder C:\windows\serviceProfiles\LocalService\AppData\Roaming\PeerNetworking\, removed my main PC from the homegroup and the started again settting the homegroup up.  Sorted

    Hope this helps someone out there!

     

    Saturday, March 27, 2010 4:14 PM
  • OK, followed LL Cool Duck's approach and it worked! Thanks!
    Tuesday, July 06, 2010 7:14 AM
  • THANX! this solved my problem too. 

    if you are still struggling to find the "AppData" folder, try typing :"C:\windows\serviceProfiles\LocalService\AppData\Roaming\PeerNetworking" into the search on your startup menu. Then you will find it, you most probably have admin rights blocking you from seeing the file, but it is there.


    Thursday, July 29, 2010 12:08 PM
  • Turns out Symatec Endpoint was blocking the IPV6 traffic for me. I had to disable Network Threat Protection and enable Windows Firewall.
    Friday, September 10, 2010 1:32 PM
  • I still cant find the AppData even by typing C:\windows\serviceProfiles\LocalService\AppData\Roaming\PeerNetworking into the search menu.
    Wednesday, October 20, 2010 6:01 PM
  • I did everything that was said on this page...the peer services are running on both my pc and laptop...and still i cant connect to the home group ived created...
    Wednesday, November 10, 2010 6:25 PM
  • I had the same problems and spent several days reading and trying everything I could think of and all the suggestions here.  Figured out I needed to remove my drive protections in my system restore.  No problems after that.

    Hope it helps 

    Don't like not having the system restore feature but it was the only way I could get it to work.

    Friday, December 10, 2010 11:14 PM
  •  

     

    This is what fixed mine. I pluged the wireless laptop directly into the router and join, after that unplug and reenable wireless.

     

    Another fix was to reshare the homegroup folders even though they were already shared. Soon as I shared again, was able to join and see the folders.

    Saturday, December 11, 2010 6:36 PM
  • I have just been through volumes of forums discussing the problem of computers not seeing one another on the network.  I have a decent computer background and work at a college that does computer training.  My two computers ... a desktop (using Windows 7 Pro) and my laptop (using Windows 7 Home Premium) initially setup Network Sharing using homegroup initially very easily and worked flawlessly.  Suddenly without cause or explanation, one could not see the other.  I have never been more frustrated than trying to get both of them to see one another again.  I have gone through every F&Q, forum, and everything else one could imagine and shared the frustrations many other had found also ... nothing seemed to work.  All settings were as recommended, all clocks were in sync, the router was reset, I left homegroup on both computers and set back up a homegroup and got a new password on the Windows 7 Pro, and I then tried to join on the laptop (which initially would not let me join), all planets the solar system were were aligned, the proper chants and sacrifices were made and nothing seemed to work.  Argg!

    This is what I did discover and there is one item in this very forum string that did work:

    After I created the new homegroup on my desktop, got the new password and checked everything I wanted to share,  I found the laptop still could not see the homegroup to join.  I did discover, however, that if I went back to the desktop, went to my libraries, right clicked one of my libraries, in the menu selected "Share With" and selected "share with Homegroup" suddenly the laptop could find a homegroup to join.  I followed the "join homegroup" process (on the laptop)and put in the newly created password I created from the desktop.  The laptop now saw my desktop.  It was a sort of "Eureka!" moment.  I then found the desktop still could not see the laptop even if went to the laptop libraries to do the same right click sharing and selected a "share with homegroup" option .  I thought then that perhaps a reboot of both computers might resolve the problem.  I did that very thing and upon reboot, I was back to square one.  Neither computer could see the other.  

    Now, the moral of this story ... I tried one thing mentioned above that instantly allowed both computers to see each other.  My desktop is directly connected to my router.  The laptop feeds to it wirelessly.  I connected my laptop directly (hardwired) to my router and poof, both could see each other and the "homegroup" was a happy family again.  

    I am wondering how many people that have the problem of their computers not seeing one another have a desktop directly connected to their router and a laptop that connects wirelessly.  It could well be that there is a bug in the wireless connection process or a setting that has changed not covered in all of these forums that is causing the problem.  Connecting both computers directly to the router seems to work, however.

    Any thoughts?

    Sunday, December 12, 2010 10:38 PM
  • Google's Gbridge certainly seems to cause problems with this.  I turned it off on both the desktop and laptop, "left" the Homegroup on each, rejoined, and it finally worked.  Now I see that GTalk server is attempting to connect upon reboot but is unable.  I suspect you can't have both running and so much choose.
    Thursday, December 30, 2010 3:45 AM
  • I have just been through volumes of forums discussing the problem of computers not seeing one another on the network.  I have a decent computer background and work at a college that does computer training.  My two computers ... a desktop (using Windows 7 Pro) and my laptop (using Windows 7 Home Premium) initially setup Network Sharing using homegroup initially very easily and worked flawlessly.  Suddenly without cause or explanation, one could not see the other.  I have never been more frustrated than trying to get both of them to see one another again.  I have gone through every F&Q, forum, and everything else one could imagine and shared the frustrations many other had found also ... nothing seemed to work.  All settings were as recommended, all clocks were in sync, the router was reset, I left homegroup on both computers and set back up a homegroup and got a new password on the Windows 7 Pro, and I then tried to join on the laptop (which initially would not let me join), all planets the solar system were were aligned, the proper chants and sacrifices were made and nothing seemed to work.  Argg!

    This is what I did discover and there is one item in this very forum string that did work:

    After I created the new homegroup on my desktop, got the new password and checked everything I wanted to share,  I found the laptop still could not see the homegroup to join.  I did discover, however, that if I went back to the desktop, went to my libraries, right clicked one of my libraries, in the menu selected "Share With" and selected "share with Homegroup" suddenly the laptop could find a homegroup to join.  I followed the "join homegroup" process (on the laptop)and put in the newly created password I created from the desktop.  The laptop now saw my desktop.  It was a sort of "Eureka!" moment.  I then found the desktop still could not see the laptop even if went to the laptop libraries to do the same right click sharing and selected a "share with homegroup" option .  I thought then that perhaps a reboot of both computers might resolve the problem.  I did that very thing and upon reboot, I was back to square one.  Neither computer could see the other.  

    Now, the moral of this story ... I tried one thing mentioned above that instantly allowed both computers to see each other.  My desktop is directly connected to my router.  The laptop feeds to it wirelessly.  I connected my laptop directly (hardwired) to my router and poof, both could see each other and the "homegroup" was a happy family again.  

    I am wondering how many people that have the problem of their computers not seeing one another have a desktop directly connected to their router and a laptop that connects wirelessly.  It could well be that there is a bug in the wireless connection process or a setting that has changed not covered in all of these forums that is causing the problem.  Connecting both computers directly to the router seems to work, however.

    Any thoughts?

    This is my trouble exactly as well: desktop hard wired to router and laptop on wireless. Wheh I connect the laptop to a hardwire homegroup seems to work etc. but fails on wireless.  Anyone else have any ideas?
    Tuesday, January 25, 2011 6:15 PM
  • Yes, deleting the idstore.sst file from windows\serviceProfiles\LocalService\AppData\Roaming\PeerNetworking solved the problem.

    I was able to finally start the "Peer Name Resolution Protocol" after removing this file and i can now join the homegroup.

    Thanks for the post.

     

    Saturday, February 05, 2011 9:35 PM
  • I think that some of the earlier posts involving wireless might be the key to my problem at least.  When setting up my homegroup I had IPv6 disabled and it would not  create the home group until I enabled it.  I have my other windows 7 box connected via wireless and am pretty sure my wireless does not support ipv6.  I am thinking that this is  the problem.  Any thoughts or ideas?

    pcgalen
    Thursday, March 10, 2011 3:34 PM
  • Helped me. I uninstalled ESET and everything including Window Remote Assistance Easy Connect, Ad hoc connection, and joining homegroup worked. Apparently, there are features in firewall like ESET that blocks all incoming computer from connecting. Thanks!
    Sunday, March 20, 2011 8:24 PM
  • I have no idea what single step fixed if for me, but it is fixed now. Here is what I did:

    1. Had all the other machines, including the one I am on, leave the homegroup. No machine is on the homegroup.
    2. Deleted the file idstore files from here: \Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking  (For those having trouble with this step, note that Windows is not always installed on Drive C. Type in what I show, and you won't have to worry about the drive.)
    3. Went to Services (Start menu, then type Services.msc), and restarted/Started the Peer Name Resolution Protocol
    4. Set up a new home group
    5. Joined the homegroup again from my other computers

    It worked for me.

    - Charlie

    Saturday, March 26, 2011 10:00 PM
  • I was having the same problem but solved it. My solution was that IPV6 was disabled on one of my PCs, re-enabled it and voila homegroup now working
    Wednesday, July 13, 2011 11:58 PM
  • thanks for your reply.  I figured out it was a V6 issue but can live without a homegroup since I now have an AD domain.  I've disabled V6 on all of my machines since it is just another possible attack vector.  Given all the MS bugs with the V4 stack, and the fact that most of the Chinese (probably 50% of the hackers in the world) are using V6 I just disabled it on all machines.  V4 works for me.  No offense to the Chinese but there are just so many of them that they are having to use V6 now.

     

    Thanks,

     



    ---
    Regards,
    NumbLock Et Al
    --------
    There are only 10 kinds of people in the world. Those who understand binary and those who don't
    --------
    Thursday, July 14, 2011 12:04 AM
  • I had Symantec Endpoint installed on the homegroup laptop which blocked all incoming connections...

    Thx to this thread!

    Monday, August 29, 2011 7:48 PM
  • I ran into this issue as well.  Win7 desktop wired to router and a win7 laptop connected via wireless.  The laptop would not connect to the homegroup that was created on the desktop.  I tried various solutions I found on forums, but none of them worked for me.

     

    I eventually opened the network connections and saw the bridge I created on the laptop in order to connect the XBox 360 to the internet.  I figured this had to be the problem so I removed the bridge from the Wireless Network Connection and tried again.  The laptop was then able to connect to the workgroup without issue.


    To remove a bridge:

    1. Enter "network connections" on the start menu search bar.
    2. Select view network connections.
    3. Right-click the network connection icon (NOT the bridge - disabling the bridge does not work) and select the option to remove bridge.
    4. Go to the network and sharing center by clicking Network and Internet in the address bar above, then network and sharing center.
    5. Join your homegroup.

    • Edited by gdigi Friday, September 30, 2011 2:17 AM formatting
    Friday, September 30, 2011 1:59 AM
  • Hello, people :) 

    I've the same problem with home network setting up. I have a desktop and a laptop. on the desktop there is absolutely not a problem with setting or leaving the homegroup. But with the laptop - there is an adventure! I tried everything I read here, but still - no fix :( Each time I delete the stuff in the peernetworking folder and try to join a homegroup after that, I'm not able to! and all the files "idstore" are born again and again! even more - some other folders are created in this particular folder, right above the "idstore" files and each time I try to join the home network - new and new folders appear! I wonder if there is something wrong with my router or in general with the laptop. 

    It even DID NOT wotk out with removing the desktop from the homegroup! I'm really stuck!!

    I'd appreciate any help with that, thanks! :)

    Thursday, December 08, 2011 9:01 AM
  • FOR ANY ONE ELSE HAVING TROUBLE....

     

    ALL YOU GOTTA DO IS RESTART THE     HOMEGROUP LISTENER    SERVICE.......     PROBZ ENABLE THEN START    DONE THRU PROPERTIES,  HAVE BOTH COMPS ON THE SAME WORKGROUP NAME  IE CALL THEM  'HOME FOR EASE... DONE   LET YOU DO OUGHT NOW,  AND ENABLE THE PEER SERVICES AS WELL  IF U GOT PROBZ, THOI THESE SHOULD START AUTO....

     

    TO START STOP SERVICES,   TYPE   SERVICES.MSC IN YOUR START BAR SEARCH

     

    HOPE HELPZ

    Friday, January 13, 2012 9:23 PM
  • You cannot vote on your own post
    0

    ALL YOU GOTTA DO IS RESTART THE     HOMEGROUP LISTENER    SERVICE.......     PROBZ ENABLE THEN START    DONE THRU PROPERTIES,  HAVE BOTH COMPS ON THE SAME WORKGROUP NAME  IE CALL THEM  'HOME FOR EASE... DONE   LET YOU DO OUGHT NOW,  AND ENABLE THE PEER SERVICES AS WELL  IF U GOT PROBZ, THOI THESE SHOULD START AUTO....

     

    TO START STOP SERVICES,   TYPE   SERVICES.MSC IN YOUR START BAR SEARCH

     

    HOPE HELPZ

    Friday, January 13, 2012 9:24 PM
  • Yeah, like a lot of other people on this forum I was following all the advice people were giving and still could not get the Homegroup thing to work. However, thanks to anthrax_666, starting up the Homegroup Listener in the Services configuration did the trick. Now I can enjoy all my media on my PS3 (without using windows media player as a server).
    Sunday, February 05, 2012 5:47 PM
  • I have tried everything I can find on the web. I am still broken.
    Friday, February 24, 2012 7:19 PM
  • What if I do not have a folder named Peernetworking?

    In the Roaming folder I only have a Microsoft folder.

    Before you ask, yes I am showing hidden files and folders.

    Any ideas?

    Wednesday, May 09, 2012 10:31 PM
  • If you have tried everything software wise and settings related, the chances that it is hardware related are almost 100%.  If you have access to another router, give it try. I went through a similar experience where I tried everything stated above, and my problem eventually turned out to be a router which (probably as a result of MS security updates) no longer relayed my Homegroup traffic. A different router solved the problem immediately.
    Wednesday, June 20, 2012 7:59 AM
  • Here is another solution that worked for me.  It is a mix of the methods above.
    Delete everything in C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking

    Start Component Services (Start, type in box Component Services)
        
     Expand Services(Local)
         
      Find Peer Name Resolution, Double Click
              Select Log On Tab
              Select "This Account"
              Select Browse
              Advance
              Find Now
              Select LOCAL SERVICES,  OK, OK
              Type in the Password, Confirm, Apply
               Select the General Tab
                     Make Sure Startup Type is Auto
                     Stop the Service
                      Start the Service
                      OK out of  the Peer Name Resolution

    Repeat for
        1. Peer Networking Grouping
        2. Peer Networking Identity Manager
        3. PNRP Machine Name Publication

    Confirm that all the services are Started.  There are several dependancies and I doubt I got the order correct above.

    They are all running now and Event Viewer shows no errors
    Sunday, June 24, 2012 12:36 PM
  • I have Win7 Ultimate of Desktop and Win7 Pro on IvyBridege I7 Ultrabook.

    It changes home Group password and cannot be duplicated.

    I now suspect Win7 bug or the reality that Home4 Group is not for Home users?

    Sunday, July 08, 2012 11:12 PM
  • Same problem, do the peer services start up, as stated at the beginning, it worked for me.

     
    Friday, August 10, 2012 3:34 PM
  • you may want to try one simple thing. after through pages of information trying to figure this out.  trying everything possible for 3 full hours. check that both computers are on the same subnet. my laptop I originally had setup with a 255.255.255.128 and my PC was setup with 255.255.255.192  made sure they both were the same, and opened network and Voila I could see everything perfectly again. went to the homegroup and it created perfectly. just remember sometimes its something so small and simple that you can overlooked.
    Sunday, August 12, 2012 7:40 PM
  • Both machines need to be running  W7. Home group will not work with any other OS and W7

    I have three computers, and three different Operating Systems. Win 2000 Pro, Win XP Pro, and Win 7 Pro.  However my home network is not named HomeGroup.  I am not a network person, or a computer expert.  Can someone shed some light about if I need to have the HomeGroup Listener active, when my home network is not named HomeGroup?  If so, How do I turn it on.
    Friday, August 31, 2012 9:49 PM
  • Hey Anthax...wish I had read down further.  Spent a couple of hours figuring this issue out.  My system utilizes Bitlocker and thought that might have contributed to the problem.  The Only thing that was wrong was Listener was disabled...absolutely no clue why.  Anyway, just wanted to say thanks for the posting!



    Sunday, September 02, 2012 12:53 PM
  • I agree removing the idstore.sst was the trick

    thanks so much

    Monday, September 03, 2012 1:54 PM
  • I've tried everything including removing the idstore.sst. Didnt work. Spent hours on this thing and finally solved by doing the most logical step I could think of: I nuked the homegroup. Removed it from all my home PCs and re-created a new homegroup on the problematic machine with a new password. Problem solved. All machines connect and work properly with each other now.


    • Edited by amuzeini Thursday, October 25, 2012 8:13 PM
    Thursday, October 25, 2012 8:12 PM
  • I struggled for hours with this, and the printer share.

    First the Home group....I tried everything on the web. Did this C:\windows\serviceProfiles\LocalService/ but  app/data never appeared. Eventually I turned off all firewalls, in windows and in my anti- virus program. Then I did this, (Start, Control Panel, Network Internet) in the (choose homegroup and sharing options). Change Advanced Sharing Settings; I made certain that all the same boxes were ticked on both computers. I chose the 128 bit encryption for both. That allowed the computers to share. Secondly the Printer. After doing all the above it was still searching, I solved the problem by installing the driver software on the second computer.

    Monday, January 07, 2013 9:37 PM
  • Charlie Calvert's plan worked for me for the most part - but I had to do these additional steps:

    Disable virtual box network adapter

    Enable IPv6 on all computers (this protocol is required for Homegroup), if your concerned about broadcasts outside of your network you should have a router between your network and the internet and use private addressing.

    Reboot your computer (even after step 3)

    I hope this works

    BK


    Bob K


    • Edited by Rocky19xx Saturday, February 16, 2013 9:46 PM
    Saturday, February 16, 2013 9:45 PM
  • I guess Microsoft didn't fix it...
    Thursday, March 28, 2013 4:27 AM
  • I have VirtualBox installed on the machine where the Homegroup was created.

    Disabling the VirtualBox Host-Only Virtual Network Adapter solved my issue.

    Friday, August 02, 2013 11:29 PM
  • Just to add my 2 cents: Got same msg trying to get laptop (Win7 Pro 64) to join homegroup already set up on my desktop (Win7 Home Prem. 64). Tried everything mentioned. Only thing that worked after hours of trying was to "Leave" the homegroup on desktop and create a "New" homegroup on the desktop. Laptop then join immediately with the new password generated.

    The thing that misled me was the laptop saying it found the homegroup on the desktop. I then figured (incorrectly) there was no problem with desktop, so I assumed (wrongly) the problem was the laptop. So much for logic :(

    Saturday, August 10, 2013 4:24 PM
  • I'm a seasoned system admin and can map network drives in my sleep, but this HomeGroup is a total piece of sh!t first it assumes everyone in your household will be on Windows 7 (Not !, my most reliable box at home is still my trusty Windows XP Pro) then it forces you to use IPv6, then it spits out a bunch of arbitrary errors like "Windows cannot setup a HomeGroup on this computer." OK fine why the hell not?

    man all i want to do is copy some music from my XP box (which has a DVD drive pronounced "can RIP CDs") to my Windows 7 Starter (pronounced "piece of crap") HP Mini which does not, so bust out the old trusty USB stick and copy the files that way, progress my @ss

    thanks for nothing Microsoft 

     
    Saturday, September 21, 2013 5:31 AM
  • I had the same problem (without an error code) and two changes solved it for me.

    First, I had IPV6 disabled on the network adapter of the homegroup host machine so I enabled that. 

    Second, when I set up the homegroup, I gave it a different workgroup name to the generic one windows provides. When I changed the workgroup name on the second machine to match the workgroup name of the first machine, I was able to join the homegroup and access files.


    • Edited by TylerDurden Saturday, January 04, 2014 10:16 PM
    Saturday, January 04, 2014 10:13 PM
  • I followed this lead and disabled every network except the one I was using for the internet right at that moment.

    On one of the clients to the homegroup I disabled Hamachi's virtual network adapter. 

    Hamachi was running, so it reenabled the adapter immediately, but I disabled it after I had put in the password while it was struggling to join the homegroup, and Hamachi's adapter was disabled just long enough for the homegroup connection to snap together. It's stayed up even though Hamachi came back. (Maybe homegroup looks only at homegroups available on the first adapter in the line, and disabling it bumped it down in priority? or maybe the homegroup will collapse on reboot. no idea.)

    Friday, March 28, 2014 1:28 AM